summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPriit Laes <plaes@plaes.org>2013-03-29 20:06:31 +0200
committerPriit Laes <plaes@plaes.org>2013-03-29 20:06:31 +0200
commit29397680c55e18a133e3d9683e7317bd7aebde92 (patch)
tree52bc8cef507119348d7368e5b6b460e9308f459a /net-libs/libsoup/libsoup-9999.ebuild
parentgnome-base/gvfs: Suggest mtp USE flag to be on by default (diff)
downloadgnome-29397680c55e18a133e3d9683e7317bd7aebde92.tar.gz
gnome-29397680c55e18a133e3d9683e7317bd7aebde92.tar.bz2
gnome-29397680c55e18a133e3d9683e7317bd7aebde92.zip
net-libs/libsoup: Moved to gx86, sync live version.
Diffstat (limited to 'net-libs/libsoup/libsoup-9999.ebuild')
-rw-r--r--net-libs/libsoup/libsoup-9999.ebuild42
1 files changed, 17 insertions, 25 deletions
diff --git a/net-libs/libsoup/libsoup-9999.ebuild b/net-libs/libsoup/libsoup-9999.ebuild
index 64907043..423756e0 100644
--- a/net-libs/libsoup/libsoup-9999.ebuild
+++ b/net-libs/libsoup/libsoup-9999.ebuild
@@ -1,12 +1,13 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
EAPI="5"
GCONF_DEBUG="yes"
GNOME2_LA_PUNT="yes"
+PYTHON_COMPAT=( python{2_5,2_6,2_7} )
-inherit gnome2 python
+inherit gnome2 python-any-r1
if [[ ${PV} = 9999 ]]; then
inherit eutils gnome2-live
fi
@@ -21,24 +22,22 @@ if [[ ${PV} = 9999 ]]; then
else
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
fi
-IUSE="debug +introspection samba ssl test"
+IUSE="debug +introspection samba ssl test gnome"
[[ ${PV} = 9999 ]] && IUSE="${IUSE} doc"
-RDEPEND="
- dev-db/sqlite:3=
- >=dev-libs/glib-2.35.0:2
+RDEPEND=">=dev-libs/glib-2.35.0:2
>=dev-libs/libxml2-2:2
- >=net-libs/glib-networking-2.35.3[ssl?]
+ dev-db/sqlite:3
+ >=net-libs/glib-networking-2.30.0[ssl?]
introspection? ( >=dev-libs/gobject-introspection-0.9.5 )
- samba? ( net-fs/samba )
-"
+ samba? ( net-fs/samba )"
DEPEND="${RDEPEND}
- =dev-lang/python-2*
+ ${PYTHON_DEPS}
>=dev-util/intltool-0.35
>=dev-util/gtk-doc-am-1.10
sys-devel/gettext
- virtual/pkgconfig
-"
+ virtual/pkgconfig"
+
if [[ ${PV} = 9999 ]]; then
DEPEND="${DEPEND}
doc? ( >=dev-util/gtk-doc-1.10 )"
@@ -50,19 +49,10 @@ fi
# net-misc/curl
# net-libs/glib-networking[ssl])"
-pkg_setup() {
- python_set_active_version 2
- python_pkg_setup
-}
-
src_prepare() {
if [[ ${PV} = 9999 ]]; then
# prevent SOUP_MAINTAINER_FLAGS from getting set
mv .git .git-bck || die
-
- # Patch *must* be applied conditionally (see patch for details)
- # Fix bug 268592 (upstream #573685) (build fails without gnome && doc)
- use doc && epatch "${FILESDIR}/${PN}-2.34.2-fix-build-without-gnome-with-doc.patch"
fi
if ! use test; then
@@ -76,14 +66,16 @@ src_prepare() {
src_configure() {
# Disable apache tests until they are usable on Gentoo, bug #326957
- # FIXME: we need addpredict to workaround bug #324779 until
- # root cause (bug #249496) is solved
- addpredict /usr/share/snmp/mibs/.index
gnome2_src_configure \
--disable-static \
--disable-tls-check \
- --without-gnome \
+ $(use_with gnome) \
--without-apache-httpd \
$(use_enable introspection) \
$(use_with samba ntlm-auth ${EPREFIX}/usr/bin/ntlm_auth)
+
+ # FIXME: we need addpredict to workaround bug #324779 until
+ # root cause (bug #249496) is solved
+ addpredict /usr/share/snmp/mibs/.index
+ gnome2_src_configure
}