summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2015-05-09 00:56:48 +0200
committerGilles Dartiguelongue <eva@gentoo.org>2015-05-09 01:21:24 +0200
commita5836469e4b447281c830fc341be5ec56b58568d (patch)
tree01da40f6a57a88896f5c98473cfb4435ceb99384 /net-misc
parentgnome-extra/gnome-system-monitor: 3.14.1 → 3.16.0 (diff)
downloadgnome-a5836469e4b447281c830fc341be5ec56b58568d.tar.gz
gnome-a5836469e4b447281c830fc341be5ec56b58568d.tar.bz2
gnome-a5836469e4b447281c830fc341be5ec56b58568d.zip
net-misc/vinagre: 3.14.3 → 3.16.0
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/vinagre/Manifest11
-rw-r--r--net-misc/vinagre/vinagre-3.16.0.ebuild64
-rw-r--r--net-misc/vinagre/vinagre-9999.ebuild4
3 files changed, 77 insertions, 2 deletions
diff --git a/net-misc/vinagre/Manifest b/net-misc/vinagre/Manifest
new file mode 100644
index 00000000..f6eca6d1
--- /dev/null
+++ b/net-misc/vinagre/Manifest
@@ -0,0 +1,11 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA512
+
+DIST vinagre-3.16.0.tar.xz 812380 SHA256 93d79e18e71509647fe4bc00a0dcef5382b2e3a79c39d2b18a91334195995c34 SHA512 15d4bf289881d9d3e5310fe5d5571ae48c36d06657fbc6f7711009bc085c86706c51d13af50d22147ba46c8c7d5172bb5f1b7f617420180571ef8ac10b06e434 WHIRLPOOL 344a4cc497065f5fcec0210994eecc1b3953ecd868dfb0b280c83ee8e68cb9fbcff65ca727abab8a225392ec59979344767f56aba8e4bf9d49be2a19eba05b61
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v2
+
+iEYEAREKAAYFAlVNPzEACgkQ1fmVwcYIWAYmbACgzzHpKbzzhCzPd9G37xjhGFBO
+94sAoLwgBOJ7ix6MCRc76HWhUTZgquCl
+=B0HR
+-----END PGP SIGNATURE-----
diff --git a/net-misc/vinagre/vinagre-3.16.0.ebuild b/net-misc/vinagre/vinagre-3.16.0.ebuild
new file mode 100644
index 00000000..8da8a755
--- /dev/null
+++ b/net-misc/vinagre/vinagre-3.16.0.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="5"
+GCONF_DEBUG="no"
+VALA_MIN_API_VERSION="0.18"
+
+inherit gnome2 vala
+
+DESCRIPTION="VNC client for the GNOME desktop"
+HOMEPAGE="https://wiki.gnome.org/Apps/Vinagre"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~ppc64 ~x86"
+IUSE="avahi rdp +ssh spice +telepathy"
+
+# cairo used in vinagre-tab
+# gdk-pixbuf used all over the place
+RDEPEND="
+ >=dev-libs/glib-2.28.0:2
+ >=x11-libs/gtk+-3.9.6:3
+ app-crypt/libsecret
+ >=dev-libs/libxml2-2.6.31:2
+ >=net-libs/gtk-vnc-0.4.3[gtk3]
+ x11-libs/cairo:=
+ x11-libs/gdk-pixbuf:2
+ x11-themes/hicolor-icon-theme
+
+ avahi? ( >=net-dns/avahi-0.6.26[dbus,gtk3] )
+ rdp? ( net-misc/freerdp )
+ ssh? ( >=x11-libs/vte-0.20:2.91 )
+ spice? (
+ app-emulation/spice-protocol
+ >=net-misc/spice-gtk-0.5[gtk3] )
+ telepathy? (
+ dev-libs/dbus-glib
+ >=net-libs/telepathy-glib-0.11.6 )
+"
+DEPEND="${RDEPEND}
+ >=dev-lang/perl-5
+ dev-libs/appstream-glib
+ >=dev-util/intltool-0.50
+ >=sys-devel/gettext-0.17
+ virtual/pkgconfig
+ $(vala_depend)
+"
+
+src_prepare() {
+ vala_src_prepare
+ gnome2_src_prepare
+}
+
+src_configure() {
+ DOCS="AUTHORS ChangeLog ChangeLog.pre-git NEWS README"
+ gnome2_src_configure \
+ $(use_with avahi) \
+ $(use_enable rdp) \
+ $(use_enable ssh) \
+ $(use_enable spice) \
+ $(use_with telepathy) \
+ ITSTOOL=$(type -P true)
+}
diff --git a/net-misc/vinagre/vinagre-9999.ebuild b/net-misc/vinagre/vinagre-9999.ebuild
index 97674271..fde58a63 100644
--- a/net-misc/vinagre/vinagre-9999.ebuild
+++ b/net-misc/vinagre/vinagre-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
@@ -19,7 +19,7 @@ SLOT="0"
if [[ ${PV} = 9999 ]]; then
KEYWORDS=""
else
- KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+ KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~ppc64 ~x86"
fi
IUSE="avahi rdp +ssh spice +telepathy"