summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPriit Laes <plaes@plaes.org>2010-05-15 17:16:35 +0300
committerPriit Laes <plaes@plaes.org>2010-05-15 17:16:35 +0300
commit7fbeb833ff954bb10c6f0bed7d0a381ee850508e (patch)
tree26d1c05784c49d8c0a9ac9b396178a5afc906237 /www-client/epiphany-extensions/epiphany-extensions-2.30.1.ebuild
parentnet-libs/webkit-gtk: Bump to 1.2.1 (diff)
downloadgnome-7fbeb833ff954bb10c6f0bed7d0a381ee850508e.tar.gz
gnome-7fbeb833ff954bb10c6f0bed7d0a381ee850508e.tar.bz2
gnome-7fbeb833ff954bb10c6f0bed7d0a381ee850508e.zip
www-client/epiphany-extensions: Bump to 2.30.1
Diffstat (limited to 'www-client/epiphany-extensions/epiphany-extensions-2.30.1.ebuild')
-rw-r--r--www-client/epiphany-extensions/epiphany-extensions-2.30.1.ebuild66
1 files changed, 66 insertions, 0 deletions
diff --git a/www-client/epiphany-extensions/epiphany-extensions-2.30.1.ebuild b/www-client/epiphany-extensions/epiphany-extensions-2.30.1.ebuild
new file mode 100644
index 00000000..9a4dadc1
--- /dev/null
+++ b/www-client/epiphany-extensions/epiphany-extensions-2.30.1.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="2"
+
+inherit gnome2 eutils versionator
+
+MY_MAJORV=$(get_version_component_range 1-2)
+
+DESCRIPTION="Extensions for the Epiphany web browser"
+HOMEPAGE="http://www.gnome.org/projects/epiphany/extensions.html"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="dbus examples pcre"
+
+RDEPEND=">=www-client/epiphany-${MY_MAJORV}
+ app-text/opensp
+ >=dev-libs/glib-2.15.5
+ >=gnome-base/gconf-2.0
+ >=dev-libs/libxml2-2.6
+ >=x11-libs/gtk+-2.12.0
+ >=gnome-base/libglade-2
+ >=net-libs/webkit-gtk-1.1
+
+ dbus? ( >=dev-libs/dbus-glib-0.34 )
+ pcre? ( >=dev-libs/libpcre-3.9-r2 )"
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.40
+ >=dev-util/pkgconfig-0.20
+ >=app-text/gnome-doc-utils-0.3.2"
+# eautoreconf dependencies:
+# gnome-base/gnome-common
+
+DOCS="AUTHORS ChangeLog HACKING NEWS README"
+
+# FIXME: Open security issues:
+# FIXME: - adblock ( https://bugzilla.gnome.org/show_bug.cgi?id=595255 )
+# FIXME: broken extensions:
+# FIXME: - session-saver ( https://bugzilla.gnome.org/show_bug.cgi?id=316245 )
+
+pkg_setup() {
+ local extensions=""
+
+ extensions="actions auto-reload auto-scroller certificates \
+ error-viewer extensions-manager-ui gestures html5tube \
+ java-console livehttpheaders page-info permissions \
+ push-scroller select-stylesheet \
+ smart-bookmarks soup-fly tab-groups tab-states"
+ use dbus && extensions="${extensions} rss"
+
+ use pcre && extensions="${extensions} greasemonkey"
+
+ use examples && extensions="${extensions} sample"
+
+ G2CONF="${G2CONF}
+ --disable-maintainer-mode
+ --with-extensions=$(echo "${extensions}" | sed -e 's/[[:space:]]\+/,/g')"
+}
+
+src_install() {
+ gnome2_src_install
+ find "${D}" -name "*.la" -delete || die "remove of la files failed"
+}