summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2009-04-18 13:49:07 +0200
committerGilles Dartiguelongue <eva@gentoo.org>2009-04-18 13:49:07 +0200
commit6b3846ccf6e47c947d8e373a9467e040193899bb (patch)
tree41b1f461f9212061cfc84fa3d1fde14974cf5105 /www-client/epiphany
parentgnome-base/gnome-control-centre: fix DEPENDS (diff)
downloadgnome-6b3846ccf6e47c947d8e373a9467e040193899bb.tar.gz
gnome-6b3846ccf6e47c947d8e373a9467e040193899bb.tar.bz2
gnome-6b3846ccf6e47c947d8e373a9467e040193899bb.zip
www-client/epiphany: fix automagic libcanberra support, bug #266232.
Diffstat (limited to 'www-client/epiphany')
-rw-r--r--www-client/epiphany/Manifest3
-rw-r--r--www-client/epiphany/epiphany-2.26.1.ebuild12
-rw-r--r--www-client/epiphany/files/epiphany-2.26.1-automagic-libcanberra.patch48
3 files changed, 58 insertions, 5 deletions
diff --git a/www-client/epiphany/Manifest b/www-client/epiphany/Manifest
index c59fb107..7e531550 100644
--- a/www-client/epiphany/Manifest
+++ b/www-client/epiphany/Manifest
@@ -1,5 +1,6 @@
AUX epiphany-2.26.0-xulrunner191.patch 491 RMD160 ae36fd6f67b9afb3c03413bed685f10816ac24d2 SHA1 b5ba78085dcf35677361af9008f3f8998788ddd8 SHA256 3c8804a9004ed27f4f2ad99f4e434d6d4050711d000ce73ce2c0fc8bc0d197df
+AUX epiphany-2.26.1-automagic-libcanberra.patch 1838 RMD160 b98c6a734f240ea000e8938ac690426c904ec37f SHA1 9a782c3c8babf1ae8ac18c2602e0eb2d46b6eb82 SHA256 9cc20da812e7a95e535e905efaedf05720e2e8c1828d644934636ccb05f77fa3
DIST epiphany-2.26.1.tar.bz2 5631650 RMD160 b25f3d3edab539ec1ce90181b4ef40e557a3286b SHA1 57b4b3112ec0a224fcd508b5cce133ebec62be03 SHA256 8b49b6e527814d2e66748a2ed35aa275738f46cab056cc58e2721a3b65f6b0ca
DIST epiphany-2.27.1.tar.bz2 5677062 RMD160 f8c4830316ced61855742e7a20dae227f56748cd SHA1 371de50c84bc69697e51cc83f03a5fc026869baa SHA256 36d2b3652b5bbf7b459fda95ac0f25c429aa2e05e42fede3e88ce463879bdb8b
-EBUILD epiphany-2.26.1.ebuild 2392 RMD160 5cd27c0d31e17f0d0753a8de111566cb7355e296 SHA1 7f2e9aba085831bb5eefc53e6b5e043ef8890156 SHA256 407916adf7778f4c253414c1c7fa15818daf648558e0a602e5a798bb4fdde46c
+EBUILD epiphany-2.26.1.ebuild 2507 RMD160 400820645af9138b9eeab0a1fb4ff20c95381804 SHA1 4b62a8373d3986c622a6cabdab1a604a4a39ffbe SHA256 514ffb0d7872740aeb97d32c52c6020add663fe55b658d7eb0f27d39b80a9e8d
EBUILD epiphany-2.27.1.ebuild 1449 RMD160 6aab1a029b5e4678c49bccc6f089afa961577a81 SHA1 8cc3dd1de6ecc0d03b2de89aaf3abf456732d379 SHA256 3715d1800c28fa613f4dbd5290ad01cea1394adebb7b757efbe86dd09bfa8e7a
diff --git a/www-client/epiphany/epiphany-2.26.1.ebuild b/www-client/epiphany/epiphany-2.26.1.ebuild
index db24e787..8f0b69f0 100644
--- a/www-client/epiphany/epiphany-2.26.1.ebuild
+++ b/www-client/epiphany/epiphany-2.26.1.ebuild
@@ -4,7 +4,7 @@
EAPI="2"
-inherit gnome2 eutils multilib
+inherit gnome2 eutils multilib autotools
DESCRIPTION="GNOME webbrowser based on the mozilla rendering engine"
HOMEPAGE="http://www.gnome.org/projects/epiphany/"
@@ -14,7 +14,6 @@ SLOT="0"
KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 -sparc ~x86"
IUSE="avahi doc networkmanager python spell"
-# FIXME: libcanberra is automagic
RDEPEND=">=dev-libs/glib-2.18.0
>=x11-libs/gtk+-2.16.0
>=dev-libs/libxml2-2.6.12
@@ -35,8 +34,7 @@ RDEPEND=">=dev-libs/glib-2.18.0
python? (
>=dev-lang/python-2.3
>=dev-python/pygtk-2.7.1
- >=dev-python/gnome-python-2.6
- )
+ >=dev-python/gnome-python-2.6 )
spell? ( app-text/enchant )
x11-themes/gnome-icon-theme"
DEPEND="${RDEPEND}
@@ -54,6 +52,7 @@ pkg_setup() {
--with-gecko=libxul-embedding
--enable-certificate-manager
--with-distributor-name=Gentoo
+ --enable-canberra
$(use_enable avahi zeroconf)
$(use_enable networkmanager network-manager)
$(use_enable spell spell-checker)
@@ -65,6 +64,11 @@ src_prepare() {
# Fix compilation with xulrunner 1.9.1, bug #263990
epatch "${FILESDIR}/${PN}-2.26.0-xulrunner191.patch"
+
+ # Fix libcanberra automagic support, bug #266232
+ epatch "${FILESDIR}/${P}-automagic-libcanberra.patch"
+
+ eautoreconf
}
src_configure() {
diff --git a/www-client/epiphany/files/epiphany-2.26.1-automagic-libcanberra.patch b/www-client/epiphany/files/epiphany-2.26.1-automagic-libcanberra.patch
new file mode 100644
index 00000000..095dc257
--- /dev/null
+++ b/www-client/epiphany/files/epiphany-2.26.1-automagic-libcanberra.patch
@@ -0,0 +1,48 @@
+---
+ Fix automagic libcanberra detection.
+
+ Gentoo: https://bugs.gentoo.org/show_bug.cgi?id=266232
+ Gnome: https://bugzilla.gnome.org/show_bug.cgi?id=579031
+
+ configure.ac | 20 ++++++++++++++++----
+ 1 files changed, 16 insertions(+), 4 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 90ed936..61b10de 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -118,13 +118,24 @@ LIBCANBERRA_GTK_REQUIRED=0.3
+ DBUS_GLIB_REQUIRED=0.35
+
+ PKG_CHECK_EXISTS([libnotify >= $LIBNOTIFY_REQUIRED],[have_libnotify=yes],[have_libnotify=no])
+-PKG_CHECK_EXISTS([libcanberra-gtk >= $LIBCANBERRA_GTK_REQUIRED],[have_libcanberra_gtk=yes],[have_libcanberra_gtk=no])
++
++AC_ARG_ENABLE([canberra],
++ AC_HELP_STRING([--enable-canberra],
++ [Enable canberra support @<:@default=yes@:>@]),
++ enable_canberra=$enableval, enable_canberra=yes)
+
+ LIBCANBERRA_GTK_PACKAGE=
+-if test "$have_libcanberra_gtk" = "yes"; then
+- LIBCANBERRA_GTK_PACKAGE="libcanberra-gtk >= $LIBCANBERRA_GTK_REQUIRED"
+- AC_DEFINE([HAVE_LIBCANBERRA_GTK],[1],[Define if libcanberra-gtk is available])
++have_libcanberra_gtk=no
++if test "$enable_canberra" = "yes"; then
++ PKG_CHECK_EXISTS([libcanberra-gtk >= $LIBCANBERRA_GTK_REQUIRED],[have_libcanberra_gtk=yes],
++ [have_libcanberra_gtk=no])
++
++ if test "$have_libcanberra_gtk" = "yes"; then
++ LIBCANBERRA_GTK_PACKAGE="libcanberra-gtk >= $LIBCANBERRA_GTK_REQUIRED"
++ AC_DEFINE([HAVE_LIBCANBERRA_GTK],[1],[Define if libcanberra-gtk is available])
++ fi
+ fi
++
+ LIBNOTIFY_PACKAGE=
+ if test "$have_libnotify" = "yes"; then
+ LIBNOTIFY_PACKAGE="libnotify >= $LIBNOTIFY_REQUIRED"
+@@ -772,4 +783,5 @@ Epiphany was configured with the following options:
+
+ Gecko backend : $gecko_cv_gecko version $gecko_cv_gecko_version
+ PSM support : $enable_psm
++ Canberra support : $have_libcanberra_gtk
+ "