summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2008-08-26 00:08:38 +0200
committerGilles Dartiguelongue <eva@gentoo.org>2008-08-26 00:08:38 +0200
commit3484ceb9b2972fe2ec87f6358d54285446237c4f (patch)
tree55718230ad214b7504a3a5e1defa5191bfabe3ce /x11-libs/gtksourceview
parentgnome-extra/gnome-utils: bump to 2.23.90 (diff)
downloadgnome-3484ceb9b2972fe2ec87f6358d54285446237c4f.tar.gz
gnome-3484ceb9b2972fe2ec87f6358d54285446237c4f.tar.bz2
gnome-3484ceb9b2972fe2ec87f6358d54285446237c4f.zip
x11-libs/gtksourceview: bump to 2.3.1
* Add function to guess the language for a given filename and mime type (bump glib dependency to 2.14 that includes gio, remove gnome-vfs dep) * Allow to set background color of paragraphs with marks * Support drawing white spaces * Improvements to some of the lang files
Diffstat (limited to 'x11-libs/gtksourceview')
-rw-r--r--x11-libs/gtksourceview/Manifest4
-rw-r--r--x11-libs/gtksourceview/files/2.0/gentoo.lang112
-rw-r--r--x11-libs/gtksourceview/files/gentoo.lang59
-rw-r--r--x11-libs/gtksourceview/gtksourceview-2.3.1.ebuild39
4 files changed, 214 insertions, 0 deletions
diff --git a/x11-libs/gtksourceview/Manifest b/x11-libs/gtksourceview/Manifest
new file mode 100644
index 00000000..070907bf
--- /dev/null
+++ b/x11-libs/gtksourceview/Manifest
@@ -0,0 +1,4 @@
+AUX 2.0/gentoo.lang 3961 RMD160 fcfc40b8508fb1735c3eb1d54ec146d9a61eb5e2 SHA1 b727837ca0ea1cc2539a364e97a410c931ac87f8 SHA256 483a34dd8f418b75b0b408d8cb0d0d4c50aa499c3f962652c93a78b248679183
+AUX gentoo.lang 2593 RMD160 c9ada6c01020af1e76dba1e66985ef14c23c82ad SHA1 6245622ae1a4229ffc32c8b4d987619e9fdbe4c5 SHA256 518bcc10cfb067b777b378ac55b5be6608114d8861183bbb8b6d64d3b47a0a59
+DIST gtksourceview-2.3.1.tar.bz2 964552 RMD160 bb351bb47cf40b3b569693062d6628d8c1bc1283 SHA1 ce4dad3b2f96d82746175259a96b41e85d64c5ff SHA256 f24e259f18d5b4f4d6316e66a03aea1d40b7fbd9d254ac4b94ff75fb12a3839e
+EBUILD gtksourceview-2.3.1.ebuild 1118 RMD160 c798df67c5ae1485d9352544925944900b0f36e2 SHA1 59088939a73c2d016a71e14c25e772687345e40d SHA256 7b3c4a7ec8a0f5919bbddcbebe8c49ea6feb50b82898d7577a0105b000af56dd
diff --git a/x11-libs/gtksourceview/files/2.0/gentoo.lang b/x11-libs/gtksourceview/files/2.0/gentoo.lang
new file mode 100644
index 00000000..3aa3a332
--- /dev/null
+++ b/x11-libs/gtksourceview/files/2.0/gentoo.lang
@@ -0,0 +1,112 @@
+<?xml version="1.0" encoding="UTF-8"?>
+
+<!--
+ GtkSourceView syntax highlight for Gentoo-specific files
+
+ Originally written for gtksourceview-1.x by:
+ Leonardo Ferreira Fontenelle <leo.fontenelle@gmail.com>, 2006.
+ Rewritten for gtksourceview-2 by:
+ Rene 'Necoro' Neumann <necoro@necoro.net>, 2007
+
+ Distributed under the same license(s) as gtksourceview.
+
+ TODO:
+ - do not highlight "enable" in the configure options
+ - perhaps highlight portage variables and portage functions different
+
+-->
+
+<language name="gentoo" id="gentoo" version="2.0" _section="Scripts">
+ <metadata>
+ <property name="mimetypes">text/plain</property>
+ <property name="globs">*.ebuild;*.eclass</property>
+ <property name="line-comment-start">#</property>
+ </metadata>
+
+ <styles>
+ <style id="variable" _name="Portage variables" map-to="def:builtin" />
+ <style id="command" _name="Portage command" map-to="def:type" />
+ <style id="function" _name="Portage function" map-to="def:function" />
+ <style id="string" _name="String" map-to="def:string" />
+ </styles>
+
+ <definitions>
+
+ <!-- rewrite shell string to show highlighted variables -->
+ <context id="string" style-ref="def:string">
+ <start>"</start>
+ <end>"</end>
+ <include>
+ <context ref="def:escape"/>
+ <context ref="def:line-continue"/>
+ <context ref="sh:variable"/>
+ </include>
+ </context>
+
+ <context id="string-2" style-ref="def:string">
+ <start>'</start>
+ <end>'</end>
+ <include>
+ <context ref="def:escape"/>
+ <context ref="def:line-continue"/>
+ <context ref="sh:variable"/>
+ </include>
+ </context>
+
+ <!-- subprograms:
+ - $(..) is not supported currently in the normal sh.lang
+ - `...` is interpreted as string - I think the subshell behavior is more acurate -->
+ <context id="subprogram">
+ <start>\$\(</start>
+ <end>\)</end>
+ <include>
+ <context sub-pattern="0" where="start" style-ref="sh:keyword"/>
+ <context sub-pattern="0" where="end" style-ref="sh:keyword"/>
+ <context ref="gentoo"/>
+ </include>
+ </context>
+
+ <context id="subprogram-2">
+ <start>`</start>
+ <end>`</end>
+ <include>
+ <context sub-pattern="0" where="start" style-ref="sh:keyword"/>
+ <context sub-pattern="0" where="end" style-ref="sh:keyword"/>
+ <context ref="gentoo"/>
+ </include>
+ </context>
+
+ <!-- portage variables - currently unused -->
+ <context id="portvars" style-ref="variable">
+ <match>\b((ARCH|HOMEPAGE|DESCRIPTION|IUSE|SRC_URI|LICENSE|SLOT|KEYWORDS|FILESDIR|WORKDIR|(P|R)?DEPEND|PROVIDE|DISTDIR|RESTRICT|USERLAND)|(S|D|T|PV|PF|P|PN|A)|C(XX)?FLAGS|LDFLAGS|C(HOST|TARGET|BUILD))\b</match>
+ </context>
+
+ <!-- portage functions - currently unused -->
+ <context id="portfuncs" style-ref="function">
+ <match>^(src_(unpack|compile|install|test)|pkg_(config|nofetch|setup|(pre|post)(inst|rm)))</match>
+ </context>
+
+ <!-- extra portage commands -->
+ <context id="portcmds" style-ref="command">
+ <match>\b(e(begin|end|conf|install|make|warn|infon?|error|patch)|die|use(_(with|enable))?|inherit|has|(has|best)_version|unpack|(do|new)(ins|s?bin|doc|lib(|\.so|\.a)|man|info|exe|initd|confd|envd|pam|menu|icon)|do(python|sed|dir|hard|sym|html|jar|mo)|keepdir|prepall(|docs|info|man|strip)|prep(info|lib|lib\.(so|a)|man|strip)|(|doc|ins|exe)into|f(owners|perms)|(exe|ins|dir)opts)\b</match>
+ </context>
+
+ <context id="built-in-command">
+ <include> <!-- do not include "sh:built-in-command" as it is replaced down there - which would lead to an endless loop -->
+ <context ref="sh:built-in-command-1" />
+ <context ref="sh:built-in-command-2" />
+ <context ref="portcmds" />
+ </include>
+ </context>
+
+ <!-- gentoo is just a shell with the replacements -->
+ <replace id="sh:built-in-command" ref="built-in-command" />
+ <replace id="sh:backtick-subshell" ref="subprogram-2" />
+ <context id="gentoo">
+ <include>
+ <context ref="subprogram"/>
+ <context ref="sh:sh"/>
+ </include>
+ </context>
+ </definitions>
+</language>
diff --git a/x11-libs/gtksourceview/files/gentoo.lang b/x11-libs/gtksourceview/files/gentoo.lang
new file mode 100644
index 00000000..ead788cf
--- /dev/null
+++ b/x11-libs/gtksourceview/files/gentoo.lang
@@ -0,0 +1,59 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE language SYSTEM "language.dtd">
+
+<!--
+ GtkSourceView syntax highlight for Gentoo-specific files
+ Leonardo Ferreira Fontenelle <leo.fontenelle@gmail.com>, 2006.
+ Distributed under the same license(s) as gtksourceview.
+
+ This .lang file should provide almost the same behaviour of
+ gentoo.nanorc. The exceptions are the line-comment and string elements.
+ If you get little
+
+ TODO:
+ - some styles don't get automatic colors, why?
+ - add syntax for /etc/portage/*
+-->
+
+<language _name="Gentoo" version="1.0" _section="Scripts" mimetypes="text/plain">
+
+ <escape-char>\</escape-char>
+
+ <line-comment _name="Line Comment" style="Comment">
+ <start-regex>#</start-regex>
+ </line-comment>
+
+ <string _name="String" style="String" end-at-line-end="false">
+ <start-regex>&quot;</start-regex>
+ <end-regex>&quot;</end-regex>
+ </string>
+
+ <pattern-item _name="Bash syntax" style="Operator">
+ <regex>(\b(case|do|done|elif|else|esac|exit|fi|for|function|if|in|local|read|return|select|shift|then|time|until|while)\b|(\{|\}|\(|\)|\;|\]|\[|`|\\|\$|&gt;|%lt;|!|=|&amp;|\|)|-(e|d|f|r|g|u|w|x|L)\b|-(eq|ne|gt|lt|ge|le|s|n|z)\b)</regex>
+ </pattern-item>
+
+ <pattern-item _name="Bash variables" style="Others">
+ <regex>\$\{?[a-zA-Z_0-9]+\}?</regex>
+ </pattern-item>
+
+ <pattern-item _name="Bash commands" style="Others 2">
+ <regex>(\bmake\b|\b(cat|cd|chmod|chown|cp|echo|env|export|grep|let|ln|mkdir|mv|rm|sed|set|tar|touch|unset)\b)</regex>
+ </pattern-item>
+
+ <pattern-item _name="Portage variables" style="Keyword">
+ <regex>\b((ARCH|HOMEPAGE|DESCRIPTION|IUSE|SRC_URI|LICENSE|SLOT|KEYWORDS|FILESDIR|WORKDIR|(P|R)?DEPEND|PROVIDE|DISTDIR|RESTRICT|USERLAND)|(S|D|T|PV|PF|P|PN|A)|C(XX)?FLAGS|LDFLAGS|C(HOST|TARGET|BUILD))\b</regex>
+ </pattern-item>
+
+ <pattern-item _name="Portage commands" style="Data Type">
+ <regex>\b(e(begin|end|conf|install|make|warn|infon?|error|patch)|die|use(_(with|enable))?|inherit|has|(has|best)_version|unpack|(do|new)(ins|s?bin|doc|lib(|\.so|\.a)|man|info|exe|initd|confd|envd|pam|menu|icon)|do(python|sed|dir|hard|sym|html|jar|mo)|keepdir|prepall(|docs|info|man|strip)|prep(info|lib|lib\.(so|a)|man|strip)|(|doc|ins|exe)into|f(owners|perms)|(exe|ins|dir)opts)\b</regex>
+ </pattern-item>
+
+ <pattern-item _name="Portage functions" style="Function">
+ <regex>^(src_(unpack|compile|install|test)|pkg_(config|nofetch|setup|(pre|post)(inst|rm)))</regex>
+ </pattern-item>
+
+ <pattern-item _name="Inherits and USE flags" style="Specials">
+ <regex>(\buse(_(with|enable))?\b [\!a-zA-Z0-9_+ -]*|inherit*$)</regex>
+ </pattern-item>
+
+</language>
diff --git a/x11-libs/gtksourceview/gtksourceview-2.3.1.ebuild b/x11-libs/gtksourceview/gtksourceview-2.3.1.ebuild
new file mode 100644
index 00000000..c5d22933
--- /dev/null
+++ b/x11-libs/gtksourceview/gtksourceview-2.3.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtksourceview/gtksourceview-2.2.2.ebuild,v 1.2 2008/08/09 12:56:31 eva Exp $
+
+inherit gnome2 eutils
+
+DESCRIPTION="A text widget implementing syntax highlighting and other features"
+HOMEPAGE="http://www.gnome.org/"
+
+LICENSE="GPL-2"
+SLOT="2.0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="doc"
+
+# glib-2.14 dep is to be sure GRegex exists, so that gtksourceview does not
+# build a copy of it. However gtk+-2.12 already can't work with lower version
+# than that
+RDEPEND=">=x11-libs/gtk+-2.12
+ >=dev-libs/libxml2-2.5
+ >=dev-libs/glib-2.14"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ >=dev-util/intltool-0.35
+ >=dev-util/pkgconfig-0.9
+ doc? ( >=dev-util/gtk-doc-1 )"
+
+DOCS="AUTHORS ChangeLog HACKING MAINTAINERS NEWS README"
+
+pkg_setup() {
+ # Removes the gnome-vfs dep
+ G2CONF="${G2CONF} --disable-build-tests"
+}
+
+src_install() {
+ gnome2_src_install
+
+ insinto /usr/share/${PN}-2.0/language-specs
+ doins "${FILESDIR}"/2.0/gentoo.lang
+}