summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Piechotka <uzytkownik2@gmail.com>2010-02-23 00:37:05 +0000
committerMaciej Piechotka <uzytkownik2@gmail.com>2010-03-29 10:46:14 +0100
commit7c386337e66e38d406d389f36ec0abcbe08727ae (patch)
tree7389dc3ca783ab98c1f2bf717110927fd85bbd3b /x11-libs/gtksourceview
parentx11-themes/gnome-themes: version 2.29.92 bump (diff)
downloadgnome-7c386337e66e38d406d389f36ec0abcbe08727ae.tar.gz
gnome-7c386337e66e38d406d389f36ec0abcbe08727ae.tar.bz2
gnome-7c386337e66e38d406d389f36ec0abcbe08727ae.zip
x11-libs/gtksourceview: version 2.10.0 bump
Diffstat (limited to 'x11-libs/gtksourceview')
-rw-r--r--x11-libs/gtksourceview/Manifest4
-rw-r--r--x11-libs/gtksourceview/files/2.0/gentoo.lang112
-rw-r--r--x11-libs/gtksourceview/files/gentoo.lang59
-rw-r--r--x11-libs/gtksourceview/gtksourceview-2.10.0.ebuild47
4 files changed, 222 insertions, 0 deletions
diff --git a/x11-libs/gtksourceview/Manifest b/x11-libs/gtksourceview/Manifest
new file mode 100644
index 00000000..f7b6c673
--- /dev/null
+++ b/x11-libs/gtksourceview/Manifest
@@ -0,0 +1,4 @@
+AUX 2.0/gentoo.lang 3961 RMD160 fcfc40b8508fb1735c3eb1d54ec146d9a61eb5e2 SHA1 b727837ca0ea1cc2539a364e97a410c931ac87f8 SHA256 483a34dd8f418b75b0b408d8cb0d0d4c50aa499c3f962652c93a78b248679183
+AUX gentoo.lang 2607 RMD160 a6532326c5ee395500726e434a36e1270c0e411a SHA1 6f859400d569c3d39fe02e6dc426d0b4caf6fe75 SHA256 3a51831952ae3661232de4ace1eae5182039d82a6d45c97ccbe9cab73519c707
+DIST gtksourceview-2.10.0.tar.bz2 1231797 RMD160 92e66e5f0a88be3b857436cf722242921c4ec01a SHA1 53a2c78d3c91c3e697b4467f48051c8f6f3f1c85 SHA256 a72484ff661d3515130911b59f78a88afc1344421431e05e99e9dab791be948f
+EBUILD gtksourceview-2.10.0.ebuild 1199 RMD160 de2ce73eecea5199fc38de91f6f34add6410de5c SHA1 8e08a08f47529f8d93b9646059dfbeeecf80d112 SHA256 56f97cf32f31fd479ff5acb7bdb47570a6b7bc388bd2e8f3fae49a7b2c010c03
diff --git a/x11-libs/gtksourceview/files/2.0/gentoo.lang b/x11-libs/gtksourceview/files/2.0/gentoo.lang
new file mode 100644
index 00000000..3aa3a332
--- /dev/null
+++ b/x11-libs/gtksourceview/files/2.0/gentoo.lang
@@ -0,0 +1,112 @@
+<?xml version="1.0" encoding="UTF-8"?>
+
+<!--
+ GtkSourceView syntax highlight for Gentoo-specific files
+
+ Originally written for gtksourceview-1.x by:
+ Leonardo Ferreira Fontenelle <leo.fontenelle@gmail.com>, 2006.
+ Rewritten for gtksourceview-2 by:
+ Rene 'Necoro' Neumann <necoro@necoro.net>, 2007
+
+ Distributed under the same license(s) as gtksourceview.
+
+ TODO:
+ - do not highlight "enable" in the configure options
+ - perhaps highlight portage variables and portage functions different
+
+-->
+
+<language name="gentoo" id="gentoo" version="2.0" _section="Scripts">
+ <metadata>
+ <property name="mimetypes">text/plain</property>
+ <property name="globs">*.ebuild;*.eclass</property>
+ <property name="line-comment-start">#</property>
+ </metadata>
+
+ <styles>
+ <style id="variable" _name="Portage variables" map-to="def:builtin" />
+ <style id="command" _name="Portage command" map-to="def:type" />
+ <style id="function" _name="Portage function" map-to="def:function" />
+ <style id="string" _name="String" map-to="def:string" />
+ </styles>
+
+ <definitions>
+
+ <!-- rewrite shell string to show highlighted variables -->
+ <context id="string" style-ref="def:string">
+ <start>"</start>
+ <end>"</end>
+ <include>
+ <context ref="def:escape"/>
+ <context ref="def:line-continue"/>
+ <context ref="sh:variable"/>
+ </include>
+ </context>
+
+ <context id="string-2" style-ref="def:string">
+ <start>'</start>
+ <end>'</end>
+ <include>
+ <context ref="def:escape"/>
+ <context ref="def:line-continue"/>
+ <context ref="sh:variable"/>
+ </include>
+ </context>
+
+ <!-- subprograms:
+ - $(..) is not supported currently in the normal sh.lang
+ - `...` is interpreted as string - I think the subshell behavior is more acurate -->
+ <context id="subprogram">
+ <start>\$\(</start>
+ <end>\)</end>
+ <include>
+ <context sub-pattern="0" where="start" style-ref="sh:keyword"/>
+ <context sub-pattern="0" where="end" style-ref="sh:keyword"/>
+ <context ref="gentoo"/>
+ </include>
+ </context>
+
+ <context id="subprogram-2">
+ <start>`</start>
+ <end>`</end>
+ <include>
+ <context sub-pattern="0" where="start" style-ref="sh:keyword"/>
+ <context sub-pattern="0" where="end" style-ref="sh:keyword"/>
+ <context ref="gentoo"/>
+ </include>
+ </context>
+
+ <!-- portage variables - currently unused -->
+ <context id="portvars" style-ref="variable">
+ <match>\b((ARCH|HOMEPAGE|DESCRIPTION|IUSE|SRC_URI|LICENSE|SLOT|KEYWORDS|FILESDIR|WORKDIR|(P|R)?DEPEND|PROVIDE|DISTDIR|RESTRICT|USERLAND)|(S|D|T|PV|PF|P|PN|A)|C(XX)?FLAGS|LDFLAGS|C(HOST|TARGET|BUILD))\b</match>
+ </context>
+
+ <!-- portage functions - currently unused -->
+ <context id="portfuncs" style-ref="function">
+ <match>^(src_(unpack|compile|install|test)|pkg_(config|nofetch|setup|(pre|post)(inst|rm)))</match>
+ </context>
+
+ <!-- extra portage commands -->
+ <context id="portcmds" style-ref="command">
+ <match>\b(e(begin|end|conf|install|make|warn|infon?|error|patch)|die|use(_(with|enable))?|inherit|has|(has|best)_version|unpack|(do|new)(ins|s?bin|doc|lib(|\.so|\.a)|man|info|exe|initd|confd|envd|pam|menu|icon)|do(python|sed|dir|hard|sym|html|jar|mo)|keepdir|prepall(|docs|info|man|strip)|prep(info|lib|lib\.(so|a)|man|strip)|(|doc|ins|exe)into|f(owners|perms)|(exe|ins|dir)opts)\b</match>
+ </context>
+
+ <context id="built-in-command">
+ <include> <!-- do not include "sh:built-in-command" as it is replaced down there - which would lead to an endless loop -->
+ <context ref="sh:built-in-command-1" />
+ <context ref="sh:built-in-command-2" />
+ <context ref="portcmds" />
+ </include>
+ </context>
+
+ <!-- gentoo is just a shell with the replacements -->
+ <replace id="sh:built-in-command" ref="built-in-command" />
+ <replace id="sh:backtick-subshell" ref="subprogram-2" />
+ <context id="gentoo">
+ <include>
+ <context ref="subprogram"/>
+ <context ref="sh:sh"/>
+ </include>
+ </context>
+ </definitions>
+</language>
diff --git a/x11-libs/gtksourceview/files/gentoo.lang b/x11-libs/gtksourceview/files/gentoo.lang
new file mode 100644
index 00000000..bfca7b26
--- /dev/null
+++ b/x11-libs/gtksourceview/files/gentoo.lang
@@ -0,0 +1,59 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE language SYSTEM "language.dtd">
+
+<!--
+ GtkSourceView syntax highlight for Gentoo-specific files
+ Leonardo Ferreira Fontenelle <leo.fontenelle@gmail.com>, 2006.
+ Distributed under the same license(s) as gtksourceview.
+
+ This .lang file should provide almost the same behaviour of
+ gentoo.nanorc. The exceptions are the line-comment and string elements.
+ If you get little
+
+ TODO:
+ - some styles don't get automatic colors, why?
+ - add syntax for /etc/portage/*
+-->
+
+<language _name="Gentoo" version="1.0" _section="Scripts" mimetypes="text/plain">
+
+ <escape-char>\</escape-char>
+
+ <line-comment _name="Line Comment" style="Comment">
+ <start-regex>#</start-regex>
+ </line-comment>
+
+ <string _name="String" style="String" end-at-line-end="false">
+ <start-regex>&quot;</start-regex>
+ <end-regex>&quot;</end-regex>
+ </string>
+
+ <pattern-item _name="Bash syntax" style="Operator">
+ <regex>(\b(case|do|done|elif|else|esac|exit|fi|for|function|if|in|local|read|return|select|shift|then|time|until|while)\b|(\{|\}|\(|\)|\;|\]|\[|`|\\|\$|&gt;|%lt;|!|=|&amp;|\|)|-(e|d|f|r|g|u|w|x|L)\b|-(eq|ne|gt|lt|ge|le|s|n|z)\b)</regex>
+ </pattern-item>
+
+ <pattern-item _name="Bash variables" style="Others">
+ <regex>\$\{?[a-zA-Z_0-9]+\}?</regex>
+ </pattern-item>
+
+ <pattern-item _name="Bash commands" style="Others 2">
+ <regex>(\bmake\b|\b(cat|cd|chmod|chown|cp|echo|env|export|grep|let|ln|mkdir|mv|rm|sed|set|tar|touch|unset)\b)</regex>
+ </pattern-item>
+
+ <pattern-item _name="Portage variables" style="Keyword">
+ <regex>\b((ARCH|HOMEPAGE|DESCRIPTION|IUSE|SRC_URI|LICENSE|SLOT|KEYWORDS|FILESDIR|WORKDIR|(P|R)?DEPEND|PROVIDE|DISTDIR|RESTRICT|USERLAND)|(S|D|T|PV|PF|P|PN|A)|C(XX)?FLAGS|LDFLAGS|C(HOST|TARGET|BUILD))\b</regex>
+ </pattern-item>
+
+ <pattern-item _name="Portage commands" style="Data Type">
+ <regex>\b(e(begin|end|conf|install|make|warn|infon?|error|patch|log|javac|ant)|die|use(_(with|enable))?|inherit|has|(has|best)_version|unpack|(do|new)(ins|s?bin|doc|lib(|\.so|\.a)|man|info|exe|initd|confd|envd|pam|menu|icon)|do(python|sed|dir|hard|sym|html|jar|mo)|keepdir|prepall(|docs|info|man|strip)|prep(info|lib|lib\.(so|a)|man|strip)|(|doc|ins|exe)into|f(owners|perms)|(exe|ins|dir)opts)\b</regex>
+ </pattern-item>
+
+ <pattern-item _name="Portage functions" style="Function">
+ <regex>^(src_(unpack|compile|install|test)|pkg_(config|nofetch|setup|(pre|post)(inst|rm)))</regex>
+ </pattern-item>
+
+ <pattern-item _name="Inherits and USE flags" style="Specials">
+ <regex>(\buse(_(with|enable))?\b [\!a-zA-Z0-9_+ -]*|inherit*$)</regex>
+ </pattern-item>
+
+</language>
diff --git a/x11-libs/gtksourceview/gtksourceview-2.10.0.ebuild b/x11-libs/gtksourceview/gtksourceview-2.10.0.ebuild
new file mode 100644
index 00000000..31aca148
--- /dev/null
+++ b/x11-libs/gtksourceview/gtksourceview-2.10.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtksourceview/gtksourceview-2.8.2.ebuild,v 1.1 2009/12/21 22:10:19 eva Exp $
+
+EAPI="2"
+GCONF_DEBUG="no"
+
+inherit gnome2
+
+DESCRIPTION="A text widget implementing syntax highlighting and other features"
+HOMEPAGE="http://www.gnome.org/"
+
+LICENSE="GPL-2"
+SLOT="2.0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="doc glade"
+
+RDEPEND=">=x11-libs/gtk+-2.12
+ >=dev-libs/libxml2-2.5
+ >=dev-libs/glib-2.14
+ glade3? ( >=dev-util/glade-3.2 )"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ >=dev-util/intltool-0.40
+ >=dev-util/pkgconfig-0.9
+ doc? ( >=dev-util/gtk-doc-1 )"
+
+DOCS="AUTHORS ChangeLog HACKING MAINTAINERS NEWS README"
+
+src_prepare() {
+ gnome2_src_prepare
+
+ # Fix intltoolize broken file, see upstream #577133
+ sed "s:'\^\$\$lang\$\$':\^\$\$lang\$\$:g" -i po/Makefile.in.in \
+ || die "sed failed"
+}
+
+pkg_config() {
+ G2CONF="${G2CONF} $(use-enable glade glade-catalog)"
+}
+
+src_install() {
+ gnome2_src_install
+
+ insinto /usr/share/${PN}-2.0/language-specs
+ doins "${FILESDIR}"/2.0/gentoo.lang || die "doins failed"
+}