summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2014-10-12 18:50:23 +0200
committerGilles Dartiguelongue <eva@gentoo.org>2014-10-12 23:40:07 +0200
commitef5b49e58af0dd438eb5047ebb1ddd80c6e13e80 (patch)
tree7474e16b349fd1f6fc5363b97c525937b164c6f9 /x11-libs/gtksourceview
parentdev-cpp/gtkmm: 3.12.0 → 3.14.0 (diff)
downloadgnome-ef5b49e58af0dd438eb5047ebb1ddd80c6e13e80.tar.gz
gnome-ef5b49e58af0dd438eb5047ebb1ddd80c6e13e80.tar.bz2
gnome-ef5b49e58af0dd438eb5047ebb1ddd80c6e13e80.zip
x11-libs/gtksourceview: 3.12.3 → 3.14.0
Diffstat (limited to 'x11-libs/gtksourceview')
-rw-r--r--x11-libs/gtksourceview/Manifest10
-rw-r--r--x11-libs/gtksourceview/gtksourceview-3.14.0.ebuild (renamed from x11-libs/gtksourceview/gtksourceview-3.12.1.ebuild)24
-rw-r--r--x11-libs/gtksourceview/gtksourceview-9999.ebuild24
3 files changed, 39 insertions, 19 deletions
diff --git a/x11-libs/gtksourceview/Manifest b/x11-libs/gtksourceview/Manifest
index 1af9717d..967550ca 100644
--- a/x11-libs/gtksourceview/Manifest
+++ b/x11-libs/gtksourceview/Manifest
@@ -1,11 +1,11 @@
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA512
-DIST gtksourceview-3.12.1.tar.xz 1195804 SHA256 008cc0758197aeb4843fc4d1220cbe1586a419455b8ef2efdc9d05a2e6f6bd3e SHA512 bdbfc77908cd09127ea21f45b41006660250f8e481d0df0906f3687e5cb7b96672da64f1aba0bbd5773c32dd0523ee99c772b6e59314f2e8b8b21db185c7cb96 WHIRLPOOL f5f561ff1655211a7fb4451ed09bb7439505dac64e72a588a7e75e169f5aac7531efce7131b25cf886cfb1836add7712d0540089c6ba7fa5be37cc449149ec43
+DIST gtksourceview-3.14.0.tar.xz 1248892 SHA256 b6a6036af0209cbc591afbae2fb13d2a92898a52cb76f652b94034da1bc0eba4 SHA512 62e899a8ce26d2a13eb90097556f04e29203e8d55d2ba433789cea42bc8efd3140fef55b4efc30893147f041f50e5f03a34e8b95d5207b6be0fae4c7ac32a4ef WHIRLPOOL 4666bea0f9eecc7c1b50ef3d293e3e837296f42ebe5c2ee706d9d0efeb35247407ff3033dd849e3cf4983f8c727c04f156ded0cb461852588c6a38ffcfd17f23
-----BEGIN PGP SIGNATURE-----
-Version: GnuPG v2.0.22 (GNU/Linux)
+Version: GnuPG v2
-iEYEAREKAAYFAlNYNpAACgkQ1fmVwcYIWAa8EwCgpGeBSxdkr/FVW+eKiuTiZ0jq
-gFYAoNjUOUghFZq6O2PeHsuBVfbrPyKS
-=DBUh
+iEYEAREKAAYFAlQ6sVAACgkQ1fmVwcYIWAaFQwCbBcGxJzhjBrRU0yAtp0ujZy9J
+2PkAoKwow1alYokMRkf0n+cgmfoQl747
+=OW62
-----END PGP SIGNATURE-----
diff --git a/x11-libs/gtksourceview/gtksourceview-3.12.1.ebuild b/x11-libs/gtksourceview/gtksourceview-3.14.0.ebuild
index 708853c9..4153ad03 100644
--- a/x11-libs/gtksourceview/gtksourceview-3.12.1.ebuild
+++ b/x11-libs/gtksourceview/gtksourceview-3.14.0.ebuild
@@ -4,22 +4,25 @@
EAPI="5"
GCONF_DEBUG="no"
+VALA_MIN_API_VERSION="0.24"
+VALA_USE_DEPEND="vapigen"
-inherit gnome2 virtualx
+inherit gnome2 vala virtualx
DESCRIPTION="A text widget implementing syntax highlighting and other features"
-HOMEPAGE="http://projects.gnome.org/gtksourceview/"
+HOMEPAGE="https://wiki.gnome.org/Projects/GtkSourceView"
LICENSE="GPL-2+ LGPL-2.1+"
-SLOT="3.0/2"
-IUSE="glade +introspection"
+SLOT="3.0/3"
+IUSE="glade +introspection vala"
+REQUIRED_USE="vala? ( introspection )"
KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-solaris"
# Note: has native OSX support, prefix teams, attack!
RDEPEND="
- >=dev-libs/glib-2.37.3:2
+ >=dev-libs/glib-2.38:2
>=dev-libs/libxml2-2.6:2
- >=x11-libs/gtk+-3.11:3[introspection?]
+ >=x11-libs/gtk+-3.13.7:3[introspection?]
glade? ( >=dev-util/glade-3.9:3.10 )
introspection? ( >=dev-libs/gobject-introspection-0.9.0 )
"
@@ -28,14 +31,21 @@ DEPEND="${RDEPEND}
>=dev-util/intltool-0.50
>=sys-devel/gettext-0.17
virtual/pkgconfig
+ vala? ( $(vala_depend) )
"
+src_prepare() {
+ use vala && vala_src_prepare
+ gnome2_src_prepare
+}
+
src_configure() {
gnome2_src_configure \
--disable-deprecations \
--enable-providers \
$(use_enable glade glade-catalog) \
- $(use_enable introspection)
+ $(use_enable introspection) \
+ $(use_enable vala)
}
src_test() {
diff --git a/x11-libs/gtksourceview/gtksourceview-9999.ebuild b/x11-libs/gtksourceview/gtksourceview-9999.ebuild
index 170edb9f..7f81e14e 100644
--- a/x11-libs/gtksourceview/gtksourceview-9999.ebuild
+++ b/x11-libs/gtksourceview/gtksourceview-9999.ebuild
@@ -4,18 +4,21 @@
EAPI="5"
GCONF_DEBUG="no"
+VALA_MIN_API_VERSION="0.24"
+VALA_USE_DEPEND="vapigen"
-inherit gnome2 virtualx
+inherit gnome2 vala virtualx
if [[ ${PV} = 9999 ]]; then
inherit gnome2-live
fi
DESCRIPTION="A text widget implementing syntax highlighting and other features"
-HOMEPAGE="http://projects.gnome.org/gtksourceview/"
+HOMEPAGE="https://wiki.gnome.org/Projects/GtkSourceView"
LICENSE="GPL-2+ LGPL-2.1+"
-SLOT="3.0/2"
-IUSE="glade +introspection"
+SLOT="3.0/3"
+IUSE="glade +introspection vala"
+REQUIRED_USE="vala? ( introspection )"
if [[ ${PV} = 9999 ]]; then
IUSE="${IUSE} doc"
KEYWORDS=""
@@ -25,9 +28,9 @@ fi
# Note: has native OSX support, prefix teams, attack!
RDEPEND="
- >=dev-libs/glib-2.37.3:2
+ >=dev-libs/glib-2.38:2
>=dev-libs/libxml2-2.6:2
- >=x11-libs/gtk+-3.11:3[introspection?]
+ >=x11-libs/gtk+-3.13.7:3[introspection?]
glade? ( >=dev-util/glade-3.9:3.10 )
introspection? ( >=dev-libs/gobject-introspection-0.9.0 )
"
@@ -36,6 +39,7 @@ DEPEND="${RDEPEND}
>=dev-util/intltool-0.50
>=sys-devel/gettext-0.17
virtual/pkgconfig
+ vala? ( $(vala_depend) )
"
if [[ ${PV} = 9999 ]]; then
@@ -43,12 +47,18 @@ if [[ ${PV} = 9999 ]]; then
doc? ( >=dev-util/gtk-doc-1.11 )"
fi
+src_prepare() {
+ use vala && vala_src_prepare
+ gnome2_src_prepare
+}
+
src_configure() {
gnome2_src_configure \
--disable-deprecations \
--enable-providers \
$(use_enable glade glade-catalog) \
- $(use_enable introspection)
+ $(use_enable introspection) \
+ $(use_enable vala)
}
src_test() {