summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2015-05-10 00:30:56 +0200
committerGilles Dartiguelongue <eva@gentoo.org>2015-05-10 17:15:29 +0200
commitf549102446d0eec9e3a64adb3ab39234c774e658 (patch)
treee859519b6cdfea260418c0ede929afcb833a507b /x11-libs/gtksourceview
parenteclass: add support for newer vala slot (diff)
downloadgnome-f549102446d0eec9e3a64adb3ab39234c774e658.tar.gz
gnome-f549102446d0eec9e3a64adb3ab39234c774e658.tar.bz2
gnome-f549102446d0eec9e3a64adb3ab39234c774e658.zip
x11-libs/gtksourceview: 3.14.4 → 3.16.1
Diffstat (limited to 'x11-libs/gtksourceview')
-rw-r--r--x11-libs/gtksourceview/Manifest11
-rw-r--r--x11-libs/gtksourceview/gtksourceview-3.16.1.ebuild61
-rw-r--r--x11-libs/gtksourceview/gtksourceview-9999.ebuild12
3 files changed, 78 insertions, 6 deletions
diff --git a/x11-libs/gtksourceview/Manifest b/x11-libs/gtksourceview/Manifest
new file mode 100644
index 00000000..958ddf17
--- /dev/null
+++ b/x11-libs/gtksourceview/Manifest
@@ -0,0 +1,11 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA512
+
+DIST gtksourceview-3.16.1.tar.xz 1272152 SHA256 669e9846ca744ec4d04ce61377e85df7ca909ad476329922a6abf4da423f1b0c SHA512 8bae196d923d08e58c8f02d7612b32aa7caec8457c2ff35c2bb2322a3013a8f1fe52cbc62540f9d83054811ee517088d4e880b82733b2a73e7724a206b2ad911 WHIRLPOOL c51a0dd6ccad2262b289509f8dfa85675ba90cf4f0242358ca2d1ad857cf06e33ad0495560b726430738d827f9204c2eb63a90209171194a7c8eb163e46a1471
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v2
+
+iEYEAREKAAYFAlVOiqEACgkQ1fmVwcYIWAYSZgCgr9Pe+Czcq7LvXeliPJptTOi6
+UqEAoJfkIaIynH4oJbUE8/MNK+OlaO0Z
+=2edq
+-----END PGP SIGNATURE-----
diff --git a/x11-libs/gtksourceview/gtksourceview-3.16.1.ebuild b/x11-libs/gtksourceview/gtksourceview-3.16.1.ebuild
new file mode 100644
index 00000000..2f12fd5e
--- /dev/null
+++ b/x11-libs/gtksourceview/gtksourceview-3.16.1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="5"
+GCONF_DEBUG="no"
+VALA_MIN_API_VERSION="0.24"
+VALA_USE_DEPEND="vapigen"
+
+inherit gnome2 vala virtualx
+
+DESCRIPTION="A text widget implementing syntax highlighting and other features"
+HOMEPAGE="https://wiki.gnome.org/Projects/GtkSourceView"
+
+LICENSE="GPL-2+ LGPL-2.1+"
+SLOT="3.0/3"
+IUSE="glade +introspection vala"
+REQUIRED_USE="vala? ( introspection )"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-solaris"
+
+# Note: has native OSX support, prefix teams, attack!
+RDEPEND="
+ >=dev-libs/glib-2.44:2
+ >=dev-libs/libxml2-2.6:2
+ >=x11-libs/gtk+-3.16:3[introspection?]
+ glade? ( >=dev-util/glade-3.9:3.10 )
+ introspection? ( >=dev-libs/gobject-introspection-1.42 )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.18
+ >=dev-util/intltool-0.50
+ >=sys-devel/gettext-0.17
+ virtual/pkgconfig
+ vala? ( $(vala_depend) )
+"
+
+src_prepare() {
+ use vala && vala_src_prepare
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-deprecations \
+ --enable-providers \
+ $(use_enable glade glade-catalog) \
+ $(use_enable introspection) \
+ $(use_enable vala)
+}
+
+src_test() {
+ Xemake check
+}
+
+src_install() {
+ DOCS="AUTHORS HACKING MAINTAINERS NEWS README"
+ gnome2_src_install
+
+ insinto /usr/share/${PN}-3.0/language-specs
+ doins "${FILESDIR}"/2.0/gentoo.lang
+}
diff --git a/x11-libs/gtksourceview/gtksourceview-9999.ebuild b/x11-libs/gtksourceview/gtksourceview-9999.ebuild
index 7f81e14e..fc7de7d4 100644
--- a/x11-libs/gtksourceview/gtksourceview-9999.ebuild
+++ b/x11-libs/gtksourceview/gtksourceview-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
@@ -28,14 +28,14 @@ fi
# Note: has native OSX support, prefix teams, attack!
RDEPEND="
- >=dev-libs/glib-2.38:2
+ >=dev-libs/glib-2.44:2
>=dev-libs/libxml2-2.6:2
- >=x11-libs/gtk+-3.13.7:3[introspection?]
+ >=x11-libs/gtk+-3.16:3[introspection?]
glade? ( >=dev-util/glade-3.9:3.10 )
- introspection? ( >=dev-libs/gobject-introspection-0.9.0 )
+ introspection? ( >=dev-libs/gobject-introspection-1.42 )
"
DEPEND="${RDEPEND}
- dev-util/gtk-doc-am
+ >=dev-util/gtk-doc-am-1.18
>=dev-util/intltool-0.50
>=sys-devel/gettext-0.17
virtual/pkgconfig
@@ -44,7 +44,7 @@ DEPEND="${RDEPEND}
if [[ ${PV} = 9999 ]]; then
DEPEND="${DEPEND}
- doc? ( >=dev-util/gtk-doc-1.11 )"
+ doc? ( >=dev-util/gtk-doc-1.18 )"
fi
src_prepare() {