summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOle Reifschneider <tranquility@gentoo.org>2015-04-26 15:48:25 +0200
committerOle Reifschneider <tranquility@gentoo.org>2015-04-26 15:53:15 +0200
commit7f5d4f19c20d8d220d046827c2469e78b03fb4f8 (patch)
treeba042d776f3d563c257261df8dd4087eb95fa514 /x11-libs
parentBump gnome-pty-helper to 0.40.0 (diff)
downloadgnome-7f5d4f19c20d8d220d046827c2469e78b03fb4f8.tar.gz
gnome-7f5d4f19c20d8d220d046827c2469e78b03fb4f8.tar.bz2
gnome-7f5d4f19c20d8d220d046827c2469e78b03fb4f8.zip
Bump vte to 0.40.0
Package-Manager: portage-2.2.14 Manifest-Sign-Key: 7E8B4D42
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/vte/Manifest15
-rw-r--r--x11-libs/vte/vte-0.40.0.ebuild80
-rw-r--r--x11-libs/vte/vte-9999.ebuild6
3 files changed, 100 insertions, 1 deletions
diff --git a/x11-libs/vte/Manifest b/x11-libs/vte/Manifest
new file mode 100644
index 00000000..8f89e6db
--- /dev/null
+++ b/x11-libs/vte/Manifest
@@ -0,0 +1,15 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA256
+
+DIST vte-0.40.0.tar.xz 923156 SHA256 54d96181626f2641c78e30ccf991ea124b8713646231e52a973dea3adf02d852 SHA512 f7ff28cdefc80e7fa5d876b8cba5d396fd98aa13c21a6cd320ac4042a8747e67ebf7a7c13ddab7bebb6b839231aebcc4fc25be9f0cc6c55859886c7948d4ac79 WHIRLPOOL ccd0241b1a2aa17cc28f26d5eafd1bfaec015983ec67bb1fed55a4bf4a436826ce64dfbfd24bc64a17390c13f61b19d0670a148243f00cfbf171f4ef8d4dd3e7
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v2
+
+iQEcBAEBCAAGBQJVPOl4AAoJEOnlaGd+i01CGRwH/3VpzaSaDe6ZGTLhagDq79sR
+z73JNsFJoFqcM7MydL+D4+XVcdncNs/kj/xQdUrvE0nDI54BJkQr/hkgWybZLUzF
+DLjFsk/YKCacUD+yFp3LwrOYrCMSbLJMS5G880PZdrcFgfUk68K8Mc6AoZn2Xy2Y
+4VfJ/20MunCmtwK8Ga0usqFD44YnEt55HzCAEbvWwLp2HtsSaFM4phHHauAYwqKz
+/tfWdbCe4O4MFf4GuehbYTnfh/UF1RT5eeWAY3Zlx1/nvCJiKKSDukIjqm3pZJ0Y
+pSDzmf+Pfs5E2PQ5MfxNIFEjMPYYkrtO0Kd143hQBZe040DYsM4b1Kyq09fU8QE=
+=UoOk
+-----END PGP SIGNATURE-----
diff --git a/x11-libs/vte/vte-0.40.0.ebuild b/x11-libs/vte/vte-0.40.0.ebuild
new file mode 100644
index 00000000..3da4be58
--- /dev/null
+++ b/x11-libs/vte/vte-0.40.0.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/vte/vte-0.38.3.ebuild,v 1.6 2015/03/29 11:19:29 jer Exp $
+
+EAPI="5"
+GCONF_DEBUG="no"
+VALA_USE_DEPEND="vapigen"
+
+inherit eutils gnome2 vala
+
+DESCRIPTION="Library providing a virtual terminal emulator widget"
+HOMEPAGE="https://wiki.gnome.org/action/show/Apps/Terminal/VTE"
+
+LICENSE="LGPL-2+"
+SLOT="2.91"
+IUSE="+crypt debug glade +introspection vala"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~x64-solaris ~x86-solaris"
+
+PDEPEND=">=x11-libs/gnome-pty-helper-${PV}"
+RDEPEND="
+ >=dev-libs/glib-2.40:2
+ >=x11-libs/gtk+-3.8:3[introspection?]
+ >=x11-libs/pango-1.22.0
+
+ sys-libs/ncurses
+ sys-libs/zlib
+ x11-libs/libX11
+ x11-libs/libXft
+
+ glade? ( >=dev-util/glade-3.9:3.10 )
+ introspection? ( >=dev-libs/gobject-introspection-0.9.0 )
+"
+DEPEND="${RDEPEND}
+ $(vala_depend)
+ >=dev-util/gtk-doc-am-1.13
+ >=dev-util/intltool-0.35
+ sys-devel/gettext
+ virtual/pkgconfig
+
+ crypt? ( >=net-libs/gnutls-3.2.0 )
+"
+RDEPEND="${RDEPEND}
+ !x11-libs/vte:2.90[glade]
+"
+
+src_prepare() {
+ vala_src_prepare
+ gnome2_src_prepare
+}
+
+src_configure() {
+ local myconf=""
+
+ if [[ ${CHOST} == *-interix* ]]; then
+ myconf="${myconf} --disable-Bsymbolic"
+
+ # interix stropts.h is empty...
+ export ac_cv_header_stropts_h=no
+ fi
+
+ # Python bindings are via gobject-introspection
+ # Ex: from gi.repository import Vte
+ # Do not disable gnome-pty-helper, bug #401389
+ gnome2_src_configure \
+ --disable-deprecation \
+ --disable-test-application \
+ --disable-static \
+ $(use_enable debug) \
+ $(use_enable glade glade-catalogue) \
+ $(use_enable crypt gnutls) \
+ $(use_enable introspection) \
+ $(use_enable vala) \
+ ${myconf}
+}
+
+src_install() {
+ DOCS="AUTHORS ChangeLog HACKING NEWS README"
+ gnome2_src_install
+ mv "${D}"/etc/profile.d/vte{,-${SLOT}}.sh || die
+}
diff --git a/x11-libs/vte/vte-9999.ebuild b/x11-libs/vte/vte-9999.ebuild
index 8ba6ab5e..98ba16ba 100644
--- a/x11-libs/vte/vte-9999.ebuild
+++ b/x11-libs/vte/vte-9999.ebuild
@@ -17,7 +17,7 @@ HOMEPAGE="https://wiki.gnome.org/action/show/Apps/Terminal/VTE"
LICENSE="LGPL-2+"
SLOT="2.91"
-IUSE="debug glade +introspection vala"
+IUSE="+crypt debug glade +introspection vala"
if [[ ${PV} = 9999 ]]; then
KEYWORDS=""
IUSE="${IUSE} doc"
@@ -32,6 +32,7 @@ RDEPEND="
>=x11-libs/pango-1.22.0
sys-libs/ncurses
+ sys-libs/zlib
x11-libs/libX11
x11-libs/libXft
@@ -44,6 +45,8 @@ DEPEND="${RDEPEND}
>=dev-util/intltool-0.35
sys-devel/gettext
virtual/pkgconfig
+
+ crypt? ( >=net-libs/gnutls-3.2.0 )
"
if [[ ${PV} = 9999 ]]; then
@@ -77,6 +80,7 @@ src_configure() {
--disable-static \
$(use_enable debug) \
$(use_enable glade glade-catalogue) \
+ $(use_enable crypt gnutls) \
$(use_enable introspection) \
$(use_enable vala) \
${myconf}