summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2013-12-22 23:20:46 +0100
committerGilles Dartiguelongue <eva@gentoo.org>2013-12-22 23:20:46 +0100
commita5027f80037d7814598fd4f8d33a192512d01eaa (patch)
treea71f439a3a488403c9309c8260afbb66a403b8c0 /x11-libs
parentprofiles: Add a mask entry for evolution-mapi (diff)
downloadgnome-a5027f80037d7814598fd4f8d33a192512d01eaa.tar.gz
gnome-a5027f80037d7814598fd4f8d33a192512d01eaa.tar.bz2
gnome-a5027f80037d7814598fd4f8d33a192512d01eaa.zip
x11-libs/vte: fix repoman issues
* Sync with gentoo-x86 * Applied team policy
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/vte/metadata.xml8
-rw-r--r--x11-libs/vte/vte-9999.ebuild68
2 files changed, 47 insertions, 29 deletions
diff --git a/x11-libs/vte/metadata.xml b/x11-libs/vte/metadata.xml
new file mode 100644
index 00000000..c47f7541
--- /dev/null
+++ b/x11-libs/vte/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>gnome</herd>
+ <use>
+ <flag name='glade'>Provide integration with <pkg>dev-util/glade</pkg>.</flag>
+ </use>
+</pkgmetadata>
diff --git a/x11-libs/vte/vte-9999.ebuild b/x11-libs/vte/vte-9999.ebuild
index 99605980..23624478 100644
--- a/x11-libs/vte/vte-9999.ebuild
+++ b/x11-libs/vte/vte-9999.ebuild
@@ -1,30 +1,31 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-EAPI="4"
+EAPI="5"
GCONF_DEBUG="yes"
-GNOME2_LA_PUNT="yes"
inherit eutils gnome2
if [[ ${PV} = 9999 ]]; then
inherit gnome2-live
fi
-DESCRIPTION="GNOME terminal widget"
-HOMEPAGE="https://live.gnome.org/VTE"
+DESCRIPTION="Library providing a virtual terminal emulator widget"
+HOMEPAGE="https://wiki.gnome.org/action/show/Apps/Terminal/VTE"
LICENSE="LGPL-2+"
SLOT="2.90"
-IUSE="debug doc glade +introspection"
+IUSE="debug glade +introspection"
if [[ ${PV} = 9999 ]]; then
KEYWORDS=""
+ IUSE="${IUSE} doc"
else
- KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~x64-solaris ~x86-solaris"
+ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~x64-solaris ~x86-solaris"
fi
PDEPEND="x11-libs/gnome-pty-helper"
-RDEPEND=">=dev-libs/glib-2.31.13:2
+RDEPEND="
+ >=dev-libs/glib-2.31.13:2
>=x11-libs/gtk+-3.1.9:3[introspection?]
>=x11-libs/pango-1.22.0
@@ -33,42 +34,51 @@ RDEPEND=">=dev-libs/glib-2.31.13:2
x11-libs/libXft
glade? ( >=dev-util/glade-3.9:3.10 )
- introspection? ( >=dev-libs/gobject-introspection-0.9.0 )"
+ introspection? ( >=dev-libs/gobject-introspection-0.9.0 )
+"
DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.13
>=dev-util/intltool-0.35
sys-devel/gettext
virtual/pkgconfig
- doc? ( >=dev-util/gtk-doc-1.13 )"
+"
-pkg_setup() {
- # Python bindings are via gobject-introspection
- # Ex: from gi.repository import Vte
- # Do not disable gnome-pty-helper, bug #401389
- G2CONF="${G2CONF}
- --disable-deprecation
- --disable-static
- $(use_enable debug)
- $(use_enable glade glade-catalogue)
- $(use_enable introspection)"
+if [[ ${PV} = 9999 ]]; then
+ DEPEND="${DEPEND}
+ doc? ( >=dev-util/gtk-doc-1.13 )"
+fi
+
+src_prepare() {
+ # https://bugzilla.gnome.org/show_bug.cgi?id=663779
+ epatch "${FILESDIR}/${PN}-0.30.1-alt-meta.patch"
+
+ gnome2_src_prepare
+}
+
+src_configure() {
+ local myconf=""
if [[ ${CHOST} == *-interix* ]]; then
- G2CONF="${G2CONF} --disable-Bsymbolic"
+ myconf="${myconf} --disable-Bsymbolic"
# interix stropts.h is empty...
export ac_cv_header_stropts_h=no
fi
- DOCS="AUTHORS ChangeLog HACKING NEWS README"
-}
-
-src_prepare() {
- # https://bugzilla.gnome.org/show_bug.cgi?id=663779
- epatch "${FILESDIR}/${PN}-0.30.1-alt-meta.patch"
-
- gnome2_src_prepare
+ # Python bindings are via gobject-introspection
+ # Ex: from gi.repository import Vte
+ # Do not disable gnome-pty-helper, bug #401389
+ gnome2_src_configure \
+ --disable-deprecation \
+ --disable-static \
+ $(use_enable debug) \
+ $(use_enable glade glade-catalogue) \
+ $(use_enable introspection) \
+ ${myconf}
}
src_install() {
+ DOCS="AUTHORS ChangeLog HACKING NEWS README"
gnome2_src_install
rm -v "${ED}usr/libexec/gnome-pty-helper" || die
}