summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRémi Cardona <remi@gentoo.org>2014-11-24 00:23:37 +0100
committerRémi Cardona <remi@gentoo.org>2014-11-24 00:48:55 +0100
commitf3cdc71f834a3723ae85a4f80acde76cdb42e721 (patch)
treed8d09a644488504699351c9efbea16acb0972488 /x11-libs
parentgnome-extra/gnome-contacts: 3.14.1 → 3.14.2 (diff)
downloadgnome-f3cdc71f834a3723ae85a4f80acde76cdb42e721.tar.gz
gnome-f3cdc71f834a3723ae85a4f80acde76cdb42e721.tar.bz2
gnome-f3cdc71f834a3723ae85a4f80acde76cdb42e721.zip
x11-libs/gtk+: sync with portage (mostly multilib)
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/gtk+/gtk+-3.14.4.ebuild121
-rw-r--r--x11-libs/gtk+/gtk+-9999.ebuild119
2 files changed, 141 insertions, 99 deletions
diff --git a/x11-libs/gtk+/gtk+-3.14.4.ebuild b/x11-libs/gtk+/gtk+-3.14.4.ebuild
index f6d91923..122f8e6a 100644
--- a/x11-libs/gtk+/gtk+-3.14.4.ebuild
+++ b/x11-libs/gtk+/gtk+-3.14.4.ebuild
@@ -6,7 +6,7 @@ EAPI="5"
GCONF_DEBUG="no"
GNOME2_LA_PUNT="yes"
-inherit eutils flag-o-matic gnome2 multilib virtualx
+inherit eutils flag-o-matic gnome2 multilib virtualx multilib-minimal
DESCRIPTION="Gimp ToolKit +"
HOMEPAGE="http://www.gtk.org/"
@@ -30,38 +30,38 @@ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86
# NOTE: cairo[svg] dep is due to bug 291283 (not patched to avoid eautoreconf)
# Use gtk+:2 for gtk-update-icon-cache
COMMON_DEPEND="
- >=dev-libs/atk-2.12[introspection?]
- >=dev-libs/glib-2.41.2:2
- media-libs/fontconfig
- >=x11-libs/cairo-1.12[aqua?,glib,svg,X?]
- >=x11-libs/gdk-pixbuf-2.30:2[introspection?,X?]
- >=x11-libs/gtk+-2.24:2
- >=x11-libs/pango-1.36.7[introspection?]
+ >=dev-libs/atk-2.12[introspection?,${MULTILIB_USEDEP}]
+ >=dev-libs/glib-2.41.2:2[${MULTILIB_USEDEP}]
+ media-libs/fontconfig[${MULTILIB_USEDEP}]
+ >=x11-libs/cairo-1.12[aqua?,glib,svg,X?,${MULTILIB_USEDEP}]
+ >=x11-libs/gdk-pixbuf-2.30:2[introspection?,X?,${MULTILIB_USEDEP}]
+ >=x11-libs/gtk+-2.24:2[${MULTILIB_USEDEP}]
+ >=x11-libs/pango-1.36.7[introspection?,${MULTILIB_USEDEP}]
x11-misc/shared-mime-info
cloudprint? (
- >=net-libs/rest-0.7
- >=dev-libs/json-glib-1.0 )
- colord? ( >=x11-misc/colord-0.1.9:0= )
- cups? ( >=net-print/cups-1.2 )
+ >=net-libs/rest-0.7[${MULTILIB_USEDEP}]
+ >=dev-libs/json-glib-1.0[${MULTILIB_USEDEP}] )
+ colord? ( >=x11-misc/colord-0.1.9:0=[${MULTILIB_USEDEP}] )
+ cups? ( >=net-print/cups-1.2[${MULTILIB_USEDEP}] )
introspection? ( >=dev-libs/gobject-introspection-1.39 )
wayland? (
- >=dev-libs/wayland-1.5.91
- media-libs/mesa[wayland]
- >=x11-libs/libxkbcommon-0.2
+ >=dev-libs/wayland-1.5.91[${MULTILIB_USEDEP}]
+ media-libs/mesa[wayland,${MULTILIB_USEDEP}]
+ >=x11-libs/libxkbcommon-0.2[${MULTILIB_USEDEP}]
)
X? (
- >=app-accessibility/at-spi2-atk-2.5.3
- x11-libs/libXrender
- x11-libs/libX11
- >=x11-libs/libXi-1.3
- x11-libs/libXext
- >=x11-libs/libXrandr-1.3
- x11-libs/libXcursor
- x11-libs/libXfixes
- x11-libs/libXcomposite
- x11-libs/libXdamage
- xinerama? ( x11-libs/libXinerama )
+ >=app-accessibility/at-spi2-atk-2.5.3[${MULTILIB_USEDEP}]
+ x11-libs/libXrender[${MULTILIB_USEDEP}]
+ x11-libs/libX11[${MULTILIB_USEDEP}]
+ >=x11-libs/libXi-1.3[${MULTILIB_USEDEP}]
+ x11-libs/libXext[${MULTILIB_USEDEP}]
+ >=x11-libs/libXrandr-1.3[${MULTILIB_USEDEP}]
+ x11-libs/libXcursor[${MULTILIB_USEDEP}]
+ x11-libs/libXfixes[${MULTILIB_USEDEP}]
+ x11-libs/libXcomposite[${MULTILIB_USEDEP}]
+ x11-libs/libXdamage[${MULTILIB_USEDEP}]
+ xinerama? ( x11-libs/libXinerama[${MULTILIB_USEDEP}] )
)
"
DEPEND="${COMMON_DEPEND}
@@ -71,13 +71,13 @@ DEPEND="${COMMON_DEPEND}
dev-util/gdbus-codegen
>=dev-util/gtk-doc-am-1.20
sys-devel/gettext
- virtual/pkgconfig
+ virtual/pkgconfig[${MULTILIB_USEDEP}]
X? (
- x11-proto/xextproto
- x11-proto/xproto
- x11-proto/inputproto
- x11-proto/damageproto
- xinerama? ( x11-proto/xineramaproto )
+ x11-proto/xextproto[${MULTILIB_USEDEP}]
+ x11-proto/xproto[${MULTILIB_USEDEP}]
+ x11-proto/inputproto[${MULTILIB_USEDEP}]
+ x11-proto/damageproto[${MULTILIB_USEDEP}]
+ xinerama? ( x11-proto/xineramaproto[${MULTILIB_USEDEP}] )
)
test? (
media-fonts/font-misc-misc
@@ -94,6 +94,10 @@ RDEPEND="${COMMON_DEPEND}
"
PDEPEND="vim-syntax? ( app-vim/gtk-syntax )"
+MULTILIB_CHOST_TOOLS=(
+ /usr/bin/gtk-query-immodules-3.0
+)
+
strip_builddir() {
local rule=$1
shift
@@ -127,17 +131,18 @@ src_prepare() {
gnome2_src_prepare
}
-src_configure() {
+multilib_src_configure() {
# Passing --disable-debug is not recommended for production use
# need libdir here to avoid a double slash in a path that libtool doesn't
# grok so well during install (// between $EPREFIX and usr ...)
+ ECONF_SOURCE=${S} \
gnome2_src_configure \
$(use_enable aqua quartz-backend) \
$(use_enable cloudprint) \
$(use_enable colord) \
$(use_enable cups cups auto) \
$(usex debug --enable-debug=yes "") \
- $(use_enable introspection) \
+ $(multilib_native_use_enable introspection) \
$(use_enable wayland wayland-backend) \
$(use_enable X x11-backend) \
$(use_enable X xcomposite) \
@@ -151,9 +156,17 @@ src_configure() {
--enable-gtk2-dependency \
--with-xml-catalog="${EPREFIX}"/etc/xml/catalog \
--libdir="${EPREFIX}"/usr/$(get_libdir)
+
+ # work-around gtk-doc out-of-source brokedness
+ if multilib_is_native_abi; then
+ local d
+ for d in gdk gtk libgail-util; do
+ ln -s "${S}"/docs/reference/${d}/html docs/reference/${d}/html || die
+ done
+ fi
}
-src_test() {
+multilib_src_test() {
# Tests require a new gnome-themes-standard, but adding it to DEPEND
# would result in circular dependencies.
# https://bugzilla.gnome.org/show_bug.cgi?id=669562
@@ -171,14 +184,9 @@ src_test() {
GSETTINGS_SCHEMA_DIR="${S}/gtk" Xemake check
}
-src_install() {
+multilib_src_install() {
gnome2_src_install
- insinto /etc/gtk-3.0
- doins "${FILESDIR}"/settings.ini
-
- dodoc AUTHORS ChangeLog* HACKING NEWS* README*
-
# add -framework Carbon to the .pc files
if use aqua ; then
for i in gtk+-3.0.pc gtk+-quartz-3.0.pc gtk+-unix-print-3.0.pc; do
@@ -188,17 +196,27 @@ src_install() {
fi
}
+multilib_src_install_all() {
+ insinto /etc/gtk-3.0
+ doins "${FILESDIR}"/settings.ini
+
+ dodoc AUTHORS ChangeLog* HACKING NEWS* README*
+}
+
pkg_preinst() {
gnome2_pkg_preinst
- # Make sure loaders.cache belongs to gdk-pixbuf alone
- local cache="usr/$(get_libdir)/gtk-3.0/3.0.0/immodules.cache"
-
- if [[ -e ${EROOT}${cache} ]]; then
- cp "${EROOT}"${cache} "${ED}"/${cache} || die
- else
- touch "${ED}"/${cache} || die
- fi
+ multilib_pkg_preinst() {
+ # Make sure loaders.cache belongs to gdk-pixbuf alone
+ local cache="usr/$(get_libdir)/gtk-3.0/3.0.0/immodules.cache"
+
+ if [[ -e ${EROOT}${cache} ]]; then
+ cp "${EROOT}"${cache} "${ED}"/${cache} || die
+ else
+ touch "${ED}"/${cache} || die
+ fi
+ }
+ multilib_parallel_foreach_abi multilib_pkg_preinst
}
pkg_postinst() {
@@ -216,6 +234,9 @@ pkg_postrm() {
gnome2_pkg_postrm
if [[ -z ${REPLACED_BY_VERSIONS} ]]; then
- rm -f "${EROOT}"usr/$(get_libdir)/gtk-3.0/3.0.0/immodules.cache
+ multilib_pkg_postrm() {
+ rm -f "${EROOT}"usr/$(get_libdir)/gtk-3.0/3.0.0/immodules.cache
+ }
+ multilib_foreach_abi multilib_pkg_postrm
fi
}
diff --git a/x11-libs/gtk+/gtk+-9999.ebuild b/x11-libs/gtk+/gtk+-9999.ebuild
index c704c0c1..f2ec93c9 100644
--- a/x11-libs/gtk+/gtk+-9999.ebuild
+++ b/x11-libs/gtk+/gtk+-9999.ebuild
@@ -6,7 +6,7 @@ EAPI="5"
GCONF_DEBUG="no"
GNOME2_LA_PUNT="yes"
-inherit eutils flag-o-matic gnome2 multilib virtualx
+inherit eutils flag-o-matic gnome2 multilib virtualx multilib-minimal
if [[ ${PV} = 9999 ]]; then
inherit gnome2-live
fi
@@ -38,38 +38,38 @@ fi
# NOTE: cairo[svg] dep is due to bug 291283 (not patched to avoid eautoreconf)
# Use gtk+:2 for gtk-update-icon-cache
COMMON_DEPEND="
- >=dev-libs/atk-2.12[introspection?]
- >=dev-libs/glib-2.41.2:2
- media-libs/fontconfig
- >=x11-libs/cairo-1.12[aqua?,glib,svg,X?]
- >=x11-libs/gdk-pixbuf-2.30:2[introspection?,X?]
- >=x11-libs/gtk+-2.24:2
- >=x11-libs/pango-1.36.7[introspection?]
+ >=dev-libs/atk-2.12[introspection?,${MULTILIB_USEDEP}]
+ >=dev-libs/glib-2.41.2:2[${MULTILIB_USEDEP}]
+ media-libs/fontconfig[${MULTILIB_USEDEP}]
+ >=x11-libs/cairo-1.12[aqua?,glib,svg,X?,${MULTILIB_USEDEP}]
+ >=x11-libs/gdk-pixbuf-2.30:2[introspection?,X?,${MULTILIB_USEDEP}]
+ >=x11-libs/gtk+-2.24:2[${MULTILIB_USEDEP}]
+ >=x11-libs/pango-1.36.7[introspection?,${MULTILIB_USEDEP}]
x11-misc/shared-mime-info
cloudprint? (
- >=net-libs/rest-0.7
- >=dev-libs/json-glib-1.0 )
- colord? ( >=x11-misc/colord-0.1.9:0= )
- cups? ( >=net-print/cups-1.2 )
+ >=net-libs/rest-0.7[${MULTILIB_USEDEP}]
+ >=dev-libs/json-glib-1.0[${MULTILIB_USEDEP}] )
+ colord? ( >=x11-misc/colord-0.1.9:0=[${MULTILIB_USEDEP}] )
+ cups? ( >=net-print/cups-1.2[${MULTILIB_USEDEP}] )
introspection? ( >=dev-libs/gobject-introspection-1.39 )
wayland? (
- >=dev-libs/wayland-1.5.91
- media-libs/mesa[wayland]
- >=x11-libs/libxkbcommon-0.2
+ >=dev-libs/wayland-1.5.91[${MULTILIB_USEDEP}]
+ media-libs/mesa[wayland,${MULTILIB_USEDEP}]
+ >=x11-libs/libxkbcommon-0.2[${MULTILIB_USEDEP}]
)
X? (
- >=app-accessibility/at-spi2-atk-2.5.3
- x11-libs/libXrender
- x11-libs/libX11
- >=x11-libs/libXi-1.3
- x11-libs/libXext
- >=x11-libs/libXrandr-1.3
- x11-libs/libXcursor
- x11-libs/libXfixes
- x11-libs/libXcomposite
- x11-libs/libXdamage
- xinerama? ( x11-libs/libXinerama )
+ >=app-accessibility/at-spi2-atk-2.5.3[${MULTILIB_USEDEP}]
+ x11-libs/libXrender[${MULTILIB_USEDEP}]
+ x11-libs/libX11[${MULTILIB_USEDEP}]
+ >=x11-libs/libXi-1.3[${MULTILIB_USEDEP}]
+ x11-libs/libXext[${MULTILIB_USEDEP}]
+ >=x11-libs/libXrandr-1.3[${MULTILIB_USEDEP}]
+ x11-libs/libXcursor[${MULTILIB_USEDEP}]
+ x11-libs/libXfixes[${MULTILIB_USEDEP}]
+ x11-libs/libXcomposite[${MULTILIB_USEDEP}]
+ x11-libs/libXdamage[${MULTILIB_USEDEP}]
+ xinerama? ( x11-libs/libXinerama[${MULTILIB_USEDEP}] )
)
"
DEPEND="${COMMON_DEPEND}
@@ -79,13 +79,13 @@ DEPEND="${COMMON_DEPEND}
dev-util/gdbus-codegen
>=dev-util/gtk-doc-am-1.20
sys-devel/gettext
- virtual/pkgconfig
+ virtual/pkgconfig[${MULTILIB_USEDEP}]
X? (
- x11-proto/xextproto
- x11-proto/xproto
- x11-proto/inputproto
- x11-proto/damageproto
- xinerama? ( x11-proto/xineramaproto )
+ x11-proto/xextproto[${MULTILIB_USEDEP}]
+ x11-proto/xproto[${MULTILIB_USEDEP}]
+ x11-proto/inputproto[${MULTILIB_USEDEP}]
+ x11-proto/damageproto[${MULTILIB_USEDEP}]
+ xinerama? ( x11-proto/xineramaproto[${MULTILIB_USEDEP}] )
)
test? (
media-fonts/font-misc-misc
@@ -108,6 +108,10 @@ RDEPEND="${COMMON_DEPEND}
"
PDEPEND="vim-syntax? ( app-vim/gtk-syntax )"
+MULTILIB_CHOST_TOOLS=(
+ /usr/bin/gtk-query-immodules-3.0
+)
+
strip_builddir() {
local rule=$1
shift
@@ -141,7 +145,7 @@ src_prepare() {
[[ ${PV} = 9999 ]] && gnome2_src_prepare
}
-src_configure() {
+multilib_src_configure() {
local myconf=""
[[ ${PV} = 9999 ]] && myconf="${myconf} $(use_enable doc gtk-doc)"
@@ -149,13 +153,14 @@ src_configure() {
# Passing --disable-debug is not recommended for production use
# need libdir here to avoid a double slash in a path that libtool doesn't
# grok so well during install (// between $EPREFIX and usr ...)
+ ECONF_SOURCE=${S} \
gnome2_src_configure \
$(use_enable aqua quartz-backend) \
$(use_enable cloudprint) \
$(use_enable colord) \
$(use_enable cups cups auto) \
$(usex debug --enable-debug=yes "") \
- $(use_enable introspection) \
+ $(multilib_native_use_enable introspection) \
$(use_enable wayland wayland-backend) \
$(use_enable X x11-backend) \
$(use_enable X xcomposite) \
@@ -170,9 +175,17 @@ src_configure() {
--with-xml-catalog="${EPREFIX}"/etc/xml/catalog \
--libdir="${EPREFIX}"/usr/$(get_libdir) \
${myconf}
+
+ # work-around gtk-doc out-of-source brokedness
+ if multilib_is_native_abi; then
+ local d
+ for d in gdk gtk libgail-util; do
+ ln -s "${S}"/docs/reference/${d}/html docs/reference/${d}/html || die
+ done
+ fi
}
-src_test() {
+multilib_src_test() {
# Tests require a new gnome-themes-standard, but adding it to DEPEND
# would result in circular dependencies.
# https://bugzilla.gnome.org/show_bug.cgi?id=669562
@@ -190,14 +203,9 @@ src_test() {
GSETTINGS_SCHEMA_DIR="${S}/gtk" Xemake check
}
-src_install() {
+multilib_src_install() {
gnome2_src_install
- insinto /etc/gtk-3.0
- doins "${FILESDIR}"/settings.ini
-
- dodoc AUTHORS ChangeLog* HACKING NEWS* README*
-
# add -framework Carbon to the .pc files
if use aqua ; then
for i in gtk+-3.0.pc gtk+-quartz-3.0.pc gtk+-unix-print-3.0.pc; do
@@ -207,17 +215,27 @@ src_install() {
fi
}
+multilib_src_install_all() {
+ insinto /etc/gtk-3.0
+ doins "${FILESDIR}"/settings.ini
+
+ dodoc AUTHORS ChangeLog* HACKING NEWS* README*
+}
+
pkg_preinst() {
gnome2_pkg_preinst
- # Make sure loaders.cache belongs to gdk-pixbuf alone
- local cache="usr/$(get_libdir)/gtk-3.0/3.0.0/immodules.cache"
+ multilib_pkg_preinst() {
+ # Make sure loaders.cache belongs to gdk-pixbuf alone
+ local cache="usr/$(get_libdir)/gtk-3.0/3.0.0/immodules.cache"
- if [[ -e ${EROOT}${cache} ]]; then
- cp "${EROOT}"${cache} "${ED}"/${cache} || die
- else
- touch "${ED}"/${cache} || die
- fi
+ if [[ -e ${EROOT}${cache} ]]; then
+ cp "${EROOT}"${cache} "${ED}"/${cache} || die
+ else
+ touch "${ED}"/${cache} || die
+ fi
+ }
+ multilib_parallel_foreach_abi multilib_pkg_preinst
}
pkg_postinst() {
@@ -235,6 +253,9 @@ pkg_postrm() {
gnome2_pkg_postrm
if [[ -z ${REPLACED_BY_VERSIONS} ]]; then
- rm -f "${EROOT}"usr/$(get_libdir)/gtk-3.0/3.0.0/immodules.cache
+ multilib_pkg_postrm() {
+ rm -f "${EROOT}"usr/$(get_libdir)/gtk-3.0/3.0.0/immodules.cache
+ }
+ multilib_foreach_abi multilib_pkg_postrm
fi
}