summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan Callen <abcd@gentoo.org>2010-06-23 00:52:54 -0400
committerJonathan Callen <abcd@gentoo.org>2010-06-23 17:10:46 -0400
commit33fc6806ff9631b96753c9abb569f68e91a77bff (patch)
tree5b18ce3e6c02255029f8faa28dfe52e11ae8a6f1 /x11-misc
parentmedia-gfx/eog: add, mask 2.31.3 (diff)
downloadgnome-33fc6806ff9631b96753c9abb569f68e91a77bff.tar.gz
gnome-33fc6806ff9631b96753c9abb569f68e91a77bff.tar.bz2
gnome-33fc6806ff9631b96753c9abb569f68e91a77bff.zip
x11-misc/alacarte: add, mask 0.13.1
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/alacarte/Manifest2
-rw-r--r--x11-misc/alacarte/alacarte-0.13.1.ebuild49
2 files changed, 51 insertions, 0 deletions
diff --git a/x11-misc/alacarte/Manifest b/x11-misc/alacarte/Manifest
new file mode 100644
index 00000000..d02e7b45
--- /dev/null
+++ b/x11-misc/alacarte/Manifest
@@ -0,0 +1,2 @@
+DIST alacarte-0.13.1.tar.bz2 190512 RMD160 66c7614b4ad6e48b8b26613d813f23c52b59a741 SHA1 bff3bfacaf0793951799bf29718b08b2f85d5f8d SHA256 76bfea066ee7e0d2b7d878d4da6452594cf9b41039c8748de06a982c162f150f
+EBUILD alacarte-0.13.1.ebuild 1073 RMD160 d97ef784330919f7f2f1329ae87caa5a26428d4c SHA1 c74ddacec83c76bfc41fa9c9c23e726ac6635e3a SHA256 372e608410865ee43c4382f0520bedfddaff690512de9f41eb0ec02f0c2d93c2
diff --git a/x11-misc/alacarte/alacarte-0.13.1.ebuild b/x11-misc/alacarte/alacarte-0.13.1.ebuild
new file mode 100644
index 00000000..477a49f0
--- /dev/null
+++ b/x11-misc/alacarte/alacarte-0.13.1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/alacarte/alacarte-0.12.4.ebuild,v 1.3 2010/06/04 20:55:50 maekke Exp $
+
+EAPI="3"
+GCONF_DEBUG="no"
+PYTHON_DEPEND="2:2.4"
+inherit gnome2 python
+
+DESCRIPTION="Simple GNOME menu editor"
+HOMEPAGE="http://live.gnome.org/"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+SLOT=0
+
+common_depends=">=dev-python/pygobject-2.15.1
+ >=dev-python/pygtk-2.13
+ >=gnome-base/gnome-menus-2.27.92[python]"
+
+RDEPEND="${common_depends}
+ >=gnome-base/gnome-panel-2.16"
+
+DEPEND="${common_depends}
+ sys-devel/gettext
+ >=dev-util/intltool-0.40.0
+ >=dev-util/pkgconfig-0.19"
+
+DOCS="AUTHORS ChangeLog NEWS README"
+
+src_prepare() {
+ gnome2_src_prepare
+
+ # disable pyc compiling
+ mv py-compile py-compile.orig
+ ln -s $(type -P true) py-compile
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ python_need_rebuild
+ python_mod_optimize Alacarte
+}
+
+pkg_postrm() {
+ gnome2_pkg_postrm
+ python_mod_cleanup Alacarte
+}