summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2017-08-14 18:10:54 +0200
committerGilles Dartiguelongue <eva@gentoo.org>2017-08-14 18:10:54 +0200
commita429aba5f83d1648e7f42b050dc260b33a494134 (patch)
tree7b59365837045f89329df8abed1e99df75f6d65c /x11-themes/gtk-engines-unico/gtk-engines-unico-9999.ebuild
parentx11-themes/gnome-themes-standard: sync with gentoo repository (diff)
downloadgnome-a429aba5f83d1648e7f42b050dc260b33a494134.tar.gz
gnome-a429aba5f83d1648e7f42b050dc260b33a494134.tar.bz2
gnome-a429aba5f83d1648e7f42b050dc260b33a494134.zip
x11-themes/gtk-engines-unico: sync with gentoo repository
Package-Manager: Portage-2.3.7, Repoman-2.3.3 Manifest-Sign-Key: 0x5A56C8CD0C13248A
Diffstat (limited to 'x11-themes/gtk-engines-unico/gtk-engines-unico-9999.ebuild')
-rw-r--r--x11-themes/gtk-engines-unico/gtk-engines-unico-9999.ebuild47
1 files changed, 15 insertions, 32 deletions
diff --git a/x11-themes/gtk-engines-unico/gtk-engines-unico-9999.ebuild b/x11-themes/gtk-engines-unico/gtk-engines-unico-9999.ebuild
index f9bde6bb..6e9b57b8 100644
--- a/x11-themes/gtk-engines-unico/gtk-engines-unico-9999.ebuild
+++ b/x11-themes/gtk-engines-unico/gtk-engines-unico-9999.ebuild
@@ -1,24 +1,26 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Id$
EAPI=5
-inherit eutils
+AUTOTOOLS_AUTORECONF=yes
+AUTOTOOLS_PRUNE_LIBTOOL_FILES=modules
+
+inherit autotools-multilib eutils
if [[ ${PV} = 9999 ]]; then
EBZR_REPO_URI="lp:unico"
- GCONF_DEBUG="no"
- inherit bzr gnome2-live # need gnome2-live for generating the build system
+ inherit bzr
fi
MY_PN=${PN/gtk-engines-}
-MY_P=${MY_PN}-${PV}
+MY_PV=${PV/_pre/+14.04.}
+MY_P=${MY_PN}_${MY_PV}
DESCRIPTION="The Unico GTK+ 3.x theming engine"
HOMEPAGE="https://launchpad.net/unico"
if [[ ${PV} != 9999 ]]; then
- SRC_URI="https://launchpad.net/ubuntu/oneiric/+source/gtk3-engines-unico/${MY_PV}-0ubuntu1/+files/gtk3-engines-unico_${MY_PV}.orig.tar.gz"
- S="${WORKDIR}/${MY_PN}-${MY_PV}"
+ SRC_URI="https://launchpad.net/ubuntu/+archive/primary/+files/${MY_P}.orig.tar.gz"
+ S=${WORKDIR}/${MY_PN}-${MY_PV}
fi
LICENSE="LGPL-2.1+"
@@ -31,41 +33,22 @@ else
fi
RDEPEND="
- >=dev-libs/glib-2.26:2
- >=x11-libs/cairo-1.10[glib]
- >=x11-libs/gtk+-3.5.2:3
-"
+ >=dev-libs/glib-2.26:2[${MULTILIB_USEDEP}]
+ >=x11-libs/cairo-1.10[glib,${MULTILIB_USEDEP}]
+ >=x11-libs/gtk+-3.5.2:3[${MULTILIB_USEDEP}]"
DEPEND="${RDEPEND}
virtual/pkgconfig
"
src_unpack() {
- if [[ ${PV} = 9999 ]]; then
- bzr_src_unpack
- else
- default
- fi
-}
-
-src_prepare() {
- if [[ ${PV} = 9999 ]]; then
- gnome2-live_src_prepare
- else
- default
- fi
+ bzr_src_unpack
}
src_configure() {
# $(use_enable debug) controls CPPFLAGS -D_DEBUG and -DNDEBUG but they are currently
# unused in the code itself.
- econf \
+ autotools-multilib_src_configure \
--disable-static \
--disable-debug \
--disable-maintainer-flags
}
-
-src_install() {
- DOCS="AUTHORS NEWS" # ChangeLog, README are empty
- default
- prune_libtool_files --modules
-}