summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2014-04-12 16:49:55 +0200
committerGilles Dartiguelongue <eva@gentoo.org>2014-04-12 17:14:29 +0200
commitdd8ea06356bb2d0b7e566583b00530760963e24a (patch)
tree890491a5a34a28f6a637d4d08cb8c46a00a6b35c /x11-themes
parentx11-themes/gnome-icon-theme-symbolic: 3.10.1 → 3.12.0 (diff)
downloadgnome-dd8ea06356bb2d0b7e566583b00530760963e24a.tar.gz
gnome-dd8ea06356bb2d0b7e566583b00530760963e24a.tar.bz2
gnome-dd8ea06356bb2d0b7e566583b00530760963e24a.zip
x11-themes/gnome-themes-standard: 3.10.0 → 3.12.0
Diffstat (limited to 'x11-themes')
-rw-r--r--x11-themes/gnome-themes-standard/Manifest11
-rw-r--r--x11-themes/gnome-themes-standard/gnome-themes-standard-3.12.0.ebuild64
-rw-r--r--x11-themes/gnome-themes-standard/gnome-themes-standard-9999.ebuild2
3 files changed, 76 insertions, 1 deletions
diff --git a/x11-themes/gnome-themes-standard/Manifest b/x11-themes/gnome-themes-standard/Manifest
new file mode 100644
index 00000000..86422381
--- /dev/null
+++ b/x11-themes/gnome-themes-standard/Manifest
@@ -0,0 +1,11 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA512
+
+DIST gnome-themes-standard-3.12.0.tar.xz 5911004 SHA256 a05d1b7ca872b944a69d0c0cc2369408ece32ff4355e37f8594a1b70d13c3217 SHA512 670ca40d0c8e79cc4aebd584ea44ef7adad3251116d1f2f26b402e52fbeac69069b10d0c262ceda01b6a455a0f4c86f7121fdc4cb611cf8b0d9813aae6ceb4b7 WHIRLPOOL 1b5eafad6306db1854830daa72b0e20293d9eb86fa9cdb8da902575d0fed73d497c71be096108b5545d60c8b03c051fc3ef74af1e3999570af0e7e4353b7033a
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v2.0.22 (GNU/Linux)
+
+iEYEAREKAAYFAlNJUpQACgkQ1fmVwcYIWAYtHgCgp0sg5VHscbruMIMKjjrHC9Nn
+/eIAnRpsmEe9ct8lQfcZSBPs6UtoCAEp
+=ioSo
+-----END PGP SIGNATURE-----
diff --git a/x11-themes/gnome-themes-standard/gnome-themes-standard-3.12.0.ebuild b/x11-themes/gnome-themes-standard/gnome-themes-standard-3.12.0.ebuild
new file mode 100644
index 00000000..720614b8
--- /dev/null
+++ b/x11-themes/gnome-themes-standard/gnome-themes-standard-3.12.0.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="5"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+
+inherit gnome2
+
+DESCRIPTION="Standard Themes for GNOME Applications"
+HOMEPAGE="https://git.gnome.org/browse/gnome-themes-standard/"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+IUSE="+gtk"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~arm-linux ~x86-linux ~x64-solaris ~x86-solaris"
+
+COMMON_DEPEND="
+ gnome-base/librsvg:2
+ x11-libs/cairo
+ >=x11-themes/gtk-engines-2.15.3:2
+ gtk? (
+ >=x11-libs/gtk+-2.24.15:2
+ >=x11-libs/gtk+-3.9.12:3 )
+"
+DEPEND="${COMMON_DEPEND}
+ >=dev-util/intltool-0.40
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+# gnome-themes{,-extras} are OBSOLETE for GNOME 3
+# http://comments.gmane.org/gmane.comp.gnome.desktop/44130
+# Depend on gsettings-desktop-schemas-3.4 to make sure 3.2 users don't lose
+# their default background image
+RDEPEND="${COMMON_DEPEND}
+ >=gnome-base/gsettings-desktop-schemas-3.4
+ !<x11-themes/gnome-themes-2.32.1-r1
+"
+
+src_prepare() {
+ # Install cursors in the right place
+ sed -e 's:^\(cursordir.*\)icons\(.*\):\1cursors/xorg-x11\2:' \
+ -i themes/Adwaita/cursors/Makefile.am \
+ -i themes/Adwaita/cursors/Makefile.in || die
+
+ gnome2_src_prepare
+}
+
+src_configure() {
+ # The icon cache needs to be generated in pkg_postinst()
+ gnome2_src_configure \
+ --disable-static \
+ $(use_enable gtk gtk2-engine) \
+ $(use_enable gtk gtk3-engine) \
+ GTK_UPDATE_ICON_CACHE=$(type -P true)
+}
+
+src_install() {
+ gnome2_src_install
+
+ # Make it the default cursor theme
+ dosym Adwaita /usr/share/cursors/xorg-x11/default
+}
diff --git a/x11-themes/gnome-themes-standard/gnome-themes-standard-9999.ebuild b/x11-themes/gnome-themes-standard/gnome-themes-standard-9999.ebuild
index aec975a0..831a9925 100644
--- a/x11-themes/gnome-themes-standard/gnome-themes-standard-9999.ebuild
+++ b/x11-themes/gnome-themes-standard/gnome-themes-standard-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $