summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNirbheek Chauhan <nirbheek@gentoo.org>2011-03-23 09:36:20 +0530
committerNirbheek Chauhan <nirbheek@gentoo.org>2011-03-23 09:48:34 +0530
commit7e34b8242b68fe56600ba1806ec205de48a0ba9c (patch)
tree184418c1ef9b9c3cf02a95688e9a7f77d709dafb /x11-wm/mutter/mutter-2.91.92.ebuild
parentgnome-base/gnome-desktop: 2.91.91 → 2.91.92 (diff)
downloadgnome-7e34b8242b68fe56600ba1806ec205de48a0ba9c.tar.gz
gnome-7e34b8242b68fe56600ba1806ec205de48a0ba9c.tar.bz2
gnome-7e34b8242b68fe56600ba1806ec205de48a0ba9c.zip
x11-wm/mutter: 2.91.91 → 2.91.92
Diffstat (limited to 'x11-wm/mutter/mutter-2.91.92.ebuild')
-rw-r--r--x11-wm/mutter/mutter-2.91.92.ebuild73
1 files changed, 73 insertions, 0 deletions
diff --git a/x11-wm/mutter/mutter-2.91.92.ebuild b/x11-wm/mutter/mutter-2.91.92.ebuild
new file mode 100644
index 00000000..25e2dded
--- /dev/null
+++ b/x11-wm/mutter/mutter-2.91.92.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="2"
+GNOME2_LA_PUNT="yes"
+
+inherit gnome2
+
+DESCRIPTION="Upcoming GNOME 3 window manager (derived from metacity)"
+HOMEPAGE="http://blogs.gnome.org/metacity/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="debug +introspection test xinerama"
+if [[ ${PV} = 9999 ]]; then
+ inherit gnome2-live
+ KEYWORDS=""
+else
+ KEYWORDS="~amd64 ~x86"
+fi
+
+RDEPEND=">=x11-libs/pango-1.2[X,introspection?]
+ >=x11-libs/cairo-1.10[X]
+ >=x11-libs/gtk+-2.91.7:3[introspection?]
+ >=gnome-base/gconf-2:2
+ >=dev-libs/glib-2.14:2
+ >=media-libs/clutter-1.2:1.0
+ >=media-libs/libcanberra-0.26[gtk3]
+ >=x11-libs/startup-notification-0.7
+ >=x11-libs/libXcomposite-0.2
+
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXcursor
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXrandr
+ x11-libs/libXrender
+
+ introspection? ( >=dev-libs/gobject-introspection-0.9.5 )
+ xinerama? ( x11-libs/libXinerama )
+ gnome-extra/zenity
+ !x11-misc/expocity"
+DEPEND="${RDEPEND}
+ >=app-text/gnome-doc-utils-0.8
+ sys-devel/gettext
+ >=dev-util/pkgconfig-0.9
+ >=dev-util/intltool-0.35
+ test? ( app-text/docbook-xml-dtd:4.5 )
+ xinerama? ( x11-proto/xineramaproto )
+ x11-proto/xextproto
+ x11-proto/xproto"
+
+DOCS="AUTHORS ChangeLog HACKING MAINTAINERS NEWS README *.txt doc/*.txt"
+
+src_prepare() {
+ G2CONF="${G2CONF}
+ --disable-static
+ --enable-gconf
+ --enable-shape
+ --enable-sm
+ --enable-startup-notification
+ --enable-xsync
+ --enable-verbose-mode
+ --enable-compile-warnings=maximum
+ --with-libcanberra
+ $(use_enable introspection)
+ $(use_enable xinerama)"
+ gnome2_src_prepare
+}