summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNirbheek Chauhan <nirbheek@gentoo.org>2010-12-06 03:54:28 +0530
committerNirbheek Chauhan <nirbheek@gentoo.org>2010-12-06 03:55:24 +0530
commit1fe65950a3d4111868b569150a37a9b09f41d29c (patch)
tree3cff71c9951a3342ebb0f8c4555c69420f8c0b66 /x11-wm/mutter
parentdev-libs/glib: bump to 2.27.4 (diff)
downloadgnome-1fe65950a3d4111868b569150a37a9b09f41d29c.tar.gz
gnome-1fe65950a3d4111868b569150a37a9b09f41d29c.tar.bz2
gnome-1fe65950a3d4111868b569150a37a9b09f41d29c.zip
x11-wm/mutter: add live ebuild
* Last version (2.91.3) and live are now identical * Live ebuild will probably fail to compile a lot since upstream is not stable right now
Diffstat (limited to 'x11-wm/mutter')
-rw-r--r--x11-wm/mutter/Manifest3
-rw-r--r--x11-wm/mutter/mutter-2.91.3.ebuild8
-rw-r--r--x11-wm/mutter/mutter-9999.ebuild71
3 files changed, 80 insertions, 2 deletions
diff --git a/x11-wm/mutter/Manifest b/x11-wm/mutter/Manifest
index b7df0d36..6dc70c83 100644
--- a/x11-wm/mutter/Manifest
+++ b/x11-wm/mutter/Manifest
@@ -1,2 +1,3 @@
DIST mutter-2.91.3.tar.bz2 2019741 RMD160 7980a406d7e586749f55e444a5006fa9d44ec9dd SHA1 ade855ff043486bf0b06e24b1667f99f5be77797 SHA256 ea2cc6c24f6b30db5079d6df4c25ffcfa5f167f66178f2b7f7a5ff73a643c591
-EBUILD mutter-2.91.3.ebuild 1583 RMD160 5868b18c5fc0a832c46c962a9f71a1b033b0c1ad SHA1 f737806284dda5e39b0b35142585d574f449cb35 SHA256 62680ebd72d581da45b364a41537ba0c5b69ed7f79b4f9ffb589969f8e6fe0c9
+EBUILD mutter-2.91.3.ebuild 1674 RMD160 53ac9cc263893b3f20f6cb249342c3e4c036dcc0 SHA1 93d6aa70bd4e6cd550189471143d282432ce786d SHA256 d290d2040b220d2d6a40eec0184a59f92c2c3111816f7d4e6814f36b2d1a1818
+EBUILD mutter-9999.ebuild 1674 RMD160 53ac9cc263893b3f20f6cb249342c3e4c036dcc0 SHA1 93d6aa70bd4e6cd550189471143d282432ce786d SHA256 d290d2040b220d2d6a40eec0184a59f92c2c3111816f7d4e6814f36b2d1a1818
diff --git a/x11-wm/mutter/mutter-2.91.3.ebuild b/x11-wm/mutter/mutter-2.91.3.ebuild
index 05fe0ac8..cf02a2e4 100644
--- a/x11-wm/mutter/mutter-2.91.3.ebuild
+++ b/x11-wm/mutter/mutter-2.91.3.ebuild
@@ -11,8 +11,13 @@ HOMEPAGE="http://blogs.gnome.org/metacity/"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
IUSE="debug +gtk3 +introspection +sound test xinerama"
+if [[ ${PV} = 9999 ]]; then
+ inherit gnome2-live
+ KEYWORDS=""
+else
+ KEYWORDS="~amd64 ~x86"
+fi
RDEPEND=">=x11-libs/pango-1.2[X,introspection?]
>=x11-libs/cairo-1.10[X]
@@ -62,4 +67,5 @@ src_prepare() {
$(use_with sound libcanberra)
$(use_with introspection)
$(use_enable xinerama)"
+ gnome2_src_prepare
}
diff --git a/x11-wm/mutter/mutter-9999.ebuild b/x11-wm/mutter/mutter-9999.ebuild
new file mode 100644
index 00000000..cf02a2e4
--- /dev/null
+++ b/x11-wm/mutter/mutter-9999.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="2"
+
+inherit autotools gnome2
+
+DESCRIPTION="Upcoming GNOME 3 window manager (derived from metacity)"
+HOMEPAGE="http://blogs.gnome.org/metacity/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="debug +gtk3 +introspection +sound test xinerama"
+if [[ ${PV} = 9999 ]]; then
+ inherit gnome2-live
+ KEYWORDS=""
+else
+ KEYWORDS="~amd64 ~x86"
+fi
+
+RDEPEND=">=x11-libs/pango-1.2[X,introspection?]
+ >=x11-libs/cairo-1.10[X]
+ >=x11-libs/gtk+-2.90.7:3[introspection?]
+ sound? ( >=media-libs/libcanberra-0.26[gtk3] )
+ >=gnome-base/gconf-2
+ >=dev-libs/glib-2.14
+ >=x11-libs/startup-notification-0.7
+ >=x11-libs/libXcomposite-0.2
+
+ >=media-libs/clutter-1.2
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXcursor
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXrandr
+ x11-libs/libXrender
+
+ introspection? ( >=dev-libs/gobject-introspection-0.9.5 )
+ xinerama? ( x11-libs/libXinerama )
+ gnome-extra/zenity
+ !x11-misc/expocity"
+DEPEND="${RDEPEND}
+ >=app-text/gnome-doc-utils-0.8
+ sys-devel/gettext
+ >=dev-util/pkgconfig-0.9
+ >=dev-util/intltool-0.35
+ test? ( app-text/docbook-xml-dtd:4.5 )
+ xinerama? ( x11-proto/xineramaproto )
+ x11-proto/xextproto
+ x11-proto/xproto"
+
+DOCS="AUTHORS ChangeLog HACKING MAINTAINERS NEWS README *.txt doc/*.txt"
+
+src_prepare() {
+ G2CONF="${G2CONF}
+ --enable-gconf
+ --enable-shape
+ --enable-sm
+ --enable-startup-notification
+ --enable-xsync
+ --enable-verbose-mode
+ --enable-compile-warnings=maximum
+ $(use_with sound libcanberra)
+ $(use_with introspection)
+ $(use_enable xinerama)"
+ gnome2_src_prepare
+}