aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-accessibility/at-spi2-atk/at-spi2-atk-9999.ebuild55
-rw-r--r--app-accessibility/at-spi2-atk/metadata.xml8
-rw-r--r--app-accessibility/at-spi2-core/at-spi2-core-9999.ebuild78
-rw-r--r--app-accessibility/at-spi2-core/files/at-spi2-core-2.0.2-disable-teamspaces-test.patch13
-rw-r--r--app-accessibility/at-spi2-core/metadata.xml8
-rw-r--r--app-crypt/libsecret/libsecret-9999.ebuild88
-rw-r--r--app-crypt/libsecret/metadata.xml11
-rw-r--r--app-emulation/libvirt-glib/libvirt-glib-9999.ebuild59
-rw-r--r--app-emulation/libvirt-glib/metadata.xml13
-rw-r--r--app-office/planner/files/0001-Speed-up-python-path-detection.patch33
-rw-r--r--app-office/planner/files/0002-Fix-build-failure-with-evolution-data-server-3.6.patch401
-rw-r--r--app-office/planner/metadata.xml8
-rw-r--r--app-office/planner/planner-9999.ebuild98
-rw-r--r--app-text/libgxps/libgxps-9999.ebuild66
-rw-r--r--app-text/libgxps/metadata.xml8
-rw-r--r--dev-libs/glib/Manifest1
-rwxr-xr-xdev-libs/glib/files/gengiotypefuncs.py45
-rw-r--r--dev-libs/glib/files/glib-2.54.2-external-codegen.patch101
-rw-r--r--dev-libs/glib/glib-9999.ebuild314
-rw-r--r--dev-libs/glib/metadata.xml31
-rw-r--r--dev-libs/gmime/gmime-9999.ebuild82
-rw-r--r--dev-libs/gmime/metadata.xml11
-rw-r--r--dev-libs/gobject-introspection/gobject-introspection-9999.ebuild85
-rw-r--r--dev-libs/gobject-introspection/metadata.xml12
-rw-r--r--dev-libs/libgdata/libgdata-9999.ebuild78
-rw-r--r--dev-libs/libgdata/metadata.xml11
-rw-r--r--dev-python/pyatspi/files/pyatspi-2.6.0-examples-python3.patch26
-rw-r--r--dev-python/pyatspi/metadata.xml8
-rw-r--r--dev-python/pyatspi/pyatspi-9999.ebuild64
-rw-r--r--dev-util/gdbus-codegen/files/gdbus-codegen-2.54.2-sitedir.patch34
-rw-r--r--dev-util/gdbus-codegen/files/gdbus-codegen-2.54.3-sitedir.patch22
-rw-r--r--dev-util/gdbus-codegen/files/gdbus-codegen-2.56.1-sitedir.patch54
-rw-r--r--dev-util/gdbus-codegen/files/setup.py-2.32.46
-rw-r--r--dev-util/gdbus-codegen/gdbus-codegen-9999.ebuild60
-rw-r--r--dev-util/gdbus-codegen/metadata.xml11
-rw-r--r--gnome-base/gnome-keyring/gnome-keyring-9999.ebuild91
-rw-r--r--gnome-base/gnome-keyring/metadata.xml21
-rw-r--r--gnome-extra/evolution-groupwise/evolution-groupwise-9999.ebuild54
-rw-r--r--gnome-extra/evolution-groupwise/metadata.xml8
-rw-r--r--gnome-extra/libgda/files/libgda-4.99.1-control-center-icon-collision.patch55
-rw-r--r--gnome-extra/libgda/files/libgda-4.99.1-gda-browser-doc-collision.patch28
-rw-r--r--gnome-extra/libgda/files/libgda-4.99.1-gda-browser-help-collision.patch38
-rw-r--r--gnome-extra/libgda/files/libgda-4.99.4-statement-rewriting-fix.patch465
-rw-r--r--gnome-extra/libgda/files/libgda-9999-fix-build-order.patch14
-rw-r--r--gnome-extra/libgda/libgda-9999.ebuild166
-rw-r--r--gnome-extra/libgda/metadata.xml21
-rw-r--r--media-libs/cogl/cogl-9999.ebuild146
-rw-r--r--media-libs/cogl/metadata.xml13
-rw-r--r--media-libs/gsound/gsound-9999.ebuild48
-rw-r--r--media-libs/gsound/metadata.xml8
-rw-r--r--media-libs/mash/mash-9999.ebuild58
-rw-r--r--media-libs/mash/metadata.xml12
-rw-r--r--net-im/empathy/empathy-9999.ebuild130
-rw-r--r--net-im/empathy/metadata.xml25
-rw-r--r--net-libs/gtk-vnc/gtk-vnc-9999.ebuild189
-rw-r--r--net-libs/gtk-vnc/metadata.xml15
-rw-r--r--net-libs/rest/metadata.xml12
-rw-r--r--net-libs/rest/rest-9999.ebuild59
-rw-r--r--net-misc/spice-gtk/metadata.xml22
-rw-r--r--net-misc/spice-gtk/spice-gtk-9999.ebuild162
-rw-r--r--net-misc/vinagre/metadata.xml16
-rw-r--r--net-misc/vinagre/vinagre-9999.ebuild85
-rw-r--r--sys-libs/libosinfo/libosinfo-9999.ebuild70
-rw-r--r--sys-libs/libosinfo/metadata.xml8
-rw-r--r--x11-libs/colord-gtk/colord-gtk-9999.ebuild75
-rw-r--r--x11-libs/colord-gtk/metadata.xml8
-rw-r--r--x11-libs/gtksourceview/files/2.0/gentoo.lang111
-rw-r--r--x11-libs/gtksourceview/gtksourceview-9999.ebuild75
-rw-r--r--x11-libs/gtksourceview/metadata.xml11
69 files changed, 0 insertions, 4322 deletions
diff --git a/app-accessibility/at-spi2-atk/at-spi2-atk-9999.ebuild b/app-accessibility/at-spi2-atk/at-spi2-atk-9999.ebuild
deleted file mode 100644
index f2b32be9..00000000
--- a/app-accessibility/at-spi2-atk/at-spi2-atk-9999.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="5"
-GCONF_DEBUG="no"
-GNOME2_LA_PUNT="yes"
-
-inherit eutils gnome2 multilib-minimal virtualx
-if [[ ${PV} = 9999 ]]; then
- inherit gnome2-live
-fi
-
-DESCRIPTION="Gtk module for bridging AT-SPI to Atk"
-HOMEPAGE="http://live.gnome.org/Accessibility"
-
-LICENSE="LGPL-2+"
-SLOT="2"
-if [[ ${PV} = 9999 ]]; then
- KEYWORDS=""
-else
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
-fi
-IUSE="test"
-
-COMMON_DEPEND="
- >=app-accessibility/at-spi2-core-2.15.5[${MULTILIB_USEDEP}]
- >=dev-libs/atk-2.15.4[${MULTILIB_USEDEP}]
- >=dev-libs/glib-2.32:2[${MULTILIB_USEDEP}]
- >=sys-apps/dbus-1.5[${MULTILIB_USEDEP}]
-"
-RDEPEND="${COMMON_DEPEND}
- !<gnome-extra/at-spi-1.32.0-r1
- abi_x86_32? (
- !<=app-emulation/emul-linux-x86-gtklibs-20140508-r3
- !app-emulation/emul-linux-x86-gtklibs[-abi_x86_32(-)]
- )
-"
-DEPEND="${COMMON_DEPEND}
- virtual/pkgconfig[${MULTILIB_USEDEP}]
- test? ( >=dev-libs/libxml2-2.9.1 )
-"
-
-multilib_src_configure() {
- ECONF_SOURCE=${S} \
- gnome2_src_configure --enable-p2p $(use_with test tests)
-}
-
-multilib_src_test() {
- unset DBUS_SESSION_BUS_ADDRESS
- Xemake check
-}
-
-multilib_src_compile() { gnome2_src_compile; }
-multilib_src_install() { gnome2_src_install; }
diff --git a/app-accessibility/at-spi2-atk/metadata.xml b/app-accessibility/at-spi2-atk/metadata.xml
deleted file mode 100644
index 39980802..00000000
--- a/app-accessibility/at-spi2-atk/metadata.xml
+++ /dev/null
@@ -1,8 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
-<maintainer type="project">
- <email>gnome@gentoo.org</email>
- <name>Gentoo GNOME Desktop</name>
-</maintainer>
-</pkgmetadata>
diff --git a/app-accessibility/at-spi2-core/at-spi2-core-9999.ebuild b/app-accessibility/at-spi2-core/at-spi2-core-9999.ebuild
deleted file mode 100644
index 5c11ce38..00000000
--- a/app-accessibility/at-spi2-core/at-spi2-core-9999.ebuild
+++ /dev/null
@@ -1,78 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="5"
-GCONF_DEBUG="no"
-GNOME2_LA_PUNT="yes"
-
-inherit eutils gnome2 multilib-minimal
-if [[ ${PV} = 9999 ]]; then
- inherit gnome2-live
-fi
-
-DESCRIPTION="D-Bus accessibility specifications and registration daemon"
-HOMEPAGE="http://live.gnome.org/Accessibility"
-
-LICENSE="LGPL-2+"
-SLOT="2"
-IUSE="+X +introspection"
-if [[ ${PV} = 9999 ]]; then
- KEYWORDS=""
- IUSE="${IUSE} doc"
-else
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
-fi
-
-# x11-libs/libSM is needed until upstream #719808 is solved either
-# making the dep unneeded or fixing their configure
-# Only libX11 is optional right now
-COMMON_DEPEND="
- >=dev-libs/glib-2.36:2[${MULTILIB_USEDEP}]
- >=sys-apps/dbus-1[${MULTILIB_USEDEP}]
- x11-libs/libSM[${MULTILIB_USEDEP}]
- x11-libs/libXi[${MULTILIB_USEDEP}]
- x11-libs/libXtst[${MULTILIB_USEDEP}]
- introspection? ( >=dev-libs/gobject-introspection-0.9.6 )
- X? ( x11-libs/libX11[${MULTILIB_USEDEP}] )
-"
-RDEPEND="${COMMON_DEPEND}
- abi_x86_32? (
- !<=app-emulation/emul-linux-x86-gtklibs-20140508-r3
- !app-emulation/emul-linux-x86-gtklibs[-abi_x86_32(-)]
- )
-"
-DEPEND="${COMMON_DEPEND}
- >=dev-util/gtk-doc-am-1.9
- >=dev-util/intltool-0.40
- virtual/pkgconfig[${MULTILIB_USEDEP}]
-"
-
-if [[ ${PV} == 9999 ]]; then
- DEPEND="${DEPEND}
- doc? ( >=dev-util/gtk-doc-1.9 )"
-fi
-
-src_prepare() {
- # disable teamspaces test since that requires Novell.ICEDesktop.Daemon
- epatch "${FILESDIR}/${PN}-2.0.2-disable-teamspaces-test.patch"
-
- gnome2_src_prepare
-}
-
-multilib_src_configure() {
- # xevie is deprecated/broken since xorg-1.6/1.7
- ECONF_SOURCE=${S} \
- gnome2_src_configure \
- --disable-xevie \
- $(multilib_native_use_enable introspection) \
- $(use_enable X x11)
-
- # work-around gtk-doc out-of-source brokedness
- if multilib_is_native_abi; then
- ln -s "${S}"/doc/libatspi/html doc/libatspi/html || die
- fi
-}
-
-multilib_src_compile() { gnome2_src_compile; }
-multilib_src_install() { gnome2_src_install; }
diff --git a/app-accessibility/at-spi2-core/files/at-spi2-core-2.0.2-disable-teamspaces-test.patch b/app-accessibility/at-spi2-core/files/at-spi2-core-2.0.2-disable-teamspaces-test.patch
deleted file mode 100644
index 269236d1..00000000
--- a/app-accessibility/at-spi2-core/files/at-spi2-core-2.0.2-disable-teamspaces-test.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/dbind/dbtest.c b/dbind/dbtest.c
-index e8bbb63..9843c3d 100644
---- a/dbind/dbtest.c
-+++ b/dbind/dbtest.c
-@@ -417,7 +417,7 @@ int main (int argc, char **argv)
-
- test_helpers ();
- test_marshalling ();
-- test_teamspaces (bus);
-+ /* test_teamspaces (bus); */
-
- return 0;
- }
diff --git a/app-accessibility/at-spi2-core/metadata.xml b/app-accessibility/at-spi2-core/metadata.xml
deleted file mode 100644
index 39980802..00000000
--- a/app-accessibility/at-spi2-core/metadata.xml
+++ /dev/null
@@ -1,8 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
-<maintainer type="project">
- <email>gnome@gentoo.org</email>
- <name>Gentoo GNOME Desktop</name>
-</maintainer>
-</pkgmetadata>
diff --git a/app-crypt/libsecret/libsecret-9999.ebuild b/app-crypt/libsecret/libsecret-9999.ebuild
deleted file mode 100644
index e4d5d072..00000000
--- a/app-crypt/libsecret/libsecret-9999.ebuild
+++ /dev/null
@@ -1,88 +0,0 @@
-# Copyright 1999-2018 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="5"
-PYTHON_COMPAT=( python2_{6,7} )
-VALA_MIN_API_VERSION=0.18
-VALA_USE_DEPEND=vapigen
-
-inherit gnome2 python-any-r1 vala virtualx
-if [[ ${PV} = 9999 ]]; then
- inherit gnome2-live
-fi
-
-DESCRIPTION="GObject library for accessing the freedesktop.org Secret Service API"
-HOMEPAGE="https://wiki.gnome.org/Projects/Libsecret"
-
-LICENSE="LGPL-2.1+ Apache-2.0" # Apache-2.0 license is used for tests only
-SLOT="0"
-IUSE="+crypt debug +introspection test vala"
-REQUIRED_USE="vala? ( introspection )"
-if [[ ${PV} = 9999 ]]; then
- IUSE="${IUSE} doc"
- KEYWORDS=""
-else
- KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd"
-fi
-
-COMMON_DEPEND="
- >=dev-libs/glib-2.38:2
- crypt? ( >=dev-libs/libgcrypt-1.2.2:0= )
- introspection? ( >=dev-libs/gobject-introspection-1.29 )
-"
-RDEPEND="${COMMON_DEPEND}
- >=gnome-base/gnome-keyring-3
-"
-# Add ksecrets to RDEPEND when it's added to portage
-DEPEND="${COMMON_DEPEND}
- dev-libs/libxslt
- dev-util/gdbus-codegen
- >=dev-util/gtk-doc-am-1.9
- >=dev-util/intltool-0.35.0
- sys-devel/gettext
- virtual/pkgconfig
- test? (
- dev-python/mock
- introspection? (
- ${PYTHON_DEPS}
- >=dev-libs/gjs-1.32
- dev-python/pygobject:3 )
- )
- vala? ( $(vala_depend) )
-"
-
-# Required while regenerating from *.vala *.vapi
-if [[ ${PV} = 9999 ]]; then
- DEPEND="${DEPEND}
- $(vala_depend)
- doc? ( >=dev-util/gtk-doc-1.9 )"
-fi
-
-src_prepare() {
- # FIXME: disable failing test
- sed -e '/test_get_sync);/d' \
- -e '/test_get_async);/d' \
- -i "${S}"/libsecret/test-service.c || die
-
- if use vala || [[ ${PV} = 9999 ]]; then
- vala_src_prepare
- fi
- gnome2_src_prepare
-}
-
-src_configure() {
- DOCS="AUTHORS ChangeLog NEWS README"
- gnome2_src_configure \
- --enable-manpages \
- --disable-strict \
- --disable-coverage \
- --disable-static \
- $(use_enable crypt gcrypt) \
- $(use_enable introspection) \
- $(use_enable vala)
-}
-
-src_test() {
- Xemake check
-}
diff --git a/app-crypt/libsecret/metadata.xml b/app-crypt/libsecret/metadata.xml
deleted file mode 100644
index 25f333c3..00000000
--- a/app-crypt/libsecret/metadata.xml
+++ /dev/null
@@ -1,11 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>gnome@gentoo.org</email>
- <name>Gentoo GNOME Desktop</name>
- </maintainer>
- <use>
- <flag name="vala">Enable bindings for <pkg>dev-lang/vala</pkg></flag>
- </use>
-</pkgmetadata>
diff --git a/app-emulation/libvirt-glib/libvirt-glib-9999.ebuild b/app-emulation/libvirt-glib/libvirt-glib-9999.ebuild
deleted file mode 100644
index 95f5cf2f..00000000
--- a/app-emulation/libvirt-glib/libvirt-glib-9999.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-GCONF_DEBUG="no"
-GNOME2_LA_PUNT="yes"
-VALA_MIN_API_VERSION="0.14"
-PYTHON_COMPAT=( python{2_6,2_7} )
-
-inherit gnome2 python-single-r1 vala
-if [[ ${PV} = 9999 ]]; then
- inherit gnome2-live
-fi
-
-DESCRIPTION="GLib and GObject mappings for libvirt"
-HOMEPAGE="http://libvirt.org/git/?p=libvirt-glib.git"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-if [[ ${PV} = 9999 ]]; then
- EGIT_REPO_URI="git://libvirt.org/${PN}.git"
- KEYWORDS=""
-else
- SRC_URI="ftp://libvirt.org/libvirt/glib/${P}.tar.gz"
- KEYWORDS="~amd64 ~x86"
-fi
-IUSE="+introspection python +vala"
-REQUIRED_USE="
- python? ( ${PYTHON_REQUIRED_USE} )
- vala? ( introspection )
-"
-
-RDEPEND="
- dev-libs/libxml2:2
- >=app-emulation/libvirt-0.9.10:=
- >=dev-libs/glib-2.38.0:2
- introspection? ( >=dev-libs/gobject-introspection-0.10.8:= )
- python? ( ${PYTHON_DEPS} )
-"
-DEPEND="${RDEPEND}
- dev-util/gtk-doc-am
- >=dev-util/intltool-0.35.0
- virtual/pkgconfig
- vala? ( $(vala_depend) )
-"
-
-pkg_setup() {
- use python && python-single-r1_pkg_setup
-}
-
-src_configure() {
- gnome2_src_configure \
- --disable-test-coverage \
- --disable-static \
- $(use_enable introspection) \
- $(use_enable vala) \
- $(use_with python)
-}
diff --git a/app-emulation/libvirt-glib/metadata.xml b/app-emulation/libvirt-glib/metadata.xml
deleted file mode 100644
index 3d9b69da..00000000
--- a/app-emulation/libvirt-glib/metadata.xml
+++ /dev/null
@@ -1,13 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
-<maintainer type="person">
- <email>tamiko@gentoo.org</email>
- <name>Matthias Maier</name>
- <description>Please CC me on bugs</description>
-</maintainer>
-<maintainer type="project">
- <email>gnome@gentoo.org</email>
- <name>Gentoo GNOME Desktop</name>
-</maintainer>
-</pkgmetadata>
diff --git a/app-office/planner/files/0001-Speed-up-python-path-detection.patch b/app-office/planner/files/0001-Speed-up-python-path-detection.patch
deleted file mode 100644
index 43e349b6..00000000
--- a/app-office/planner/files/0001-Speed-up-python-path-detection.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-From 750f1489360a34b80f963eddb5af77b1cc51a1c3 Mon Sep 17 00:00:00 2001
-From: Pacho Ramos <pacho@condmat1.ciencias.uniovi.es>
-Date: Sat, 29 Dec 2012 17:13:05 +0100
-Subject: [PATCH 1/2] Speed up python path detection
-
----
- acinclude.m4 | 10 ++--------
- 1 file changed, 2 insertions(+), 8 deletions(-)
-
-diff --git a/acinclude.m4 b/acinclude.m4
-index c4996ee..fadbf2c 100644
---- a/acinclude.m4
-+++ b/acinclude.m4
-@@ -85,14 +85,8 @@ CPPFLAGS="$save_CPPFLAGS"
-
- # Check for Python library path
- AC_MSG_CHECKING([for Python library path])
-- python_path=`echo $PYTHON | sed "s,/bin.*$,,"`
-- for i in "$python_path/lib/python$PYTHON_VERSION/config/" "$python_path/lib/python$PYTHON_VERSION/" "$python_path/lib/python/config/" "$python_path/lib/python/" "$python_path/" ; do
-- python_path=`find $i -type f -name libpython$PYTHON_VERSION.* -print | sed "1q"`
-- if test -n "$python_path" ; then
-- break
-- fi
-- done
-- python_path=`echo $python_path | sed "s,/libpython.*$,,"`
-+ [python_path=`$PYTHON -c 'import distutils.sysconfig, os; \
-+ print(os.path.sep.join(distutils.sysconfig.get_python_lib(standard_lib=True).split(os.path.sep)[:-1]))'`]
- AC_MSG_RESULT([$python_path])
- if test -z "$python_path" ; then
- AC_MSG_ERROR([cannot find Python library path])
---
-1.8.2.1
-
diff --git a/app-office/planner/files/0002-Fix-build-failure-with-evolution-data-server-3.6.patch b/app-office/planner/files/0002-Fix-build-failure-with-evolution-data-server-3.6.patch
deleted file mode 100644
index 1bb1076b..00000000
--- a/app-office/planner/files/0002-Fix-build-failure-with-evolution-data-server-3.6.patch
+++ /dev/null
@@ -1,401 +0,0 @@
-From 60ff192322517ca26e33da36c4a9ec03ae4f3539 Mon Sep 17 00:00:00 2001
-From: Gilles Dartiguelongue <eva@gentoo.org>
-Date: Sat, 29 Dec 2012 16:48:30 +0100
-Subject: [PATCH 2/2] Fix build failure with evolution-data-server-3.6
-
-Only cover plugin code enabled through --enable-eds.
-EDS backend has been broken for a long time and needs more work.
----
- configure.ac | 2 +-
- src/planner-eds-plugin.c | 141 +++++++++++++++++++++++++----------------------
- 2 files changed, 75 insertions(+), 68 deletions(-)
-
-diff --git a/configure.ac b/configure.ac
-index 77127c3..5c995d8 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -243,7 +243,7 @@ dnl -----------------------------
- AC_ARG_ENABLE(eds, [ --enable-eds build evolution-data-server support [default=no]], enable_eds="$enableval", enable_eds=no)
-
- if test "x$enable_eds" = "xyes" ; then
-- EDS_REQUIRED=1.1.0
-+ EDS_REQUIRED=3.6
- EDS_PACKAGE=1.2
- PKG_CHECK_MODULES(EDS,
- [
-diff --git a/src/planner-eds-plugin.c b/src/planner-eds-plugin.c
-index 4eb060c..a8229c9 100644
---- a/src/planner-eds-plugin.c
-+++ b/src/planner-eds-plugin.c
-@@ -30,7 +30,6 @@
- #include <gdk/gdkkeysyms.h>
- #include <glade/glade.h>
- #include <gtk/gtk.h>
--#include <gconf/gconf-client.h>
- #include <libplanner/mrp-object.h>
- #include <libplanner/mrp-property.h>
- #include "libplanner/mrp-paths.h"
-@@ -39,13 +38,11 @@
- #include "planner-resource-cmd.h"
-
- /* Evolution Data Server sources */
--#include <libedataserver/e-source-list.h>
--#include <libedataserver/e-source-group.h>
--#include <libedataserver/e-uid.h>
-+#include <libedataserver/libedataserver.h>
- /* Calendar */
--#include <libecal/e-cal.h>
-+#include <libecal/libecal.h>
- /* Addressbook */
--#include <libebook/e-book.h>
-+#include <libebook/libebook.h>
-
- struct _PlannerPluginPriv {
- MrpProject *project;
-@@ -66,7 +63,8 @@ struct _PlannerPluginPriv {
- gchar *current_query_id;
- GList *queries_cancelled;
- /* Books open */
-- GList *books;
-+ ESourceRegistry *registry;
-+ GList *books;
-
- GtkActionGroup *actions;
- };
-@@ -95,7 +93,7 @@ enum {
- static void eds_plugin_import (GtkAction *action,
- gpointer user_data,
- const gchar *cname);
--static void eds_create_groups_model (GSList *groups,
-+static void eds_create_groups_model (GList *groups,
- PlannerPlugin *plugin);
- static void eds_ok_button_clicked (GtkButton *button,
- PlannerPlugin *plugin);
-@@ -130,15 +128,14 @@ static MrpResource * eds_find_resource (PlannerPlugin *plugin,
- const gchar *uid,
- GList *resources_orig);
- static gboolean eds_create_uid_property (PlannerPlugin *plugin);
--static void eds_load_resources (ESourceGroup *group,
-+static void eds_load_resources (ESource *source,
- PlannerPlugin *plugin,
- const gchar *search);
--static void eds_receive_contacts_cb (EBook *book,
-- EBookStatus status,
-- GList *contacts,
-+static void eds_receive_contacts_cb (EBookClient *book,
-+ GAsyncResult *result,
- gpointer plugin);
--static void eds_receive_book_cb (EBook *book,
-- EBookStatus status,
-+static void eds_receive_book_cb (EBookClient *book,
-+ GAsyncResult *result,
- gpointer user_data);
- static void eds_plugin_busy (PlannerPlugin *plugin,
- gboolean busy);
-@@ -236,9 +233,7 @@ eds_plugin_import (GtkAction *action,
- PlannerPlugin *plugin;
- PlannerPluginPriv *priv;
- GtkCellRenderer *renderer;
-- GConfClient *gconf_client;
-- ESourceList *source_list;
-- GSList *groups;
-+ GList *groups;
- gchar *filename;
-
- plugin = PLANNER_PLUGIN (user_data);
-@@ -293,11 +288,9 @@ eds_plugin_import (GtkAction *action,
- gtk_widget_show (priv->dialog_get_resources);
-
-
-- gconf_client = gconf_client_get_default ();
-- source_list = e_source_list_new_for_gconf (gconf_client,
-- "/apps/evolution/addressbook/sources");
- /* List with addressbook groups */
-- groups = e_source_list_peek_groups (source_list);
-+ groups = e_source_registry_list_sources (priv->registry,
-+ E_SOURCE_EXTENSION_ADDRESS_BOOK);
- eds_create_groups_model (groups, plugin);
- gtk_combo_box_set_model (priv->select_group, priv->groups_model);
- renderer = gtk_cell_renderer_text_new ();
-@@ -305,52 +298,58 @@ eds_plugin_import (GtkAction *action,
- renderer, TRUE);
- gtk_cell_layout_set_attributes (GTK_CELL_LAYOUT (priv->select_group),
- renderer, "text", 0, NULL);
-- /* g_object_unref (source_list); */
-+ g_list_free_full (groups, g_object_unref);
- }
-
- static void
--eds_create_groups_model (GSList *groups,
-+eds_create_groups_model (GList *groups,
- PlannerPlugin *plugin)
- {
-+ PlannerPluginPriv *priv;
- GtkListStore *model;
- GtkTreeIter iter;
-- GSList *sl;
-+ GList *sl;
-+ ESource *parent;
-+ const gchar *parent_name;
- const gchar *name;
-
- if (groups == NULL) {
- return;
- }
-
-+ priv = plugin->priv;
- model = gtk_list_store_new (NUM_GROUP_COLS, G_TYPE_STRING, G_TYPE_OBJECT);
-
- for (sl = groups; sl; sl = sl->next) {
-- name = e_source_group_peek_name (sl->data);
-+ name = e_source_get_display_name (sl->data);
-+ parent = e_source_registry_ref_source(priv->registry, e_source_get_parent(sl->data));
-+ parent_name = e_source_get_display_name(parent);
- gtk_list_store_append (model, &iter);
- gtk_list_store_set (model, &iter,
-- COL_GROUP_NAME, name,
-+ COL_GROUP_NAME, g_strdup_printf("%s (%s)", name, parent_name),
- COL_GROUP_OBJECT, sl->data, -1);
-+ g_object_unref(parent);
- }
- plugin->priv->groups_model = GTK_TREE_MODEL (model);
- }
-
- /* For now we show all the sources from a group in a List.
-- Later we will us a Tree to show them usings groups. */
-+ Later we will use a Tree to show them usings groups. */
- static void
--eds_load_resources (ESourceGroup *group,
-- PlannerPlugin *plugin,
-- const gchar *search)
-+eds_load_resources (ESource *source,
-+ PlannerPlugin *plugin,
-+ const gchar *search)
- {
- GtkListStore *model;
-- GSList *sources, *sl;
-- PlannerPluginPriv *priv;
-+ GList *sources, *sl;
-+ PlannerPluginPriv *priv = NULL;
-
-- g_return_if_fail (E_IS_SOURCE_GROUP (group));
-- sources = e_source_group_peek_sources (group);
-+ g_return_if_fail (E_IS_SOURCE (source));
-
- priv = plugin->priv;
- model = GTK_LIST_STORE (priv->resources_model);
-
-- if (sources == NULL) {
-+ if (source == NULL) {
- if (model) {
- gtk_list_store_clear (model);
- }
-@@ -439,9 +438,12 @@ eds_load_resources (ESourceGroup *group,
- gtk_tree_view_set_headers_clickable (priv->resources_tree_view, TRUE);
- }
-
-+ sources = e_source_registry_list_sources (priv->registry,
-+ E_SOURCE_EXTENSION_ADDRESS_BOOK);
-+
- for (sl = sources; sl; sl = sl->next) {
-- EBook *client;
-- AsyncQuery *async_query = g_new0 (AsyncQuery, 1);
-+ EBookClient *client;
-+ AsyncQuery *async_query = g_new0 (AsyncQuery, 1);
-
- g_free (plugin->priv->current_query_id);
- plugin->priv->current_query_id = e_uid_new ();
-@@ -450,11 +452,12 @@ eds_load_resources (ESourceGroup *group,
- async_query->uid = plugin->priv->current_query_id;
- async_query->search = search;
-
-- client = e_book_new (sl->data, NULL);
-+ client = e_book_client_new (sl->data, NULL);
- g_message ("Open book async query: %s", async_query->uid);
-- e_book_async_open (client, TRUE, eds_receive_book_cb, async_query);
-+ e_client_open (E_CLIENT (client), TRUE, NULL, (GAsyncReadyCallback) eds_receive_book_cb, async_query);
- eds_plugin_busy (plugin, TRUE);
- }
-+ g_list_free_full (sources, g_object_unref);
- }
-
- static gboolean
-@@ -478,16 +481,17 @@ eds_query_cancelled (PlannerPlugin *plugin,
- }
-
- static void
--eds_receive_book_cb (EBook *client,
-- EBookStatus status,
-+eds_receive_book_cb (EBookClient *client,
-+ GAsyncResult *result,
- gpointer user_data)
- {
- PlannerPlugin *plugin;
- EBookQuery *query;
- AsyncQuery *async_query;
- const gchar *search;
-+ const gchar *sexp;
- const gchar *uid;
-- const gchar *book_uri;
-+ const gchar *book_uid;
- GtkListStore *model;
-
- async_query = user_data;
-@@ -499,25 +503,25 @@ eds_receive_book_cb (EBook *client,
- gtk_list_store_clear (model);
- g_free (async_query);
-
-- book_uri = e_book_get_uri (client);
-+ book_uid = e_source_get_uid(e_client_get_source(E_CLIENT (client)));
-
- if (eds_query_cancelled (plugin, uid)) {
-- g_message ("Open book query cancelled: %s (%s)", book_uri, uid);
-+ g_message ("Open book query cancelled: %s (%s)", book_uid, uid);
- gtk_widget_set_sensitive (glade_xml_get_widget (plugin->priv->glade,
- "search_box"), TRUE);
- eds_plugin_busy (plugin, FALSE);
- return;
- }
-
-- if (status != E_BOOK_ERROR_OK) {
-- g_warning ("Problems opening: %s", book_uri);
-+ if (!e_client_open_finish(E_CLIENT (client), result, NULL)) {
-+ g_warning ("Problems opening: %s", book_uid);
- gtk_widget_set_sensitive (glade_xml_get_widget (plugin->priv->glade,
- "search_box"), TRUE);
- eds_plugin_busy (plugin, FALSE);
- return;
- }
-
-- g_message ("Looking the book: %s", book_uri);
-+ g_message ("Looking the book: %s", book_uid);
- plugin->priv->books = g_list_append (plugin->priv->books, client);
-
- async_query = g_new0 (AsyncQuery, 1);
-@@ -527,22 +531,23 @@ eds_receive_book_cb (EBook *client,
- async_query->plugin = plugin;
-
- query = e_book_query_any_field_contains (search);
-- e_book_async_get_contacts (client, query,
-- eds_receive_contacts_cb,
-- (gpointer) async_query);
-+ sexp = e_book_query_to_string(query);
-+ e_book_client_get_contacts (client, sexp, NULL,
-+ (GAsyncReadyCallback) eds_receive_contacts_cb,
-+ (gpointer) async_query);
-
- eds_plugin_busy (plugin, TRUE);
- e_book_query_unref (query);
- }
-
- static void
--eds_receive_contacts_cb (EBook *book,
-- EBookStatus status,
-- GList *contacts,
-+eds_receive_contacts_cb (EBookClient *client,
-+ GAsyncResult *result,
- gpointer user_data)
- {
- GtkTreeIter iter;
-- GList *l;
-+ GSList *l;
-+ GSList *contacts;
- GtkListStore *model;
- PlannerPlugin *plugin;
- PlannerPluginPriv *priv;
-@@ -550,6 +555,7 @@ eds_receive_contacts_cb (EBook *book,
- AsyncQuery *async_query;
- const gchar *uid;
- gchar *filename;
-+ GError *error;
-
- async_query = (AsyncQuery *) user_data;
-
-@@ -565,11 +571,10 @@ eds_receive_contacts_cb (EBook *book,
- return;
- }
-
-- g_message ("Book status response: %d", status);
- g_message ("Answer for the query: %s", uid);
-
-- /* Exceed limit is E_BOOK_ERROR_OTHER_ERROR :( */
-- if (status == E_BOOK_ERROR_OK || status == E_BOOK_ERROR_OTHER_ERROR) {
-+ if (e_book_client_get_contacts_finish(client, result, &contacts, &error)) {
-+ g_message ("Book status response: %d", g_slist_length(contacts));
- filename = mrp_paths_get_image_dir ("/resources.png");
- pixbuf = gdk_pixbuf_new_from_file (filename, NULL);
- g_free (filename);
-@@ -586,8 +591,9 @@ eds_receive_contacts_cb (EBook *book,
- COL_RESOURCE_PHOTO, pixbuf,
- COL_RESOURCE_OBJECT, l->data, -1);
- }
-+ e_client_util_free_object_slist(contacts);
- } else {
-- g_warning ("Problem getting contacts ...");
-+ g_warning ("Problem getting contacts: %s", error->message);
- }
-
- eds_plugin_busy (plugin, FALSE);
-@@ -697,13 +703,13 @@ eds_group_selected (GtkComboBox *select_group,
- {
- GtkTreeIter iter;
- PlannerPluginPriv *priv = plugin->priv;
-- ESourceGroup *group;
-+ ESource *source;
-
- gtk_widget_set_sensitive (glade_xml_get_widget (priv->glade, "search_box"), TRUE);
-
- if (gtk_combo_box_get_active_iter (select_group, &iter)) {
-- gtk_tree_model_get (priv->groups_model, &iter, COL_GROUP_OBJECT, &group, -1);
-- eds_load_resources (group, plugin, "");
-+ gtk_tree_model_get (priv->groups_model, &iter, COL_GROUP_OBJECT, &source, -1);
-+ eds_load_resources (source, plugin, "");
- }
- }
-
-@@ -805,14 +811,14 @@ eds_search_button_clicked (GtkButton *button,
- const gchar *search;
- PlannerPluginPriv *priv = plugin->priv;
- GtkTreeIter iter;
-- ESourceGroup *group;
-+ ESource *source;
-
- search = gtk_entry_get_text (GTK_ENTRY
- (glade_xml_get_widget (priv->glade,"search_entry")));
-
- if (gtk_combo_box_get_active_iter (priv->select_group, &iter)) {
-- gtk_tree_model_get (priv->groups_model, &iter, COL_GROUP_OBJECT, &group, -1);
-- eds_load_resources (group, plugin, search);
-+ gtk_tree_model_get (priv->groups_model, &iter, COL_GROUP_OBJECT, &source, -1);
-+ eds_load_resources (source, plugin, search);
- }
- }
-
-@@ -823,13 +829,13 @@ eds_search_key_pressed (GtkEntry *entry,
- {
- PlannerPluginPriv *priv = plugin->priv;
- GtkTreeIter iter;
-- ESourceGroup *group;
-+ ESource *source;
-
- if (event->keyval == GDK_Return) {
- if (gtk_combo_box_get_active_iter (priv->select_group, &iter)) {
- gtk_tree_model_get (priv->groups_model, &iter,
-- COL_GROUP_OBJECT, &group, -1);
-- eds_load_resources (group, plugin, gtk_entry_get_text (entry));
-+ COL_GROUP_OBJECT, &source, -1);
-+ eds_load_resources (source, plugin, gtk_entry_get_text (entry));
- }
- }
- return FALSE;
-@@ -935,6 +941,7 @@ plugin_init (PlannerPlugin *plugin)
- plugin->priv = priv;
- priv->project = planner_window_get_project (plugin->main_window);
-
-+ priv->registry = e_source_registry_new_sync(NULL, NULL);
- priv->actions = gtk_action_group_new ("EDS plugin actions");
- gtk_action_group_set_translation_domain (priv->actions, GETTEXT_PACKAGE);
-
---
-1.8.2.1
-
diff --git a/app-office/planner/metadata.xml b/app-office/planner/metadata.xml
deleted file mode 100644
index 4cbddcaa..00000000
--- a/app-office/planner/metadata.xml
+++ /dev/null
@@ -1,8 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>gnome@gentoo.org</email>
- <name>Gentoo GNOME Desktop</name>
- </maintainer>
-</pkgmetadata>
diff --git a/app-office/planner/planner-9999.ebuild b/app-office/planner/planner-9999.ebuild
deleted file mode 100644
index b6e88f43..00000000
--- a/app-office/planner/planner-9999.ebuild
+++ /dev/null
@@ -1,98 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="5"
-GCONF_DEBUG="no"
-GNOME2_LA_PUNT="yes"
-PYTHON_COMPAT=( python2_{6,7} )
-
-inherit autotools eutils gnome2 python-single-r1
-if [[ ${PV} = 9999 ]]; then
- inherit gnome2-live
-fi
-
-DESCRIPTION="Project manager for Gnome"
-HOMEPAGE="http://live.gnome.org/Planner/"
-
-SLOT="0"
-LICENSE="GPL-2"
-IUSE="eds examples python"
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-if [[ ${PV} = 9999 ]]; then
- IUSE="${IUSE} doc"
- KEYWORDS=""
-else
- KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
-fi
-
-RDEPEND="
- >=dev-libs/glib-2.6:2
- >=x11-libs/gtk+-2.14:2
- >=gnome-base/libgnomecanvas-2.10
- >=gnome-base/libgnomeui-2.10
- >=gnome-base/libglade-2.4:2.0
- >=gnome-base/gconf-2.6:2
- >=dev-libs/libxml2-2.6.27:2
- >=dev-libs/libxslt-1.1.23
- python? (
- ${PYTHON_DEPS}
- >=dev-python/pygtk-2.6:2[${PYTHON_USEDEP}] )
- eds? (
- >=gnome-extra/evolution-data-server-3.6
- >=mail-client/evolution-3.6 )"
-
-DEPEND="${RDEPEND}
- app-text/scrollkeeper
- dev-util/gtk-doc-am
- >=dev-util/intltool-0.35.5
- gnome-base/gnome-common
- virtual/pkgconfig
-"
-
-if [[ ${PV} = 9999 ]]; then
- DEPEND="${DEPEND}
- doc? ( >=dev-util/gtk-doc-1 )"
-fi
-
-src_prepare() {
- # Find python in a faster way, bug #344231, upstream bug #654044
- epatch "${FILESDIR}"/0001-Speed-up-python-path-detection.patch
-
- # Fix build with eds-3.6
- epatch "${FILESDIR}"/0002-Fix-build-failure-with-evolution-data-server-3.6.patch
-
- [[ ${PV} != 9999 ]] && eautoreconf
-
- # Somehow needs this even if macro is not present
- [[ ${PV} = 9999 ]] && gnome-doc-common
- gnome2_src_prepare
-
-}
-
-src_configure() {
- # FIXME: disable eds backend for now, it fails, upstream bug #654005
- # We need to set compile-warnings to a different value as it doesn't use
- # standard macro: https://bugzilla.gnome.org/703067
- gnome2_src_configure \
- $(use_enable python) \
- $(use_enable python python-plugin) \
- $(use_enable eds) \
- --disable-eds-backend \
- --with-database=no \
- --disable-update-mimedb \
- --enable-compile-warnings=yes
- #$(use_enable eds eds-backend)
-}
-
-src_install() {
- # error: relink `libstorage-mrproject-1.la' with the above command before installing it
- # Try to drop workaround on next snapshot or bump
- MAKEOPTS="${MAKEOPTS} -j1" gnome2_src_install \
- sqldocdir="\$(datadir)/doc/${PF}" \
- sampledir="\$(datadir)/doc/${PF}/examples"
-
- if ! use examples; then
- rm -rf "${D}/usr/share/doc/${PF}/examples"
- fi
-}
diff --git a/app-text/libgxps/libgxps-9999.ebuild b/app-text/libgxps/libgxps-9999.ebuild
deleted file mode 100644
index f43a1640..00000000
--- a/app-text/libgxps/libgxps-9999.ebuild
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="4"
-GNOME2_LA_PUNT="yes"
-GCONF_DEBUG="yes"
-
-inherit gnome2
-if [[ ${PV} = 9999 ]]; then
- inherit gnome2-live
-fi
-
-DESCRIPTION="Library for handling and rendering XPS documents"
-HOMEPAGE="http://live.gnome.org/libgxps"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-IUSE="debug doc +introspection jpeg lcms static-libs tiff"
-if [[ ${PV} = 9999 ]]; then
- KEYWORDS=""
- IUSE="${IUSE} doc"
-else
- KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
-fi
-
-RDEPEND="
- >=app-arch/libarchive-2.8
- >=dev-libs/glib-2.24:2
- media-libs/freetype:2
- media-libs/libpng:0
- >=x11-libs/cairo-1.10[svg]
- introspection? ( >=dev-libs/gobject-introspection-0.10.1 )
- jpeg? ( virtual/jpeg )
- lcms? ( media-libs/lcms:2 )
- tiff? ( media-libs/tiff[zlib] )
-"
-DEPEND="${RDEPEND}
- app-text/docbook-xsl-stylesheets
- dev-libs/libxslt
- >=dev-util/gtk-doc-am-1.14
- virtual/pkgconfig
-"
-
-if [[ ${PV} = 9999 ]]; then
- DEPEND="${DEPEND}
- doc? (
- app-text/docbook-xml-dtd:4.1.2
- >=dev-util/gtk-doc-1.14 )"
-fi
-
-# There is no automatic test suite, only an interactive test application
-RESTRICT="test"
-
-src_configure() {
- DOCS="AUTHORS ChangeLog NEWS README TODO"
- gnome2_src_configure \
- --enable-man \
- --disable-test \
- $(use_enable debug) \
- $(use_enable introspection) \
- $(use_with jpeg libjpeg) \
- $(use_with lcms liblcms2) \
- $(use_enable static-libs static) \
- $(use_with tiff libtiff)
-}
diff --git a/app-text/libgxps/metadata.xml b/app-text/libgxps/metadata.xml
deleted file mode 100644
index 39980802..00000000
--- a/app-text/libgxps/metadata.xml
+++ /dev/null
@@ -1,8 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
-<maintainer type="project">
- <email>gnome@gentoo.org</email>
- <name>Gentoo GNOME Desktop</name>
-</maintainer>
-</pkgmetadata>
diff --git a/dev-libs/glib/Manifest b/dev-libs/glib/Manifest
deleted file mode 100644
index b3852fbd..00000000
--- a/dev-libs/glib/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST pkg-config-0.28.tar.gz 1931203 BLAKE2B bafdd4e838623965c6bd454421ddd9051fc43fc29948e1615b49fef463c3c3a18807aabe6416f96cfdf58d6b1c9e114d77f97bd985facee7c14284a8a64a768b SHA512 6eafa5ca77c5d44cd15f48457a5e96fcea2555b66d8e35ada5ab59864a0aa03d441e15f54ab9c6343693867b3b490f392c75b7d9312f024c9b7ec6a0194d8320
diff --git a/dev-libs/glib/files/gengiotypefuncs.py b/dev-libs/glib/files/gengiotypefuncs.py
deleted file mode 100755
index 9732d789..00000000
--- a/dev-libs/glib/files/gengiotypefuncs.py
+++ /dev/null
@@ -1,45 +0,0 @@
-#!/usr/bin/env python3
-# -*- coding: utf-8 -*-
-
-import sys
-import re
-import os
-
-debug = os.getenv('GIO_GENTYPEFUNCS_DEBUG') is not None
-
-out_file = sys.argv[1]
-in_files = sys.argv[2:]
-
-funcs = []
-
-
-if debug: print ('Output file: ', out_file)
-
-if debug: print (len(in_files), 'input files')
-
-for filename in in_files:
- if debug: print ('Input file: ', filename)
- with open(filename, "r") as f:
- for line in f:
- line = line.rstrip('\n').rstrip('\r')
- # print line
- match = re.search(r'\bg_[a-zA-Z0-9_]*_get_type\b', line)
- if match:
- func = match.group(0)
- if not func in funcs:
- funcs.append(func)
- if debug: print ('Found ', func)
-
-file_output = 'G_GNUC_BEGIN_IGNORE_DEPRECATIONS\n'
-
-funcs = sorted(funcs)
-
-for f in funcs:
- if f not in ['g_io_extension_get_type', 'g_settings_backend_get_type']:
- file_output += '*tp++ = {0} ();\n'.format(f)
-
-if debug: print (len(funcs), 'functions')
-
-ofile = open(out_file, "w")
-ofile.write(file_output)
-ofile.close()
diff --git a/dev-libs/glib/files/glib-2.54.2-external-codegen.patch b/dev-libs/glib/files/glib-2.54.2-external-codegen.patch
deleted file mode 100644
index 3c654216..00000000
--- a/dev-libs/glib/files/glib-2.54.2-external-codegen.patch
+++ /dev/null
@@ -1,101 +0,0 @@
-From d4a7cb8d053daab95b8d250af6b21c81bc860777 Mon Sep 17 00:00:00 2001
-From: Sobhan Mohammadpour <mohammadpour.sobhan@gmail.com>
-Date: Sat, 16 Dec 2017 21:30:22 +0330
-Subject: [PATCH] glib-2.54.2 external codegen
-
----
- docs/reference/gio/meson.build | 4 +---
- gio/meson.build | 6 +++---
- gio/tests/gdbus-object-manager-example/meson.build | 2 +-
- gio/tests/meson.build | 2 +-
- 4 files changed, 6 insertions(+), 8 deletions(-)
-
-diff --git a/docs/reference/gio/meson.build b/docs/reference/gio/meson.build
-index 7f04677..71b5e0c 100644
---- a/docs/reference/gio/meson.build
-+++ b/docs/reference/gio/meson.build
-@@ -121,7 +121,6 @@ if get_option('with-docs') != 'no'
- 'gsettings.xml',
- 'gresource.xml',
- 'gdbus.xml',
-- 'gdbus-codegen.xml',
- ],
- expand_content_files : [
- 'overview.xml',
-@@ -129,7 +128,6 @@ if get_option('with-docs') != 'no'
- 'migrating-gnome-vfs.xml',
- 'migrating-gconf.xml',
- 'migrating-gdbus.xml',
-- 'gdbus-codegen.xml',
- ],
- html_assets : [
- 'gvfs-overview.png',
-@@ -149,7 +147,7 @@ endif
- if get_option('with-man') != 'no' and xsltproc.found()
- manpages = ['gapplication', 'gio-querymodules', 'glib-compile-schemas',
- 'glib-compile-resources', 'gsettings', 'gresource', 'gdbus',
-- 'gio', 'gdbus-codegen']
-+ 'gio']
- foreach page : manpages
- custom_target(page + '-man',
- input: page + '.xml',
-diff --git a/gio/meson.build b/gio/meson.build
-index 3252636..3c566ed 100644
---- a/gio/meson.build
-+++ b/gio/meson.build
-@@ -165,7 +165,7 @@ gdbus_sources = [
- ]
-
- # Generate gdbus-codegen
--subdir('gdbus-2.0/codegen')
-+#subdir('gdbus-2.0/codegen')
-
- # Generate xdp-dbus.{c,h}
- xdp_dbus_generated = custom_target('xdp-dbus',
-@@ -174,7 +174,7 @@ xdp_dbus_generated = custom_target('xdp-dbus',
- 'org.freedesktop.portal.NetworkMonitor.xml',
- 'org.freedesktop.portal.ProxyResolver.xml'],
- output : ['xdp-dbus.h', 'xdp-dbus.c'],
-- command : [python, gdbus_codegen,
-+ command : [find_program('gdbus-codegen'),
- '--interface-prefix', 'org.freedesktop.portal.',
- '--output-directory', '@OUTDIR@',
- '--generate-c-code', 'xdp-dbus',
-@@ -193,7 +193,7 @@ xdp_dbus_generated = custom_target('xdp-dbus',
- gdbus_daemon_generated = custom_target('gdbus-daemon-generated',
- input : ['dbus-daemon.xml'],
- output : ['gdbus-daemon-generated.h', 'gdbus-daemon-generated.c'],
-- command : [python, gdbus_codegen,
-+ command : [find_program('gdbus-codegen'),
- '--interface-prefix', 'org.',
- '--output-directory', '@OUTDIR@',
- '--generate-c-code', 'gdbus-daemon-generated',
-diff --git a/gio/tests/gdbus-object-manager-example/meson.build b/gio/tests/gdbus-object-manager-example/meson.build
-index 6303573..499bb9a 100644
---- a/gio/tests/gdbus-object-manager-example/meson.build
-+++ b/gio/tests/gdbus-object-manager-example/meson.build
-@@ -5,7 +5,7 @@ gdbus_example_objectmanager_generated = custom_target('gdbus-example-objectmanag
- 'gdbus-example-objectmanager-generated.c',
- 'gdbus-example-objectmanager-generated-org.gtk.GDBus.Example.ObjectManager.Animal.xml',
- 'gdbus-example-objectmanager-generated-org.gtk.GDBus.Example.ObjectManager.Cat.xml'],
-- command : [python, gdbus_codegen,
-+ command : [find_program('gdbus-codegen'),
- '--interface-prefix', 'org.gtk.GDBus.Example.ObjectManager.',
- '--c-namespace', 'Example',
- '--c-generate-object-manager',
-diff --git a/gio/tests/meson.build b/gio/tests/meson.build
-index e149a4b..69a161e 100644
---- a/gio/tests/meson.build
-+++ b/gio/tests/meson.build
-@@ -145,7 +145,7 @@ if host_machine.system() != 'windows'
- input : ['test-codegen.xml'],
- output : ['gdbus-test-codegen-generated.h',
- 'gdbus-test-codegen-generated.c'],
-- command : [python, gdbus_codegen,
-+ command : [find_program('gdbus-codegen'),
- '--interface-prefix', 'org.project.',
- '--output-directory', '@OUTDIR@',
- '--generate-c-code', 'gdbus-test-codegen-generated',
---
-2.15.1
-
diff --git a/dev-libs/glib/glib-9999.ebuild b/dev-libs/glib/glib-9999.ebuild
deleted file mode 100644
index b921c712..00000000
--- a/dev-libs/glib/glib-9999.ebuild
+++ /dev/null
@@ -1,314 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-# Until bug #537330 glib is a reverse dependency of pkgconfig and, then
-# adding new dependencies end up making stage3 to grow. Every addition needs
-# then to be think very closely.
-
-EAPI=6
-PYTHON_COMPAT=( python2_7 )
-# Completely useless with or without USE static-libs, people need to use pkg-config
-GNOME2_LA_PUNT="yes"
-
-inherit bash-completion-r1 flag-o-matic gnome-meson libtool linux-info \
- multilib multilib-minimal pax-utils python-r1 toolchain-funcs versionator virtualx
-
-if [[ ${PV} = 9999 ]]; then
- inherit git-r3
-fi
-
-DESCRIPTION="The GLib library of C routines"
-HOMEPAGE="https://www.gtk.org/"
-SRC_URI="${SRC_URI}
- https://pkgconfig.freedesktop.org/releases/pkg-config-0.28.tar.gz" # pkg.m4 for eautoreconf
-
-if [[ ${PV} = 9999 ]]; then
- EGIT_REPO_URI="https://git.gnome.org/browse/${GNOME_ORG_MODULE}"
- SRC_URI="https://pkgconfig.freedesktop.org/releases/pkg-config-0.28.tar.gz" # pkg.m4 for eautoreconf
-fi
-
-LICENSE="LGPL-2.1+"
-SLOT="2"
-IUSE="dbus debug fam kernel_linux +mime selinux static-libs systemtap test utils xattr"
-REQUIRED_USE="
- utils? ( ${PYTHON_REQUIRED_USE} )
- test? ( ${PYTHON_REQUIRED_USE} )
-"
-
-if [[ ${PV} = 9999 ]]; then
- KEYWORDS=""
-else
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux"
-fi
-
-RDEPEND="
- !<dev-util/gdbus-codegen-${PV}
- >=dev-libs/libpcre-8.13:3[${MULTILIB_USEDEP},static-libs?]
- >=virtual/libiconv-0-r1[${MULTILIB_USEDEP}]
- >=virtual/libffi-3.0.13-r1[${MULTILIB_USEDEP}]
- >=virtual/libintl-0-r2[${MULTILIB_USEDEP}]
- >=sys-libs/zlib-1.2.8-r1[${MULTILIB_USEDEP}]
- kernel_linux? ( sys-apps/util-linux[${MULTILIB_USEDEP}] )
- selinux? ( >=sys-libs/libselinux-2.2.2-r5[${MULTILIB_USEDEP}] )
- xattr? ( >=sys-apps/attr-2.4.47-r1[${MULTILIB_USEDEP}] )
- fam? ( >=virtual/fam-0-r1[${MULTILIB_USEDEP}] )
- utils? (
- ${PYTHON_DEPS}
- >=dev-util/gdbus-codegen-${PV}[${PYTHON_USEDEP}]
- virtual/libelf:0=
- )
-"
-DEPEND="${RDEPEND}
- app-text/docbook-xml-dtd:4.1.2
- >=dev-libs/libxslt-1.0
- >=sys-devel/gettext-0.11
- >=dev-util/gtk-doc-am-1.20
- systemtap? ( >=dev-util/systemtap-1.3 )
- test? (
- sys-devel/gdb
- ${PYTHON_DEPS}
- >=dev-util/gdbus-codegen-${PV}[${PYTHON_USEDEP}]
- >=sys-apps/dbus-1.2.14 )
- !<dev-util/gtk-doc-1.15-r2
-"
-PDEPEND="!<gnome-base/gvfs-1.6.4-r990
- dbus? ( gnome-base/dconf )
- mime? ( x11-misc/shared-mime-info )
-"
-# shared-mime-info needed for gio/xdgmime, bug #409481
-# dconf is needed to be able to save settings, bug #498436
-# Earlier versions of gvfs do not work with glib
-
-MULTILIB_CHOST_TOOLS=(
- /usr/bin/gio-querymodules$(get_exeext)
-)
-
-pkg_setup() {
- if use kernel_linux ; then
- CONFIG_CHECK="~INOTIFY_USER"
- if use test ; then
- CONFIG_CHECK="~IPV6"
- WARNING_IPV6="Your kernel needs IPV6 support for running some tests, skipping them."
- fi
- linux-info_pkg_setup
- fi
-}
-
-src_unpack() {
- git-r3_src_unpack
- default
-}
-src_prepare() {
- # Prevent build failure in stage3 where pkgconfig is not available, bug #481056
- mv -f "${WORKDIR}"/pkg-config-*/pkg.m4 "${S}"/m4macros/ || die
- # Copy missing gengiotypefuncs.py
- cp "${FILESDIR}"/gengiotypefuncs.py "${S}"/gio/tests/ || die
-
- # We need gengiotypefuncs
- if use test; then
- # Disable tests requiring dev-util/desktop-file-utils when not installed, bug #286629, upstream bug #629163
- if ! has_version dev-util/desktop-file-utils ; then
- ewarn "Some tests will be skipped due dev-util/desktop-file-utils not being present on your system,"
- ewarn "think on installing it to get these tests run."
- sed -i -e "/appinfo\/associations/d" gio/tests/appinfo.c || die
- sed -i -e "/g_test_add_func/d" gio/tests/desktop-app-info.c || die
- fi
-
- # gdesktopappinfo requires existing terminal (gnome-terminal or any
- # other), falling back to xterm if one doesn't exist
- if ! has_version x11-terms/xterm && ! has_version x11-terms/gnome-terminal ; then
- ewarn "Some tests will be skipped due to missing terminal program"
- sed -i -e "/appinfo\/launch/d" gio/tests/appinfo.c || die
- fi
-
- # https://bugzilla.gnome.org/show_bug.cgi?id=722604
- sed -i -e "/timer\/stop/d" glib/tests/timer.c || die
- sed -i -e "/timer\/basic/d" glib/tests/timer.c || die
-
- ewarn "Tests for search-utils have been skipped"
- sed -i -e "/search-utils/d" glib/tests/Makefile.am || die
- else
- # Don't build tests, also prevents extra deps, bug #512022
- sed -i -e 's/ tests//' {.,gio,glib}/Makefile.am || die
- fi
-
- # gdbus-codegen is a separate package
- eapply "${FILESDIR}"/${PN}-2.54.2-external-codegen.patch
-
- # Leave python shebang alone - handled by python_replicate_script
- # We could call python_setup and give configure a valid --with-python
- # arg, but that would mean a build dep on python when USE=utils.
- sed -e '/${PYTHON}/d' \
- -i glib/Makefile.{am,in} || die
-
- gnome-meson_src_prepare
-}
-
-multilib_src_configure() {
- # TODO is this still relevent?
- # Avoid circular depend with dev-util/pkgconfig and
- # native builds (cross-compiles won't need pkg-config
- # in the target ROOT to work here)
- if ! tc-is-cross-compiler && ! $(tc-getPKG_CONFIG) --version >& /dev/null; then
- if has_version sys-apps/dbus; then
- export DBUS1_CFLAGS="-I/usr/include/dbus-1.0 -I/usr/$(get_libdir)/dbus-1.0/include"
- export DBUS1_LIBS="-ldbus-1"
- fi
- export LIBFFI_CFLAGS="-I$(echo /usr/$(get_libdir)/libffi-*/include)"
- export LIBFFI_LIBS="-lffi"
- export PCRE_CFLAGS=" " # test -n "$PCRE_CFLAGS" needs to pass
- export PCRE_LIBS="-lpcre"
- fi
-
- # These configure tests don't work when cross-compiling.
- if tc-is-cross-compiler ; then
- # https://bugzilla.gnome.org/show_bug.cgi?id=756473
- case ${CHOST} in
- hppa*|metag*) export glib_cv_stack_grows=yes ;;
- *) export glib_cv_stack_grows=no ;;
- esac
- # https://bugzilla.gnome.org/show_bug.cgi?id=756474
- export glib_cv_uscore=no
- # https://bugzilla.gnome.org/show_bug.cgi?id=756475
- export ac_cv_func_posix_get{pwuid,grgid}_r=yes
- fi
-
- local myconf
-
- # FIXME multilib automagic for libelf
- # FIXME set systemtap/tapse/static-lib install dir and test it.
- # FIXME no selinux, fam, xattr for now.
- # FIXME is this still valid.
- # libelf used only by the gresource bin ??
- # FIXME enable docs if possible.
-
- use static-libs && myconf="-Ddefault_library='static'"
- use debug && myconf="$myconf -Dbuildtype='debug'"
-
- gnome-meson_src_configure \
- ${myconf} \
- -Denable-libmount=$(usex kernel_linux yes no) \
- $(meson_use systemtap enable-dtrace) \
- $(meson_use systemtap enable-systemtap) \
- -Dwith-pcre=system \
- -Dwith-docs=no \
- -Dwith-man=yes
-
- if multilib_is_native_abi; then
- local d
- for d in glib gio gobject; do
- ln -s "${S}"/docs/reference/${d}/html docs/reference/${d}/html || die
- done
- fi
-}
-
-multilib_src_compile() {
- gnome-meson_src_compile
-}
-# FIXME
-multilib_src_test() {
- export XDG_CONFIG_DIRS=/etc/xdg
- export XDG_DATA_DIRS=/usr/local/share:/usr/share
- export G_DBUS_COOKIE_SHA1_KEYRING_DIR="${T}/temp"
- export LC_TIME=C # bug #411967
- unset GSETTINGS_BACKEND # bug #596380
- python_setup
-
- # Related test is a bit nitpicking
- mkdir "$G_DBUS_COOKIE_SHA1_KEYRING_DIR"
- chmod 0700 "$G_DBUS_COOKIE_SHA1_KEYRING_DIR"
-
- # Hardened: gdb needs this, bug #338891
- if host-is-pax ; then
- pax-mark -mr "${BUILD_DIR}"/tests/.libs/assert-msg-test \
- || die "Hardened adjustment failed"
- fi
-
- # Need X for dbus-launch session X11 initialization
- virtx meson_src_test
-}
-
-multilib_src_install() {
- chmod +x glib-gettextize || die
- gnome-meson_src_install completiondir="$(get_bashcompdir)"
- keepdir /usr/$(get_libdir)/gio/modules
-}
-
-multilib_src_install_all() {
- einstalldocs
-
- if use utils ; then
- python_replicate_script "${ED}"/usr/bin/gtester-report
- else
- rm "${ED}usr/bin/gtester-report"
- rm "${ED}usr/share/man/man1/gtester-report.1"
- fi
-
- # Do not install charset.alias even if generated, leave it to libiconv
- rm -f "${ED}/usr/lib/charset.alias"
-
- # Don't install gdb python macros, bug 291328
- rm -rf "${ED}/usr/share/gdb/" "${ED}/usr/share/glib-2.0/gdb/"
-}
-
-pkg_preinst() {
- gnome-meson_pkg_preinst
-
- # Make gschemas.compiled belong to glib alone
- local cache="usr/share/glib-2.0/schemas/gschemas.compiled"
-
- if [[ -e ${EROOT}${cache} ]]; then
- cp "${EROOT}"${cache} "${ED}"/${cache} || die
- else
- touch "${ED}"/${cache} || die
- fi
-
- multilib_pkg_preinst() {
- # Make giomodule.cache belong to glib alone
- local cache="usr/$(get_libdir)/gio/modules/giomodule.cache"
-
- if [[ -e ${EROOT}${cache} ]]; then
- cp "${EROOT}"${cache} "${ED}"/${cache} || die
- else
- touch "${ED}"/${cache} || die
- fi
- }
-
- # Don't run the cache ownership when cross-compiling, as it would end up with an empty cache
- # file due to inability to create it and GIO might not look at any of the modules there
- if ! tc-is-cross-compiler ; then
- multilib_foreach_abi multilib_pkg_preinst
- fi
-}
-
-pkg_postinst() {
- # force (re)generation of gschemas.compiled
- GNOME2_ECLASS_GLIB_SCHEMAS="force"
-
- gnome-meson_pkg_postinst
-
- multilib_pkg_postinst() {
- gnome2_giomodule_cache_update \
- || die "Update GIO modules cache failed (for ${ABI})"
- }
- if ! tc-is-cross-compiler ; then
- multilib_foreach_abi multilib_pkg_postinst
- else
- ewarn "Updating of GIO modules cache skipped due to cross-compilation."
- ewarn "You might want to run gio-querymodules manually on the target for"
- ewarn "your final image for performance reasons and re-run it when packages"
- ewarn "installing GIO modules get upgraded or added to the image."
- fi
-}
-
-pkg_postrm() {
- gnome-meson_pkg_postrm
-
- if [[ -z ${REPLACED_BY_VERSION} ]]; then
- multilib_pkg_postrm() {
- rm -f "${EROOT}"usr/$(get_libdir)/gio/modules/giomodule.cache
- }
- multilib_foreach_abi multilib_pkg_postrm
- rm -f "${EROOT}"usr/share/glib-2.0/schemas/gschemas.compiled
- fi
-}
diff --git a/dev-libs/glib/metadata.xml b/dev-libs/glib/metadata.xml
deleted file mode 100644
index b88ccebb..00000000
--- a/dev-libs/glib/metadata.xml
+++ /dev/null
@@ -1,31 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>gnome@gentoo.org</email>
- <name>Gentoo GNOME Desktop</name>
- </maintainer>
- <use>
- <flag name="dbus">
- Enable dependencies required by glib libraries
- using dbus service to manage settings saving
- </flag>
- <flag name="mime">
- Pull in shared MIME database that many glib-based
- applications require at runtime to detect or open files. Warning:
- do not disable this flag unless installing on a headless server.
- </flag>
- <flag name="systemtap">
- Build support for profiling and tracing using
- <pkg>dev-util/systemtap</pkg>
- </flag>
- <flag name="utils">
- Install gtester-report utility to generate test
- report files for your software; build gresource utility with
- ELF support.
- </flag>
- </use>
- <upstream>
- <remote-id type="cpe">cpe:/a:gnome:glib</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/dev-libs/gmime/gmime-9999.ebuild b/dev-libs/gmime/gmime-9999.ebuild
deleted file mode 100644
index e83e816f..00000000
--- a/dev-libs/gmime/gmime-9999.ebuild
+++ /dev/null
@@ -1,82 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="5"
-GCONF_DEBUG="no"
-VALA_USE_DEPEND="vapigen"
-
-inherit eutils mono-env gnome2 vala
-if [[ ${PV} = 9999 ]]; then
- inherit gnome2-live
-fi
-
-DESCRIPTION="Utilities for creating and parsing messages using MIME"
-HOMEPAGE="http://spruce.sourceforge.net/gmime/ http://developer.gnome.org/gmime/stable/"
-
-SLOT="2.6"
-LICENSE="LGPL-2.1"
-if [[ ${PV} = 9999 ]]; then
- KEYWORDS=""
-else
- KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
-fi
-IUSE="doc mono static-libs vala"
-
-RDEPEND="
- >=dev-libs/glib-2.18:2
- sys-libs/zlib
- >=app-crypt/gpgme-1.1.6
- mono? (
- dev-lang/mono
- >=dev-dotnet/glib-sharp-2.4.0:2 )
-"
-DEPEND="${RDEPEND}
- >=dev-util/gtk-doc-am-1.8
- virtual/pkgconfig
- doc? ( app-text/docbook-sgml-utils )
- mono? ( dev-dotnet/gtk-sharp-gapi:2 )
- vala? (
- $(vala_depend)
- >=dev-libs/gobject-introspection-1.30.0 )
-"
-
-if [[ ${PV} = 9999 ]]; then
- DEPEND="${DEPEND}
- doc? ( >=dev-util/gtk-doc-1.8 )"
-fi
-
-pkg_setup() {
- use mono && mono-env_pkg_setup
-}
-
-src_prepare() {
- use vala && vala_src_prepare
- gnome2_src_prepare
-}
-
-src_configure() {
- gnome2_src_configure \
- --enable-cryptography \
- --disable-strict-parser \
- $(use_enable mono) \
- $(use_enable static-libs static) \
- $(use_enable vala)
-}
-
-src_compile() {
- MONO_PATH="${S}" gnome2_src_compile
- if use doc; then
- emake -C docs/tutorial html
- fi
-}
-
-src_install() {
- GACUTIL_FLAGS="/root '${ED}/usr/$(get_libdir)' /gacdir '${EPREFIX}/usr/$(get_libdir)' /package ${PN}" \
- gnome2_src_install
-
- if use doc ; then
- docinto tutorial
- dodoc docs/tutorial/html/*
- fi
-}
diff --git a/dev-libs/gmime/metadata.xml b/dev-libs/gmime/metadata.xml
deleted file mode 100644
index 24ed35a7..00000000
--- a/dev-libs/gmime/metadata.xml
+++ /dev/null
@@ -1,11 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>gnome@gentoo.org</email>
- <name>Gentoo GNOME Desktop</name>
- </maintainer>
- <upstream>
- <remote-id type="sourceforge">spruce</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/dev-libs/gobject-introspection/gobject-introspection-9999.ebuild b/dev-libs/gobject-introspection/gobject-introspection-9999.ebuild
deleted file mode 100644
index a4951ac1..00000000
--- a/dev-libs/gobject-introspection/gobject-introspection-9999.ebuild
+++ /dev/null
@@ -1,85 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6,3_7} )
-PYTHON_REQ_USE="xml"
-
-inherit eapi7-ver gnome2 python-single-r1 toolchain-funcs
-if [[ ${PV} = 9999 ]]; then
- inherit gnome2-live
-fi
-
-DESCRIPTION="Introspection system for GObject-based libraries"
-HOMEPAGE="https://wiki.gnome.org/Projects/GObjectIntrospection"
-
-LICENSE="LGPL-2+ GPL-2+"
-SLOT="0"
-IUSE="cairo doctool test"
-REQUIRED_USE="
- ${PYTHON_REQUIRED_USE}
- test? ( cairo )
-"
-if [[ ${PV} = 9999 ]]; then
- KEYWORDS=""
- IUSE="${IUSE} doc"
-else
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-fi
-
-# virtual/pkgconfig needed at runtime, bug #505408
-# We force glib and g-i to be in sync by this way as explained in bug #518424
-RDEPEND="
- >=dev-libs/gobject-introspection-common-${PV}
- >=dev-libs/glib-9999:2
- doctool? ( dev-python/mako[${PYTHON_USEDEP}] )
- virtual/libffi:=
- virtual/pkgconfig
- !<dev-lang/vala-0.20.0
- ${PYTHON_DEPS}
-"
-# Wants real bison, not virtual/yacc
-DEPEND="${RDEPEND}
- >=dev-util/gtk-doc-am-1.19
- sys-devel/bison
- sys-devel/flex
- test? ( x11-libs/cairo[glib] )
-"
-
-if [[ ${PV} == 9999 ]]; then
- DEPEND="${DEPEND}
- doc? ( >=dev-util/gtk-doc-1.19 )"
-fi
-
-# PDEPEND to avoid circular dependencies, bug #391213; but needed for tests, thus test DEPEND as well
-PDEPEND="cairo? ( x11-libs/cairo[glib] )"
-
-pkg_setup() {
- python-single-r1_pkg_setup
-}
-
-src_configure() {
- if ! has_version "x11-libs/cairo[glib]"; then
- # Bug #391213: enable cairo-gobject support even if it's not installed
- # We only PDEPEND on cairo to avoid circular dependencies
- export CAIRO_LIBS="-lcairo -lcairo-gobject"
- export CAIRO_CFLAGS="-I${EPREFIX}/usr/include/cairo"
- fi
-
- # To prevent crosscompiling problems, bug #414105
- gnome2_src_configure \
- --disable-static \
- CC="$(tc-getCC)" \
- YACC="$(type -p yacc)" \
- $(use_with cairo) \
- $(use_enable doctool)
-}
-
-src_install() {
- gnome2_src_install
-
- # Prevent collision with gobject-introspection-common
- rm -v "${ED}"usr/share/aclocal/introspection.m4 \
- "${ED}"usr/share/gobject-introspection-1.0/Makefile.introspection || die
- rmdir "${ED}"usr/share/aclocal || die
-}
diff --git a/dev-libs/gobject-introspection/metadata.xml b/dev-libs/gobject-introspection/metadata.xml
deleted file mode 100644
index ed75a827..00000000
--- a/dev-libs/gobject-introspection/metadata.xml
+++ /dev/null
@@ -1,12 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
-<maintainer type="project">
- <email>gnome@gentoo.org</email>
- <name>Gentoo GNOME Desktop</name>
-</maintainer>
-<use>
- <flag name="doctool">Install g-ir-doc-tool for generating documentation
- from introspected data</flag>
-</use>
-</pkgmetadata>
diff --git a/dev-libs/libgdata/libgdata-9999.ebuild b/dev-libs/libgdata/libgdata-9999.ebuild
deleted file mode 100644
index f16ec5fb..00000000
--- a/dev-libs/libgdata/libgdata-9999.ebuild
+++ /dev/null
@@ -1,78 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="5"
-GCONF_DEBUG="yes"
-VALA_MIN_API_VERSION="0.20"
-VALA_USE_DEPEND="vapigen"
-
-inherit gnome2 vala
-if [[ ${PV} = 9999 ]]; then
- inherit gnome2-live
-fi
-
-DESCRIPTION="GLib-based library for accessing online service APIs using the GData protocol"
-HOMEPAGE="https://wiki.gnome.org/Projects/libgdata"
-
-LICENSE="LGPL-2.1+"
-SLOT="0/22" # subslot = libgdata soname version
-IUSE="gnome +introspection static-libs test vala"
-if [[ ${PV} = 9999 ]]; then
- IUSE="${IUSE} doc"
- KEYWORDS=""
-else
- KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
-fi
-REQUIRED_IUSE="vala? ( introspection )"
-
-# gtk+ is needed for gdk
-# configure checks for gtk:3, but only uses it for demos which are not installed
-RDEPEND="
- >=dev-libs/glib-2.32:2
- >=dev-libs/json-glib-0.15
- >=dev-libs/libxml2-2:2
- >=net-libs/liboauth-0.9.4
- >=net-libs/libsoup-2.42.0:2.4[introspection?]
- >=x11-libs/gdk-pixbuf-2.14:2
- gnome? (
- app-crypt/gcr:=
- >=net-libs/gnome-online-accounts-3.8 )
- introspection? ( >=dev-libs/gobject-introspection-0.9.7 )
-"
-DEPEND="${RDEPEND}
- >=dev-util/gtk-doc-am-1.14
- >=dev-util/intltool-0.40
- >=gnome-base/gnome-common-3.6
- virtual/pkgconfig
- test? ( net-libs/uhttpmock )
- vala? ( $(vala_depend) )
-"
-
-if [[ ${PV} = 9999 ]]; then
- DEPEND="${DEPEND}
- doc? ( >=dev-util/gtk-doc-1.14 )"
-fi
-
-src_prepare() {
- vala_src_prepare
- gnome2_src_prepare
-}
-
-src_configure() {
- DOCS="AUTHORS ChangeLog HACKING NEWS README"
- gnome2_src_configure \
- $(use_enable gnome) \
- $(use_enable gnome goa) \
- $(use_enable introspection) \
- $(use_enable vala) \
- $(use_enable static-libs static) \
- $(use_enable test tests)
-}
-
-src_test() {
- unset ORBIT_SOCKETDIR
- unset DBUS_SESSION_BUS_ADDRESS
- export GSETTINGS_BACKEND="memory" #486412
- dbus-launch emake check
-}
diff --git a/dev-libs/libgdata/metadata.xml b/dev-libs/libgdata/metadata.xml
deleted file mode 100644
index 4b8d03fb..00000000
--- a/dev-libs/libgdata/metadata.xml
+++ /dev/null
@@ -1,11 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
-<maintainer type="project">
- <email>gnome@gentoo.org</email>
- <name>Gentoo GNOME Desktop</name>
-</maintainer>
-<use>
- <flag name="gnome-online-accounts">Enable <pkg>net-libs/gnome-online-accounts</pkg> support</flag>
-</use>
-</pkgmetadata>
diff --git a/dev-python/pyatspi/files/pyatspi-2.6.0-examples-python3.patch b/dev-python/pyatspi/files/pyatspi-2.6.0-examples-python3.patch
deleted file mode 100644
index 423cd644..00000000
--- a/dev-python/pyatspi/files/pyatspi-2.6.0-examples-python3.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-From 4f10a696002179082e41568b5109400ac8478a96 Mon Sep 17 00:00:00 2001
-From: Alexandre Rostovtsev <tetromino@gentoo.org>
-Date: Mon, 10 Dec 2012 04:52:03 -0500
-Subject: [PATCH] examples: support python2 and python3 syntax
-
-https://bugzilla.gnome.org/show_bug.cgi?id=689957
----
- examples/magFocusTracker.py | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/examples/magFocusTracker.py b/examples/magFocusTracker.py
-index 47efe00..7ca3b67 100755
---- a/examples/magFocusTracker.py
-+++ b/examples/magFocusTracker.py
-@@ -282,7 +282,7 @@ def main():
- startTracking()
- pyatspi.Registry.start()
- else:
-- print 'Magnification service not available. Exiting.'
-+ print('Magnification service not available. Exiting.')
-
- return 0
-
---
-1.8.0
-
diff --git a/dev-python/pyatspi/metadata.xml b/dev-python/pyatspi/metadata.xml
deleted file mode 100644
index 39980802..00000000
--- a/dev-python/pyatspi/metadata.xml
+++ /dev/null
@@ -1,8 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
-<maintainer type="project">
- <email>gnome@gentoo.org</email>
- <name>Gentoo GNOME Desktop</name>
-</maintainer>
-</pkgmetadata>
diff --git a/dev-python/pyatspi/pyatspi-9999.ebuild b/dev-python/pyatspi/pyatspi-9999.ebuild
deleted file mode 100644
index 50395370..00000000
--- a/dev-python/pyatspi/pyatspi-9999.ebuild
+++ /dev/null
@@ -1,64 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
-
-inherit gnome2 python-r1
-if [[ ${PV} = 9999 ]]; then
- GNOME_LIVE_MODULE="pyatspi2"
- inherit gnome2-live
-fi
-
-DESCRIPTION="Python binding to at-spi library"
-HOMEPAGE="https://wiki.gnome.org/Accessibility"
-
-# Note: only some of the tests are GPL-licensed, everything else is LGPL
-LICENSE="LGPL-2 GPL-2+"
-SLOT="0"
-if [[ ${PV} = 9999 ]]; then
- KEYWORDS=""
-else
- KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
-fi
-IUSE="" # test
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-COMMON_DEPEND="${PYTHON_DEPS}
- >=dev-libs/atk-2.11.2
- dev-python/dbus-python[${PYTHON_USEDEP}]
- >=dev-python/pygobject-2.90.1:3[${PYTHON_USEDEP}]
-"
-RDEPEND="${COMMON_DEPEND}
- >=sys-apps/dbus-1
- >=app-accessibility/at-spi2-core-${PV}[introspection]
- !<gnome-extra/at-spi-1.32.0-r1
-"
-DEPEND="${COMMON_DEPEND}
- virtual/pkgconfig
-"
-
-PATCHES=(
- # https://bugzilla.gnome.org/show_bug.cgi?id=689957
- "${FILESDIR}/${PN}-2.6.0-examples-python3.patch"
-)
-
-src_prepare() {
- gnome2_src_prepare
- python_copy_sources
-}
-
-src_configure() {
- python_foreach_impl run_in_build_dir gnome2_src_configure --disable-tests
-}
-
-src_compile() {
- python_foreach_impl run_in_build_dir gnome2_src_compile
-}
-
-src_install() {
- python_foreach_impl run_in_build_dir gnome2_src_install
-
- docinto examples
- dodoc examples/*.py
-}
diff --git a/dev-util/gdbus-codegen/files/gdbus-codegen-2.54.2-sitedir.patch b/dev-util/gdbus-codegen/files/gdbus-codegen-2.54.2-sitedir.patch
deleted file mode 100644
index fc003abc..00000000
--- a/dev-util/gdbus-codegen/files/gdbus-codegen-2.54.2-sitedir.patch
+++ /dev/null
@@ -1,34 +0,0 @@
-From f2f8ccb15cc6288455f4780d016789aa2e023d6d Mon Sep 17 00:00:00 2001
-From: Sobhan Mohammadpour <mohammadpour.sobhan@gmail.com>
-Date: Thu, 14 Dec 2017 17:10:50 +0330
-Subject: [PATCH] glib-2.54.2 external gdbus codegen
-
---
- gio/gdbus-2.0/codegen/gdbus-codegen.in | 11 +----------
- 1 file changed, 1 insertion(+), 10 deletions(-)
-
-diff --git a/gio/gdbus-2.0/codegen/gdbus-codegen.in b/gio/gdbus-2.0/codegen/gdbus-codegen.in
-index 8050981..c097702 100644
---- a/gio/gdbus-2.0/codegen/gdbus-codegen.in
-+++ b/gio/gdbus-2.0/codegen/gdbus-codegen.in
-@@ -28,16 +28,7 @@ filedir = os.path.dirname(__file__)
-
- if srcdir is not None:
- path = os.path.join(srcdir, 'gio', 'gdbus-2.0')
--elif os.path.basename(filedir) == 'bin':
-- # Make the prefix containing gdbus-codegen 'relocatable' at runtime by
-- # adding /some/prefix/bin/../share/glib-2.0 to the python path
-- path = os.path.join(filedir, '..', 'share', 'glib-2.0')
- else:
-- # Assume that the modules we need are in the current directory and add the
-- # parent directory to the python path.
-- path = os.path.join(filedir, '..')
--
--sys.path.insert(0, os.path.abspath(path))
--from codegen import codegen_main
-+ from gdbus_codegen import codegen_main
-
- sys.exit(codegen_main.codegen_main())
---
-2.15.1
-
diff --git a/dev-util/gdbus-codegen/files/gdbus-codegen-2.54.3-sitedir.patch b/dev-util/gdbus-codegen/files/gdbus-codegen-2.54.3-sitedir.patch
deleted file mode 100644
index f739026d..00000000
--- a/dev-util/gdbus-codegen/files/gdbus-codegen-2.54.3-sitedir.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-diff --git a/gio/gdbus-2.0/codegen/gdbus-codegen.in b/gio/gdbus-2.0/codegen/gdbus-codegen.in
-index 8050981..932410a 100644
---- a/gdbus-codegen.in
-+++ b/gdbus-codegen.in
-@@ -28,16 +28,7 @@ filedir = os.path.dirname(__file__)
-
- if srcdir is not None:
- path = os.path.join(srcdir, 'gio', 'gdbus-2.0')
--elif os.path.basename(filedir) == 'bin':
-- # Make the prefix containing gdbus-codegen 'relocatable' at runtime by
-- # adding /some/prefix/bin/../share/glib-2.0 to the python path
-- path = os.path.join(filedir, '..', 'share', 'glib-2.0')
- else:
-- # Assume that the modules we need are in the current directory and add the
-- # parent directory to the python path.
-- path = os.path.join(filedir, '..')
--
--sys.path.insert(0, os.path.abspath(path))
--from codegen import codegen_main
-+ from gdbus_codegen import codegen_main
-
- sys.exit(codegen_main.codegen_main())
diff --git a/dev-util/gdbus-codegen/files/gdbus-codegen-2.56.1-sitedir.patch b/dev-util/gdbus-codegen/files/gdbus-codegen-2.56.1-sitedir.patch
deleted file mode 100644
index 30f0d7dc..00000000
--- a/dev-util/gdbus-codegen/files/gdbus-codegen-2.56.1-sitedir.patch
+++ /dev/null
@@ -1,54 +0,0 @@
-From 9eaaa76e2e36e46a43dbd419724696fd7ff8ea64 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?R=C3=A9mi=20Cardona?= <remi@gentoo.org>
-Date: Sat, 14 Apr 2018 09:55:22 +0200
-Subject: [PATCH 1/2] gdbus-codegen-2.54.3-sitedir.patch
-
----
- gio/gdbus-2.0/codegen/gdbus-codegen.in | 28 --------------------------
- 1 file changed, 28 deletions(-)
-
-diff --git a/gio/gdbus-2.0/codegen/gdbus-codegen.in b/gio/gdbus-2.0/codegen/gdbus-codegen.in
-index 67d367543..190afa28f 100755
---- a/gdbus-codegen.in
-+++ b/gdbus-codegen.in
-@@ -20,36 +20,8 @@
- # Author: David Zeuthen <davidz@redhat.com>
-
-
--import os
- import sys
-
--srcdir = os.getenv('UNINSTALLED_GLIB_SRCDIR', None)
--filedir = os.path.dirname(__file__)
--
--if srcdir is not None:
-- path = os.path.join(srcdir, 'gio', 'gdbus-2.0')
--elif os.path.basename(filedir) == 'bin':
-- # Make the prefix containing gdbus-codegen 'relocatable' at runtime by
-- # adding /some/prefix/bin/../share/glib-2.0 to the python path
-- path = os.path.join(filedir, '..', 'share', 'glib-2.0')
--else:
-- # Assume that the modules we need are in the current directory and add the
-- # parent directory to the python path.
-- path = os.path.join(filedir, '..')
--
--# Canonicalize, then do further testing
--path = os.path.abspath(path)
--
--# If the above path detection failed, use the hard-coded datadir. This can
--# happen when, for instance, bindir and datadir are not in the same prefix or
--# on Windows where we cannot make any guarantees about the directory structure.
--#
--# In these cases our installation cannot be relocatable, but at least we should
--# be able to find the codegen module.
--if not os.path.isfile(os.path.join(path, 'codegen', 'codegen_main.py')):
-- path = os.path.join('@DATADIR@', 'glib-2.0')
--
--sys.path.insert(0, path)
--from codegen import codegen_main
-+from gdbus_codegen import codegen_main
-
- sys.exit(codegen_main.codegen_main())
---
-2.17.0
-
diff --git a/dev-util/gdbus-codegen/files/setup.py-2.32.4 b/dev-util/gdbus-codegen/files/setup.py-2.32.4
deleted file mode 100644
index c5318e30..00000000
--- a/dev-util/gdbus-codegen/files/setup.py-2.32.4
+++ /dev/null
@@ -1,6 +0,0 @@
-from distutils.core import setup
-setup(name="gdbus_codegen",
- version="@PV@",
- packages=["gdbus_codegen"],
- package_dir={"gdbus_codegen" : ""},
- scripts=["gdbus-codegen"])
diff --git a/dev-util/gdbus-codegen/gdbus-codegen-9999.ebuild b/dev-util/gdbus-codegen/gdbus-codegen-9999.ebuild
deleted file mode 100644
index 6b0aa57d..00000000
--- a/dev-util/gdbus-codegen/gdbus-codegen-9999.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-GNOME_ORG_MODULE="glib"
-PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
-PYTHON_REQ_USE="xml"
-
-inherit gnome.org distutils-r1
-if [[ ${PV} = 9999 ]]; then
- inherit git-r3
-fi
-
-DESCRIPTION="GDBus code and documentation generator"
-HOMEPAGE="http://www.gtk.org/"
-
-if [[ ${PV} = 9999 ]]; then
- EGIT_REPO_URI="https://git.gnome.org/browse/${GNOME_ORG_MODULE}"
- SRC_URI=""
-fi
-
-LICENSE="LGPL-2+"
-SLOT="0"
-
-if [[ ${PV} = 9999 ]]; then
- KEYWORDS=""
-else
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux"
-fi
-
-IUSE=""
-
-RDEPEND="${PYTHON_DEPS}"
-DEPEND="${RDEPEND}"
-
-# To prevent circular dependencies with glib[test]
-PDEPEND=">=dev-libs/glib-${PV}:2"
-
-S="${WORKDIR}/glib-${PV}/gio/gdbus-2.0/codegen"
-
-python_prepare_all() {
- PATCHES=(
- "${FILESDIR}/${PN}-2.54.2-sitedir.patch"
- )
- distutils-r1_python_prepare_all
-
- sed -e 's:@PYTHON@:python:' gdbus-codegen.in > gdbus-codegen || die
- cp "${FILESDIR}/setup.py-2.32.4" setup.py || die "cp failed"
- sed -e "s/@PV@/${PV}/" -i setup.py || die "sed setup.py failed"
-}
-
-src_test() {
- einfo "Skipping tests. This package is tested by dev-libs/glib"
- einfo "when merged with FEATURES=test"
-}
-
-python_install_all() {
- distutils-r1_python_install_all # no-op, but prevents QA warning
- doman "${WORKDIR}/glib-${PV}/docs/reference/gio/gdbus-codegen.1"
-}
diff --git a/dev-util/gdbus-codegen/metadata.xml b/dev-util/gdbus-codegen/metadata.xml
deleted file mode 100644
index 922faa44..00000000
--- a/dev-util/gdbus-codegen/metadata.xml
+++ /dev/null
@@ -1,11 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>gnome@gentoo.org</email>
- <name>Gentoo GNOME Desktop</name>
- </maintainer>
- <longdescription>
- gdbus-codegen is used to generate code and/or documentation for one or more D-Bus interfaces. The tool reads D-Bus Introspection XML files and generates output files.
- </longdescription>
-</pkgmetadata>
diff --git a/gnome-base/gnome-keyring/gnome-keyring-9999.ebuild b/gnome-base/gnome-keyring/gnome-keyring-9999.ebuild
deleted file mode 100644
index 7cf4a74a..00000000
--- a/gnome-base/gnome-keyring/gnome-keyring-9999.ebuild
+++ /dev/null
@@ -1,91 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="5"
-GCONF_DEBUG="yes" # Not gnome macro but similar
-GNOME2_LA_PUNT="yes"
-PYTHON_COMPAT=( python2_7 )
-
-inherit fcaps gnome2 pam python-any-r1 versionator virtualx
-if [[ ${PV} = 9999 ]]; then
- inherit gnome2-live
-fi
-
-DESCRIPTION="Password and keyring managing daemon"
-HOMEPAGE="https://wiki.gnome.org/Projects/GnomeKeyring"
-
-LICENSE="GPL-2+ LGPL-2+"
-SLOT="0"
-IUSE="+caps debug pam selinux +ssh-agent test"
-if [[ ${PV} = 9999 ]]; then
- KEYWORDS=""
-else
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~sparc-solaris ~x86-solaris"
-fi
-
-# Replace gkd gpg-agent with pinentry[gnome-keyring] one, bug #547456
-COMMON_DEPEND="
- >=app-crypt/gcr-3.5.3:=[gtk]
- >=dev-libs/glib-2.38:2
- app-misc/ca-certificates
- >=dev-libs/libgcrypt-1.2.2:0=
- caps? ( sys-libs/libcap-ng )
- pam? ( virtual/pam )
-
- >=app-crypt/gnupg-2.0.28
-"
-RDEPEND="${COMMON_DEPEND}
- app-crypt/pinentry[gnome-keyring]
-"
-DEPEND="${COMMON_DEPEND}
- >=app-eselect/eselect-pinentry-0.5
- app-text/docbook-xml-dtd:4.3
- dev-libs/libxslt
- >=dev-util/intltool-0.35
- sys-devel/gettext
- virtual/pkgconfig
- test? ( ${PYTHON_DEPS} )
-"
-
-pkg_setup() {
- use test && python-any-r1_pkg_setup
-}
-
-src_prepare() {
- # Disable stupid CFLAGS with debug enabled
- sed -e 's/CFLAGS="$CFLAGS -g"//' \
- -e 's/CFLAGS="$CFLAGS -O0"//' \
- -i configure.ac configure || die
-
- gnome2_src_prepare
-}
-
-src_configure() {
- gnome2_src_configure \
- $(use_with caps libcap-ng) \
- $(use_enable pam) \
- $(use_with pam pam-dir $(getpam_mod_dir)) \
- $(use_enable selinux) \
- $(use_enable ssh-agent) \
- --enable-doc
-}
-
-src_test() {
- # FIXME: this should be handled at eclass level
- "${EROOT}${GLIB_COMPILE_SCHEMAS}" --allow-any-name "${S}/schema" || die
-
- unset DBUS_SESSION_BUS_ADDRESS
- GSETTINGS_SCHEMA_DIR="${S}/schema" Xemake check
-}
-
-pkg_postinst() {
- # cap_ipc_lock only needed if building --with-libcap-ng
- # Never install as suid root, this breaks dbus activation, see bug #513870
- use caps && fcaps -m 755 cap_ipc_lock usr/bin/gnome-keyring-daemon
- gnome2_pkg_postinst
-
- if ! [[ $(eselect pinentry show | grep "pinentry-gnome3") ]] ; then
- ewarn "Please select pinentry-gnome3 as default pinentry provider:"
- ewarn " # eselect pinentry set pinentry-gnome3"
- fi
-}
diff --git a/gnome-base/gnome-keyring/metadata.xml b/gnome-base/gnome-keyring/metadata.xml
deleted file mode 100644
index f8058de6..00000000
--- a/gnome-base/gnome-keyring/metadata.xml
+++ /dev/null
@@ -1,21 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>gnome@gentoo.org</email>
- <name>Gentoo GNOME Desktop</name>
- </maintainer>
- <longdescription lang="en">
- GNOME Keyring is a collection of components in GNOME that store
- secrets, passwords, keys, certificates and make them available to
- applications. It is integrated with the user's login, so that
- their secret storage can be unlocked when the user logins into their
- session. It is based around a standard called PKCS#11, which is a
- standard way for applications to manage certificates and keys on
- smart cards or secure storage.
- </longdescription>
- <use>
- <flag name="ssh-agent">Use GNOME Keyring to unlock SSH keys.
- Recommended unless you are using ECDSA or Ed25519 keys.</flag>
- </use>
-</pkgmetadata>
diff --git a/gnome-extra/evolution-groupwise/evolution-groupwise-9999.ebuild b/gnome-extra/evolution-groupwise/evolution-groupwise-9999.ebuild
deleted file mode 100644
index 37061df2..00000000
--- a/gnome-extra/evolution-groupwise/evolution-groupwise-9999.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="4"
-GCONF_DEBUG="no"
-GNOME2_LA_PUNT="yes"
-
-inherit db-use eutils flag-o-matic gnome2
-if [[ ${PV} = 9999 ]]; then
- inherit gnome2-live
-fi
-
-DESCRIPTION="Evolution module for connecting to Novell Groupwise"
-HOMEPAGE="http://www.gnome.org/projects/evolution/"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-if [[ ${PV} = 9999 ]]; then
- KEYWORDS=""
-else
- KEYWORDS="~amd64 ~x86"
-fi
-IUSE="" # doc
-
-RDEPEND=">=mail-client/evolution-${PV}:2.0
- >=gnome-extra/evolution-data-server-${PV}
- >=dev-libs/glib-2.16
- >=dev-libs/libxml2-2
- >=gnome-base/gconf-2:2
- gnome-extra/gtkhtml:4.0
- >=net-libs/libsoup-2.3:2.4
- sys-libs/db
- x11-libs/gdk-pixbuf:2
- >=x11-libs/gtk+-2.90.4:3
-"
-DEPEND="${RDEPEND}
- >=dev-util/intltool-0.35.5
- virtual/pkgconfig
-"
-# For now, this package has no gtk-doc documentation to build
-# doc? ( >=dev-util/gtk-doc-1.9 )
-
-pkg_setup() {
- DOCS="ChangeLog NEWS" # AUTHORS, README are empty
-}
-
-src_prepare() {
- # /usr/include/db.h is always db-1 on FreeBSD
- # so include the right dir in CPPFLAGS
- append-cppflags "-I$(db_includedir)"
-
- gnome2_src_prepare
-}
diff --git a/gnome-extra/evolution-groupwise/metadata.xml b/gnome-extra/evolution-groupwise/metadata.xml
deleted file mode 100644
index 39980802..00000000
--- a/gnome-extra/evolution-groupwise/metadata.xml
+++ /dev/null
@@ -1,8 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
-<maintainer type="project">
- <email>gnome@gentoo.org</email>
- <name>Gentoo GNOME Desktop</name>
-</maintainer>
-</pkgmetadata>
diff --git a/gnome-extra/libgda/files/libgda-4.99.1-control-center-icon-collision.patch b/gnome-extra/libgda/files/libgda-4.99.1-control-center-icon-collision.patch
deleted file mode 100644
index fe814a73..00000000
--- a/gnome-extra/libgda/files/libgda-4.99.1-control-center-icon-collision.patch
+++ /dev/null
@@ -1,55 +0,0 @@
-From 6ec47f4cf542ad9f7c4d30d557e4813b5c6f31d5 Mon Sep 17 00:00:00 2001
-From: Alexandre Rostovtsev <tetromino@gmail.com>
-Date: Sat, 4 Jun 2011 05:45:35 -0400
-Subject: [PATCH] Prevent file collision with gda-control-center-4.0's icons
-
----
- control-center/data/Makefile.am | 12 ++++++------
- ... hicolor_apps_16x16_gda-control-center-5.0.png} | Bin 833 -> 833 bytes
- ... hicolor_apps_22x22_gda-control-center-5.0.png} | Bin 1157 -> 1157 bytes
- ... hicolor_apps_24x24_gda-control-center-5.0.png} | Bin 1144 -> 1144 bytes
- ...icolor_apps_256x256_gda-control-center-5.0.png} | Bin 33543 -> 33543 bytes
- ... hicolor_apps_32x32_gda-control-center-5.0.png} | Bin 1867 -> 1867 bytes
- ... hicolor_apps_48x48_gda-control-center-5.0.png} | Bin 3144 -> 3144 bytes
- control-center/gda-control-center-5.0.desktop.in | 2 +-
- 8 files changed, 7 insertions(+), 7 deletions(-)
-
-diff --git a/control-center/data/Makefile.am b/control-center/data/Makefile.am
-index 03fa362..862ec88 100644
---- a/control-center/data/Makefile.am
-+++ b/control-center/data/Makefile.am
-@@ -5,12 +5,12 @@ public_icons_themes = \
- $(NULL)
-
- public_icons = \
-- hicolor_apps_16x16_gda-control-center.png \
-- hicolor_apps_22x22_gda-control-center.png \
-- hicolor_apps_24x24_gda-control-center.png \
-- hicolor_apps_256x256_gda-control-center.png \
-- hicolor_apps_32x32_gda-control-center.png \
-- hicolor_apps_48x48_gda-control-center.png \
-+ hicolor_apps_16x16_gda-control-center-5.0.png \
-+ hicolor_apps_22x22_gda-control-center-5.0.png \
-+ hicolor_apps_24x24_gda-control-center-5.0.png \
-+ hicolor_apps_256x256_gda-control-center-5.0.png \
-+ hicolor_apps_32x32_gda-control-center-5.0.png \
-+ hicolor_apps_48x48_gda-control-center-5.0.png \
- $(NULL)
-
- private_icons = \
-diff --git a/control-center/gda-control-center-5.0.desktop.in b/control-center/gda-control-center-5.0.desktop.in
-index 6fd5b58..429787d 100644
---- a/control-center/gda-control-center-5.0.desktop.in
-+++ b/control-center/gda-control-center-5.0.desktop.in
-@@ -1,7 +1,7 @@
- [Desktop Entry]
- _Name=Database access control center
- _Comment=Configure your database access environment
--Icon=gda-control-center
-+Icon=gda-control-center-5.0
- Exec=gda-control-center-5.0
- Terminal=false
- Type=Application
---
-1.7.5.3
-
diff --git a/gnome-extra/libgda/files/libgda-4.99.1-gda-browser-doc-collision.patch b/gnome-extra/libgda/files/libgda-4.99.1-gda-browser-doc-collision.patch
deleted file mode 100644
index 2fd31ab7..00000000
--- a/gnome-extra/libgda/files/libgda-4.99.1-gda-browser-doc-collision.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-From bfb0d952d111929174c3326dbc69ab65a808a235 Mon Sep 17 00:00:00 2001
-From: Alexandre Rostovtsev <tetromino@gmail.com>
-Date: Sat, 4 Jun 2011 05:59:46 -0400
-Subject: [PATCH] Prevent file collision with gda-browser-4.0's gtk-doc files
-
----
- tools/browser/doc/Makefile.am | 2 +-
- ...browser-docs.sgml => gda-browser-5.0-docs.sgml} | 0
- ...r-sections.txt => gda-browser-5.0-sections.txt} | 0
- .../{gda-browser.types => gda-browser-5.0.types} | 0
- 4 files changed, 1 insertions(+), 1 deletions(-)
-
-diff --git a/tools/browser/doc/Makefile.am b/tools/browser/doc/Makefile.am
-index 971fa79..cf6637a 100644
---- a/tools/browser/doc/Makefile.am
-+++ b/tools/browser/doc/Makefile.am
-@@ -3,7 +3,7 @@
- AUTOMAKE_OPTIONS = 1.6
-
- # The name of the module.
--DOC_MODULE=gda-browser
-+DOC_MODULE=gda-browser-5.0
-
- # The top-level SGML file.
- DOC_MAIN_SGML_FILE=$(DOC_MODULE)-docs.sgml
---
-1.7.5.3
-
diff --git a/gnome-extra/libgda/files/libgda-4.99.1-gda-browser-help-collision.patch b/gnome-extra/libgda/files/libgda-4.99.1-gda-browser-help-collision.patch
deleted file mode 100644
index 46e72823..00000000
--- a/gnome-extra/libgda/files/libgda-4.99.1-gda-browser-help-collision.patch
+++ /dev/null
@@ -1,38 +0,0 @@
-From 01b13e22b215647c2343ec5f633b51d3c2b37824 Mon Sep 17 00:00:00 2001
-From: Alexandre Rostovtsev <tetromino@gmail.com>
-Date: Sat, 4 Jun 2011 01:59:14 -0400
-Subject: [PATCH] Prevent file collision with gda-browser-4.0's help files
-
----
- tools/browser/help/Makefile.am | 2 +-
- tools/browser/support.c | 2 +-
- 2 files changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/tools/browser/help/Makefile.am b/tools/browser/help/Makefile.am
-index 93acaf8..48fcdc4 100644
---- a/tools/browser/help/Makefile.am
-+++ b/tools/browser/help/Makefile.am
-@@ -1,6 +1,6 @@
- include $(top_srcdir)/gnome-doc-utils.make
-
--DOC_ID = gda-browser
-+DOC_ID = gda-browser-5.0
-
- DOC_INCLUDES = legal.xml
- DOC_FIGURES = \
-diff --git a/tools/browser/support.c b/tools/browser/support.c
-index 5b1b4e6..f462efc 100644
---- a/tools/browser/support.c
-+++ b/tools/browser/support.c
-@@ -223,7 +223,7 @@ browser_show_help (GtkWindow *parent, const gchar *topic)
- if (strchr (lang, '.'))
- continue;
-
-- uri = gda_gbr_get_file_path (GDA_DATA_DIR, "gnome", "help", "gda-browser", lang, NULL);
-+ uri = gda_gbr_get_file_path (GDA_DATA_DIR, "gnome", "help", "gda-browser-5.0", lang, NULL);
-
- /*g_print ("TST URI [%s]\n", uri);*/
- if (g_file_test (uri, G_FILE_TEST_EXISTS)) {
---
-1.7.5.3
-
diff --git a/gnome-extra/libgda/files/libgda-4.99.4-statement-rewriting-fix.patch b/gnome-extra/libgda/files/libgda-4.99.4-statement-rewriting-fix.patch
deleted file mode 100644
index 07077e54..00000000
--- a/gnome-extra/libgda/files/libgda-4.99.4-statement-rewriting-fix.patch
+++ /dev/null
@@ -1,465 +0,0 @@
-From 7d7742477ad03f19a168c763b988a7807421e9ca Mon Sep 17 00:00:00 2001
-From: Vivien Malerba <malerba@gnome-db.org>
-Date: Sat, 17 Sep 2011 14:26:09 +0000
-Subject: Fixed nasty bug introduced in commit #036420a459b0bb241716cd9a14c3dd1eb2b21f63
-
-which "Improved statement rewriting for NULL parameters", and in other
-commits for each provider
----
-diff --git a/libgda/sqlite/gda-sqlite-provider.c b/libgda/sqlite/gda-sqlite-provider.c
-index afeab3c..69ccd16 100644
---- a/libgda/sqlite/gda-sqlite-provider.c
-+++ b/libgda/sqlite/gda-sqlite-provider.c
-@@ -2935,7 +2935,33 @@ gda_sqlite_provider_statement_execute (GdaServerProvider *provider, GdaConnectio
- else if (!rstmt)
- return NULL;
- else {
-+ /* The strategy here is to execute @rstmt using the prepared
-+ * statement associcted to @stmt, but adapted to @rstmt, so all
-+ * the column names, etc remain the same.
-+ *
-+ * The adaptation consists to replace SQLite specific information
-+ * in the GdaSqlitePStmt object.
-+ *
-+ * The trick is to adapt @ps, then associate @ps with @rstmt, then
-+ * execute @rstmt, and then undo the trick */
- GObject *obj;
-+ GdaSqlitePStmt *tps;
-+ if (!gda_sqlite_provider_statement_prepare (provider, cnc,
-+ rstmt, error))
-+ return NULL;
-+ tps = (GdaSqlitePStmt *)
-+ gda_connection_get_prepared_statement (cnc, rstmt);
-+
-+ /* adapt @ps with @tps's SQLite specific information */
-+ GdaSqlitePStmt hps;
-+ hps.sqlite_stmt = ps->sqlite_stmt; /* save */
-+ ps->sqlite_stmt = tps->sqlite_stmt; /* override */
-+ hps.stmt_used = ps->stmt_used; /* save */
-+ ps->stmt_used = tps->stmt_used; /* override */
-+ g_object_ref (tps);
-+ gda_connection_add_prepared_statement (cnc, rstmt, (GdaPStmt *) ps);
-+
-+ /* execute rstmt (it will use @ps) */
- obj = gda_sqlite_provider_statement_execute (provider, cnc,
- rstmt, params,
- model_usage,
-@@ -2943,15 +2969,14 @@ gda_sqlite_provider_statement_execute (GdaServerProvider *provider, GdaConnectio
- last_inserted_row,
- task_id, async_cb,
- cb_data, error);
-+
-+ /* revert adaptations */
-+ ps->sqlite_stmt = hps.sqlite_stmt;
-+ ps->stmt_used = hps.stmt_used;
-+ gda_connection_add_prepared_statement (cnc, rstmt, (GdaPStmt *) tps);
-+ g_object_unref (tps);
- g_object_unref (rstmt);
-- if (GDA_IS_DATA_SELECT (obj)) {
-- GdaPStmt *pstmt;
-- g_object_get (obj, "prepared-stmt", &pstmt, NULL);
-- if (pstmt) {
-- gda_pstmt_set_gda_statement (pstmt, stmt);
-- g_object_unref (pstmt);
-- }
-- }
-+
- if (new_ps)
- g_object_unref (ps);
- pending_blobs_free_list (blobs_list);
-diff --git a/providers/jdbc/gda-jdbc-provider.c b/providers/jdbc/gda-jdbc-provider.c
-index 164e67f..c1192fb 100644
---- a/providers/jdbc/gda-jdbc-provider.c
-+++ b/providers/jdbc/gda-jdbc-provider.c
-@@ -1429,9 +1429,49 @@ gda_jdbc_provider_statement_execute (GdaServerProvider *provider, GdaConnection
- else if (!rstmt)
- return NULL;
- else {
-- GObject *obj;
-- g_object_unref (ps);
- _gda_jdbc_release_jenv (jni_detach);
-+
-+ /* The strategy here is to execute @rstmt using the prepared
-+ * statement associcted to @stmt, but adapted to @rstmt, so all
-+ * the column names, etc remain the same.
-+ *
-+ * The adaptation consists to replace Jdbc specific information
-+ * in the GdaJdbcPStmt object.
-+ *
-+ * The trick is to adapt @ps, then associate @ps with @rstmt, then
-+ * execute @rstmt, and then undo the trick */
-+ GObject *obj;
-+ GdaJdbcPStmt *tps;
-+ if (!gda_jdbc_provider_statement_prepare (provider, cnc,
-+ rstmt, error)) {
-+ g_object_unref (ps);
-+ return NULL;
-+ }
-+ tps = (GdaJdbcPStmt *)
-+ gda_connection_get_prepared_statement (cnc, rstmt);
-+
-+ /* adapt @ps with @tps's Jdbc specific information */
-+ GdaJdbcPStmt hps;
-+ hps.pstmt_obj = ps->pstmt_obj; /* save */
-+ ps->pstmt_obj = tps->pstmt_obj; /* override */
-+ g_object_ref (tps);
-+ gda_connection_add_prepared_statement (cnc, rstmt, (GdaPStmt *) ps);
-+
-+ /* execute rstmt (it will use @ps) */
-+ obj = gda_jdbc_provider_statement_execute (provider, cnc,
-+ rstmt, params,
-+ model_usage,
-+ col_types,
-+ last_inserted_row,
-+ task_id, async_cb,
-+ cb_data, error);
-+
-+ /* revert adaptations */
-+ ps->pstmt_obj = hps.pstmt_obj;
-+ gda_connection_add_prepared_statement (cnc, rstmt, (GdaPStmt *) tps);
-+ g_object_unref (tps);
-+ g_object_unref (rstmt);
-+
- obj = gda_jdbc_provider_statement_execute (provider, cnc,
- rstmt, params,
- model_usage,
-@@ -1440,14 +1480,7 @@ gda_jdbc_provider_statement_execute (GdaServerProvider *provider, GdaConnection
- task_id, async_cb,
- cb_data, error);
- g_object_unref (rstmt);
-- if (GDA_IS_DATA_SELECT (obj)) {
-- GdaPStmt *pstmt;
-- g_object_get (obj, "prepared-stmt", &pstmt, NULL);
-- if (pstmt) {
-- gda_pstmt_set_gda_statement (pstmt, stmt);
-- g_object_unref (pstmt);
-- }
-- }
-+ g_object_unref (ps);
- return obj;
- }
- }
-diff --git a/providers/mysql/gda-mysql-provider.c b/providers/mysql/gda-mysql-provider.c
-index d581828..8baf0a3 100644
---- a/providers/mysql/gda-mysql-provider.c
-+++ b/providers/mysql/gda-mysql-provider.c
-@@ -2304,8 +2304,35 @@ gda_mysql_provider_statement_execute (GdaServerProvider *provider,
- else if (!rstmt)
- return NULL;
- else {
-- GObject *obj;
- free_bind_param_data (mem_to_free);
-+
-+ /* The strategy here is to execute @rstmt using the prepared
-+ * statement associcted to @stmt, but adapted to @rstmt, so all
-+ * the column names, etc remain the same.
-+ *
-+ * The adaptation consists to replace MySQL specific information
-+ * in the GdaMysqlPStmt object.
-+ *
-+ * The trick is to adapt @ps, then associate @ps with @rstmt, then
-+ * execute @rstmt, and then undo the trick */
-+ GObject *obj;
-+ GdaMysqlPStmt *tps;
-+ if (!gda_mysql_provider_statement_prepare (provider, cnc,
-+ rstmt, error))
-+ return NULL;
-+ tps = (GdaMysqlPStmt *)
-+ gda_connection_get_prepared_statement (cnc, rstmt);
-+
-+ /* adapt @ps with @tps's Mysql specific information */
-+ GdaMysqlPStmt hps;
-+ hps.mysql_stmt = ps->mysql_stmt; /* save */
-+ ps->mysql_stmt = tps->mysql_stmt; /* override */
-+ hps.stmt_used = ps->stmt_used; /* save */
-+ ps->stmt_used = tps->stmt_used; /* override */
-+ g_object_ref (tps);
-+ gda_connection_add_prepared_statement (cnc, rstmt, (GdaPStmt *) ps);
-+
-+ /* execute rstmt (it will use @ps) */
- obj = gda_mysql_provider_statement_execute (provider, cnc,
- rstmt, params,
- model_usage,
-@@ -2313,15 +2340,13 @@ gda_mysql_provider_statement_execute (GdaServerProvider *provider,
- last_inserted_row,
- task_id, async_cb,
- cb_data, error);
-+
-+ /* revert adaptations */
-+ ps->mysql_stmt = hps.mysql_stmt;
-+ ps->stmt_used = hps.stmt_used;
-+ gda_connection_add_prepared_statement (cnc, rstmt, (GdaPStmt *) tps);
-+ g_object_unref (tps);
- g_object_unref (rstmt);
-- if (GDA_IS_DATA_SELECT (obj)) {
-- GdaPStmt *pstmt;
-- g_object_get (obj, "prepared-stmt", &pstmt, NULL);
-- if (pstmt) {
-- gda_pstmt_set_gda_statement (pstmt, stmt);
-- g_object_unref (pstmt);
-- }
-- }
- return obj;
- }
- }
-diff --git a/providers/oracle/gda-oracle-provider.c b/providers/oracle/gda-oracle-provider.c
-index 1d40105..9d0f485 100644
---- a/providers/oracle/gda-oracle-provider.c
-+++ b/providers/oracle/gda-oracle-provider.c
-@@ -1931,8 +1931,35 @@ gda_oracle_provider_statement_execute (GdaServerProvider *provider, GdaConnectio
- else if (!rstmt)
- return NULL;
- else {
-+ /* The strategy here is to execute @rstmt using the prepared
-+ * statement associcted to @stmt, but adapted to @rstmt, so all
-+ * the column names, etc remain the same.
-+ *
-+ * The adaptation consists to replace Oracle specific information
-+ * in the GdaOraclePStmt object.
-+ *
-+ * The trick is to adapt @ps, then associate @ps with @rstmt, then
-+ * execute @rstmt, and then undo the trick */
- GObject *obj;
-- g_object_unref (ps);
-+ GdaOraclePStmt *tps;
-+ if (!gda_oracle_provider_statement_prepare (provider, cnc,
-+ rstmt, error)) {
-+ g_object_unref (ps);
-+ return NULL;
-+ }
-+ tps = (GdaOraclePStmt *)
-+ gda_connection_get_prepared_statement (cnc, rstmt);
-+
-+ /* adapt @ps with @tps's Oracle specific information */
-+ GdaOraclePStmt hps;
-+ hps.hstmt = ps->hstmt; /* save */
-+ ps->hstmt = tps->hstmt; /* override */
-+ hps.ora_values = ps->ora_values; /* save */
-+ ps->ora_values = tps->ora_values; /* override */
-+ g_object_ref (tps);
-+ gda_connection_add_prepared_statement (cnc, rstmt, (GdaPStmt *) ps);
-+
-+ /* execute rstmt (it will use @ps) */
- obj = gda_oracle_provider_statement_execute (provider, cnc,
- rstmt, params,
- model_usage,
-@@ -1940,15 +1967,14 @@ gda_oracle_provider_statement_execute (GdaServerProvider *provider, GdaConnectio
- last_inserted_row,
- task_id, async_cb,
- cb_data, error);
-+
-+ /* revert adaptations */
-+ ps->hstmt = hps.hstmt;
-+ ps->ora_values = hps.ora_values;
-+ gda_connection_add_prepared_statement (cnc, rstmt, (GdaPStmt *) tps);
-+ g_object_unref (tps);
- g_object_unref (rstmt);
-- if (GDA_IS_DATA_SELECT (obj)) {
-- GdaPStmt *pstmt;
-- g_object_get (obj, "prepared-stmt", &pstmt, NULL);
-- if (pstmt) {
-- gda_pstmt_set_gda_statement (pstmt, stmt);
-- g_object_unref (pstmt);
-- }
-- }
-+ g_object_unref (ps);
- return obj;
- }
- }
-diff --git a/providers/postgres/gda-postgres-provider.c b/providers/postgres/gda-postgres-provider.c
-index 6adca14..85db58e 100644
---- a/providers/postgres/gda-postgres-provider.c
-+++ b/providers/postgres/gda-postgres-provider.c
-@@ -2017,13 +2017,39 @@ gda_postgres_provider_statement_execute (GdaServerProvider *provider, GdaConnect
- else if (!rstmt)
- return NULL;
- else {
-- GObject *obj;
- params_freev (param_values, param_mem, nb_params);
- g_free (param_lengths);
- g_free (param_formats);
- if (transaction_started)
- gda_connection_rollback_transaction (cnc, NULL, NULL);
-
-+ /* The strategy here is to execute @rstmt using the prepared
-+ * statement associcted to @stmt, but adapted to @rstmt, so all
-+ * the column names, etc remain the same.
-+ *
-+ * The adaptation consists to replace Postgresql specific information
-+ * in the GdaPostgresPStmt object.
-+ *
-+ * The trick is to adapt @ps, then associate @ps with @rstmt, then
-+ * execute @rstmt, and then undo the trick */
-+ GObject *obj;
-+ GdaPostgresPStmt *tps;
-+ if (!gda_postgres_provider_statement_prepare (provider, cnc,
-+ rstmt, error))
-+ return NULL;
-+ tps = (GdaPostgresPStmt *)
-+ gda_connection_get_prepared_statement (cnc, rstmt);
-+
-+ /* adapt @ps with @tps's SQLite specific information */
-+ GdaPostgresPStmt hps;
-+ hps.pconn = ps->pconn; /* save */
-+ ps->pconn = tps->pconn; /* override */
-+ hps.prep_name = ps->prep_name; /* save */
-+ ps->prep_name = tps->prep_name; /* override */
-+ g_object_ref (tps);
-+ gda_connection_add_prepared_statement (cnc, rstmt, (GdaPStmt *) ps);
-+
-+ /* execute rstmt (it will use @ps) */
- obj = gda_postgres_provider_statement_execute (provider, cnc,
- rstmt, params,
- model_usage,
-@@ -2031,15 +2057,13 @@ gda_postgres_provider_statement_execute (GdaServerProvider *provider, GdaConnect
- last_inserted_row,
- task_id, async_cb,
- cb_data, error);
-+
-+ /* revert adaptations */
-+ ps->pconn = hps.pconn;
-+ ps->prep_name = hps.prep_name;
-+ gda_connection_add_prepared_statement (cnc, rstmt, (GdaPStmt *) tps);
-+ g_object_unref (tps);
- g_object_unref (rstmt);
-- if (GDA_IS_DATA_SELECT (obj)) {
-- GdaPStmt *pstmt;
-- g_object_get (obj, "prepared-stmt", &pstmt, NULL);
-- if (pstmt) {
-- gda_pstmt_set_gda_statement (pstmt, stmt);
-- g_object_unref (pstmt);
-- }
-- }
- return obj;
- }
- }
-diff --git a/providers/skel-implementation/capi/gda-capi-provider.c b/providers/skel-implementation/capi/gda-capi-provider.c
-index 653f9ea..764d027 100644
---- a/providers/skel-implementation/capi/gda-capi-provider.c
-+++ b/providers/skel-implementation/capi/gda-capi-provider.c
-@@ -1181,7 +1181,31 @@ gda_capi_provider_statement_execute (GdaServerProvider *provider, GdaConnection
- else if (!rstmt)
- return NULL;
- else {
-+ /* The strategy here is to execute @rstmt using the prepared
-+ * statement associcted to @stmt, but adapted to @rstmt, so all
-+ * the column names, etc remain the same.
-+ *
-+ * The adaptation consists to replace Capi specific information
-+ * in the GdaCapiPStmt object.
-+ *
-+ * The trick is to adapt @ps, then associate @ps with @rstmt, then
-+ * execute @rstmt, and then undo the trick */
- GObject *obj;
-+ GdaCapiPStmt *tps;
-+ if (!gda_capi_provider_statement_prepare (provider, cnc,
-+ rstmt, error))
-+ return NULL;
-+ tps = (GdaCapiPStmt *)
-+ gda_connection_get_prepared_statement (cnc, rstmt);
-+
-+ /* adapt @ps with @tps's Capi specific information */
-+ GdaCapiPStmt hps;
-+ /* TO ADD: hps.capi_stmt = ps->capi_stmt;*/ /* save */
-+ /* TO_ADD: ps->capi_stmt = tps->capi_stmt;*/ /* override */
-+ g_object_ref (tps);
-+ gda_connection_add_prepared_statement (cnc, rstmt, (GdaPStmt *) ps);
-+
-+ /* execute rstmt (it will use @ps) */
- obj = gda_capi_provider_statement_execute (provider, cnc,
- rstmt, params,
- model_usage,
-@@ -1189,15 +1213,13 @@ gda_capi_provider_statement_execute (GdaServerProvider *provider, GdaConnection
- last_inserted_row,
- task_id, async_cb,
- cb_data, error);
-+
-+ /* revert adaptations */
-+ /* TO_ADD: ps->capi_stmt = hps.capi_stmt; */
-+
-+ gda_connection_add_prepared_statement (cnc, rstmt, (GdaPStmt *) tps);
-+ g_object_unref (tps);
- g_object_unref (rstmt);
-- if (GDA_IS_DATA_SELECT (obj)) {
-- GdaPStmt *pstmt;
-- g_object_get (obj, "prepared-stmt", &pstmt, NULL);
-- if (pstmt) {
-- gda_pstmt_set_gda_statement (pstmt, stmt);
-- g_object_unref (pstmt);
-- }
-- }
- return obj;
- }
- }
-diff --git a/providers/web/gda-web-provider.c b/providers/web/gda-web-provider.c
-index 4500f01..9061126 100644
---- a/providers/web/gda-web-provider.c
-+++ b/providers/web/gda-web-provider.c
-@@ -1572,25 +1572,49 @@ gda_web_provider_statement_execute (GdaServerProvider *provider, GdaConnection *
- else if (!rstmt)
- return NULL;
- else {
-- GObject *obj;
-- g_object_unref (ps);
- xmlFreeDoc (doc);
-+
-+ /* The strategy here is to execute @rstmt using the prepared
-+ * statement associcted to @stmt, but adapted to @rstmt, so all
-+ * the column names, etc remain the same.
-+ *
-+ * The adaptation consists to replace Web specific information
-+ * in the GdaWebPStmt object.
-+ *
-+ * The trick is to adapt @ps, then associate @ps with @rstmt, then
-+ * execute @rstmt, and then undo the trick */
-+ GObject *obj;
-+ GdaWebPStmt *tps;
-+ if (!gda_web_provider_statement_prepare (provider, cnc,
-+ rstmt, error)) {
-+ g_object_unref (ps);
-+ return NULL;
-+ }
-+ tps = (GdaWebPStmt *)
-+ gda_connection_get_prepared_statement (cnc, rstmt);
-+
-+ /* adapt @ps with @tps's Web specific information */
-+ GdaWebPStmt hps;
-+ hps.pstmt_hash = ps->pstmt_hash; /* save */
-+ ps->pstmt_hash = tps->pstmt_hash; /* override */
-+ g_object_ref (tps);
-+ gda_connection_add_prepared_statement (cnc, rstmt, (GdaPStmt *) ps);
-+
-+ /* execute rstmt (it will use @ps) */
- obj = gda_web_provider_statement_execute (provider, cnc,
-- rstmt, params,
-- model_usage,
-- col_types,
-- last_inserted_row,
-- task_id, async_cb,
-- cb_data, error);
-+ rstmt, params,
-+ model_usage,
-+ col_types,
-+ last_inserted_row,
-+ task_id, async_cb,
-+ cb_data, error);
-+
-+ /* revert adaptations */
-+ ps->pstmt_hash = hps.pstmt_hash;
-+ gda_connection_add_prepared_statement (cnc, rstmt, (GdaPStmt *) tps);
-+ g_object_unref (tps);
- g_object_unref (rstmt);
-- if (GDA_IS_DATA_SELECT (obj)) {
-- GdaPStmt *pstmt;
-- g_object_get (obj, "prepared-stmt", &pstmt, NULL);
-- if (pstmt) {
-- gda_pstmt_set_gda_statement (pstmt, stmt);
-- g_object_unref (pstmt);
-- }
-- }
-+ g_object_unref (ps);
- return obj;
- }
- }
---
-cgit v0.9.0.2
diff --git a/gnome-extra/libgda/files/libgda-9999-fix-build-order.patch b/gnome-extra/libgda/files/libgda-9999-fix-build-order.patch
deleted file mode 100644
index cd2fbb50..00000000
--- a/gnome-extra/libgda/files/libgda-9999-fix-build-order.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-diff --git a/libgda/sqlite/Makefile.am b/libgda/sqlite/Makefile.am
-index b3bf302..c7be5e1 100644
---- a/libgda/sqlite/Makefile.am
-+++ b/libgda/sqlite/Makefile.am
-@@ -58,7 +58,8 @@ sqlitesources = \
- gda-sqlite.h \
- keywords_hash.h \
- gda-symbols-util.h \
-- gda-symbols-util.c
-+ gda-symbols-util.c \
-+ $(BUILT_SOURCES)
-
- BUILT_SOURCES = xml_embedded.h keywords_hash.c
-
diff --git a/gnome-extra/libgda/libgda-9999.ebuild b/gnome-extra/libgda/libgda-9999.ebuild
deleted file mode 100644
index 9fe2e068..00000000
--- a/gnome-extra/libgda/libgda-9999.ebuild
+++ /dev/null
@@ -1,166 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="5"
-GNOME2_LA_PUNT="yes"
-GCONF_DEBUG="yes"
-PYTHON_COMPAT=( python2_7 )
-VALA_MIN_API_VERSION="0.18"
-VALA_MAX_API_VERSION="0.26"
-VALA_USE_DEPEND="vapigen"
-
-inherit autotools db-use eutils flag-o-matic gnome2 java-pkg-opt-2 python-single-r1 vala
-if [[ ${PV} = 9999 ]]; then
- inherit gnome2-live
-fi
-
-DESCRIPTION="GNOME database access library"
-HOMEPAGE="http://www.gnome-db.org/"
-LICENSE="GPL-2+ LGPL-2+"
-
-IUSE="berkdb canvas firebird gtk graphviz http +introspection json ldap libsecret mdb mysql oci8 postgres reports sourceview ssl vala"
-REQUIRED_USE="
- reports? ( ${PYTHON_REQUIRED_USE} )
- canvas? ( gtk )
- graphviz? ( gtk )
- sourceview? ( gtk )
- vala? ( introspection )
-"
-# firebird license is not GPL compatible
-
-SLOT="5/4" # subslot = libgda-5.0 soname version
-if [[ ${PV} = 9999 ]]; then
- IUSE="${IUSE} doc"
- KEYWORDS=""
-else
- KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
-fi
-
-RDEPEND="
- app-text/iso-codes
- >=dev-libs/glib-2.32:2
- >=dev-libs/libxml2-2
- dev-libs/libxslt
- sys-libs/readline:=
- sys-libs/ncurses:=
- berkdb? ( sys-libs/db:= )
- firebird? ( dev-db/firebird )
- gtk? (
- >=x11-libs/gtk+-3.0.0:3
- canvas? ( x11-libs/goocanvas:2.0= )
- sourceview? ( x11-libs/gtksourceview:3.0 )
- graphviz? ( media-gfx/graphviz )
- )
- http? ( >=net-libs/libsoup-2.24:2.4 )
- introspection? ( >=dev-libs/gobject-introspection-1.30 )
- json? ( dev-libs/json-glib )
- ldap? ( net-nds/openldap:= )
- libsecret? ( app-crypt/libsecret )
- mdb? ( >app-office/mdbtools-0.5:= )
- mysql? ( virtual/mysql:= )
- postgres? ( dev-db/postgresql:= )
- reports? (
- ${PYTHON_DEPS}
- dev-java/fop
- dev-python/reportlab[${PYTHON_USEDEP}] )
- ssl? ( dev-libs/openssl:= )
- >=dev-db/sqlite-3.6.22:3=
- vala? ( dev-libs/libgee:0.8 )
-"
-DEPEND="${RDEPEND}
- app-text/yelp-tools
- >=dev-util/gtk-doc-am-1.14
- >=dev-util/intltool-0.40.6
- virtual/pkgconfig
- java? ( virtual/jdk:1.6 )
- vala? ( $(vala_depend) )
-"
-if [[ ${PV} = 9999 ]]; then
- DEPEND="${DEPEND}
- app-text/yelp-tools
- doc? ( >=dev-util/gtk-doc-1.14 )
- vala? ( $(vala_depend) )"
-fi
-
-pkg_setup() {
- java-pkg-opt-2_pkg_setup
- use reports && python-single-r1_pkg_setup
-}
-
-src_prepare() {
- use reports ||
- sed -e '/SUBDIRS =/ s/trml2html//' \
- -e '/SUBDIRS =/ s/trml2pdf//' \
- -i libgda-report/RML/Makefile.{am,in} || die
-
- # Prevent file collisions with libgda:4
- epatch "${FILESDIR}/${PN}-4.99.1-gda-browser-doc-collision.patch"
- epatch "${FILESDIR}/${PN}-4.99.1-control-center-icon-collision.patch"
- # Move files with mv (since epatch can't handle rename diffs) and
- # update pre-generated gtk-doc files (for non-git versions of libgda)
- local f
- for f in tools/browser/doc/gda-browser* ; do
- mv ${f} ${f/gda-browser/gda-browser-5.0} || die "mv ${f} failed"
- done
- if [[ ${PV} != 9999 ]] ; then
- for f in tools/browser/doc/html/gda-browser.devhelp* ; do
- sed -e 's:name="gda-browser":name="gda-browser-5.0":' \
- -i ${f} || die "sed ${f} failed"
- mv ${f} ${f/gda-browser/gda-browser-5.0} || die "mv ${f} failed"
- done
- fi
- for f in control-center/data/*_gda-control-center.png ; do
- mv ${f} ${f/_gda-control-center.png/_gda-control-center-5.0.png} ||
- die "mv ${f} failed"
- done
-
- [[ ${PV} = 9999 ]] || eautoreconf
- gnome2_src_prepare
- java-pkg-opt-2_src_prepare
- use vala && vala_src_prepare
-}
-
-src_configure() {
- use berkdb && append-cppflags "-I$(db_includedir)"
-
- gnome2_src_configure \
- --with-help \
- --disable-static \
- --enable-system-sqlite \
- $(use_with berkdb bdb /usr) \
- $(use_with canvas goocanvas) \
- $(use_with firebird firebird /usr) \
- $(use_with graphviz) \
- $(use_with gtk ui) \
- $(use_with http libsoup) \
- $(use_enable introspection) \
- "$(use_with java java $JAVA_HOME)" \
- $(use_enable json) \
- $(use_with ldap) \
- $(use_with libsecret) \
- $(use_with mdb mdb /usr) \
- $(use_with mysql mysql /usr) \
- $(use_with oci8 oracle) \
- $(use_with postgres postgres /usr) \
- $(use_enable ssl crypto) \
- $(use_with sourceview gtksourceview) \
- --disable-default-binary \
- --disable-vala
- # vala bindings fail to build
-}
-
-pkg_preinst() {
- gnome2_pkg_preinst
- java-pkg-opt-2_pkg_preinst
-}
-
-src_install() {
- gnome2_src_install
- if use reports; then
- for t in trml2{html,pdf}; do
- python_scriptinto /usr/share/libgda-5.0/gda_${t}
- python_doscript libgda-report/RML/${t}/${t}.py
- done
- fi
-}
diff --git a/gnome-extra/libgda/metadata.xml b/gnome-extra/libgda/metadata.xml
deleted file mode 100644
index b009aff4..00000000
--- a/gnome-extra/libgda/metadata.xml
+++ /dev/null
@@ -1,21 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>gnome@gentoo.org</email>
- <name>Gentoo GNOME Desktop</name>
- </maintainer>
- <use>
- <flag name="bindist">Disable support for <pkg>dev-db/firebird</pkg> database
- which is not GPL compatible.</flag>
- <flag name="canvas">Enable support for <pkg>x11-libs/goocanvas</pkg></flag>
- <flag name="http">Enable embedded <pkg>net-libs/libsoup</pkg> based server</flag>
- <flag name="libsecret">Enable <pkg>app-crypt/libsecret</pkg> support to
- store login credentials</flag>
- <flag name="json">Enable support for JSON format</flag>
- <flag name="mdb">Enable support for Microsoft Access database using
- <pkg>app-office/mdbtools</pkg></flag>
- <flag name="reports">Install tools for generating graphical reports</flag>
- <flag name="sourceview">Enable support for <pkg>x11-libs/gtksourceview</pkg></flag>
- </use>
-</pkgmetadata>
diff --git a/media-libs/cogl/cogl-9999.ebuild b/media-libs/cogl/cogl-9999.ebuild
deleted file mode 100644
index b1e1c858..00000000
--- a/media-libs/cogl/cogl-9999.ebuild
+++ /dev/null
@@ -1,146 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="5"
-GCONF_DEBUG="yes"
-
-inherit gnome2 multilib virtualx
-if [[ ${PV} = 9999 ]]; then
- inherit gnome2-live
-fi
-
-DESCRIPTION="A library for using 3D graphics hardware to draw pretty pictures"
-HOMEPAGE="http://www.cogl3d.org/"
-
-LICENSE="MIT BSD"
-SLOT="2.0/0" # subslot = .so version
-# doc and profile disable for now due bugs #484750 and #483332
-IUSE="examples gles2 gstreamer +introspection +kms +opengl +pango test wayland" # doc profile
-REQUIRED_USE="wayland? ( gles2 )"
-if [[ ${PV} = 9999 ]]; then
- KEYWORDS=""
- IUSE="${IUSE} doc"
-else
- KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
-fi
-
-COMMON_DEPEND="
- >=dev-libs/glib-2.32:2
- x11-libs/cairo:=
- >=x11-libs/gdk-pixbuf-2:2
- x11-libs/libX11
- >=x11-libs/libXcomposite-0.4
- x11-libs/libXdamage
- x11-libs/libXext
- >=x11-libs/libXfixes-3
- >=x11-libs/libXrandr-1.2
- virtual/opengl
- gles2? ( media-libs/mesa[gles2] )
- gstreamer? (
- media-libs/gstreamer:1.0
- media-libs/gst-plugins-base:1.0 )
-
- introspection? ( >=dev-libs/gobject-introspection-1.34.2:= )
- kms? (
- media-libs/mesa[gbm]
- x11-libs/libdrm:= )
- pango? ( >=x11-libs/pango-1.20.0[introspection?] )
- wayland? (
- >=dev-libs/wayland-1.1.90
- media-libs/mesa[egl,wayland] )
-"
-# before clutter-1.7, cogl was part of clutter
-RDEPEND="${COMMON_DEPEND}
- !<media-libs/clutter-1.7
-"
-DEPEND="${COMMON_DEPEND}
- >=dev-util/gtk-doc-am-1.13
- sys-devel/gettext
- virtual/pkgconfig
- test? (
- app-eselect/eselect-opengl
- media-libs/mesa[classic] )
-"
-
-# Need classic mesa swrast for tests, llvmpipe causes a test failure
-# For some reason GL3 conformance test all fails again...
-RESTRICT="test"
-
-if [[ ${PV} = 9999 ]]; then
- DEPEND="${DEPEND}
- doc? (
- app-text/docbook-xml-dtd:4.1.2
- >=dev-util/gtk-doc-1.13 )"
-fi
-
-src_prepare() {
- # Do not build examples
- sed -e "s/^\(SUBDIRS +=.*\)examples\(.*\)$/\1\2/" \
- -i Makefile.am || die
-
- if ! use test ; then
- # For some reason the configure switch will not completely disable
- # tests being built
- sed -e "s/^\(SUBDIRS =.*\)test-fixtures\(.*\)$/\1\2/" \
- -e "s/^\(SUBDIRS +=.*\)tests\(.*\)$/\1\2/" \
- -e "s/^\(.*am__append.* \)tests\(.*\)$/\1\2/" \
- -i Makefile.am || die
- fi
-
- gnome2_src_prepare
-}
-
-src_configure() {
- # TODO: think about quartz, sdl
- # Prefer gl over gles2 if both are selected
- # Profiling needs uprof, which is not available in portage yet, bug #484750
- # FIXME: Doesn't provide prebuilt docs, but they can neither be rebuilt, bug #483332
- gnome2_src_configure \
- --disable-examples-install \
- --disable-maintainer-flags \
- --enable-cairo \
- --enable-deprecated \
- --enable-gdk-pixbuf \
- --enable-glib \
- $(use_enable opengl glx) \
- $(use_enable opengl gl) \
- $(use_enable gles2) \
- $(use_enable gles2 cogl-gles2) \
- $(use_enable gles2 xlib-egl-platform) \
- $(usex gles2 --with-default-driver=$(usex opengl gl gles2)) \
- $(use_enable gstreamer cogl-gst) \
- $(use_enable introspection) \
- $(use_enable kms kms-egl-platform) \
- $(use_enable pango cogl-pango) \
- $(use_enable test unit-tests) \
- $(use_enable wayland wayland-egl-platform) \
- $(use_enable wayland wayland-egl-server) \
- --disable-profile
-# $(use_enable profile)
-}
-
-src_test() {
- # Use swrast for tests, llvmpipe is incomplete and "test_sub_texture" fails
- # NOTE: recheck if this is needed after every mesa bump
- if [[ "$(eselect opengl show)" != "xorg-x11" ]]; then
- ewarn "Skipping tests because a binary OpenGL library is enabled. To"
- ewarn "run tests for ${PN}, you need to enable the Mesa library:"
- ewarn "# eselect opengl set xorg-x11"
- return
- fi
- LIBGL_DRIVERS_PATH="${EROOT}/usr/$(get_libdir)/mesa" Xemake check
-}
-
-src_install() {
- DOCS="NEWS README"
- if use examples; then
- insinto /usr/share/doc/${PF}/examples
- doins examples/{*.c,*.jpg}
- fi
-
- gnome2_src_install
-
- # Remove silly examples-data directory
- rm -rvf "${ED}/usr/share/cogl/examples-data/" || die
-}
diff --git a/media-libs/cogl/metadata.xml b/media-libs/cogl/metadata.xml
deleted file mode 100644
index 009b6abd..00000000
--- a/media-libs/cogl/metadata.xml
+++ /dev/null
@@ -1,13 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
-<maintainer type="project">
- <email>gnome@gentoo.org</email>
- <name>Gentoo GNOME Desktop</name>
-</maintainer>
-<use>
- <flag name="gles2">Enable OpenGL ES 2.0 support</flag>
- <flag name="kms">Enable KMS support.</flag>
- <flag name="pango">Build cogl-pango library for <pkg>x11-libs/pango</pkg> integration</flag>
-</use>
-</pkgmetadata>
diff --git a/media-libs/gsound/gsound-9999.ebuild b/media-libs/gsound/gsound-9999.ebuild
deleted file mode 100644
index e18d4d44..00000000
--- a/media-libs/gsound/gsound-9999.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="5"
-GCONF_DEBUG="no"
-VALA_USE_DEPEND="vapigen"
-VALA_MIN_API_VERSION="0.20"
-
-inherit gnome2 vala
-if [[ ${PV} = 9999 ]]; then
- inherit gnome2-live
-fi
-
-DESCRIPTION="Thin GObject wrapper around the libcanberra sound event library"
-HOMEPAGE="https://wiki.gnome.org/Projects/GSound"
-
-LICENSE="LGPL-2.1+"
-SLOT="0"
-if [[ ${PV} = 9999 ]]; then
- KEYWORDS=""
-else
- KEYWORDS="~amd64 ~x86"
-fi
-IUSE="+introspection"
-
-# vala setup required for vapigen check
-RDEPEND="
- >=dev-libs/glib-2.36:2
- media-libs/libcanberra
- introspection? ( >=dev-libs/gobject-introspection-1.2.9 )
-"
-DEPEND="${RDEPEND}
- $(vala_depend)
- >=dev-util/gtk-doc-am-1.20
- virtual/pkgconfig
-"
-
-src_prepare() {
- vala_src_prepare
- gnome2_src_prepare
-}
-
-src_configure () {
- gnome2_src_configure \
- --disable-static \
- $(use_enable introspection)
-}
diff --git a/media-libs/gsound/metadata.xml b/media-libs/gsound/metadata.xml
deleted file mode 100644
index 4cbddcaa..00000000
--- a/media-libs/gsound/metadata.xml
+++ /dev/null
@@ -1,8 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>gnome@gentoo.org</email>
- <name>Gentoo GNOME Desktop</name>
- </maintainer>
-</pkgmetadata>
diff --git a/media-libs/mash/mash-9999.ebuild b/media-libs/mash/mash-9999.ebuild
deleted file mode 100644
index 3bf1a849..00000000
--- a/media-libs/mash/mash-9999.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="4"
-GCONF_DEBUG="no"
-GNOME2_LA_PUNT="yes"
-
-# clutter.eclass does not support .xz tarballs
-inherit gnome2 versionator
-if [[ ${PV} = 9999 ]]; then
- SRC_URI=""
- EGIT_REPO_URI="git://github.com/clutter-project/mash.git"
- inherit gnome2-live
-else
- RV=($(get_version_components))
- SRC_URI="http://source.clutter-project.org/sources/${PN}/${RV[0]}.${RV[1]}/${P}.tar.xz"
-fi
-
-DESCRIPTION="A library for rendering 3D models with Clutter"
-HOMEPAGE="http://wiki.clutter-project.org/wiki/Mash"
-
-LICENSE="LGPL-2.1"
-SLOT="0.2"
-IUSE="doc examples +introspection"
-if [[ ${PV} = 9999 ]]; then
- KEYWORDS=""
-else
- KEYWORDS="~amd64 ~x86"
-fi
-
-# Automagically detects x11-libs/mx, but only uses it for building examples.
-# Note: mash is using a bundled copy of rply because mash developers have
-# modified its API by adding extra arguments to various functions.
-RDEPEND=">=dev-libs/glib-2.16:2
- >=media-libs/clutter-1.5.10:1.0[introspection?]
- virtual/opengl
-
- introspection? ( >=dev-libs/gobject-introspection-0.6.1 )"
-DEPEND="${RDEPEND}
- virtual/pkgconfig
- doc? ( >=dev-util/gtk-doc-1.14 )"
-
-pkg_setup() {
- DOCS="AUTHORS NEWS README"
- G2CONF="${G2CONF}
- --disable-static
- $(use_enable introspection)"
-}
-
-src_install() {
- gnome2_src_install
-
- if use examples; then
- insinto /usr/share/doc/${PF}/examples
- doins example/{*.c,*.ply}
- fi
-}
diff --git a/media-libs/mash/metadata.xml b/media-libs/mash/metadata.xml
deleted file mode 100644
index f31bff46..00000000
--- a/media-libs/mash/metadata.xml
+++ /dev/null
@@ -1,12 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
-<maintainer type="project">
- <email>gnome@gentoo.org</email>
- <name>Gentoo GNOME Desktop</name>
-</maintainer>
-<use>
- <flag name="introspection">Use <pkg>dev-libs/gobject-introspection</pkg>
- for introspection</flag>
-</use>
-</pkgmetadata>
diff --git a/net-im/empathy/empathy-9999.ebuild b/net-im/empathy/empathy-9999.ebuild
deleted file mode 100644
index a3f2bd0b..00000000
--- a/net-im/empathy/empathy-9999.ebuild
+++ /dev/null
@@ -1,130 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="5"
-GCONF_DEBUG="no"
-GNOME2_LA_PUNT="yes"
-PYTHON_COMPAT=( python2_{6,7} python3_{2,3} )
-
-inherit gnome2 python-any-r1 virtualx
-if [[ ${PV} = 9999 ]]; then
- inherit gnome2-live
-fi
-
-DESCRIPTION="Telepathy instant messaging and video/audio call client for GNOME"
-HOMEPAGE="https://wiki.gnome.org/Apps/Empathy"
-
-LICENSE="GPL-2 CC-BY-SA-3.0 FDL-1.3 LGPL-2.1"
-SLOT="0"
-
-# sendto: support from building nautilus sendto plugins from it was dropped in 3.7
-IUSE="debug +geoloc gnome gnome-online-accounts +map spell test +v4l"
-if [[ ${PV} = 9999 ]]; then
- KEYWORDS=""
-else
- KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-linux"
-fi
-
-# False positives caused by nested configure scripts
-QA_CONFIGURE_OPTIONS=".*"
-
-# gdk-pixbuf and pango extensively used in libempathy-gtk
-COMMON_DEPEND="
- >=dev-libs/glib-2.37.6:2
- x11-libs/gdk-pixbuf:2
- >=x11-libs/gtk+-3.9.4:3
- x11-libs/pango
- >=dev-libs/dbus-glib-0.51
- >=dev-libs/folks-0.9.5:=[telepathy]
- dev-libs/libgee:0.8=
- >=app-crypt/libsecret-0.5
- >=media-libs/libcanberra-0.25[gtk3]
- >=net-libs/gnutls-2.8.5:=
- >=net-libs/webkit-gtk-1.9.1:3
- >=x11-libs/libnotify-0.7:=
-
- media-libs/gstreamer:1.0
- >=media-libs/clutter-1.10.0:1.0
- >=media-libs/clutter-gtk-1.1.2:1.0
- media-libs/clutter-gst:2.0
- >=media-libs/cogl-1.14:1.0=
-
- net-libs/farstream:0.2
- >=net-libs/telepathy-farstream-0.6.0:=
- >=net-libs/telepathy-glib-0.23.2
- >=net-im/telepathy-logger-0.8.0:=
-
- app-crypt/gcr
- dev-libs/libxml2:2
- gnome-base/gsettings-desktop-schemas
- media-sound/pulseaudio[glib]
- net-libs/libsoup:2.4
- x11-libs/libX11
-
- geoloc? (
- >=app-misc/geoclue-1.99.3:2.0
- >=sci-geosciences/geocode-glib-3.10 )
- gnome-online-accounts? ( >=net-libs/gnome-online-accounts-3.5.1 )
- map? (
- >=media-libs/clutter-1.7.14:1.0
- >=media-libs/clutter-gtk-0.90.3:1.0
- >=media-libs/libchamplain-0.12.1:0.12[gtk] )
- spell? (
- >=app-text/enchant-1.2
- >=app-text/iso-codes-0.35 )
- v4l? (
- media-plugins/gst-plugins-v4l2:1.0
- >=media-video/cheese-3.4:=
- virtual/libgudev:= )
-"
-
-# >=empathy-3.4 is incompatible with telepathy-rakia-0.6, bug #403861
-RDEPEND="${COMMON_DEPEND}
- media-libs/gst-plugins-base:1.0
- net-im/telepathy-connection-managers
- !<net-voip/telepathy-rakia-0.7
- x11-themes/gnome-icon-theme-symbolic
- gnome? ( gnome-extra/gnome-contacts )
-"
-DEPEND="${COMMON_DEPEND}
- ${PYTHON_DEPS}
- dev-libs/libxml2:2
- dev-libs/libxslt
- >=dev-util/intltool-0.50.0
- virtual/pkgconfig
- test? (
- sys-apps/grep
- >=dev-libs/check-0.9.4 )
-"
-PDEPEND=">=net-im/telepathy-mission-control-5.14"
-
-pkg_setup() {
- python-any-r1_pkg_setup
- export PYTHONIOENCODING=UTF-8 # See bug 489774
-}
-
-src_configure() {
- local myconf=""
- [[ ${PV} = 9999 ]] || myconf="${myconf} ITSTOOL=$(type -P true)"
- DOCS="CONTRIBUTORS AUTHORS ChangeLog NEWS README"
- gnome2_src_configure \
- --disable-Werror \
- --disable-coding-style-checks \
- --disable-static \
- --disable-ubuntu-online-accounts \
- --enable-gst-1.0 \
- $(use_enable debug) \
- $(use_enable geoloc geocode) \
- $(use_enable geoloc location) \
- $(use_enable gnome-online-accounts goa) \
- $(use_enable map) \
- $(use_enable spell) \
- $(use_enable v4l gudev) \
- $(use_with v4l cheese) \
- ${myconf}
-}
-
-src_test() {
- dbus-launch Xemake check #504516
-}
diff --git a/net-im/empathy/metadata.xml b/net-im/empathy/metadata.xml
deleted file mode 100644
index 2ed4da56..00000000
--- a/net-im/empathy/metadata.xml
+++ /dev/null
@@ -1,25 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
-<maintainer type="project">
- <email>gnome@gentoo.org</email>
- <name>Gentoo GNOME Desktop</name>
- </maintainer>
- <use>
- <flag name="geoloc">Enable geolocation support through
- <pkg>app-misc/geoclue</pkg></flag>
- <flag name="gnome-online-accounts">Enable using
- <pkg>net-libs/gnome-online-accounts</pkg> for authorization (e.g.
- for Google Talk)</flag>
- <flag name="map">Enable world map support through
- <pkg>media-libs/libchamplain</pkg></flag>
- </use>
- <longdescription>
- Empathy consists of a rich set of reusable instant messaging widgets,
- and a GNOME client using those widgets. It uses Telepathy and Nokia's
- Mission Control. The main goal is to permit desktop integration by
- providing libempathy and libempathy-gtk libraries. libempathy-gtk is a
- set of powerful widgets that can be embeded into any GNOME application.
- A client application is provided.
- </longdescription>
-</pkgmetadata>
diff --git a/net-libs/gtk-vnc/gtk-vnc-9999.ebuild b/net-libs/gtk-vnc/gtk-vnc-9999.ebuild
deleted file mode 100644
index ec2ab1d7..00000000
--- a/net-libs/gtk-vnc/gtk-vnc-9999.ebuild
+++ /dev/null
@@ -1,189 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="5"
-GCONF_DEBUG="no"
-GNOME2_LA_PUNT="yes"
-PYTHON_COMPAT=( python2_7 )
-VALA_MIN_API_VERSION="0.16"
-VALA_USE_DEPEND="vapigen"
-
-inherit eutils gnome2 python-r1 vala
-if [[ ${PV} = 9999 ]]; then
- inherit gnome2-live
-fi
-
-DESCRIPTION="VNC viewer widget for GTK"
-HOMEPAGE="https://wiki.gnome.org/Projects/gtk-vnc"
-
-LICENSE="GPL-2"
-SLOT="0"
-if [[ ${PV} = 9999 ]]; then
- KEYWORDS=""
-else
- KEYWORDS="~alpha amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc x86 ~x86-fbsd"
-fi
-IUSE="examples +gtk3 +introspection pulseaudio python sasl vala"
-REQUIRED_USE="
- python? ( ${PYTHON_REQUIRED_USE} )
- vala? ( gtk3 introspection )
-"
-
-# libview is used in examples/gvncviewer -- no need
-COMMON_DEPEND="
- >=dev-libs/glib-2.30.1:2
- >=dev-libs/libgcrypt-1.4.2:0
- dev-libs/libgpg-error
- >=net-libs/gnutls-2.12
- >=x11-libs/cairo-1.2
- >=x11-libs/gtk+-2.18:2
- x11-libs/libX11
- gtk3? ( >=x11-libs/gtk+-2.91.3:3 )
- introspection? ( >=dev-libs/gobject-introspection-0.9.4 )
- pulseaudio? ( media-sound/pulseaudio )
- python? (
- ${PYTHON_DEPS}
- >=dev-python/pygtk-2:2[${PYTHON_USEDEP}] )
- sasl? ( dev-libs/cyrus-sasl )
-"
-RDEPEND="${COMMON_DEPEND}"
-
-DEPEND="${COMMON_DEPEND}
- >=dev-lang/perl-5
- >=dev-util/intltool-0.40
- sys-devel/gettext
- virtual/pkgconfig
- vala? (
- $(vala_depend)
- >=dev-libs/gobject-introspection-0.9.4 )
-"
-# eautoreconf requires gnome-common
-
-if [[ ${PV} = 9999 ]]; then
- # Needed by src/keymap-gen.pl to autogenerate keymap .c/.h files
- # Not needed in the tarball because they're created during distcheck
- DEPEND="${DEPEND}
- dev-perl/Text-CSV"
-fi
-
-GTK2_BUILDDIR="${WORKDIR}/${P}_gtk2"
-GTK3_BUILDDIR="${WORKDIR}/${P}_gtk3"
-
-src_prepare() {
- mkdir -p "${GTK2_BUILDDIR}" || die
- mkdir -p "${GTK3_BUILDDIR}" || die
- prepare_python() {
- mkdir -p "${BUILD_DIR}" || die
- }
- if use python; then
- python_foreach_impl prepare_python
- fi
-
- # Fix incorrect codegendir check: h2def.py is in pygobject, not pygtk, upstream bug#744393
- sed -e 's/codegendir pygtk-2.0/codegendir pygobject-2.0/g' \
- -i src/Makefile.am || die
-
- # libtool seems unable to find this via VPATH so help it
- sed -r "s:(gtkvnc_la_LIBADD =) libgtk-vnc-.*\.la:\1 ${GTK2_BUILDDIR}/src/libgtk-vnc-1.0.la:" \
- -i src/Makefile.am || die
-
- vala_src_prepare
- gnome2_src_prepare
-}
-
-src_configure() {
- local myconf
- myconf="
- $(use_with examples) \
- $(use_enable introspection) \
- $(use_with pulseaudio) \
- $(use_with sasl) \
- --with-coroutine=gthread \
- --without-libview \
- --disable-static \
- --disable-vala"
-
- cd "${GTK2_BUILDDIR}" || die
- einfo "Running configure in ${GTK2_BUILDDIR}"
- ECONF_SOURCE="${S}" gnome2_src_configure ${myconf} \
- --with-python=no \
- --with-gtk=2.0
-
- configure_python() {
- ECONF_SOURCE="${S}" gnome2_src_configure ${myconf} \
- $(use_with python) \
- --with-gtk=2.0
- }
- if use python; then
- python_foreach_impl run_in_build_dir configure_python
- fi
-
- if use gtk3; then
- cd "${GTK3_BUILDDIR}" || die
- einfo "Running configure in ${GTK3_BUILDDIR}"
- # Python support is via gobject-introspection
- # Ex: from gi.repository import GtkVnc
- ECONF_SOURCE="${S}" gnome2_src_configure ${myconf} \
- $(use_enable vala) \
- --with-python=no \
- --with-gtk=3.0
- fi
-}
-
-src_compile() {
- cd "${GTK2_BUILDDIR}" || die
- einfo "Running make in ${GTK2_BUILDDIR}"
- gnome2_src_compile
-
- compile_python() {
- cd "${BUILD_DIR}"/src || die
- # CPPFLAGS set to help find includes for gvnc.override
- emake gtkvnc.la \
- VPATH="${S}/src:${GTK2_BUILDDIR}/src:${BUILD_DIR}/src" \
- CPPFLAGS="${CPPFLAGS} -I${GTK2_BUILDDIR}/src"
- }
- if use python; then
- python_foreach_impl run_in_build_dir compile_python
- fi
-
- if use gtk3; then
- cd "${GTK3_BUILDDIR}" || die
- einfo "Running make in ${GTK3_BUILDDIR}"
- gnome2_src_compile
- fi
-}
-
-src_test() {
- cd "${GTK2_BUILDDIR}" || die
- einfo "Running make check in ${GTK2_BUILDDIR}"
- default
-
- if use gtk3; then
- cd "${GTK3_BUILDDIR}" || die
- einfo "Running make check in ${GTK3_BUILDDIR}"
- default
- fi
-}
-
-src_install() {
- cd "${GTK2_BUILDDIR}" || die
- einfo "Running make install in ${GTK2_BUILDDIR}"
- gnome2_src_install
-
- install_python() {
- cd "${BUILD_DIR}"/src || die
- emake install-pyexecLTLIBRARIES DESTDIR="${D}" \
- VPATH="${S}/src:${GTK2_BUILDDIR}/src:${BUILD_DIR}/src" \
- CPPFLAGS="${CPPFLAGS} -I${GTK2_BUILDDIR}/src"
- }
- if use python; then
- python_foreach_impl run_in_build_dir install_python
- fi
-
- if use gtk3; then
- cd "${GTK3_BUILDDIR}" || die
- einfo "Running make install in ${GTK3_BUILDDIR}"
- gnome2_src_install
- fi
-}
diff --git a/net-libs/gtk-vnc/metadata.xml b/net-libs/gtk-vnc/metadata.xml
deleted file mode 100644
index c977e3a0..00000000
--- a/net-libs/gtk-vnc/metadata.xml
+++ /dev/null
@@ -1,15 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>gnome@gentoo.org</email>
- <name>Gentoo GNOME Desktop</name>
- </maintainer>
- <maintainer type="project">
- <email>virtualization@gentoo.org</email>
- <name>Gentoo Virtualization Project</name>
- </maintainer>
- <use>
- <flag name="gtk3">Build the gtk3 gtk-vnc library and other gtk3 assets</flag>
- </use>
-</pkgmetadata>
diff --git a/net-libs/rest/metadata.xml b/net-libs/rest/metadata.xml
deleted file mode 100644
index 76314469..00000000
--- a/net-libs/rest/metadata.xml
+++ /dev/null
@@ -1,12 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>gnome@gentoo.org</email>
- <name>Gentoo GNOME Desktop</name>
- </maintainer>
- <use>
- <flag name="gnome">Extract proxy information using
- <pkg>net-libs/libsoup-gnome</pkg></flag>
- </use>
-</pkgmetadata>
diff --git a/net-libs/rest/rest-9999.ebuild b/net-libs/rest/rest-9999.ebuild
deleted file mode 100644
index 70899cff..00000000
--- a/net-libs/rest/rest-9999.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="5"
-GCONF_DEBUG="no"
-GNOME2_LA_PUNT="yes"
-
-inherit gnome2 virtualx
-if [[ ${PV} = 9999 ]]; then
- inherit gnome2-live
-fi
-
-DESCRIPTION="Helper library for RESTful services"
-HOMEPAGE="http://live.gnome.org/Librest"
-
-LICENSE="LGPL-2.1"
-SLOT="0.7"
-IUSE="+gnome +introspection test"
-if [[ ${PV} = 9999 ]]; then
- IUSE="${IUSE} doc"
- KEYWORDS=""
-else
- KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
-fi
-
-# Coverage testing should not be enabled
-RDEPEND="app-misc/ca-certificates
- >=dev-libs/glib-2.24:2
- dev-libs/libxml2:2
- net-libs/libsoup:2.4
- gnome? ( >=net-libs/libsoup-gnome-2.25.1:2.4 )
- introspection? ( >=dev-libs/gobject-introspection-0.6.7 )
-"
-DEPEND="${RDEPEND}
- >=dev-util/gtk-doc-am-1.13
- >=dev-util/intltool-0.40
- virtual/pkgconfig
- test? ( sys-apps/dbus )
-"
-
-if [[ ${PV} = 9999 ]]; then
- DEPEND="${DEPEND}
- doc? ( >=dev-util/gtk-doc-1.13 )"
-fi
-
-src_configure() {
- gnome2_src_configure \
- --disable-static \
- --disable-gcov \
- --with-ca-certificates="${EPREFIX}"/etc/ssl/certs/ca-certificates.crt \
- $(use_with gnome) \
- $(use_enable introspection)
-}
-
-src_test() {
- # Tests need dbus
- Xemake check || die
-}
diff --git a/net-misc/spice-gtk/metadata.xml b/net-misc/spice-gtk/metadata.xml
deleted file mode 100644
index 92aeee0d..00000000
--- a/net-misc/spice-gtk/metadata.xml
+++ /dev/null
@@ -1,22 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>virtualization@gentoo.org</email>
- <name>Gentoo Virtualization Project</name>
- </maintainer>
- <use>
- <flag name="dbus">Support for desktop integration such as
- automounting and other APIs exposed by your DE via D-Bus</flag>
- <flag name="gtk3">Link against <pkg>x11-libs/gtk+</pkg>:3 instead of
- <pkg>x11-libs/gtk+</pkg>:2</flag>
- <flag name="lz4">Enable support for LZ4 compression using
- <pkg>app-arch/lz4</pkg></flag>
- <flag name="policykit">Enable <pkg>sys-auth/polkit</pkg> support for the
- usbredir acl helper</flag>
- <flag name="usbredir">Use <pkg>sys-apps/usbredir</pkg> to redirect USB
- devices to another machine over TCP</flag>
- <flag name="webdav">Support for folder-sharing between guest and client
- using <pkg>net-libs/phodav</pkg></flag>
- </use>
-</pkgmetadata>
diff --git a/net-misc/spice-gtk/spice-gtk-9999.ebuild b/net-misc/spice-gtk/spice-gtk-9999.ebuild
deleted file mode 100644
index 9dee3f28..00000000
--- a/net-misc/spice-gtk/spice-gtk-9999.ebuild
+++ /dev/null
@@ -1,162 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-GCONF_DEBUG="no"
-VALA_MIN_API_VERSION="0.14"
-VALA_USE_DEPEND="vapigen"
-PYTHON_COMPAT=( python2_7 )
-
-inherit autotools eutils multibuild python-single-r1 vala
-if [[ ${PV} = 9999 ]]; then
- inherit gnome2-live
-fi
-
-DESCRIPTION="Set of GObject and Gtk objects for connecting to Spice servers and a client GUI"
-HOMEPAGE="http://spice-space.org http://gitorious.org/spice-gtk"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-if [[ ${PV} = 9999 ]]; then
- EGIT_REPO_URI="git://anongit.freedesktop.org/spice/${PN}"
- KEYWORDS=""
-else
- SRC_URI="http://spice-space.org/download/gtk/${P}.tar.bz2"
- KEYWORDS="~alpha ~amd64 ~arm ~ppc ~ppc64 ~x86"
-fi
-IUSE="dbus gstreamer gtk2 gtk3 +introspection lz4 policykit pulseaudio python sasl smartcard static-libs usbredir vala webdav"
-REQUIRED_USE="
- python? ( gtk2 ${PYTHON_REQUIRED_USE} )
- ?? ( pulseaudio gstreamer )
-"
-
-# TODO:
-# * check if sys-freebsd/freebsd-lib (from virtual/acl) provides acl/libacl.h
-# * use external pnp.ids as soon as that means not pulling in gnome-desktop
-RDEPEND="
- ${PYTHON_DEPS}
- pulseaudio? ( media-sound/pulseaudio[glib] )
- gstreamer? (
- media-libs/gstreamer:1.0
- media-libs/gst-plugins-base:1.0 )
- >=x11-libs/pixman-0.17.7
- >=media-libs/celt-0.5.1.1:0.5.1
- media-libs/opus
- dev-libs/openssl:=
- gtk2? ( x11-libs/gtk+:2[introspection?] )
- gtk3? ( x11-libs/gtk+:3[introspection?] )
- >=dev-libs/glib-2.28:2
- >=x11-libs/cairo-1.2
- virtual/jpeg:=
- sys-libs/zlib
- introspection? ( dev-libs/gobject-introspection )
- lz4? ( app-arch/lz4 )
- python? ( dev-python/pygtk:2 )
- sasl? ( dev-libs/cyrus-sasl )
- smartcard? ( app-emulation/qemu[smartcard] )
- usbredir? (
- sys-apps/hwids
- >=sys-apps/usbredir-0.4.2
- virtual/libusb:1
- virtual/libgudev:=
- policykit? (
- sys-apps/acl
- >=sys-auth/polkit-0.110-r1
- !~sys-auth/polkit-0.111 )
- )
- webdav? (
- net-libs/phodav:2.0
- >=dev-libs/glib-2.43.90:2
- >=net-libs/libsoup-2.49.91 )
-"
-DEPEND="${RDEPEND}
- dev-lang/python
- dev-python/pyparsing
- dev-perl/Text-CSV
- >=dev-util/gtk-doc-am-1.14
- >=dev-util/intltool-0.40.0
- >=sys-devel/gettext-0.17
- virtual/pkgconfig
- vala? ( $(vala_depend) )
-"
-
-if [[ ${PV} = 9999 ]]; then
- DEPEND="${DEPEND}
- $(vala_depend)
- dev-lang/perl
- dev-perl/Text-CSV"
-fi
-
-src_prepare() {
- epatch_user
-
- AT_NO_RECURSIVE="yes" eautoreconf
-
- use vala && vala_src_prepare
-}
-
-src_configure() {
- local myconf
- local audio="no"
-
- use gstreamer && audio="gstreamer"
- use pulseaudio && audio="pulse"
-
- if use vala ; then
- # force vala regen for MinGW, etc
- rm -fv gtk/controller/controller.{c,vala.stamp} gtk/controller/menu.c
- fi
-
- myconf="
- --disable-maintainer-mode \
- $(use_enable static-libs static) \
- $(use_enable introspection) \
- --with-audio=${audio} \
- $(use_with python) \
- $(use_with sasl) \
- $(use_enable smartcard) \
- $(use_enable usbredir) \
- $(use_with usbredir usb-ids-path /usr/share/misc/usb.ids) \
- $(use_with usbredir usb-acl-helper-dir /usr/libexec) \
- $(use_enable policykit polkit) \
- $(use_enable vala) \
- $(use_enable webdav) \
- $(use_enable dbus) \
- --disable-gtk-doc \
- --disable-werror \
- --enable-pie"
-
- # Parameter of --with-gtk
- MULTIBUILD_VARIANTS=( no )
- use gtk2 && MULTIBUILD_VARIANTS+=( 2.0 )
- use gtk3 && MULTIBUILD_VARIANTS+=( 3.0 )
-
- configure() {
- [[ ${MULTIBUILD_VARIANT} != "2.0" ]] && myconf+=( --with-python )
- myconf+=( --with-gtk=${MULTIBUILD_VARIANT} )
- ECONF_SOURCE="${S}" econf ${myconf[@]}
- }
- multibuild_foreach_variant run_in_build_dir configure
-}
-
-src_compile() {
- multibuild_foreach_variant run_in_build_dir default
-}
-
-src_test() {
- multibuild_foreach_variant run_in_build_dir default
-}
-
-src_install() {
- dodoc AUTHORS ChangeLog NEWS README THANKS TODO
-
- multibuild_foreach_variant run_in_build_dir default
-
- # Remove .la files if they're not needed
- use static-libs || prune_libtool_files
-
- use python && rm -rf "${ED}"/usr/lib*/python*/site-packages/*.la
-
- make_desktop_entry spicy Spicy "utilities-terminal" "Network;RemoteAccess;"
-}
diff --git a/net-misc/vinagre/metadata.xml b/net-misc/vinagre/metadata.xml
deleted file mode 100644
index 10b7a1e0..00000000
--- a/net-misc/vinagre/metadata.xml
+++ /dev/null
@@ -1,16 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>gnome@gentoo.org</email>
- <name>Gentoo GNOME Desktop</name>
- </maintainer>
- <use>
- <flag name="rdp">Enable access to Windows RDP protocol using
- <pkg>net-misc/rdesktop</pkg></flag>
- <flag name="ssh">Enable ssh plugin using <pkg>x11-libs/vte</pkg></flag>
- <flag name="spice">Enable access to SPICE-enabled virtual machines</flag>
- <flag name="telepathy">Enable access to remote desktop via a
- <pkg>net-libs/telepathy-glib</pkg> client</flag>
- </use>
-</pkgmetadata>
diff --git a/net-misc/vinagre/vinagre-9999.ebuild b/net-misc/vinagre/vinagre-9999.ebuild
deleted file mode 100644
index 5e9377a4..00000000
--- a/net-misc/vinagre/vinagre-9999.ebuild
+++ /dev/null
@@ -1,85 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="5"
-GCONF_DEBUG="no"
-VALA_MIN_API_VERSION="0.18"
-
-inherit gnome2 linux-info vala
-if [[ ${PV} = 9999 ]]; then
- inherit gnome2-live
-fi
-
-DESCRIPTION="VNC client for the GNOME desktop"
-HOMEPAGE="https://wiki.gnome.org/Apps/Vinagre"
-
-LICENSE="GPL-3+"
-SLOT="0"
-if [[ ${PV} = 9999 ]]; then
- KEYWORDS=""
-else
- KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~ppc64 ~x86"
-fi
-IUSE="rdp +ssh spice +telepathy zeroconf"
-
-# cairo used in vinagre-tab
-# gdk-pixbuf used all over the place
-RDEPEND="
- >=dev-libs/glib-2.32.0:2
- >=x11-libs/gtk+-3.9.6:3
- app-crypt/libsecret
- >=dev-libs/libxml2-2.6.31:2
- >=net-libs/gtk-vnc-0.4.3[gtk3]
- x11-libs/cairo:=
- x11-libs/gdk-pixbuf:2
- x11-themes/hicolor-icon-theme
-
- rdp? ( net-misc/freerdp )
- ssh? ( >=x11-libs/vte-0.20:2.91 )
- spice? (
- app-emulation/spice-protocol
- >=net-misc/spice-gtk-0.5[gtk3] )
- telepathy? (
- dev-libs/dbus-glib
- >=net-libs/telepathy-glib-0.11.6 )
- zeroconf? ( >=net-dns/avahi-0.6.26[dbus,gtk3] )
-"
-DEPEND="${RDEPEND}
- >=dev-lang/perl-5
- dev-libs/appstream-glib
- >=dev-util/intltool-0.50
- >=sys-devel/gettext-0.17
- virtual/pkgconfig
- $(vala_depend)
-"
-
-if [[ ${PV} = 9999 ]]; then
- DEPEND+="
- app-text/yelp-tools
- gnome-base/gnome-common"
-fi
-
-pkg_pretend() {
- # Needed for VNC ssh tunnel, bug #518574
- CONFIG_CHECK="~IPV6"
- check_extra_config
-}
-
-src_prepare() {
- vala_src_prepare
- gnome2_src_prepare
-}
-
-src_configure() {
- local myconf=""
- [[ ${PV} = 9999 ]] || myconf="ITSTOOL=$(type -P true)"
- DOCS="AUTHORS ChangeLog ChangeLog.pre-git NEWS README"
- gnome2_src_configure \
- $(use_enable rdp) \
- $(use_enable ssh) \
- $(use_enable spice) \
- $(use_with telepathy) \
- $(use_with zeroconf avahi) \
- ${myconf}
-}
diff --git a/sys-libs/libosinfo/libosinfo-9999.ebuild b/sys-libs/libosinfo/libosinfo-9999.ebuild
deleted file mode 100644
index d2003db0..00000000
--- a/sys-libs/libosinfo/libosinfo-9999.ebuild
+++ /dev/null
@@ -1,70 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-GCONF_DEBUG="no"
-VALA_MIN_API_VERSION="0.16"
-VALA_USE_DEPEND="vapigen"
-
-inherit gnome2 udev vala
-if [[ ${PV} = 9999 ]]; then
- inherit gnome2-live
-fi
-
-DESCRIPTION="GObject library for managing information about real and virtual OSes"
-HOMEPAGE="http://libosinfo.org/"
-
-LICENSE="GPL-2 LGPL-2.1"
-SLOT="0"
-IUSE="+introspection +vala test"
-REQUIRED_USE="vala? ( introspection )"
-if [[ ${PV} = 9999 ]]; then
- EGIT_REPO_URI="git://git.fedorahosted.org/${PN}.git"
- KEYWORDS=""
- IUSE="${IUSE} doc"
-else
- SRC_URI="http://fedorahosted.org/releases/${PN:0:1}/${PN:1:1}/${PN}/${P}.tar.gz"
- KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
-fi
-
-RDEPEND="
- >=dev-libs/glib-2:2
- >=dev-libs/libxslt-1.0.0:=
- dev-libs/libxml2:=
- net-libs/libsoup-gnome:2.4
- sys-apps/hwids
- introspection? ( >=dev-libs/gobject-introspection-0.9.7:= )
-"
-DEPEND="${RDEPEND}
- dev-libs/gobject-introspection-common
- >=dev-util/gtk-doc-am-1.10
- virtual/pkgconfig
- test? ( dev-libs/check )
- vala? ( $(vala_depend) )
-"
-
-if [[ ${PV} = 9999 ]]; then
- DEPEND="${DEPEND}
- doc? ( >=dev-util/gtk-doc-1.10 )"
-fi
-
-src_prepare() {
- use vala && vala_src_prepare
- gnome2_src_prepare
-}
-
-src_configure() {
- # --enable-udev is only for rules.d file install
- gnome2_src_configure \
- --disable-static \
- $(use_enable doc gtk-doc) \
- $(use_enable test tests) \
- $(use_enable introspection) \
- $(use_enable vala) \
- --enable-udev \
- --disable-coverage \
- --with-udev-rulesdir="$(get_udevdir)"/rules.d \
- --with-usb-ids-path=/usr/share/misc/usb.ids \
- --with-pci-ids-path=/usr/share/misc/pci.ids
-}
diff --git a/sys-libs/libosinfo/metadata.xml b/sys-libs/libosinfo/metadata.xml
deleted file mode 100644
index 39980802..00000000
--- a/sys-libs/libosinfo/metadata.xml
+++ /dev/null
@@ -1,8 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
-<maintainer type="project">
- <email>gnome@gentoo.org</email>
- <name>Gentoo GNOME Desktop</name>
-</maintainer>
-</pkgmetadata>
diff --git a/x11-libs/colord-gtk/colord-gtk-9999.ebuild b/x11-libs/colord-gtk/colord-gtk-9999.ebuild
deleted file mode 100644
index 5b3b91fd..00000000
--- a/x11-libs/colord-gtk/colord-gtk-9999.ebuild
+++ /dev/null
@@ -1,75 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="5"
-VALA_MIN_API_VERSION="0.14"
-VALA_USE_DEPEND="vapigen"
-
-inherit eutils vala
-if [[ ${PV} = 9999 ]]; then
- GCONF_DEBUG="no"
- inherit gnome2-live # need all the hacks from gnome2-live_src_prepare
-fi
-
-DESCRIPTION="GTK support library for colord"
-HOMEPAGE="http://www.freedesktop.org/software/colord/"
-if [[ ${PV} = 9999 ]]; then
- EGIT_REPO_URI="git://gitorious.org/colord/colord-gtk.git"
-else
- SRC_URI="http://www.freedesktop.org/software/colord/releases/${P}.tar.xz"
-fi
-
-LICENSE="LGPL-3+"
-SLOT="0/1" # subslot = libcolord-gtk soname version
-IUSE="doc +introspection vala"
-REQUIRED_USE="vala? ( introspection )"
-if [[ ${PV} = 9999 ]]; then
- KEYWORDS=""
-else
- KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
-fi
-
-COMMON_DEPEND="
- >=dev-libs/glib-2.28:2
- >=media-libs/lcms-2.2:2=
- x11-libs/gdk-pixbuf:2[introspection?]
- x11-libs/gtk+:3[X(+),introspection?]
- x11-misc/colord:=[introspection?,vala?]
- introspection? ( >=dev-libs/gobject-introspection-0.9.8 )"
-# ${PN} was part of x11-misc/colord until 0.1.22
-RDEPEND="${COMMON_DEPEND}
- !<x11-misc/colord-0.1.27
-"
-DEPEND="${COMMON_DEPEND}
- app-arch/xz-utils
- dev-libs/libxslt
- >=dev-util/intltool-0.35
- >=sys-devel/gettext-0.17
- virtual/pkgconfig
- doc? (
- app-text/docbook-xml-dtd:4.1.2
- >=dev-util/gtk-doc-1.9
- )
- vala? ( $(vala_depend) )
-"
-
-src_prepare() {
- use vala && vala_src_prepare
- if [[ ${PV} = 9999 ]]; then
- gnome2_src_prepare
- fi
-}
-
-src_configure() {
- econf \
- --disable-static \
- $(use_enable doc gtk-doc) \
- $(use_enable introspection) \
- $(use_enable vala)
-}
-
-src_install() {
- default
- prune_libtool_files --modules
-}
diff --git a/x11-libs/colord-gtk/metadata.xml b/x11-libs/colord-gtk/metadata.xml
deleted file mode 100644
index 39980802..00000000
--- a/x11-libs/colord-gtk/metadata.xml
+++ /dev/null
@@ -1,8 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
-<maintainer type="project">
- <email>gnome@gentoo.org</email>
- <name>Gentoo GNOME Desktop</name>
-</maintainer>
-</pkgmetadata>
diff --git a/x11-libs/gtksourceview/files/2.0/gentoo.lang b/x11-libs/gtksourceview/files/2.0/gentoo.lang
deleted file mode 100644
index f1e0660c..00000000
--- a/x11-libs/gtksourceview/files/2.0/gentoo.lang
+++ /dev/null
@@ -1,111 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-
-<!--
- GtkSourceView syntax highlight for Gentoo-specific files
-
- Originally written for gtksourceview-1.x by:
- Leonardo Ferreira Fontenelle <leo.fontenelle@gmail.com>, 2006.
- Rewritten for gtksourceview-2 by:
- Rene 'Necoro' Neumann <necoro@necoro.net>, 2007
-
- Distributed under the same license(s) as gtksourceview.
-
- TODO:
- - do not highlight "enable" in the configure options
- - perhaps highlight portage variables and portage functions different
-
--->
-
-<language name="gentoo" id="gentoo" version="2.0" _section="Scripts">
- <metadata>
- <property name="globs">*.ebuild;*.eclass</property>
- <property name="line-comment-start">#</property>
- </metadata>
-
- <styles>
- <style id="variable" _name="Portage variables" map-to="def:builtin" />
- <style id="command" _name="Portage command" map-to="def:type" />
- <style id="function" _name="Portage function" map-to="def:function" />
- <style id="string" _name="String" map-to="def:string" />
- </styles>
-
- <definitions>
-
- <!-- rewrite shell string to show highlighted variables -->
- <context id="string" style-ref="def:string">
- <start>"</start>
- <end>"</end>
- <include>
- <context ref="def:escape"/>
- <context ref="def:line-continue"/>
- <context ref="sh:variable"/>
- </include>
- </context>
-
- <context id="string-2" style-ref="def:string">
- <start>'</start>
- <end>'</end>
- <include>
- <context ref="def:escape"/>
- <context ref="def:line-continue"/>
- <context ref="sh:variable"/>
- </include>
- </context>
-
- <!-- subprograms:
- - $(..) is not supported currently in the normal sh.lang
- - `...` is interpreted as string - I think the subshell behavior is more acurate -->
- <context id="subprogram">
- <start>\$\(</start>
- <end>\)</end>
- <include>
- <context sub-pattern="0" where="start" style-ref="sh:keyword"/>
- <context sub-pattern="0" where="end" style-ref="sh:keyword"/>
- <context ref="gentoo"/>
- </include>
- </context>
-
- <context id="subprogram-2">
- <start>`</start>
- <end>`</end>
- <include>
- <context sub-pattern="0" where="start" style-ref="sh:keyword"/>
- <context sub-pattern="0" where="end" style-ref="sh:keyword"/>
- <context ref="gentoo"/>
- </include>
- </context>
-
- <!-- portage variables - currently unused -->
- <context id="portvars" style-ref="variable">
- <match>\b((ARCH|HOMEPAGE|DESCRIPTION|IUSE|SRC_URI|LICENSE|SLOT|KEYWORDS|FILESDIR|WORKDIR|(P|R)?DEPEND|PROVIDE|DISTDIR|RESTRICT|USERLAND)|(S|D|T|PV|PF|P|PN|A)|C(XX)?FLAGS|LDFLAGS|C(HOST|TARGET|BUILD))\b</match>
- </context>
-
- <!-- portage functions - currently unused -->
- <context id="portfuncs" style-ref="function">
- <match>^(src_(unpack|compile|install|test)|pkg_(config|nofetch|setup|(pre|post)(inst|rm)))</match>
- </context>
-
- <!-- extra portage commands -->
- <context id="portcmds" style-ref="command">
- <match>\b(e(begin|end|conf|install|make|warn|infon?|error|patch)|die|use(_(with|enable))?|inherit|has|(has|best)_version|unpack|(do|new)(ins|s?bin|doc|lib(|\.so|\.a)|man|info|exe|initd|confd|envd|pam|menu|icon)|do(python|sed|dir|hard|sym|html|jar|mo)|keepdir|prepall(|docs|info|man|strip)|prep(info|lib|lib\.(so|a)|man|strip)|(|doc|ins|exe)into|f(owners|perms)|(exe|ins|dir)opts)\b</match>
- </context>
-
- <context id="built-in-command">
- <include> <!-- do not include "sh:built-in-command" as it is replaced down there - which would lead to an endless loop -->
- <context ref="sh:built-in-command-1" />
- <context ref="sh:built-in-command-2" />
- <context ref="portcmds" />
- </include>
- </context>
-
- <!-- gentoo is just a shell with the replacements -->
- <replace id="sh:built-in-command" ref="built-in-command" />
- <replace id="sh:backtick-subshell" ref="subprogram-2" />
- <context id="gentoo">
- <include>
- <context ref="subprogram"/>
- <context ref="sh:sh"/>
- </include>
- </context>
- </definitions>
-</language>
diff --git a/x11-libs/gtksourceview/gtksourceview-9999.ebuild b/x11-libs/gtksourceview/gtksourceview-9999.ebuild
deleted file mode 100644
index 20ad3b5a..00000000
--- a/x11-libs/gtksourceview/gtksourceview-9999.ebuild
+++ /dev/null
@@ -1,75 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="5"
-GCONF_DEBUG="no"
-VALA_MIN_API_VERSION="0.24"
-VALA_USE_DEPEND="vapigen"
-
-inherit gnome2 vala virtualx
-if [[ ${PV} = 9999 ]]; then
- inherit gnome2-live
-fi
-
-DESCRIPTION="A text widget implementing syntax highlighting and other features"
-HOMEPAGE="https://wiki.gnome.org/Projects/GtkSourceView"
-
-LICENSE="GPL-2+ LGPL-2.1+"
-SLOT="3.0/3"
-
-IUSE="glade +introspection vala"
-REQUIRED_USE="vala? ( introspection )"
-if [[ ${PV} = 9999 ]]; then
- IUSE="${IUSE} doc"
- KEYWORDS=""
-else
- KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-solaris"
-fi
-
-# Note: has native OSX support, prefix teams, attack!
-RDEPEND="
- >=dev-libs/glib-2.47:2
- >=dev-libs/libxml2-2.6:2
- >=x11-libs/gtk+-3.19.6:3[introspection?]
- glade? ( >=dev-util/glade-3.9:3.10 )
- introspection? ( >=dev-libs/gobject-introspection-1.42:= )
-"
-DEPEND="${RDEPEND}
- >=dev-util/gtk-doc-am-1.24
- >=sys-devel/gettext-0.19.4
- dev-util/itstool
- virtual/pkgconfig
- vala? ( $(vala_depend) )
-"
-
-if [[ ${PV} = 9999 ]]; then
- DEPEND="${DEPEND}
- doc? ( >=dev-util/gtk-doc-1.18 )"
-fi
-
-src_prepare() {
- use vala && vala_src_prepare
- gnome2_src_prepare
-}
-
-src_configure() {
- gnome2_src_configure \
- --disable-deprecations \
- --enable-providers \
- $(use_enable glade glade-catalog) \
- $(use_enable introspection) \
- $(use_enable vala)
-}
-
-src_test() {
- Xemake check
-}
-
-src_install() {
- DOCS="AUTHORS HACKING MAINTAINERS NEWS README"
- gnome2_src_install
-
- insinto /usr/share/${PN}-3.0/language-specs
- doins "${FILESDIR}"/2.0/gentoo.lang
-}
diff --git a/x11-libs/gtksourceview/metadata.xml b/x11-libs/gtksourceview/metadata.xml
deleted file mode 100644
index 7bcd75b4..00000000
--- a/x11-libs/gtksourceview/metadata.xml
+++ /dev/null
@@ -1,11 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
-<maintainer type="project">
- <email>gnome@gentoo.org</email>
- <name>Gentoo GNOME Desktop</name>
-</maintainer>
-<use>
- <flag name="glade">Install a glade catalog file</flag>
-</use>
-</pkgmetadata>