summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games-board/aisleriot/Manifest10
-rw-r--r--games-board/aisleriot/aisleriot-3.22.0.ebuild86
-rw-r--r--games-board/aisleriot/aisleriot-9999.ebuild23
-rw-r--r--games-board/aisleriot/files/aisleriot-3.22.0-detect-svg.patch40
4 files changed, 143 insertions, 16 deletions
diff --git a/games-board/aisleriot/Manifest b/games-board/aisleriot/Manifest
index 386b5737..3c2f3aa3 100644
--- a/games-board/aisleriot/Manifest
+++ b/games-board/aisleriot/Manifest
@@ -2,9 +2,13 @@
Hash: SHA512
DIST aisleriot-3.20.2.tar.xz 6329212 SHA256 62036bdc69f8ae63a4405b4dd530a3def2958d5075b4e0a7caeb91fad789176e SHA512 017f98af29ba21867592a0349daf5b32db9f182ff0e5699c045bbf8270ebb76942e9c862541920f45e02764cdf5153d700c7847579e06763b7bb6f1307d92d8f WHIRLPOOL 24476f9ace152547ef75cc2578c35c58f59309eec9e28d0cf8e87a514a1f4fbdd2d7be95fd8a84a67bcf665f89e267168a30ddcb2d194caac46111a7ffedf143
+DIST aisleriot-3.22.0.tar.xz 6345548 SHA256 e7b603df0a482bdd0ab8083efc096a24a46aea1b36cc8608846e568b7a353eb7 SHA512 0e565466ee7b0847c995db6e48eab293c161f9812028e37d535facdeab85d4546971a7dc583a45e2ac71fd92ca1451a2ffeaf5cc54b202c92da7f61fb2009f02 WHIRLPOOL 0559c3ff4bd2ec7e35bf82261d559c8806f35ee78a0f4dbb01099b03ad03fd270fe86fa32c0ad437315fcdeb89828b3bb6e44207c61dcddf7a4127fadbc2986c
-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v2
-iEYEAREKAAYFAlfN55sACgkQ1fmVwcYIWAZZUQCg79qrnIJIKn/g18KrlRAksrBs
-uYsAoMBblV6FAvI4qNLbIXvVhMqP1AQa
-=2a99
+iKYEAREKAGYFAlgV1+lfFIAAAAAALgAoaXNzdWVyLWZwckBub3RhdGlvbnMub3Bl
+bnBncC5maWZ0aGhvcnNlbWFuLm5ldDVDQTQxN0YyN0IxMzFCQTU5M0MwQkU5MEQ1
+Rjk5NUMxQzYwODU4MDYACgkQ1fmVwcYIWAb2RgCfZLryo5TKWo3yAKTFIAzK1WL+
+tsoAoNj3cRmPaC29nFUzKQsRGdoj7rB6
+=aldV
-----END PGP SIGNATURE-----
diff --git a/games-board/aisleriot/aisleriot-3.22.0.ebuild b/games-board/aisleriot/aisleriot-3.22.0.ebuild
new file mode 100644
index 00000000..9e0f323c
--- /dev/null
+++ b/games-board/aisleriot/aisleriot-3.22.0.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit autotools gnome2
+
+DESCRIPTION="A collection of solitaire card games for GNOME"
+HOMEPAGE="https://wiki.gnome.org/action/show/Apps/Aisleriot"
+
+LICENSE="GPL-3 LGPL-3 FDL-1.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug gnome qt5"
+
+# FIXME: quartz support?
+# Does not build with guile-2.0.0 or 2.0.1
+COMMON_DEPEND="
+ >=dev-libs/glib-2.32:2
+ >=dev-scheme/guile-2.0.5:12[deprecated,regex]
+ >=gnome-base/librsvg-2.32:2
+ >=media-libs/libcanberra-0.26[gtk3]
+ >=x11-libs/cairo-1.10
+ >=x11-libs/gtk+-3.4:3
+ gnome? ( >=gnome-base/gconf-2.0:2 )
+ qt5? ( >=dev-qt/qtsvg-5:5 )
+"
+DEPEND="${COMMON_DEPEND}
+ app-arch/gzip
+ app-text/yelp-tools
+ >=dev-util/intltool-0.40.4
+ gnome-base/gnome-common
+ sys-apps/lsb-release
+ >=sys-devel/gettext-0.12
+ virtual/pkgconfig
+ gnome? ( app-text/docbook-xml-dtd:4.3 )
+"
+
+src_prepare() {
+ # Fix SVG detection and usage
+ eapply "${FILESDIR}"/${PN}-3.22.0-detect-svg.patch
+
+ eautoreconf
+ gnome2_src_prepare
+}
+
+src_configure() {
+ local myconf=()
+
+ if use gnome; then
+ myconf+=(
+ --with-platform=gnome
+ --with-help-method=ghelp
+ )
+ else
+ myconf+=(
+ --with-platform=gtk-only
+ --with-help-method=library
+ )
+ fi
+
+ if use qt5 ; then
+ myconf+=(
+ --with-card-theme-formats=all
+ --with-kde-card-theme-path="${EPREFIX}"/usr/share/apps/carddecks
+ )
+ else
+ myconf+=( --with-card-theme-formats=svg,fixed,pysol )
+ fi
+
+ gnome2_src_configure \
+ --with-gtk=3.0 \
+ --with-guile=2.0 \
+ $(usex debug --enable-debug=yes --enable-debug=minimum) \
+ --enable-sound \
+ --with-pysol-card-theme-path="${EPREFIX}${GAMES_DATADIR}"/pysolfc \
+ ${myconf[@]}
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+
+ elog "Aisleriot can use additional card themes from games-board/pysolfc"
+ elog "and kde-base/libkdegames."
+}
diff --git a/games-board/aisleriot/aisleriot-9999.ebuild b/games-board/aisleriot/aisleriot-9999.ebuild
index 535d6b48..77df6e25 100644
--- a/games-board/aisleriot/aisleriot-9999.ebuild
+++ b/games-board/aisleriot/aisleriot-9999.ebuild
@@ -1,11 +1,10 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI="5"
-GCONF_DEBUG="yes"
+EAPI=6
-inherit autotools eutils gnome-games
+inherit autotools gnome2
if [[ ${PV} = 9999 ]]; then
inherit gnome2-live
fi
@@ -20,7 +19,7 @@ if [[ ${PV} = 9999 ]]; then
else
KEYWORDS="~amd64 ~x86"
fi
-IUSE="gnome qt4"
+IUSE="debug gnome qt5"
# FIXME: quartz support?
# Does not build with guile-2.0.0 or 2.0.1
@@ -32,24 +31,22 @@ COMMON_DEPEND="
>=x11-libs/cairo-1.10
>=x11-libs/gtk+-3.4:3
gnome? ( >=gnome-base/gconf-2.0:2 )
- qt4? ( >=dev-qt/qtsvg-4.4:4 )
+ qt5? ( >=dev-qt/qtsvg-5:5 )
"
DEPEND="${COMMON_DEPEND}
app-arch/gzip
- dev-libs/libxml2
+ app-text/yelp-tools
>=dev-util/intltool-0.40.4
- dev-util/itstool
+ gnome-base/gnome-common
sys-apps/lsb-release
>=sys-devel/gettext-0.12
virtual/pkgconfig
gnome? ( app-text/docbook-xml-dtd:4.3 )
"
-# dev-util/itstool really needed for help file generation
-# >=app-text/yelp-tools-3.1.1
src_prepare() {
# Fix SVG detection and usage
- epatch "${FILESDIR}"/${PN}-3.16.2-detect-svg.patch
+ eapply "${FILESDIR}"/${PN}-3.22.0-detect-svg.patch
eautoreconf
gnome2_src_prepare
@@ -70,7 +67,7 @@ src_configure() {
)
fi
- if use qt4 ; then
+ if use qt5 ; then
myconf+=(
--with-card-theme-formats=all
--with-kde-card-theme-path="${EPREFIX}"/usr/share/apps/carddecks
@@ -82,9 +79,9 @@ src_configure() {
gnome2_src_configure \
--with-gtk=3.0 \
--with-guile=2.0 \
+ $(usex debug --enable-debug=yes --enable-debug=minimum) \
--enable-sound \
--with-pysol-card-theme-path="${EPREFIX}${GAMES_DATADIR}"/pysolfc \
- GUILE=$(type -P guile-2.0) \
${myconf[@]}
}
diff --git a/games-board/aisleriot/files/aisleriot-3.22.0-detect-svg.patch b/games-board/aisleriot/files/aisleriot-3.22.0-detect-svg.patch
new file mode 100644
index 00000000..827abcf7
--- /dev/null
+++ b/games-board/aisleriot/files/aisleriot-3.22.0-detect-svg.patch
@@ -0,0 +1,40 @@
+From f8dfa11c318c33847670cd06a43dd5b19f1d5231 Mon Sep 17 00:00:00 2001
+From: Gilles Dartiguelongue <eva@gentoo.org>
+Date: Mon, 31 Oct 2016 11:23:30 +0100
+Subject: [PATCH] Do not require a particular SVG library unless actually found
+
+---
+ configure.ac | 10 +++++++---
+ 1 file changed, 7 insertions(+), 3 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 8c4a38e..06e174f 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -325,7 +325,9 @@ if test "$need_rsvg" = "yes"; then
+
+ PKG_CHECK_EXISTS([librsvg-2.0 >= $RSVG_REQUIRED],[have_rsvg=yes],[have_rsvg=no])
+
+- PKGS="$PKGS librsvg-2.0 >= $RSVG_REQUIRED cairo >= $CAIRO_REQUIRED"
++ if test "$have_rsvg" = "yes" ; then
++ PKGS="$PKGS librsvg-2.0 >= $RSVG_REQUIRED cairo >= $CAIRO_REQUIRED"
++ fi
+
+ AC_DEFINE([HAVE_RSVG],[1],[Refine if librsvg is available])
+ fi
+@@ -340,8 +342,10 @@ if test "$need_qtsvg" = "yes"; then
+
+ PKG_CHECK_EXISTS([Qt5Svg >= $QT_SVG_REQUIRED],[have_qtsvg=yes],[have_qtsvg=no])
+
+- PKGS="$PKGS Qt5Svg >= $QT_SVG_REQUIRED"
+- EXTRA_CXX_LIBS="$EXTRA_CXX_LIBS -lstdc++"
++ if test "$have_qtsvg" = "yes" ; then
++ PKGS="$PKGS Qt5Svg >= $QT_SVG_REQUIRED"
++ EXTRA_CXX_LIBS="$EXTRA_CXX_LIBS -lstdc++"
++ fi
+
+ AC_DEFINE([HAVE_QTSVG],[1],[Refine if QtSvg is available])
+ fi
+--
+2.10.1
+