summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www-client/epiphany/Manifest4
-rw-r--r--www-client/epiphany/epiphany-2.91.6.ebuild75
-rw-r--r--www-client/epiphany/epiphany-9999.ebuild4
3 files changed, 80 insertions, 3 deletions
diff --git a/www-client/epiphany/Manifest b/www-client/epiphany/Manifest
index 115ae9c6..412e0948 100644
--- a/www-client/epiphany/Manifest
+++ b/www-client/epiphany/Manifest
@@ -1,3 +1,5 @@
DIST epiphany-2.91.5.tar.bz2 5979006 RMD160 f10f9c63ceffc235d42906fb220f8462585b4846 SHA1 99fe285491631df4fb2841e1098799b5b4bee94d SHA256 ba97978cb851664f8675ffeea5a7591437de27dee1463fb6489ea34dd7f9083e
+DIST epiphany-2.91.6.tar.bz2 5966834 RMD160 667f8748f7c918bbd1579299407f840a577ecd04 SHA1 e4c4acce953aae1cb9514e560a390f2370a0f9ff SHA256 478b6afa8c8d7700de6bb1c70f0eb9c0a23035551670306cd2884f2feae25ada
EBUILD epiphany-2.91.5.ebuild 2068 RMD160 7b35486fb49ddb534b8617d6e5ae962e4b236137 SHA1 486389d94b31a443f173afeb7c5ab5e9ae62aa9c SHA256 cfa4b2708bfede73cac742654b09eb24e867c8920a1ebadf68eba24600d7d8df
-EBUILD epiphany-9999.ebuild 2068 RMD160 7b35486fb49ddb534b8617d6e5ae962e4b236137 SHA1 486389d94b31a443f173afeb7c5ab5e9ae62aa9c SHA256 cfa4b2708bfede73cac742654b09eb24e867c8920a1ebadf68eba24600d7d8df
+EBUILD epiphany-2.91.6.ebuild 2068 RMD160 3359069983ee9765416538303bde525d7612168c SHA1 d4a9fca94f51b69cbcc1e92ae0366fc9cab6d2cd SHA256 0c52d58a197ed132b5bc92366a40854d65cba2b35c3971cee5db85f1a28c82ea
+EBUILD epiphany-9999.ebuild 2068 RMD160 3359069983ee9765416538303bde525d7612168c SHA1 d4a9fca94f51b69cbcc1e92ae0366fc9cab6d2cd SHA256 0c52d58a197ed132b5bc92366a40854d65cba2b35c3971cee5db85f1a28c82ea
diff --git a/www-client/epiphany/epiphany-2.91.6.ebuild b/www-client/epiphany/epiphany-2.91.6.ebuild
new file mode 100644
index 00000000..47e30be2
--- /dev/null
+++ b/www-client/epiphany/epiphany-2.91.6.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-client/epiphany/epiphany-2.30.2.ebuild,v 1.1 2010/06/13 21:09:33 pacho Exp $
+
+EAPI="2"
+
+inherit eutils gnome2
+
+DESCRIPTION="GNOME webbrowser based on Webkit"
+HOMEPAGE="http://www.gnome.org/projects/epiphany/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="avahi doc +introspection networkmanager +nss test"
+if [[ ${PV} = 9999 ]]; then
+ inherit gnome2-live
+ KEYWORDS=""
+else
+ KEYWORDS="~alpha ~amd64 ~ia64 ~sparc ~x86"
+fi
+
+# XXX: Should we add seed support? Seed seems to be unmaintained now.
+RDEPEND=">=dev-libs/glib-2.25.3
+ >=x11-libs/gtk+-2.99.0:3[introspection?]
+ >=dev-libs/libxml2-2.6.12
+ >=dev-libs/libxslt-1.1.7
+ >=x11-libs/startup-notification-0.5
+ >=dev-libs/dbus-glib-0.71
+ >=app-text/iso-codes-0.35
+ >=net-libs/webkit-gtk-1.3.11:3[introspection?]
+ >=net-libs/libsoup-gnome-2.33.1
+ >=gnome-base/gnome-keyring-2.26.0
+ >=gnome-base/gsettings-desktop-schemas-0.0.1
+
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+
+ avahi? ( >=net-dns/avahi-0.6.22 )
+ introspection? ( >=dev-libs/gobject-introspection-0.9.5 )
+ networkmanager? ( net-misc/networkmanager )
+ nss? ( dev-libs/nss )
+ x11-themes/gnome-icon-theme"
+DEPEND="${RDEPEND}
+ app-text/gnome-doc-utils
+ gnome-base/gnome-common
+ >=dev-util/intltool-0.40
+ dev-util/pkgconfig
+ sys-devel/gettext
+ doc? ( >=dev-util/gtk-doc-1 )"
+
+DOCS="AUTHORS ChangeLog* HACKING MAINTAINERS NEWS README TODO"
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ --enable-shared
+ --disable-maintainer-mode
+ --disable-schemas-compile
+ --disable-scrollkeeper
+ --disable-static
+ --with-distributor-name=Gentoo
+ --with-ca-file=${ROOT}/etc/ssl/certs/ca-certificates.crt
+ $(use_enable avahi zeroconf)
+ $(use_enable introspection)
+ $(use_enable networkmanager network-manager)
+ $(use_enable nss)
+ $(use_enable test tests)"
+}
+
+src_compile() {
+ # Fix sandbox error with USE="introspection"
+ # https://bugs.webkit.org/show_bug.cgi?id=35471
+ addpredict "$(unset HOME; echo ~)/.local"
+ emake || die "Compile failed"
+}
diff --git a/www-client/epiphany/epiphany-9999.ebuild b/www-client/epiphany/epiphany-9999.ebuild
index 8f829ea8..47e30be2 100644
--- a/www-client/epiphany/epiphany-9999.ebuild
+++ b/www-client/epiphany/epiphany-9999.ebuild
@@ -27,8 +27,8 @@ RDEPEND=">=dev-libs/glib-2.25.3
>=x11-libs/startup-notification-0.5
>=dev-libs/dbus-glib-0.71
>=app-text/iso-codes-0.35
- >=net-libs/webkit-gtk-1.3.9:3[introspection?]
- >=net-libs/libsoup-gnome-2.29.91
+ >=net-libs/webkit-gtk-1.3.11:3[introspection?]
+ >=net-libs/libsoup-gnome-2.33.1
>=gnome-base/gnome-keyring-2.26.0
>=gnome-base/gsettings-desktop-schemas-0.0.1