summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/packagekit-gtk/packagekit-gtk-1.0.10.ebuild')
-rw-r--r--app-admin/packagekit-gtk/packagekit-gtk-1.0.10.ebuild63
1 files changed, 63 insertions, 0 deletions
diff --git a/app-admin/packagekit-gtk/packagekit-gtk-1.0.10.ebuild b/app-admin/packagekit-gtk/packagekit-gtk-1.0.10.ebuild
new file mode 100644
index 00000000..99f3ba45
--- /dev/null
+++ b/app-admin/packagekit-gtk/packagekit-gtk-1.0.10.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit eutils
+
+MY_PN="PackageKit"
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="Gtk3 PackageKit backend library"
+HOMEPAGE="http://www.packagekit.org/"
+SRC_URI="http://www.packagekit.org/releases/${MY_P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-libs/dbus-glib
+ media-libs/fontconfig
+ >=x11-libs/gtk+-3.0:3
+ x11-libs/pango
+ ~app-admin/packagekit-base-${PV}[introspection]
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+"
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+ econf \
+ --disable-bash-completion \
+ --disable-browser-plugin \
+ --disable-command-not-found \
+ --disable-cron \
+ --disable-gstreamer-plugin \
+ --disable-gtk-doc \
+ --disable-local \
+ --disable-man-pages \
+ --disable-networkmanager \
+ --disable-static \
+ --disable-systemd \
+ --disable-vala \
+ --enable-dummy \
+ --enable-gtk-module \
+ --enable-introspection=yes \
+ --localstatedir=/var
+}
+
+src_compile() {
+ cd "${S}"/contrib/gtk-module || die
+ emake
+}
+
+src_install() {
+ cd "${S}"/contrib/gtk-module || die
+ emake DESTDIR="${D}" install
+ prune_libtool_files --all
+}