summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/seahorse/seahorse-3.6.3.ebuild')
-rw-r--r--app-crypt/seahorse/seahorse-3.6.3.ebuild75
1 files changed, 0 insertions, 75 deletions
diff --git a/app-crypt/seahorse/seahorse-3.6.3.ebuild b/app-crypt/seahorse/seahorse-3.6.3.ebuild
deleted file mode 100644
index 73412204..00000000
--- a/app-crypt/seahorse/seahorse-3.6.3.ebuild
+++ /dev/null
@@ -1,75 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-EAPI="4"
-GCONF_DEBUG="yes"
-GNOME2_LA_PUNT="yes"
-
-inherit gnome2
-if [[ ${PV} = 9999 ]]; then
- inherit gnome2-live
-fi
-
-DESCRIPTION="A GNOME application for managing encryption keys"
-HOMEPAGE="http://www.gnome.org/projects/seahorse/index.html"
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="avahi debug ldap"
-if [[ ${PV} = 9999 ]]; then
- KEYWORDS=""
-else
- KEYWORDS="~amd64 ~x86 ~x86-fbsd"
-fi
-
-COMMON_DEPEND="
- >=app-crypt/gcr-3.3.4
- >=dev-libs/glib-2.10:2
- >=x11-libs/gtk+-3.4:3
- >=app-crypt/libsecret-0.5
- net-libs/libsoup:2.4
- x11-misc/shared-mime-info
-
- net-misc/openssh
- >=app-crypt/gpgme-1
- || (
- =app-crypt/gnupg-2.0*
- =app-crypt/gnupg-1.4* )
-
- avahi? ( >=net-dns/avahi-0.6 )
- ldap? ( net-nds/openldap )
-"
-DEPEND="${COMMON_DEPEND}
- app-text/yelp-tools
- >=dev-util/intltool-0.35
- sys-devel/gettext
- virtual/pkgconfig
-"
-# Need seahorse-plugins git snapshot
-RDEPEND="${COMMON_DEPEND}
- !<app-crypt/seahorse-plugins-2.91.0_pre20110114
-"
-
-src_prepare() {
- # FIXME: Do not mess with CFLAGS with USE="debug"
- sed -e '/CFLAGS="$CFLAGS -g/d' \
- -e '/CFLAGS="$CFLAGS -O0/d' \
- -i configure.ac configure || die "sed 1 failed"
-
- gnome2_src_prepare
-}
-
-src_configure() {
- DOCS="AUTHORS ChangeLog NEWS README TODO THANKS"
- G2CONF="${G2CONF}
- --enable-pgp
- --enable-ssh
- --enable-pkcs11
- --disable-static
- --enable-hkp
- $(use_enable avahi sharing)
- $(use_enable debug)
- $(use_enable ldap)"
- gnome2_src_configure
-}