summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'gnome-extra/seahorse-nautilus/seahorse-nautilus-9999.ebuild')
-rw-r--r--gnome-extra/seahorse-nautilus/seahorse-nautilus-9999.ebuild65
1 files changed, 0 insertions, 65 deletions
diff --git a/gnome-extra/seahorse-nautilus/seahorse-nautilus-9999.ebuild b/gnome-extra/seahorse-nautilus/seahorse-nautilus-9999.ebuild
deleted file mode 100644
index 6a0c792c..00000000
--- a/gnome-extra/seahorse-nautilus/seahorse-nautilus-9999.ebuild
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="5"
-GCONF_DEBUG="no" # --disable-debug disables all assertions
-GNOME2_LA_PUNT="yes"
-
-inherit gnome2
-if [[ ${PV} = 9999 ]]; then
- inherit gnome2-live
-fi
-
-DESCRIPTION="Nautilus extension for encrypting and decrypting files with GnuPG"
-HOMEPAGE="https://wiki.gnome.org/action/show/Apps/Seahorse"
-
-LICENSE="GPL-2"
-SLOT="0"
-if [[ ${PV} = 9999 ]]; then
- KEYWORDS=""
-else
- KEYWORDS="~amd64 ~x86"
-fi
-IUSE=""
-
-COMMON_DEPEND="
- >=app-crypt/gpgme-1.0.0
- >=app-crypt/gcr-3.4
- >=dev-libs/dbus-glib-0.35
- >=dev-libs/glib-2.28:2
- gnome-base/gnome-keyring
- >=gnome-base/nautilus-3
- x11-libs/gtk+:3
- >=x11-libs/libcryptui-3.9.90
- >=x11-libs/libnotify-0.3:=
- || (
- =app-crypt/gnupg-1.4*
- =app-crypt/gnupg-2.0* )
-"
-# seahorse-nautilus was formerly part of seahorse-plugins
-RDEPEND="${COMMON_DEPEND}
- !app-crypt/seahorse-plugins[nautilus]
-"
-DEPEND="${COMMON_DEPEND}
- >=dev-util/intltool-0.35
- virtual/pkgconfig
-"
-
-src_prepare() {
- # Do not let configure mangle CFLAGS
- sed -e '/^[ \t]*CFLAGS="$CFLAGS \(-g\|-O0\)/d' -i configure.ac configure ||
- die "sed failed"
-
- # Fix icon location, upstream bug #719763
- sed -i 's/pixmaps\/seahorse-plugins\/48x48/pixmaps\/cryptui\/48x48/' \
- tool/seahorse-notification.c || die
-
- gnome2_src_prepare
-}
-
-src_configure() {
- gnome2_src_configure \
- --disable-gpg-check \
- --enable-libnotify
-}