summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/gnome-netstatus/Manifest3
-rw-r--r--net-analyzer/gnome-netstatus/files/gnome-netstatus-2.12.1-fix-iflist.patch25
-rw-r--r--net-analyzer/gnome-netstatus/gnome-netstatus-2.26.0.ebuild43
3 files changed, 71 insertions, 0 deletions
diff --git a/net-analyzer/gnome-netstatus/Manifest b/net-analyzer/gnome-netstatus/Manifest
new file mode 100644
index 00000000..4d883893
--- /dev/null
+++ b/net-analyzer/gnome-netstatus/Manifest
@@ -0,0 +1,3 @@
+AUX gnome-netstatus-2.12.1-fix-iflist.patch 959 RMD160 524a965cc96171afdc56721273b9225621f85272 SHA1 9f310d1d918d4e0776997ded82d8c96a3d9ce761 SHA256 ba294eff55fcbe8b58a9d2e82f0f30be5e5697995fca9c6f4535c48db2858998
+DIST gnome-netstatus-2.26.0.tar.bz2 552061 RMD160 5cf01deb990c503d9691e514cc7bd3ca5d4b00f9 SHA1 53ca180d45a42b011ae6765461ae55c6a69d66af SHA256 17169ef602037ac40e5d6b43a7add0593c9fe3f04da65aa06d70c59bc6bbccd8
+EBUILD gnome-netstatus-2.26.0.ebuild 1022 RMD160 0dbdcce28c3c6fda7f6ebb9019de5abf7bf3c898 SHA1 a00fa74d1130e77ef9d641a65019e5a0cf4473d1 SHA256 d23bb31f1b5fc88271d0e68dfcbf5899fa63c757a7417641de6c597841345500
diff --git a/net-analyzer/gnome-netstatus/files/gnome-netstatus-2.12.1-fix-iflist.patch b/net-analyzer/gnome-netstatus/files/gnome-netstatus-2.12.1-fix-iflist.patch
new file mode 100644
index 00000000..b81d045e
--- /dev/null
+++ b/net-analyzer/gnome-netstatus/files/gnome-netstatus-2.12.1-fix-iflist.patch
@@ -0,0 +1,25 @@
+diff -ur a/src/netstatus-iface.c b/src/netstatus-iface.c
+--- a/src/netstatus-iface.c 2007-02-13 09:39:19.000000000 +0000
++++ b/src/netstatus-iface.c 2007-07-16 00:03:02.000000000 +0100
+@@ -1122,9 +1122,10 @@
+ }
+
+ #if !defined(HAVE_SOCKADDR_SA_LEN)
+-#define NETSTATUS_SA_LEN(saddr) (sizeof (struct sockaddr))
++#define NETSTATUS_IFREQ_LEN(ifr) (sizeof (struct ifreq))
+ #else
+-#define NETSTATUS_SA_LEN(saddr) (MAX ((saddr)->sa_len, sizeof (struct sockaddr)))
++#define NETSTATUS_IFREQ_LEN(ifr) sizeof (ifr->ifr_name) + \
++ (MAX (ifr->ifr_addr.sa_len, sizeof (struct sockaddr)))
+ #endif /* HAVE_SOCKADDR_SA_LEN */
+
+ /* Taken From R. Stevens Unix Network Programming Vol. 1.
+@@ -1220,7 +1221,7 @@
+ struct ifreq *if_req = (struct ifreq *) p;
+ gboolean loopback = FALSE;
+
+- p += sizeof (if_req->ifr_name) + NETSTATUS_SA_LEN (&if_req->ifr_addr);
++ p += NETSTATUS_IFREQ_LEN (if_req);
+
+ if (ioctl (fd, SIOCGIFFLAGS, if_req) < 0)
+ {
diff --git a/net-analyzer/gnome-netstatus/gnome-netstatus-2.26.0.ebuild b/net-analyzer/gnome-netstatus/gnome-netstatus-2.26.0.ebuild
new file mode 100644
index 00000000..88952517
--- /dev/null
+++ b/net-analyzer/gnome-netstatus/gnome-netstatus-2.26.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/gnome-netstatus/gnome-netstatus-2.12.2.ebuild,v 1.4 2009/03/11 02:24:01 dang Exp $
+EAPI=1
+
+inherit eutils gnome2
+
+DESCRIPTION="Network interface information applet"
+HOMEPAGE="http://www.gnome.org/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND="
+ =dev-lang/perl-5*
+ dev-libs/glib:2
+ >=x11-libs/gtk+-2.14
+ >=gnome-base/libglade-2
+ >=gnome-base/gnome-panel-2
+ >=gnome-base/gconf-2"
+
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.40
+ >=dev-util/pkgconfig-0.9
+ app-text/scrollkeeper
+ app-text/gnome-doc-utils"
+
+DOCS="AUTHORS ChangeLog MAINTAINERS NEWS README TODO"
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ --disable-deprecations
+ --disable-scrollkeeper"
+}
+
+src_unpack() {
+ gnome2_src_unpack
+
+ # Fix interface listing on all (known) arches; bug #183969
+ epatch "${FILESDIR}"/${PN}-2.12.1-fix-iflist.patch
+}