summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/gnome-online-accounts/Manifest11
-rw-r--r--net-libs/gnome-online-accounts/gnome-online-accounts-3.16.0.ebuild76
-rw-r--r--net-libs/gnome-online-accounts/gnome-online-accounts-9999.ebuild10
3 files changed, 91 insertions, 6 deletions
diff --git a/net-libs/gnome-online-accounts/Manifest b/net-libs/gnome-online-accounts/Manifest
new file mode 100644
index 00000000..214d926f
--- /dev/null
+++ b/net-libs/gnome-online-accounts/Manifest
@@ -0,0 +1,11 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA512
+
+DIST gnome-online-accounts-3.16.0.tar.xz 1417040 SHA256 2ca9c404c6a42aac34073087606a962f49f7986f0cc549cfe9100ac29c91ffd6 SHA512 f55653e64593af879d241a153c7e08f0d917b866a9b0911e6e3c894a6f9161cdaba6b8012eac21981d52663a89ef5d2944f2a587ee9e00898009d85d0324628b WHIRLPOOL 6301b0a04d66613816f3b2c3ad8a084a83af71751c035131bad8832d6e988b8d59a1a320426e05c14d39cc7b490d948f205dcca1fb05b834339dc5ba47aa6c8b
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v2
+
+iEYEAREKAAYFAlVOEUgACgkQ1fmVwcYIWAb5eQCdELZTZZt+jH5KqeIC7hLNb28L
+KnoAoN37hmUCZcpDBbPjBdHtTHkMGlC+
+=vpCs
+-----END PGP SIGNATURE-----
diff --git a/net-libs/gnome-online-accounts/gnome-online-accounts-3.16.0.ebuild b/net-libs/gnome-online-accounts/gnome-online-accounts-3.16.0.ebuild
new file mode 100644
index 00000000..fdd0d4e1
--- /dev/null
+++ b/net-libs/gnome-online-accounts/gnome-online-accounts-3.16.0.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="5"
+GCONF_DEBUG="yes"
+
+inherit gnome2
+
+DESCRIPTION="GNOME framework for accessing online accounts"
+HOMEPAGE="https://wiki.gnome.org/Projects/GnomeOnlineAccounts"
+
+LICENSE="LGPL-2+"
+SLOT="0/1"
+IUSE="gnome +introspection kerberos" # telepathy"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+# pango used in goaeditablelabel
+# libsoup used in goaoauthprovider
+# goa kerberos provider is incompatible with app-crypt/heimdal, see
+# https://bugzilla.gnome.org/show_bug.cgi?id=692250
+# json-glib-0.16 needed for bug #485092
+RDEPEND="
+ >=dev-libs/glib-2.35:2
+ >=app-crypt/libsecret-0.5
+ >=dev-libs/json-glib-0.16
+ dev-libs/libxml2:2
+ >=net-libs/libsoup-2.42:2.4
+ net-libs/rest:0.7
+ net-libs/telepathy-glib
+ >=net-libs/webkit-gtk-2.7.2:4
+ >=x11-libs/gtk+-3.11.1:3
+ x11-libs/pango
+
+ introspection? ( >=dev-libs/gobject-introspection-0.6.2 )
+ kerberos? (
+ app-crypt/gcr:0=
+ app-crypt/mit-krb5 )
+"
+# telepathy? ( net-libs/telepathy-glib )
+# goa-daemon can launch gnome-control-center
+PDEPEND="gnome? ( >=gnome-base/gnome-control-center-3.2[gnome-online-accounts(+)] )"
+
+DEPEND="${RDEPEND}
+ dev-libs/libxslt
+ >=dev-util/gtk-doc-am-1.3
+ >=dev-util/gdbus-codegen-2.30.0
+ >=dev-util/intltool-0.50.1
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+# Due to sub-configure
+QA_CONFIGURE_OPTIONS=".*"
+
+src_configure() {
+ # TODO: Give users a way to set the G/FB/Windows Live secrets
+ # telepathy optional support is really badly done, bug #494456
+ gnome2_src_configure \
+ --disable-static \
+ --enable-documentation \
+ --enable-exchange \
+ --enable-facebook \
+ --enable-flickr \
+ --enable-foursquare \
+ --enable-imap-smtp \
+ --enable-media-server \
+ --enable-owncloud \
+ --enable-pocket \
+ --enable-telepathy \
+ --enable-windows-live \
+ $(use_enable kerberos)
+ #$(use_enable telepathy)
+ # gudev & cheese from sub-configure is overriden
+ # by top level configure, and disabled so leave it like that
+}
diff --git a/net-libs/gnome-online-accounts/gnome-online-accounts-9999.ebuild b/net-libs/gnome-online-accounts/gnome-online-accounts-9999.ebuild
index 5a7a8426..05609467 100644
--- a/net-libs/gnome-online-accounts/gnome-online-accounts-9999.ebuild
+++ b/net-libs/gnome-online-accounts/gnome-online-accounts-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
@@ -36,7 +36,7 @@ RDEPEND="
>=net-libs/libsoup-2.42:2.4
net-libs/rest:0.7
net-libs/telepathy-glib
- >=net-libs/webkit-gtk-2.1.90:3
+ >=net-libs/webkit-gtk-2.7.2:4
>=x11-libs/gtk+-3.11.1:3
x11-libs/pango
@@ -67,17 +67,15 @@ if [[ ${PV} = 9999 ]]; then
fi
src_configure() {
- # TODO: Give users a way to set the G/Y!/FB/Twitter/Windows Live secrets
- # Twitter/Y! disabled per upstream recommendation, bug #497168
+ # TODO: Give users a way to set the G/FB/Windows Live secrets
# telepathy optional support is really badly done, bug #494456
gnome2_src_configure \
--disable-static \
- --disable-twitter \
- --disable-yahoo \
--enable-documentation \
--enable-exchange \
--enable-facebook \
--enable-flickr \
+ --enable-foursquare \
--enable-imap-smtp \
--enable-media-server \
--enable-owncloud \