summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-client')
-rw-r--r--www-client/epiphany/Manifest5
-rw-r--r--www-client/epiphany/epiphany-2.91.5.ebuild (renamed from www-client/epiphany/epiphany-2.31.5.ebuild)37
-rw-r--r--www-client/epiphany/epiphany-9999.ebuild75
3 files changed, 100 insertions, 17 deletions
diff --git a/www-client/epiphany/Manifest b/www-client/epiphany/Manifest
index e32e4d9a..115ae9c6 100644
--- a/www-client/epiphany/Manifest
+++ b/www-client/epiphany/Manifest
@@ -1,2 +1,3 @@
-DIST epiphany-2.31.5.tar.bz2 5948565 RMD160 a4d3ef6dcc096d57d7365eab980ee7e8db54f5b2 SHA1 449e95f91d32ab37a99e2a452ef6556fced08b52 SHA256 804633bcd234b8830004d5f7a17fd86c43661f30db545d07aca73276d28e7fe0
-EBUILD epiphany-2.31.5.ebuild 1850 RMD160 6ef294bf5d863edb2e3b2f681eb85b4fd4b94e23 SHA1 a83baa3086d81ea4a671d2fdb86a473222791c95 SHA256 9961aed6da5ca9aea3b6ea6cbe70931a72754b1dffefab5b38b2fe051f690885
+DIST epiphany-2.91.5.tar.bz2 5979006 RMD160 f10f9c63ceffc235d42906fb220f8462585b4846 SHA1 99fe285491631df4fb2841e1098799b5b4bee94d SHA256 ba97978cb851664f8675ffeea5a7591437de27dee1463fb6489ea34dd7f9083e
+EBUILD epiphany-2.91.5.ebuild 2068 RMD160 7b35486fb49ddb534b8617d6e5ae962e4b236137 SHA1 486389d94b31a443f173afeb7c5ab5e9ae62aa9c SHA256 cfa4b2708bfede73cac742654b09eb24e867c8920a1ebadf68eba24600d7d8df
+EBUILD epiphany-9999.ebuild 2068 RMD160 7b35486fb49ddb534b8617d6e5ae962e4b236137 SHA1 486389d94b31a443f173afeb7c5ab5e9ae62aa9c SHA256 cfa4b2708bfede73cac742654b09eb24e867c8920a1ebadf68eba24600d7d8df
diff --git a/www-client/epiphany/epiphany-2.31.5.ebuild b/www-client/epiphany/epiphany-2.91.5.ebuild
index 885e974a..8f829ea8 100644
--- a/www-client/epiphany/epiphany-2.31.5.ebuild
+++ b/www-client/epiphany/epiphany-2.91.5.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/www-client/epiphany/epiphany-2.30.2.ebuild,v 1.1 2010/06/13 21:09:33 pacho Exp $
@@ -11,48 +11,55 @@ HOMEPAGE="http://www.gnome.org/projects/epiphany/"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~ia64 ~sparc ~x86"
-
IUSE="avahi doc +introspection networkmanager +nss test"
+if [[ ${PV} = 9999 ]]; then
+ inherit gnome2-live
+ KEYWORDS=""
+else
+ KEYWORDS="~alpha ~amd64 ~ia64 ~sparc ~x86"
+fi
-# TODO: add seed support
-RDEPEND=">=dev-libs/glib-2.19.7
- >=x11-libs/gtk+-2.90.4:3[introspection?]
+# XXX: Should we add seed support? Seed seems to be unmaintained now.
+RDEPEND=">=dev-libs/glib-2.25.3
+ >=x11-libs/gtk+-2.99.0:3[introspection?]
>=dev-libs/libxml2-2.6.12
>=dev-libs/libxslt-1.1.7
>=x11-libs/startup-notification-0.5
- >=x11-libs/libnotify-0.5.1
>=dev-libs/dbus-glib-0.71
- >=gnome-base/gconf-2
>=app-text/iso-codes-0.35
- >=net-libs/webkit-gtk-1.3.2:3.0[introspection?]
- >=net-libs/libsoup-2.29.91[gnome]
+ >=net-libs/webkit-gtk-1.3.9:3[introspection?]
+ >=net-libs/libsoup-gnome-2.29.91
>=gnome-base/gnome-keyring-2.26.0
+ >=gnome-base/gsettings-desktop-schemas-0.0.1
x11-libs/libICE
x11-libs/libSM
x11-libs/libX11
avahi? ( >=net-dns/avahi-0.6.22 )
- introspection? ( >=dev-libs/gobject-introspection-0.6.7 )
+ introspection? ( >=dev-libs/gobject-introspection-0.9.5 )
networkmanager? ( net-misc/networkmanager )
nss? ( dev-libs/nss )
x11-themes/gnome-icon-theme"
DEPEND="${RDEPEND}
- >=dev-util/pkgconfig-0.9
+ app-text/gnome-doc-utils
+ gnome-base/gnome-common
>=dev-util/intltool-0.40
- >=app-text/gnome-doc-utils-0.3.2
+ dev-util/pkgconfig
sys-devel/gettext
- gnome-base/gnome-common
doc? ( >=dev-util/gtk-doc-1 )"
DOCS="AUTHORS ChangeLog* HACKING MAINTAINERS NEWS README TODO"
pkg_setup() {
G2CONF="${G2CONF}
- --disable-scrollkeeper
+ --enable-shared
--disable-maintainer-mode
+ --disable-schemas-compile
+ --disable-scrollkeeper
+ --disable-static
--with-distributor-name=Gentoo
+ --with-ca-file=${ROOT}/etc/ssl/certs/ca-certificates.crt
$(use_enable avahi zeroconf)
$(use_enable introspection)
$(use_enable networkmanager network-manager)
diff --git a/www-client/epiphany/epiphany-9999.ebuild b/www-client/epiphany/epiphany-9999.ebuild
new file mode 100644
index 00000000..8f829ea8
--- /dev/null
+++ b/www-client/epiphany/epiphany-9999.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-client/epiphany/epiphany-2.30.2.ebuild,v 1.1 2010/06/13 21:09:33 pacho Exp $
+
+EAPI="2"
+
+inherit eutils gnome2
+
+DESCRIPTION="GNOME webbrowser based on Webkit"
+HOMEPAGE="http://www.gnome.org/projects/epiphany/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="avahi doc +introspection networkmanager +nss test"
+if [[ ${PV} = 9999 ]]; then
+ inherit gnome2-live
+ KEYWORDS=""
+else
+ KEYWORDS="~alpha ~amd64 ~ia64 ~sparc ~x86"
+fi
+
+# XXX: Should we add seed support? Seed seems to be unmaintained now.
+RDEPEND=">=dev-libs/glib-2.25.3
+ >=x11-libs/gtk+-2.99.0:3[introspection?]
+ >=dev-libs/libxml2-2.6.12
+ >=dev-libs/libxslt-1.1.7
+ >=x11-libs/startup-notification-0.5
+ >=dev-libs/dbus-glib-0.71
+ >=app-text/iso-codes-0.35
+ >=net-libs/webkit-gtk-1.3.9:3[introspection?]
+ >=net-libs/libsoup-gnome-2.29.91
+ >=gnome-base/gnome-keyring-2.26.0
+ >=gnome-base/gsettings-desktop-schemas-0.0.1
+
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+
+ avahi? ( >=net-dns/avahi-0.6.22 )
+ introspection? ( >=dev-libs/gobject-introspection-0.9.5 )
+ networkmanager? ( net-misc/networkmanager )
+ nss? ( dev-libs/nss )
+ x11-themes/gnome-icon-theme"
+DEPEND="${RDEPEND}
+ app-text/gnome-doc-utils
+ gnome-base/gnome-common
+ >=dev-util/intltool-0.40
+ dev-util/pkgconfig
+ sys-devel/gettext
+ doc? ( >=dev-util/gtk-doc-1 )"
+
+DOCS="AUTHORS ChangeLog* HACKING MAINTAINERS NEWS README TODO"
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ --enable-shared
+ --disable-maintainer-mode
+ --disable-schemas-compile
+ --disable-scrollkeeper
+ --disable-static
+ --with-distributor-name=Gentoo
+ --with-ca-file=${ROOT}/etc/ssl/certs/ca-certificates.crt
+ $(use_enable avahi zeroconf)
+ $(use_enable introspection)
+ $(use_enable networkmanager network-manager)
+ $(use_enable nss)
+ $(use_enable test tests)"
+}
+
+src_compile() {
+ # Fix sandbox error with USE="introspection"
+ # https://bugs.webkit.org/show_bug.cgi?id=35471
+ addpredict "$(unset HOME; echo ~)/.local"
+ emake || die "Compile failed"
+}