summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-client')
-rw-r--r--www-client/epiphany/Manifest12
-rw-r--r--www-client/epiphany/epiphany-3.7.91.ebuild (renamed from www-client/epiphany/epiphany-3.10.0.ebuild)32
-rw-r--r--www-client/epiphany/epiphany-9999.ebuild36
3 files changed, 34 insertions, 46 deletions
diff --git a/www-client/epiphany/Manifest b/www-client/epiphany/Manifest
index 471a7fd4..7a951635 100644
--- a/www-client/epiphany/Manifest
+++ b/www-client/epiphany/Manifest
@@ -1,11 +1 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA512
-
-DIST epiphany-3.10.0.tar.xz 3085076 SHA256 7bd2c3b21464a83909d75befe2f9501c1ab2f00e2371f26023f79818faec351e SHA512 26a5afca461db4a05824ae44d66032387e1777480a9a78f38b202a3f99396db016e440183f978aa1184d9f6cd4a645793b6d214facf3b5c7cca740bda91a71a7 WHIRLPOOL 073df0f1d2149493a2d16cd8d57608657fffadd73749e6a1ad31ec077f9e6302c3cc09ba8f1c6d441c2125ed2e77389fb38fd6f4425f789ea84e1e9dc28a2435
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v2.0.21 (GNU/Linux)
-
-iEYEAREKAAYFAlJbGGwACgkQ1fmVwcYIWAZplQCgvOxSAkMVZndctn53QaKEZQJ/
-0mUAn38nG8pBCwUtO011LK1hzDCbcoDW
-=mqhI
------END PGP SIGNATURE-----
+DIST epiphany-3.7.91.tar.xz 2482380 SHA256 52f09d84c813206d6721681d37a05c50f028e734e8c52b606508669071a32b86 SHA512 1821011184d6a98c1d6f3ef240e5463b10289609b2eca647bfee71a9b43961cba4da70790f3e0d42b5c7d2fb759bbb9c225b582530b29880fae93a3b81fdff30 WHIRLPOOL 0f108f72992c805554335abb61467108c8bdb7b43cc89ef86132d29f5a99594978330bbc56f39f2dc3c7a31ba831efb47a9a7b7f1883247221e27fdfe5e6dfdd
diff --git a/www-client/epiphany/epiphany-3.10.0.ebuild b/www-client/epiphany/epiphany-3.7.91.ebuild
index 74dd4215..0d22fc44 100644
--- a/www-client/epiphany/epiphany-3.10.0.ebuild
+++ b/www-client/epiphany/epiphany-3.7.91.ebuild
@@ -4,9 +4,11 @@
EAPI="5"
GCONF_DEBUG="yes"
-GNOME2_LA_PUNT="yes"
-inherit eutils gnome2 pax-utils versionator virtualx
+inherit autotools eutils gnome2 pax-utils versionator virtualx
+if [[ ${PV} = 9999 ]]; then
+ inherit gnome2-live
+fi
DESCRIPTION="GNOME webbrowser based on Webkit"
HOMEPAGE="http://projects.gnome.org/epiphany/"
@@ -14,26 +16,30 @@ HOMEPAGE="http://projects.gnome.org/epiphany/"
# TODO: coverage
LICENSE="GPL-2"
SLOT="0"
-IUSE="+jit +nss test"
-KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="+nss test"
+if [[ ${PV} = 9999 ]]; then
+ KEYWORDS=""
+else
+ KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+fi
RDEPEND="
- >=app-crypt/gcr-3.5.5
>=app-crypt/libsecret-0.14
+ >=app-crypt/gcr-3.5.5
>=app-text/iso-codes-0.35
>=dev-libs/glib-2.35.6:2
>=dev-libs/libxml2-2.6.12:2
>=dev-libs/libxslt-1.1.7
>=gnome-base/gsettings-desktop-schemas-0.0.1
- >=net-dns/avahi-0.6.22[dbus]
- >=net-libs/webkit-gtk-2.1.4:3[jit?]
- >=net-libs/libsoup-2.42.1:2.4
- >=x11-libs/gtk+-3.9.12:3
+ >=net-dns/avahi-0.6.22
+ >=net-libs/webkit-gtk-1.11.5:3
+ >=net-libs/libsoup-2.41.3:2.4
+ >=x11-libs/gtk+-3.7.10:3
>=x11-libs/libnotify-0.5.1:=
gnome-base/gnome-desktop:3=
dev-db/sqlite:3
- x11-libs/libwnck:3
+ x11-libs/libwnck
x11-libs/libX11
x11-themes/gnome-icon-theme
@@ -55,9 +61,8 @@ src_configure() {
--enable-shared \
--disable-static \
--with-distributor-name=Gentoo \
- $(use_enable nss) \
- $(use_enable test tests) \
- ITSTOOL=$(type -P true)
+ $(use_enable nss)
+ $(use_enable test tests)
}
src_compile() {
@@ -76,5 +81,4 @@ src_test() {
src_install() {
DOCS="AUTHORS ChangeLog* HACKING MAINTAINERS NEWS README TODO"
gnome2_src_install
- use jit && pax-mark m "${ED}usr/bin/epiphany"
}
diff --git a/www-client/epiphany/epiphany-9999.ebuild b/www-client/epiphany/epiphany-9999.ebuild
index 1c6bd509..7e6cdeb7 100644
--- a/www-client/epiphany/epiphany-9999.ebuild
+++ b/www-client/epiphany/epiphany-9999.ebuild
@@ -4,9 +4,8 @@
EAPI="5"
GCONF_DEBUG="yes"
-GNOME2_LA_PUNT="yes"
-inherit eutils gnome2 pax-utils versionator virtualx
+inherit autotools eutils gnome2 pax-utils versionator virtualx
if [[ ${PV} = 9999 ]]; then
inherit gnome2-live
fi
@@ -17,7 +16,7 @@ HOMEPAGE="http://projects.gnome.org/epiphany/"
# TODO: coverage
LICENSE="GPL-2"
SLOT="0"
-IUSE="+jit +nss test"
+IUSE="+nss test"
if [[ ${PV} = 9999 ]]; then
KEYWORDS=""
else
@@ -26,21 +25,21 @@ fi
RDEPEND="
>=app-crypt/gcr-3.5.5
- >=app-crypt/libsecret-0.14
>=app-text/iso-codes-0.35
>=dev-libs/glib-2.35.6:2
>=dev-libs/libxml2-2.6.12:2
>=dev-libs/libxslt-1.1.7
+ >=gnome-base/gnome-keyring-2.26.0
>=gnome-base/gsettings-desktop-schemas-0.0.1
- >=net-dns/avahi-0.6.22[dbus]
- >=net-libs/webkit-gtk-2.1.4:3[jit?]
- >=net-libs/libsoup-2.42.1:2.4
- >=x11-libs/gtk+-3.9.12:3
+ >=net-dns/avahi-0.6.22
+ >=net-libs/webkit-gtk-1.11.5:3
+ >=net-libs/libsoup-2.41.3:2.4
+ >=x11-libs/gtk+-3.5.4:3
>=x11-libs/libnotify-0.5.1:=
gnome-base/gnome-desktop:3=
dev-db/sqlite:3
- x11-libs/libwnck:3
+ x11-libs/libwnck
x11-libs/libX11
x11-themes/gnome-icon-theme
@@ -56,20 +55,15 @@ DEPEND="${RDEPEND}
sys-devel/gettext
virtual/pkgconfig
"
-if [[ ${PV} == 9999 ]]; then
- DEPEND="${DEPEND} app-text/yelp-tools"
-fi
src_configure() {
- local myconf=""
- [[ ${PV} != 9999 ]] && myconf="ITSTOOL=$(type -P true)"
- gnome2_src_configure \
- --enable-shared \
- --disable-static \
- --with-distributor-name=Gentoo \
- $(use_enable nss) \
- $(use_enable test tests) \
- ${myconf}
+ G2CONF="${G2CONF}
+ --enable-shared
+ --disable-static
+ --with-distributor-name=Gentoo
+ $(use_enable nss)
+ $(use_enable test tests)"
+ gnome2_src_configure
}
src_compile() {