summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-libs/gtksourceview/gtksourceview-3.12.0.ebuild')
-rw-r--r--x11-libs/gtksourceview/gtksourceview-3.12.0.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/x11-libs/gtksourceview/gtksourceview-3.12.0.ebuild b/x11-libs/gtksourceview/gtksourceview-3.12.0.ebuild
new file mode 100644
index 00000000..708853c9
--- /dev/null
+++ b/x11-libs/gtksourceview/gtksourceview-3.12.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="5"
+GCONF_DEBUG="no"
+
+inherit gnome2 virtualx
+
+DESCRIPTION="A text widget implementing syntax highlighting and other features"
+HOMEPAGE="http://projects.gnome.org/gtksourceview/"
+
+LICENSE="GPL-2+ LGPL-2.1+"
+SLOT="3.0/2"
+IUSE="glade +introspection"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-solaris"
+
+# Note: has native OSX support, prefix teams, attack!
+RDEPEND="
+ >=dev-libs/glib-2.37.3:2
+ >=dev-libs/libxml2-2.6:2
+ >=x11-libs/gtk+-3.11:3[introspection?]
+ glade? ( >=dev-util/glade-3.9:3.10 )
+ introspection? ( >=dev-libs/gobject-introspection-0.9.0 )
+"
+DEPEND="${RDEPEND}
+ dev-util/gtk-doc-am
+ >=dev-util/intltool-0.50
+ >=sys-devel/gettext-0.17
+ virtual/pkgconfig
+"
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-deprecations \
+ --enable-providers \
+ $(use_enable glade glade-catalog) \
+ $(use_enable introspection)
+}
+
+src_test() {
+ Xemake check
+}
+
+src_install() {
+ DOCS="AUTHORS HACKING MAINTAINERS NEWS README"
+ gnome2_src_install
+
+ insinto /usr/share/${PN}-3.0/language-specs
+ doins "${FILESDIR}"/2.0/gentoo.lang
+}