summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-terms/gnome-terminal/gnome-terminal-9999.ebuild')
-rw-r--r--x11-terms/gnome-terminal/gnome-terminal-9999.ebuild77
1 files changed, 0 insertions, 77 deletions
diff --git a/x11-terms/gnome-terminal/gnome-terminal-9999.ebuild b/x11-terms/gnome-terminal/gnome-terminal-9999.ebuild
deleted file mode 100644
index d253183a..00000000
--- a/x11-terms/gnome-terminal/gnome-terminal-9999.ebuild
+++ /dev/null
@@ -1,77 +0,0 @@
-# Copyright 1999-2018 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="6"
-GNOME2_LA_PUNT="yes"
-
-inherit gnome2 readme.gentoo-r1
-if [[ ${PV} = 9999 ]]; then
- inherit gnome2-live
-fi
-
-DESCRIPTION="The Gnome Terminal"
-HOMEPAGE="https://wiki.gnome.org/Apps/Terminal/"
-
-LICENSE="GPL-3+"
-SLOT="0"
-IUSE="debug +gnome-shell +nautilus"
-if [[ ${PV} != 9999 ]]; then
- KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
-fi
-
-# FIXME: automagic dependency on gtk+[X], just transitive but needs proper control, bug 624960
-RDEPEND="
- >=dev-libs/glib-2.42:2
- >=x11-libs/gtk+-3.20:3
- >=x11-libs/vte-0.54.1:2.91
- >=dev-libs/libpcre2-10
- >=gnome-base/dconf-0.14
- >=gnome-base/gsettings-desktop-schemas-0.1.0
- sys-apps/util-linux
- gnome-shell? ( gnome-base/gnome-shell )
- nautilus? ( >=gnome-base/nautilus-3 )
-"
-# itstool required for help/* with non-en LINGUAS, see bug #549358
-# xmllint required for glib-compile-resources, see bug #549304
-DEPEND="${RDEPEND}
- dev-libs/libxml2:2
- dev-util/gdbus-codegen
- dev-util/glib-utils
- >=dev-util/intltool-0.50
- dev-util/itstool
- sys-devel/gettext
- virtual/pkgconfig
-"
-
-DOC_CONTENTS="To get previous working directory inherited in new opened tab, or
- notifications of long-running commands finishing, you will need
- to add the following line to your ~/.bashrc:\n
- . /etc/profile.d/vte-2.91.sh"
-
-src_configure() {
- local myconf=""
-
- if [[ ${PV} != 9999 ]]; then
- myconf="${myconf}
- VALAC=$(type -P true)
- "
- fi
-
- gnome2_src_configure \
- --disable-static \
- $(use_enable debug) \
- $(use_enable gnome-shell search-provider) \
- $(use_with nautilus nautilus-extension) \
- ${myconf}
-}
-
-src_install() {
- DOCS="AUTHORS ChangeLog HACKING NEWS"
- gnome2_src_install
- readme.gentoo_create_doc
-}
-
-pkg_postinst() {
- gnome2_pkg_postinst
- readme.gentoo_print_elog
-}