aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2015-06-30 22:15:35 -0400
committerAnthony G. Basile <blueness@gentoo.org>2015-06-30 22:15:35 -0400
commit8885d6a5b9035f2eb0c02e697dc0bfb45c8b5a7f (patch)
tree165b052003e580934854a5e9da1182cde1312d62 /setup.py
downloadgrss-8885d6a5b9035f2eb0c02e697dc0bfb45c8b5a7f.tar.gz
grss-8885d6a5b9035f2eb0c02e697dc0bfb45c8b5a7f.tar.bz2
grss-8885d6a5b9035f2eb0c02e697dc0bfb45c8b5a7f.zip
Initial commit.
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py22
1 files changed, 22 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100755
index 0000000..e5934a8
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,22 @@
+#!/usr/bin/env python
+
+from distutils.core import setup
+
+setup(
+ name = 'grs',
+ version = '0.1',
+ description = 'Gentoo Release System Suite',
+ long_description =
+ """
+ The Gentoo Reference System (GRS) Suite is a set of utilities for producing
+ and maintaining identical Gentoo systems from a series of configuration files
+ housed on a central git repository.
+ """,
+ url = 'https://wiki.gentoo.org/wiki/Project:Gentoo_Release_System',
+ author = 'Anthony G. Basile',
+ author_email = 'blueness@gentoo.org',
+ license = 'GNU General Public License, Version 2',
+ packages = ['grs'],
+ scripts = ['grsrun', 'grsup', 'clean-worldconf', 'install-worldconf'],
+ data_files = [('/etc/grs', ['systems.conf'])]
+)