aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/libtirpc/libtirpc-0.2.5-r99.ebuild')
-rw-r--r--net-libs/libtirpc/libtirpc-0.2.5-r99.ebuild74
1 files changed, 0 insertions, 74 deletions
diff --git a/net-libs/libtirpc/libtirpc-0.2.5-r99.ebuild b/net-libs/libtirpc/libtirpc-0.2.5-r99.ebuild
deleted file mode 100644
index 74341b7f..00000000
--- a/net-libs/libtirpc/libtirpc-0.2.5-r99.ebuild
+++ /dev/null
@@ -1,74 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libtirpc/libtirpc-0.2.5.ebuild,v 1.4 2014/12/30 18:09:41 maekke Exp $
-
-EAPI="4"
-
-inherit multilib-minimal toolchain-funcs autotools
-
-DESCRIPTION="Transport Independent RPC library (SunRPC replacement)"
-HOMEPAGE="http://libtirpc.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2
- mirror://gentoo/${PN}-glibc-nfs.tar.xz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 arm ~mips ppc x86"
-IUSE="ipv6 kerberos static-libs"
-
-RDEPEND="kerberos? ( >=virtual/krb5-0-r1[${MULTILIB_USEDEP}] )"
-DEPEND="${RDEPEND}
- app-arch/xz-utils
- >=virtual/pkgconfig-0-r1[${MULTILIB_USEDEP}]"
-RDEPEND="${RDEPEND}
- abi_x86_32? (
- !<=app-emulation/emul-linux-x86-baselibs-20140508-r7
- !app-emulation/emul-linux-x86-baselibs[-abi_x86_32(-)]
- )"
-
-src_unpack() {
- unpack ${A}
- cp -r tirpc "${S}"/ || die
-}
-
-src_prepare() {
- epatch "${FILESDIR}"/${P}-stdarg.patch
- epatch "${FILESDIR}"/0001-Provide-getrpcbynumber-and-getrpcbyname-if-those-are.patch
- epatch "${FILESDIR}"/0002-Misc-header-fixes.patch
- epatch "${FILESDIR}"/0003-fix_cdefs_h_include.patch
- epatch "${FILESDIR}"/0004-fix_DECLS.patch
- epatch "${FILESDIR}"/0005-fix_remaining_issues.patch
- epatch "${FILESDIR}"/0006-fix_queue_h_include.patch
- epatch "${FILESDIR}"/0007-no-des.patch
- eautoconf
- eautoreconf
-}
-
-multilib_src_configure() {
- ECONF_SOURCE=${S} \
- econf \
- $(use_enable ipv6) \
- $(use_enable kerberos gssapi) \
- $(use_enable static-libs static)
-}
-
-multilib_src_install() {
- default
-
- # libtirpc replaces rpc support in glibc, so we need it in /
- multilib_is_native_abi && gen_usr_ldscript -a tirpc
-}
-
-multilib_src_install_all() {
- einstalldocs
-
- insinto /etc
- doins doc/netconfig
-
- insinto /usr/include/tirpc
- doins -r "${WORKDIR}"/tirpc/*
-
- # makes sure that the linking order for nfs-utils is proper, as
- # libtool would inject a libgssglue dependency in the list.
- use static-libs || prune_libtool_files
-}