aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2016-04-29 10:29:53 +0100
committerJames Le Cuirot <chewi@gentoo.org>2016-04-29 10:29:53 +0100
commit9a43a57c066770fe2159d99b0328919eebbb7ca7 (patch)
tree661cc8fe6a16b630303457ddfeb9a903004528ab
parentdev-java/lwjgl: Version bump to 2.9.3, fix bug #560018 (diff)
downloadjava-9a43a57c066770fe2159d99b0328919eebbb7ca7.tar.gz
java-9a43a57c066770fe2159d99b0328919eebbb7ca7.tar.bz2
java-9a43a57c066770fe2159d99b0328919eebbb7ca7.zip
dev-java/asm: Remove the overlay copy, 4.0 RC1 isn't needed any more
-rw-r--r--dev-java/asm/Manifest1
-rw-r--r--dev-java/asm/asm-4.0_rc1.ebuild38
-rw-r--r--dev-java/asm/metadata.xml21
3 files changed, 0 insertions, 60 deletions
diff --git a/dev-java/asm/Manifest b/dev-java/asm/Manifest
deleted file mode 100644
index 17df8bc4..00000000
--- a/dev-java/asm/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST asm-4.0_RC1.tar.gz 865772 SHA256 a3c43ea927383afddca710a5ee4954d928cf79eceab62f24f3aed45ead71965b
diff --git a/dev-java/asm/asm-4.0_rc1.ebuild b/dev-java/asm/asm-4.0_rc1.ebuild
deleted file mode 100644
index 78f87aea..00000000
--- a/dev-java/asm/asm-4.0_rc1.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-MY_P="${PN}-${PV/rc/RC}"
-JAVA_PKG_IUSE="doc source"
-
-inherit java-pkg-2 java-ant-2
-
-DESCRIPTION="Bytecode manipulation framework for Java"
-HOMEPAGE="http://asm.ow2.org"
-SRC_URI="http://download.forge.objectweb.org/${PN}/${MY_P}.tar.gz"
-LICENSE="BSD"
-SLOT="3.999" # 4rc1 is valid but breaks our Java stuff.
-IUSE=""
-KEYWORDS="~amd64 ~x86"
-
-DEPEND=">=virtual/jdk-1.5"
-RDEPEND=">=virtual/jre-1.5"
-
-# Needs dependencies we don't have yet.
-RESTRICT="test"
-
-S="${WORKDIR}/${MY_P}"
-EANT_DOC_TARGET="jdoc"
-
-# Fails if this objectweb.ant.tasks.path is not set.
-# Java generics seem to break unless product.noshrink is set.
-EANT_EXTRA_ARGS="-Dobjectweb.ant.tasks.path=foobar -Dproduct.noshrink=true"
-
-src_install() {
- for x in output/dist/lib/*.jar ; do
- java-pkg_newjar "${x}" $(basename "${x%-*}.jar")
- done
-
- use doc && java-pkg_dojavadoc output/dist/doc/javadoc/user/
- use source && java-pkg_dosrc src/*
-}
diff --git a/dev-java/asm/metadata.xml b/dev-java/asm/metadata.xml
deleted file mode 100644
index 22a45186..00000000
--- a/dev-java/asm/metadata.xml
+++ /dev/null
@@ -1,21 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-
-<pkgmetadata>
-<herd>java</herd>
-
-<longdescription>
-ASM is a Java bytecode manipulation framework. It can be used to
-dynamically generate stub classes or other proxy classes, directly in
-binary form, or to dynamically modify classes at load time, i.e., just
-before they are loaded into the Java Virtual Machine.
-
-ASM offers similar functionalities as BCEL or SERP, but is much more
-smaller (25KB instead of 350KB for BCEL and 150KB for SERP) and faster
-than these tools (the overhead of a load time class transformation is of
-the order of 60% with ASM, 700% or more with BCEL, and 1100% or more
-with SERP). Indeed ASM was designed to be used in a dynamic way* and was
-therefore designed and implemented to be as small and as fast as
-possible.
-</longdescription>
-</pkgmetadata>