aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-java/icedtea-web/icedtea-web-1.2.ebuild')
-rw-r--r--dev-java/icedtea-web/icedtea-web-1.2.ebuild23
1 files changed, 3 insertions, 20 deletions
diff --git a/dev-java/icedtea-web/icedtea-web-1.2.ebuild b/dev-java/icedtea-web/icedtea-web-1.2.ebuild
index b2666c3e..ceda08f7 100644
--- a/dev-java/icedtea-web/icedtea-web-1.2.ebuild
+++ b/dev-java/icedtea-web/icedtea-web-1.2.ebuild
@@ -26,28 +26,11 @@ DEPEND="${RDEPEND}
>=net-libs/xulrunner-1.9.1 ) )
test? ( >=dev-java/junit-4.8:4 )"
-# a bit of hack so the VM switching is triggered without causing dependency troubles
-JAVA_PKG_NV_DEPEND=">=virtual/jdk-1.6"
-JAVA_PKG_WANT_SOURCE="1.6"
-JAVA_PKG_WANT_TARGET="1.6"
-
pkg_setup() {
- [[ "${MERGE_TYPE}" == "binary" ]] && return # bug 258423
-
- # quite a hack since java-config does not provide a way for a package
- # to limit supported VM's for building and their preferred order
- if [[ -n "${JAVA_PKG_FORCE_VM}" ]]; then
- einfo "Honoring user-set JAVA_PKG_FORCE_VM"
- else
- # migration logic
- if [[ -L /usr/lib/jvm/icedtea${SLOT} ]]; then
- JAVA_PKG_FORCE_VM="icedtea${SLOT}"
- else
- JAVA_PKG_FORCE_VM="icedtea-${SLOT}"
- fi
- fi
+ JAVA_PKG_WANT_BUILD_VM="icedtea-6 icedtea-6"
+ JAVA_PKG_WANT_SOURCE="1.6"
+ JAVA_PKG_WANT_TARGET="1.6"
- einfo "Forced vm ${JAVA_PKG_FORCE_VM}"
java-vm-2_pkg_setup
java-pkg-2_pkg_setup
}