aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-java/icedtea/icedtea-7.2.7.0_pre05.ebuild')
-rw-r--r--dev-java/icedtea/icedtea-7.2.7.0_pre05.ebuild15
1 files changed, 8 insertions, 7 deletions
diff --git a/dev-java/icedtea/icedtea-7.2.7.0_pre05.ebuild b/dev-java/icedtea/icedtea-7.2.7.0_pre05.ebuild
index d1b397c3..7559d6b4 100644
--- a/dev-java/icedtea/icedtea-7.2.7.0_pre05.ebuild
+++ b/dev-java/icedtea/icedtea-7.2.7.0_pre05.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
# Build written by Andrew John Hughes (gnu_andrew@member.fsf.org)
@@ -7,7 +7,7 @@
# * IF YOU CHANGE THIS EBUILD, CHANGE ICEDTEA-6.* AS WELL *
# *********************************************************
-EAPI="5"
+EAPI="6"
SLOT="7"
inherit autotools check-reqs gnome2-utils java-pkg-2 java-vm-2 mercurial multiprocessing pax-utils prefix versionator virtualx
@@ -193,17 +193,18 @@ src_unpack() {
mercurial_src_unpack
}
-java_prepare() {
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
# For bootstrap builds as the sandbox control file might not yet exist.
addpredict /proc/self/coredump_filter
# icedtea doesn't like some locales. #330433 #389717
export LANG="C" LC_ALL="C"
- eautoreconf
-}
-
-src_configure() {
local cacao_config config hotspot_port jamvm_config use_cacao use_jamvm use_zero zero_config
local vm=$(java-pkg_get-current-vm)