summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-08-16 18:00:39 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-08-16 18:00:39 +0200
commit2cbfeabe27292baa58182c30840aad8afb2943bb (patch)
tree2505a51eaf401e718458549feb8a779a5d408491
parentkde-plasma/kephal: Fix build in GCC 6 (diff)
downloadkde-sunset-2cbfeabe.tar.gz
kde-sunset-2cbfeabe.tar.bz2
kde-sunset-2cbfeabe.zip
kde-plasma/kwin: Fix build in GCC 6
Thanks-to: Stas Cymbalov <dummyunit@gmail.com> Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--kde-plasma/kwin/files/kwin-4.11.22-gcc6.patch11
-rw-r--r--kde-plasma/kwin/kwin-4.11.22.ebuild6
2 files changed, 16 insertions, 1 deletions
diff --git a/kde-plasma/kwin/files/kwin-4.11.22-gcc6.patch b/kde-plasma/kwin/files/kwin-4.11.22-gcc6.patch
new file mode 100644
index 00000000..60bd08a0
--- /dev/null
+++ b/kde-plasma/kwin/files/kwin-4.11.22-gcc6.patch
@@ -0,0 +1,11 @@
+--- a/kwin/glxbackend.cpp
++++ b/kwin/glxbackend.cpp
+@@ -45,7 +45,7 @@
+ , window(None)
+ , fbconfig(NULL)
+ , glxWindow(None)
+- , ctx(None)
++ , ctx(NULL)
+ , m_bufferAge(0)
+ , haveSwapInterval(false)
+ {
diff --git a/kde-plasma/kwin/kwin-4.11.22.ebuild b/kde-plasma/kwin/kwin-4.11.22.ebuild
index b11d168b..c691ead5 100644
--- a/kde-plasma/kwin/kwin-4.11.22.ebuild
+++ b/kde-plasma/kwin/kwin-4.11.22.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -56,6 +56,10 @@ KMEXTRACTONLY="
libs/oxygen/
"
+PATCHES=(
+ "${FILESDIR}/${P}-gcc6.patch"
+)
+
# you need one of these
REQUIRED_USE="!opengl? ( gles ) !gles? ( opengl ) wayland? ( gles )"