summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2018-03-28 21:45:42 +0200
committerJohannes Huber <johu@gentoo.org>2018-03-28 21:45:42 +0200
commit6eb1ac22a9ef48b9f8d2bb33a35be62baa9bf22c (patch)
tree1aa31c532c7e8618d755c05551bb8e313c7dba74
parentkde-base/kde1-kdebase: New package (diff)
downloadkde-sunset-6eb1ac22.tar.gz
kde-sunset-6eb1ac22.tar.bz2
kde-sunset-6eb1ac22.zip
app-i18n/kcm-fcitx: New package
Import from gentoo main tree. Bug: https://bugs.gentoo.org/635072 Package-Manager: Portage-2.3.26, Repoman-2.3.7
-rw-r--r--app-i18n/kcm-fcitx/Manifest1
-rw-r--r--app-i18n/kcm-fcitx/kcm-fcitx-0.4.3.ebuild47
-rw-r--r--app-i18n/kcm-fcitx/kcm-fcitx-4.4.9999.ebuild47
-rw-r--r--app-i18n/kcm-fcitx/metadata.xml15
4 files changed, 110 insertions, 0 deletions
diff --git a/app-i18n/kcm-fcitx/Manifest b/app-i18n/kcm-fcitx/Manifest
new file mode 100644
index 00000000..b5f4c5a8
--- /dev/null
+++ b/app-i18n/kcm-fcitx/Manifest
@@ -0,0 +1 @@
+DIST kcm-fcitx-0.4.3.tar.xz 56864 BLAKE2B 29fd64075273b08f4bf36d7f5c63b3548dbbb5ad408f0e48920b6665c7389c408aa3d4b3a88d9299bd29b26fcf06562a21dd739444a444ed4d7bfb56edf3715a SHA512 d311699a5d99f75d353899b7fba0a950491ee8b891724b855033449900ec4b3db9408bb1b80e60ceb0dbb0ce91072162062261a497f83a2a683214b71c3f4713
diff --git a/app-i18n/kcm-fcitx/kcm-fcitx-0.4.3.ebuild b/app-i18n/kcm-fcitx/kcm-fcitx-0.4.3.ebuild
new file mode 100644
index 00000000..63d4b476
--- /dev/null
+++ b/app-i18n/kcm-fcitx/kcm-fcitx-0.4.3.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit cmake-utils
+
+if [[ "${PV}" =~ (^|\.)9999$ ]]; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/fcitx/kcm-fcitx"
+ EGIT_BRANCH="kde4"
+fi
+
+DESCRIPTION="KDE configuration module for Fcitx"
+HOMEPAGE="https://fcitx-im.org/ https://github.com/fcitx/kcm-fcitx"
+if [[ "${PV}" =~ (^|\.)9999$ ]]; then
+ SRC_URI=""
+else
+ SRC_URI="https://download.fcitx-im.org/${PN}/${P}.tar.xz"
+fi
+
+LICENSE="GPL-2+"
+SLOT="4-plasma4"
+KEYWORDS="~amd64 ~x86"
+IUSE="minimal"
+
+RDEPEND=">=app-i18n/fcitx-4.2.9:4[qt4]
+ dev-qt/qtcore:4
+ dev-qt/qtdbus:4
+ dev-qt/qtgui:4
+ kde-frameworks/kdelibs:4
+ virtual/libintl
+ x11-libs/libX11
+ x11-libs/libxkbfile"
+DEPEND="${RDEPEND}
+ dev-util/automoc
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+src_prepare() {
+ if use minimal; then
+ cmake_comment_add_subdirectory layout po
+ fi
+
+ cmake-utils_src_prepare
+}
diff --git a/app-i18n/kcm-fcitx/kcm-fcitx-4.4.9999.ebuild b/app-i18n/kcm-fcitx/kcm-fcitx-4.4.9999.ebuild
new file mode 100644
index 00000000..3f695d98
--- /dev/null
+++ b/app-i18n/kcm-fcitx/kcm-fcitx-4.4.9999.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit cmake-utils
+
+if [[ "${PV}" =~ (^|\.)9999$ ]]; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/fcitx/kcm-fcitx"
+ EGIT_BRANCH="kde4"
+fi
+
+DESCRIPTION="KDE configuration module for Fcitx"
+HOMEPAGE="https://fcitx-im.org/ https://github.com/fcitx/kcm-fcitx"
+if [[ "${PV}" =~ (^|\.)9999$ ]]; then
+ SRC_URI=""
+else
+ SRC_URI="https://download.fcitx-im.org/${PN}/${P}.tar.xz"
+fi
+
+LICENSE="GPL-2+"
+SLOT="4-plasma4"
+KEYWORDS=""
+IUSE="minimal"
+
+RDEPEND=">=app-i18n/fcitx-4.2.9:4[qt4]
+ dev-qt/qtcore:4
+ dev-qt/qtdbus:4
+ dev-qt/qtgui:4
+ kde-frameworks/kdelibs:4
+ virtual/libintl
+ x11-libs/libX11
+ x11-libs/libxkbfile"
+DEPEND="${RDEPEND}
+ dev-util/automoc
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+src_prepare() {
+ if use minimal; then
+ cmake_comment_add_subdirectory layout po
+ fi
+
+ cmake-utils_src_prepare
+}
diff --git a/app-i18n/kcm-fcitx/metadata.xml b/app-i18n/kcm-fcitx/metadata.xml
new file mode 100644
index 00000000..68e05235
--- /dev/null
+++ b/app-i18n/kcm-fcitx/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>arfrever.fta@gmail.com</email>
+ <name>Arfrever Frehtes Taifersar Arahesis</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>cjk@gentoo.org</email>
+ <name>Cjk</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">fcitx/kcm-fcitx</remote-id>
+ </upstream>
+</pkgmetadata>