summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-08-24 19:19:25 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-08-25 16:59:24 +0200
commit836b930445ea412ad2b2672291dc30861a38b010 (patch)
tree07d1d742c0879102a2ca46078c224381d99e6948
parentkde-apps/kig: Switch to PYTHON_MULTI_USEDEP API (diff)
downloadkde-sunset-836b9304.tar.gz
kde-sunset-836b9304.tar.bz2
kde-sunset-836b9304.zip
kde-apps/dolphin-plugins: Drop IUSE=bazaar for missing dev-vcs/bzr
Package was last-rited in Gentoo ebuild repo and eclass as well. Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--kde-apps/dolphin-plugins/dolphin-plugins-4.14.3.ebuild9
-rw-r--r--kde-apps/dolphin-plugins/metadata.xml1
2 files changed, 4 insertions, 6 deletions
diff --git a/kde-apps/dolphin-plugins/dolphin-plugins-4.14.3.ebuild b/kde-apps/dolphin-plugins/dolphin-plugins-4.14.3.ebuild
index f3dbd9b2..8862a49f 100644
--- a/kde-apps/dolphin-plugins/dolphin-plugins-4.14.3.ebuild
+++ b/kde-apps/dolphin-plugins/dolphin-plugins-4.14.3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -7,25 +7,24 @@ inherit kde4-base
DESCRIPTION="Extra Dolphin plugins"
KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
-IUSE="debug bazaar git mercurial subversion"
+IUSE="debug git mercurial subversion"
DEPEND="
$(add_kdeapps_dep libkonq)
"
RDEPEND="${DEPEND}
$(add_kdeapps_dep kompare)
- bazaar? ( dev-vcs/bzr )
git? ( dev-vcs/git )
mercurial? ( dev-vcs/mercurial )
subversion? ( dev-vcs/subversion )
"
src_install() {
- { use bazaar || use git || use mercurial || use subversion; } && kde4-base_src_install
+ { use git || use mercurial || use subversion; } && kde4-base_src_install
}
pkg_postinst() {
- if ! use bazaar && ! use git && ! use mercurial && ! use subversion ; then
+ if ! use git && ! use mercurial && ! use subversion ; then
einfo
einfo "You have disabled all plugin use flags. If you want to have vcs"
einfo "integration in dolphin, enable those of your needs."
diff --git a/kde-apps/dolphin-plugins/metadata.xml b/kde-apps/dolphin-plugins/metadata.xml
index 34d0cdf6..ebb817ee 100644
--- a/kde-apps/dolphin-plugins/metadata.xml
+++ b/kde-apps/dolphin-plugins/metadata.xml
@@ -3,7 +3,6 @@
<pkgmetadata>
<!-- maintainer-needed -->
<use>
- <flag name="bazaar">Enable support for the bazaar VCS</flag>
<flag name="git">Enable support for the git VCS</flag>
<flag name="mercurial">Enable support for the mercurial VCS</flag>
</use>