summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-08-15 00:53:56 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-08-16 17:52:07 +0200
commitb2f91a1beb33b1cd30f0791faefd2660231dc48d (patch)
tree780ad0d1c5100869ebdf448ebe8f1bd56ad8eef3
parentdev-libs/qjson: Import from Gentoo ebuild repo before last-rites (diff)
downloadkde-sunset-b2f91a1b.tar.gz
kde-sunset-b2f91a1b.tar.bz2
kde-sunset-b2f91a1b.zip
dev-libs/qoauth: Import from Gentoo ebuild repo before last-rites
Required by kde-plasma/kdeplasma-addons. Package-Manager: Portage-3.0.2, Repoman-2.3.23 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--dev-libs/qoauth/Manifest1
-rw-r--r--dev-libs/qoauth/metadata.xml5
-rw-r--r--dev-libs/qoauth/qoauth-1.0.1.ebuild68
3 files changed, 74 insertions, 0 deletions
diff --git a/dev-libs/qoauth/Manifest b/dev-libs/qoauth/Manifest
new file mode 100644
index 00000000..5afefcc3
--- /dev/null
+++ b/dev-libs/qoauth/Manifest
@@ -0,0 +1 @@
+DIST qoauth-1.0.1-src.tar.bz2 42298 BLAKE2B f524a0ab873578e0699ba62b8ca26a9eaa432e981bc4123f145da5436867dac39947724ad4590fb2a8c4b1e9f57d75bf31c691f01217ee9bcb17ec10554c28c1 SHA512 86869c82e6efd490888f3bb16cba5bb014821e35507d3d396a84f5112a2d0bd7cb1251ba5dff82a8913eeae77a0feeebfdf4a7d1e9870023fb3c106d603c3dd8
diff --git a/dev-libs/qoauth/metadata.xml b/dev-libs/qoauth/metadata.xml
new file mode 100644
index 00000000..6f49eba8
--- /dev/null
+++ b/dev-libs/qoauth/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<!-- maintainer-needed -->
+</pkgmetadata>
diff --git a/dev-libs/qoauth/qoauth-1.0.1.ebuild b/dev-libs/qoauth/qoauth-1.0.1.ebuild
new file mode 100644
index 00000000..d3209406
--- /dev/null
+++ b/dev-libs/qoauth/qoauth-1.0.1.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=4
+
+inherit qt4-r2
+
+DESCRIPTION="A Qt-based library for OAuth support"
+HOMEPAGE="https://github.com/ayoy/qoauth/wiki"
+SRC_URI="http://files.ayoy.net/qoauth/release/${PV}/src/${P}-src.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 ppc ~ppc64 x86"
+IUSE="debug doc static-libs test"
+
+COMMON_DEPEND="app-crypt/qca:2[debug?,qt4(+)]"
+DEPEND="${COMMON_DEPEND}
+ doc? ( app-doc/doxygen )
+ test? ( dev-qt/qttest:4 )
+"
+RDEPEND="${COMMON_DEPEND}
+ app-crypt/qca:2[ssl]
+"
+
+S=${WORKDIR}/${P}-src
+
+DOCS="README CHANGELOG"
+PATCHES=(
+ # disable functional tests that require network connection
+ # and rely on 3rd party external server (bug #341267)
+ "${FILESDIR}/${P}-disable-ft.patch"
+)
+
+src_prepare() {
+ qt4-r2_src_prepare
+
+ if ! use test; then
+ sed -i -e '/SUBDIRS/s/tests//' ${PN}.pro || die "sed failed"
+ fi
+
+ sed -i -e '/^ *docs \\$/d' \
+ -e '/^ *build_all \\$/d' \
+ -e 's/^\#\(!macx\)/\1/' \
+ src/src.pro || die "sed failed"
+
+ sed -i -e "s/\(.*\)lib$/\1$(get_libdir)/" src/pcfile.sh || die "sed failed"
+}
+
+src_compile() {
+ default
+ if use static-libs; then
+ emake -C src static
+ fi
+}
+
+src_install() {
+ qt4-r2_src_install
+
+ if use static-libs; then
+ dolib.a "${S}"/lib/lib${PN}.a
+ fi
+
+ if use doc; then
+ doxygen "${S}"/Doxyfile || die "failed to generate documentation"
+ dohtml "${S}"/doc/html/*
+ fi
+}