summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-07-21 16:46:17 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-08-16 17:52:05 +0200
commitb52e7e4890781e173d915c1872c551001a1d5fe0 (patch)
treecc4441ca8baa39264e3bd5ceb1334d8fcb8e9253
parentmedia-libs/qimageblitz: Import from Gentoo ebuild repo before last-rites (diff)
downloadkde-sunset-b52e7e4890781e173d915c1872c551001a1d5fe0.tar.gz
kde-sunset-b52e7e4890781e173d915c1872c551001a1d5fe0.tar.bz2
kde-sunset-b52e7e4890781e173d915c1872c551001a1d5fe0.zip
media-libs/qimageblitz: Fix build with >=dev-util/cmake-3.15
Closes: https://bugs.gentoo.org/690360 Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--media-libs/qimageblitz/files/qimageblitz-0.0.6_p20131029-cxx11.patch11
-rw-r--r--media-libs/qimageblitz/qimageblitz-0.0.6_p20131029.ebuild5
2 files changed, 15 insertions, 1 deletions
diff --git a/media-libs/qimageblitz/files/qimageblitz-0.0.6_p20131029-cxx11.patch b/media-libs/qimageblitz/files/qimageblitz-0.0.6_p20131029-cxx11.patch
new file mode 100644
index 00000000..da962cd1
--- /dev/null
+++ b/media-libs/qimageblitz/files/qimageblitz-0.0.6_p20131029-cxx11.patch
@@ -0,0 +1,11 @@
+--- a/CMakeLists.txt 2017-03-15 00:31:04.000000000 +0100
++++ b/CMakeLists.txt 2019-07-21 16:39:14.365729343 +0200
+@@ -14,6 +14,8 @@
+ set(CMAKE_AUTOMOC ON)
+ find_package(Qt5Core REQUIRED)
+ find_package(Qt5Gui REQUIRED)
++ set (CMAKE_CXX_STANDARD 11)
++ set (CMAKE_CXX_EXTENSIONS OFF)
+ else()
+ find_package(Qt4 REQUIRED)
+ # properly set up compile flags (QT_DEBUG/QT_NO_DEBUG, ...)
diff --git a/media-libs/qimageblitz/qimageblitz-0.0.6_p20131029.ebuild b/media-libs/qimageblitz/qimageblitz-0.0.6_p20131029.ebuild
index 96e5ffaa..2b488b7f 100644
--- a/media-libs/qimageblitz/qimageblitz-0.0.6_p20131029.ebuild
+++ b/media-libs/qimageblitz/qimageblitz-0.0.6_p20131029.ebuild
@@ -27,7 +27,10 @@ DEPEND="
"
RDEPEND="${DEPEND}"
-PATCHES=( "${FILESDIR}/${P}-gcc.patch" )
+PATCHES=(
+ "${FILESDIR}/${P}-gcc.patch"
+ "${FILESDIR}/${P}-cxx11.patch" # bug 690360
+)
src_configure() {
local mycmakeargs=(