summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-08-24 21:10:08 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-08-25 17:48:40 +0200
commitcd7d2ed73a9ef3c7c2834f274c799c6a727d63c2 (patch)
tree768580e1eca8d94df989ffdf80485809d153f5b9
parentkde-plasma/ksshaskpass: Switch SRC_URI to GitHub (diff)
downloadkde-sunset-cd7d2ed7.tar.gz
kde-sunset-cd7d2ed7.tar.bz2
kde-sunset-cd7d2ed7.zip
kde-apps/kde4-l10n: Migrate to L10N
Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--kde-apps/kde4-l10n/kde4-l10n-4.11.2.ebuild24
1 files changed, 10 insertions, 14 deletions
diff --git a/kde-apps/kde4-l10n/kde4-l10n-4.11.2.ebuild b/kde-apps/kde4-l10n/kde4-l10n-4.11.2.ebuild
index e89cdac9..5b6321b7 100644
--- a/kde-apps/kde4-l10n/kde4-l10n-4.11.2.ebuild
+++ b/kde-apps/kde4-l10n/kde4-l10n-4.11.2.ebuild
@@ -1,6 +1,5 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kde-l10n/kde-l10n-4.11.2.ebuild,v 1.5 2013/12/11 20:26:53 ago Exp $
EAPI=5
@@ -15,20 +14,19 @@ DEPEND="
RDEPEND="!<kde-apps/konq-plugins-4.6:4"
KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
-IUSE="+handbook"
# /usr/portage/distfiles $ ls -1 kde-l10n-*-${PV}.* |sed -e 's:-${PV}.tar.xz::' -e 's:kde-l10n-::' |tr '\n' ' '
MY_LANGS="ar bg bs ca ca@valencia cs da de el en_GB es et eu fa fi fr ga gl he
hi hr hu ia is it ja kk km ko lt lv mr nb nds nl nn pa pl pt pt_BR ro ru sk sl
sr sv tg tr ug uk vi wa zh_CN zh_TW"
-URI_BASE="${SRC_URI/-${PV}.tar.xz/}"
-URI_BASE="${URI_BASE/${PN}/kde-l10n}"
+IUSE="+handbook $(printf 'l10n_%s ' ${MY_LANGS//[@_]/-})"
+
+URI_BASE="mirror://kde/Attic/4.11.2/src/kde-l10n"
SRC_URI=""
for MY_LANG in ${MY_LANGS} ; do
- IUSE="${IUSE} linguas_${MY_LANG}"
- SRC_URI="${SRC_URI} linguas_${MY_LANG}? ( ${URI_BASE}/kde-l10n-${MY_LANG}-${PV}.tar.xz )"
+ SRC_URI="${SRC_URI} l10n_${MY_LANG/[@_]/-}? ( ${URI_BASE}/kde-l10n-${MY_LANG}-${PV}.tar.xz )"
done
S="${WORKDIR}"
@@ -37,21 +35,19 @@ src_unpack() {
local LNG DIR
if [[ -z ${A} ]]; then
elog
- elog "You either have the LINGUAS variable unset, or it only"
- elog "contains languages not supported by ${P}."
- elog "You won't have any additional language support."
+ elog "None of the requested L10N are supported by ${P}."
elog
elog "${P} supports these language codes:"
- elog "${MY_LANGS}"
+ elog "${MY_LANGS//[@_]/-}"
elog
fi
[[ -n ${A} ]] && unpack ${A}
cd "${S}"
- # add all linguas to cmake
+ # add all l10n to cmake
if [[ -n ${A} ]]; then
- for LNG in ${LINGUAS}; do
+ for LNG in ${MY_LANGS}; do
DIR="kde-l10n-${LNG}-${PV}"
if [[ -d "${DIR}" ]] ; then
echo "add_subdirectory( ${DIR} )" >> "${S}"/CMakeLists.txt
@@ -67,7 +63,7 @@ src_prepare() {
-exec sed -i -e 's:^ *add_subdirectory( *kdepim *):# no kdepim:g' {} +
# bug 481106, please remove in 4.11.1 and later
- use linguas_pl && rm "${S}"/kde-l10n-pl-${PV}/messages/kde-runtime/{accountwizard*,akonadi_*}.po
+ use l10n_pl && rm "${S}"/kde-l10n-pl-${PV}/messages/kde-runtime/{accountwizard*,akonadi_*}.po
kde4-base_src_prepare
}