summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-08-16 18:00:28 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-08-16 18:00:28 +0200
commitd8ba7e6785d6fbdcbb9a766af55af87fcbb1fef2 (patch)
tree8261841a701126e27294fe469dcb269a38ef0bf2
parentapp-pda/libopensync-plugin-kdepim: Drop obsolete and bump the rest to EAPI-6 (diff)
downloadkde-sunset-d8ba7e67.tar.gz
kde-sunset-d8ba7e67.tar.bz2
kde-sunset-d8ba7e67.zip
kde-plasma/kephal: Fix build in GCC 6
Thanks-to: Stas Cymbalov <dummyunit@gmail.com> Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--kde-plasma/kephal/files/kephal-4.11.22-gcc6.patch11
-rw-r--r--kde-plasma/kephal/kephal-4.11.22.ebuild6
2 files changed, 16 insertions, 1 deletions
diff --git a/kde-plasma/kephal/files/kephal-4.11.22-gcc6.patch b/kde-plasma/kephal/files/kephal-4.11.22-gcc6.patch
new file mode 100644
index 00000000..26f6c577
--- /dev/null
+++ b/kde-plasma/kephal/files/kephal-4.11.22-gcc6.patch
@@ -0,0 +1,11 @@
+--- a/libs/kephal/service/xrandr12/randroutput.cpp
++++ b/libs/kephal/service/xrandr12/randroutput.cpp
+@@ -230,7 +230,7 @@
+ RandRMode RandROutput::mode() const
+ {
+ if (!isConnected())
+- return None;
++ return RandRMode();
+
+ if (!m_crtc)
+ return RandRMode();
diff --git a/kde-plasma/kephal/kephal-4.11.22.ebuild b/kde-plasma/kephal/kephal-4.11.22.ebuild
index 90937cbe..48ffda15 100644
--- a/kde-plasma/kephal/kephal-4.11.22.ebuild
+++ b/kde-plasma/kephal/kephal-4.11.22.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -22,3 +22,7 @@ DEPEND="${RDEPEND}
KMEXTRACTONLY+="
kephal/kephal/screens.h
"
+
+PATCHES=(
+ "${FILESDIR}/${P}-gcc6.patch"
+)