summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-12-06 02:17:32 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2020-12-06 10:04:25 +0100
commitcdac754622644f2442f315e67df973b1cdad9d3f (patch)
tree1be3b64cb3bee86048ce932144031c05fbc1fbeb /media-libs
parentqmake-utils.eclass: Drop EAPI-[01234] support (diff)
downloadkde-sunset-cdac754622644f2442f315e67df973b1cdad9d3f.tar.gz
kde-sunset-cdac754622644f2442f315e67df973b1cdad9d3f.tar.bz2
kde-sunset-cdac754622644f2442f315e67df973b1cdad9d3f.zip
media-libs/phonon: Import 4.10.2 (SLOT="0-qt4") from before last-rites
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/phonon/Manifest1
-rw-r--r--media-libs/phonon/phonon-4.10.2.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/media-libs/phonon/Manifest b/media-libs/phonon/Manifest
index 7d4d727a..1f0dd513 100644
--- a/media-libs/phonon/Manifest
+++ b/media-libs/phonon/Manifest
@@ -1 +1,2 @@
+DIST phonon-4.10.2.tar.xz 322176 BLAKE2B a73fa78e732ba56745e0791559a1ab195e9a5d867d368935ebc779cc1705a405dfd8302f6b5d92678098da8b6fdb52ec4cc2d553c361c3fefc738d502e3c38b6 SHA512 205c2f41691ed37a2b24aa5e900f7720ba024d2046ea4bf0a9b9c46235ffd72dfb4010287ccf753b13e395f84c2a202cbb76454806de3519faf52c3ac7001c4e
DIST phonon-4.9.1.tar.xz 321872 BLAKE2B a315189f578ad71e241ebfbea1bc6c81f06cf041b2eb2914d66f82f35c69c3811d16dbf4303551aafdd1a63d6ff6da619b06a6f03274a9867393f6d032348673 SHA512 a1741765071a625d9b9073d9ad1571b91cf5bfce2223bd1b034828d02dc52624587a6ec5352f3702df79f6e4201007596843fbcb9f15c9b489a858200787d728
diff --git a/media-libs/phonon/phonon-4.10.2.ebuild b/media-libs/phonon/phonon-4.10.2.ebuild
new file mode 100644
index 00000000..c3965937
--- /dev/null
+++ b/media-libs/phonon/phonon-4.10.2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+CMAKE_ECLASS=cmake
+inherit cmake-multilib qmake-utils
+
+DESCRIPTION="KDE multimedia API"
+HOMEPAGE="https://community.kde.org/Phonon"
+SRC_URI="mirror://kde/stable/phonon/${PV}/${P}.tar.xz"
+
+LICENSE="|| ( LGPL-2.1 LGPL-3 )"
+SLOT="0-qt4"
+KEYWORDS="amd64 ~arm ~ppc ~ppc64 x86"
+IUSE="debug designer gstreamer pulseaudio +vlc"
+
+DEPEND="
+ !!dev-qt/qtphonon:4
+ >=dev-qt/qtcore-4.8.7-r2:4[${MULTILIB_USEDEP}]
+ >=dev-qt/qtdbus-4.8.7:4[${MULTILIB_USEDEP}]
+ >=dev-qt/qtgui-4.8.7:4[${MULTILIB_USEDEP}]
+ designer? ( >=dev-qt/designer-4.8.7:4[${MULTILIB_USEDEP}] )
+ pulseaudio? (
+ dev-libs/glib:2
+ >=media-sound/pulseaudio-0.9.21[glib]
+ )
+"
+RDEPEND="${DEPEND}
+ !<media-libs/phonon-4.11:0
+"
+BDEPEND="virtual/pkgconfig"
+PDEPEND="
+ gstreamer? ( media-libs/phonon-gstreamer:0-qt4 )
+ vlc? ( media-libs/phonon-vlc:0-qt4 )
+"
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DPHONON_BUILD_PHONON4QT5=OFF
+ -DWITH_QZeitgeist=OFF
+ -DPHONON_INSTALL_QT_EXTENSIONS_INTO_SYSTEM_QT=ON
+ -DPHONON_BUILD_DESIGNER_PLUGIN=$(usex designer)
+ -DWITH_GLIB2=$(usex pulseaudio)
+ -DWITH_PulseAudio=$(usex pulseaudio)
+ -DQT_QMAKE_EXECUTABLE="$(qt4_get_bindir)"/qmake
+ )
+ cmake_src_configure
+}