summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-apps/kate/kate-4.14.3.ebuild')
-rw-r--r--kde-apps/kate/kate-4.14.3.ebuild26
1 files changed, 5 insertions, 21 deletions
diff --git a/kde-apps/kate/kate-4.14.3.ebuild b/kde-apps/kate/kate-4.14.3.ebuild
index 612794df..18c92cf4 100644
--- a/kde-apps/kate/kate-4.14.3.ebuild
+++ b/kde-apps/kate/kate-4.14.3.ebuild
@@ -1,29 +1,22 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
+
KDE_HANDBOOK="optional"
KMNAME="kate"
-PYTHON_COMPAT=( python{2_7,3_3,3_4} )
-
-inherit python-single-r1 kde4-meta kde4-functions-extra
+inherit kde4-meta kde4-functions-extra
DESCRIPTION="Kate is an MDI texteditor"
HOMEPAGE="https://www.kde.org/applications/utilities/kate http://kate-editor.org"
KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
-IUSE="debug python"
-
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+IUSE="debug"
DEPEND="
$(add_kdeframeworks_dep kactivities '' 4.13)
dev-libs/libxml2
dev-libs/libxslt
dev-libs/qjson
- python? (
- ${PYTHON_DEPS}
- $(add_kdeapps_dep pykde4 "${PYTHON_USEDEP}" 4.9.2-r1)
- )
"
RDEPEND="${DEPEND}
$(add_kdeapps_dep katepart)
@@ -34,16 +27,9 @@ KMEXTRA="
addons/plasma
"
-pkg_setup() {
- if use python; then
- python-single-r1_pkg_setup
- fi
- kde4-meta_pkg_setup
-}
-
src_configure() {
local mycmakeargs=(
- $(cmake-utils_use_build python pate)
+ -DBUILD_pate=OFF
)
kde4-meta_src_configure
@@ -53,9 +39,7 @@ pkg_postinst() {
kde4-meta_pkg_postinst
if ! has_version kde-apps/kaddressbook:${SLOT}; then
- echo
elog "File templates plugin requires kde-apps/kaddressbook:${SLOT}."
elog "Please install it if you plan to use this plugin."
- echo
fi
}