summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-apps/kget/kget-4.14.3.ebuild')
-rw-r--r--kde-apps/kget/kget-4.14.3.ebuild9
1 files changed, 4 insertions, 5 deletions
diff --git a/kde-apps/kget/kget-4.14.3.ebuild b/kde-apps/kget/kget-4.14.3.ebuild
index 3466941d..a74b6706 100644
--- a/kde-apps/kget/kget-4.14.3.ebuild
+++ b/kde-apps/kget/kget-4.14.3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -9,17 +9,16 @@ inherit kde4-base kde4-functions-extra
DESCRIPTION="An advanced download manager for KDE"
HOMEPAGE="https://www.kde.org/applications/internet/kget/"
KEYWORDS="amd64 ~arm ~ppc ~ppc64 x86 ~amd64-linux ~x86-linux"
-IUSE="debug bittorrent gpg mms sqlite webkit"
+IUSE="debug bittorrent gpg mms sqlite"
RDEPEND="
app-crypt/qca:2[qt4]
$(add_kdeapps_dep libkonq)
$(add_kdeplasma_dep libkworkspace '' 4.11)
- bittorrent? ( >=net-libs/libktorrent-1.0.3 )
+ bittorrent? ( >=net-libs/libktorrent-1.0.3:4 )
gpg? ( $(add_kdeapps_dep kdepimlibs) )
mms? ( media-libs/libmms )
sqlite? ( dev-db/sqlite:3 )
- webkit? ( >=kde-misc/kwebkitpart-0.9.6:4 )
"
DEPEND="${RDEPEND}
dev-libs/boost
@@ -29,11 +28,11 @@ src_configure() {
local mycmakeargs=(
-DWITH_NepomukCore=OFF
-DWITH_NepomukWidgets=OFF
+ -DWITH_KWebKitPart=OFF
$(cmake-utils_use_with bittorrent KTorrent)
$(cmake-utils_use_with gpg QGpgme)
$(cmake-utils_use_with mms LibMms)
$(cmake-utils_use_with sqlite)
- $(cmake-utils_use_with webkit KWebKitPart)
)
kde4-base_src_configure
}