aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2016-04-12 19:41:38 +0200
committerJohannes Huber <johu@gentoo.org>2016-04-12 19:41:38 +0200
commit01c937900910b60d2c59095de0aab41511bb7555 (patch)
tree39222327c84c5cbcac1ed544718eeaee85d494c3
parentkde-apps/kig: DEPEND on kde-frameworks/ktexteditor (diff)
downloadkde-01c937900910b60d2c59095de0aab41511bb7555.tar.gz
kde-01c937900910b60d2c59095de0aab41511bb7555.tar.bz2
kde-01c937900910b60d2c59095de0aab41511bb7555.zip
media-sound/amarok: Fix build with USE -embedded
By adding upstreamed patch from Matt Whitlock <gentoo@mattwhitlock.name>. Gentoo-bug: 566980 Package-Manager: portage-2.2.28
-rw-r--r--media-sound/amarok/amarok-2.8.90.ebuild5
-rw-r--r--media-sound/amarok/files/amarok-2.8.90-mysql-embedded.patch34
2 files changed, 38 insertions, 1 deletions
diff --git a/media-sound/amarok/amarok-2.8.90.ebuild b/media-sound/amarok/amarok-2.8.90.ebuild
index d9f98714fc..4db4e9724a 100644
--- a/media-sound/amarok/amarok-2.8.90.ebuild
+++ b/media-sound/amarok/amarok-2.8.90.ebuild
@@ -72,7 +72,10 @@ RDEPEND="${COMMONDEPEND}
$(add_kdeapps_dep phonon-kde)
"
-PATCHES=( "${FILESDIR}/${PN}-2.8.0-taglib110.patch" )
+PATCHES=(
+ "${FILESDIR}/${PN}-2.8.0-taglib110.patch"
+ "${FILESDIR}/${P}-mysql-embedded.patch"
+)
src_configure() {
# Append minimal-toc cflag for ppc64, see bug 280552 and 292707
diff --git a/media-sound/amarok/files/amarok-2.8.90-mysql-embedded.patch b/media-sound/amarok/files/amarok-2.8.90-mysql-embedded.patch
new file mode 100644
index 0000000000..b03aa1897c
--- /dev/null
+++ b/media-sound/amarok/files/amarok-2.8.90-mysql-embedded.patch
@@ -0,0 +1,34 @@
+From 048ca3d57228759f05af7b9553200fd362aeaa8b Mon Sep 17 00:00:00 2001
+From: Matt Whitlock <kde@mattwhitlock.name>
+Date: Tue, 29 Mar 2016 12:22:41 -0400
+Subject: [PATCH] Only link with MYSQL_EMBEDDED_LIBRARIES if
+ WITH_MYSQL_EMBEDDED
+
+REVIEW: 127523
+---
+ src/core-impl/collections/db/sql/mysqlcollection/CMakeLists.txt | 5 ++++-
+ 1 file changed, 4 insertions(+), 1 deletion(-)
+
+diff --git a/src/core-impl/collections/db/sql/mysqlcollection/CMakeLists.txt b/src/core-impl/collections/db/sql/mysqlcollection/CMakeLists.txt
+index 244cde1..4c618fc 100644
+--- a/src/core-impl/collections/db/sql/mysqlcollection/CMakeLists.txt
++++ b/src/core-impl/collections/db/sql/mysqlcollection/CMakeLists.txt
+@@ -21,11 +21,14 @@ target_link_libraries(amarok_collection-mysqlcollection
+ ${KDE4_KDECORE_LIBS}
+ ${QT_QTCORE_LIBRARY}
+ ${QT_QTGUI_LIBRARY}
+- ${MYSQL_EMBEDDED_LIBRARIES}
+ ${CMAKE_DL_LIBS}
+ ${ZLIB_LIBRARIES}
+ )
+
++if(WITH_MYSQL_EMBEDDED)
++ target_link_libraries( amarok_collection-mysqlcollection ${MYSQL_EMBEDDED_LIBRARIES} )
++endif(WITH_MYSQL_EMBEDDED)
++
+ if(NOT WIN32 AND NOT APPLE)
+ target_link_libraries( amarok_collection-mysqlcollection crypt pthread )
+ endif(NOT WIN32 AND NOT APPLE)
+--
+2.8.1
+