aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <andreas.sturmlechner@gmail.com>2016-04-26 20:10:38 +0200
committerJohannes Huber <johu@gentoo.org>2016-04-27 09:45:06 +0200
commit0a153dd2b6875b48e8558081e9efe0c387c5c78a (patch)
tree76bca7f931f29eef46d002a0affc9226d7e24ee4
parentprofiles: Mask zanshin for akonadi dependency (diff)
downloadkde-0a153dd2.tar.gz
kde-0a153dd2.tar.bz2
kde-0a153dd2.zip
kde-misc/zanshin: Version bump to 0.4.0, fix deps
Package-Manager: portage-2.2.28 Signed-off-by: Johannes Huber <johu@gentoo.org>
-rw-r--r--kde-misc/zanshin/Manifest1
-rw-r--r--kde-misc/zanshin/zanshin-0.4.0.ebuild59
-rw-r--r--kde-misc/zanshin/zanshin-9999.ebuild9
3 files changed, 67 insertions, 2 deletions
diff --git a/kde-misc/zanshin/Manifest b/kde-misc/zanshin/Manifest
new file mode 100644
index 0000000000..3cfccd1f09
--- /dev/null
+++ b/kde-misc/zanshin/Manifest
@@ -0,0 +1 @@
+DIST zanshin-0.4.0.tar.bz2 366156 SHA256 1cf0a46632ec9c6c2e556133aef80d1f76ea27dbba447ce0eb367e857d0d0756 SHA512 94c4931d59b78392117b5bc3259badec7fe3b472f3029c88d2d983391ef771365c1357802e7b77403e52760eede7e11e6e8438bab07fb82b963175e1923e8f08 WHIRLPOOL 174999b04d99741a44ab29fa92eeba07d62f3490a5a385f4ad7cadac2a31a414d032c95ef56f3542a091831ba0a8ea440bb81a589fe12cb9b8fe044b52fa0593
diff --git a/kde-misc/zanshin/zanshin-0.4.0.ebuild b/kde-misc/zanshin/zanshin-0.4.0.ebuild
new file mode 100644
index 0000000000..e9be325aba
--- /dev/null
+++ b/kde-misc/zanshin/zanshin-0.4.0.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+CMAKE_MIN_VERSION="3.2.0"
+KDE_TEST="forceoptional"
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="Getting things done application by KDE"
+HOMEPAGE="https://zanshin.kde.org/"
+[[ ${KDE_BUILD_TYPE} != live ]] && SRC_URI="http://files.kde.org/zanshin/${P}.tar.bz2"
+
+LICENSE="|| ( GPL-2 GPL-3 )"
+KEYWORDS="~amd64"
+IUSE=""
+
+# FIXME: bundles libkdepim
+COMMON_DEPEND="
+ $(add_frameworks_dep kcodecs)
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdelibs4support)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kitemmodels)
+ $(add_frameworks_dep kitemviews)
+ $(add_frameworks_dep kjobwidgets)
+ $(add_frameworks_dep kparts)
+ $(add_frameworks_dep krunner)
+ $(add_frameworks_dep kwallet)
+ $(add_frameworks_dep kxmlgui)
+ $(add_kdeapps_dep akonadi)
+ $(add_kdeapps_dep akonadi-calendar)
+ $(add_kdeapps_dep akonadi-notes)
+ $(add_kdeapps_dep akonadi-search)
+ $(add_kdeapps_dep kcalcore)
+ $(add_kdeapps_dep kcontacts)
+ $(add_kdeapps_dep kidentitymanagement)
+ $(add_kdeapps_dep kldap)
+ $(add_kdeapps_dep kmime)
+ $(add_kdeapps_dep kontactinterface)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtdeclarative)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtnetwork)
+ $(add_qt_dep qtwidgets)
+ dev-libs/boost
+"
+DEPEND="${COMMON_DEPEND}
+ test? ( $(add_kdeapps_dep akonadi 'tools') )
+"
+RDEPEND="${COMMON_DEPEND}
+ !kde-misc/zanshin:4
+"
diff --git a/kde-misc/zanshin/zanshin-9999.ebuild b/kde-misc/zanshin/zanshin-9999.ebuild
index 959946c7c0..4fb9039c63 100644
--- a/kde-misc/zanshin/zanshin-9999.ebuild
+++ b/kde-misc/zanshin/zanshin-9999.ebuild
@@ -11,13 +11,14 @@ inherit kde5
DESCRIPTION="Getting things done application by KDE"
HOMEPAGE="https://zanshin.kde.org/"
+[[ ${KDE_BUILD_TYPE} != live ]] && SRC_URI="http://files.kde.org/zanshin/${P}.tar.bz2"
LICENSE="|| ( GPL-2 GPL-3 )"
KEYWORDS=""
IUSE=""
# FIXME: bundles libkdepim
-RDEPEND="
+COMMON_DEPEND="
$(add_frameworks_dep kcodecs)
$(add_frameworks_dep kcompletion)
$(add_frameworks_dep kconfig)
@@ -42,6 +43,7 @@ RDEPEND="
$(add_kdeapps_dep kidentitymanagement)
$(add_kdeapps_dep kldap)
$(add_kdeapps_dep kmime)
+ $(add_kdeapps_dep kontactinterface)
$(add_qt_dep qtdbus)
$(add_qt_dep qtdeclarative)
$(add_qt_dep qtgui)
@@ -49,6 +51,9 @@ RDEPEND="
$(add_qt_dep qtwidgets)
dev-libs/boost
"
-DEPEND="${RDEPEND}
+DEPEND="${COMMON_DEPEND}
+ test? ( $(add_kdeapps_dep akonadi 'tools') )
+"
+RDEPEND="${COMMON_DEPEND}
!kde-misc/zanshin:4
"