aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2015-08-27 20:36:48 +1000
committerMichael Palimaka <kensington@gentoo.org>2015-08-27 20:37:59 +1000
commit0d1e5903c0fc404a9d7a78aa98353b716c5dfbf2 (patch)
tree1ec894d3f4e61359b1e80504e69d8d33296645de
parentkde-frameworks/kdeclarative: Drop revert patch (diff)
downloadkde-0d1e5903.tar.gz
kde-0d1e5903.tar.bz2
kde-0d1e5903.zip
kde-apps/dolphin: backport patch from upstream to fix bogus deps.
Package-Manager: portage-2.2.20.1
-rw-r--r--kde-apps/dolphin/dolphin-15.08.0.ebuild2
-rw-r--r--kde-apps/dolphin/dolphin-15.08.49.9999.ebuild2
-rw-r--r--kde-apps/dolphin/files/dolphin-15.08.0-deps.patch48
3 files changed, 52 insertions, 0 deletions
diff --git a/kde-apps/dolphin/dolphin-15.08.0.ebuild b/kde-apps/dolphin/dolphin-15.08.0.ebuild
index 6dabf46ee3..a00333ce83 100644
--- a/kde-apps/dolphin/dolphin-15.08.0.ebuild
+++ b/kde-apps/dolphin/dolphin-15.08.0.ebuild
@@ -64,6 +64,8 @@ RDEPEND="${DEPEND}
RESTRICT="test"
+PATCHES=( "${FILESDIR}/${PN}-15.08.0-deps.patch" )
+
src_configure() {
local mycmakeargs=(
$(cmake-utils_use_with semantic-desktop KF5Baloo)
diff --git a/kde-apps/dolphin/dolphin-15.08.49.9999.ebuild b/kde-apps/dolphin/dolphin-15.08.49.9999.ebuild
index 0e90513941..0e8c7c7061 100644
--- a/kde-apps/dolphin/dolphin-15.08.49.9999.ebuild
+++ b/kde-apps/dolphin/dolphin-15.08.49.9999.ebuild
@@ -64,6 +64,8 @@ RDEPEND="${DEPEND}
RESTRICT="test"
+PATCHES=( "${FILESDIR}/${PN}-15.08.0-deps.patch" )
+
src_configure() {
local mycmakeargs=(
$(cmake-utils_use_with semantic-desktop KF5Baloo)
diff --git a/kde-apps/dolphin/files/dolphin-15.08.0-deps.patch b/kde-apps/dolphin/files/dolphin-15.08.0-deps.patch
new file mode 100644
index 0000000000..43ae391fb7
--- /dev/null
+++ b/kde-apps/dolphin/files/dolphin-15.08.0-deps.patch
@@ -0,0 +1,48 @@
+From 4c0d110b2d36153a564602223b4dd3e04b1f4158 Mon Sep 17 00:00:00 2001
+From: Michael Palimaka <kensington@gentoo.org>
+Date: Wed, 26 Aug 2015 22:53:44 +1000
+Subject: [PATCH] Update dependencies.
+
+It appears that KF5TextEditor was added for KTextEdit, but that is actually
+provided by KF5TextWidgets. It's then necessary to explicitly link to KF5Parts
+(it was previously brought in implicitly by KF5TextEditor).
+
+REVIEW: 124932
+---
+ CMakeLists.txt | 2 +-
+ src/CMakeLists.txt | 3 ++-
+ 2 files changed, 3 insertions(+), 2 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index b56fd7a..a5580e9 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -62,7 +62,7 @@ find_package(KF5 ${KF5_MIN_VERSION} REQUIRED COMPONENTS
+ Solid
+ IconThemes
+ Completion
+- TextEditor
++ TextWidgets
+ WindowSystem
+ Notifications
+ )
+diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
+index 2a5e5a6..9689923 100644
+--- a/src/CMakeLists.txt
++++ b/src/CMakeLists.txt
+@@ -143,10 +143,11 @@ target_link_libraries(
+ KF5::KIOWidgets
+ KF5::KIOFileWidgets
+ KF5::Completion
+- KF5::TextEditor
++ KF5::TextWidgets
+ KF5::WindowSystem
+ KF5::ConfigCore
+ KF5::NewStuff
++ KF5::Parts
+ )
+
+ if(HAVE_BALOO)
+--
+2.4.6
+