aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-06-10 23:52:03 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-06-11 00:02:51 +0200
commit1c696f46e11ace58458cd57542f23e3684822d6b (patch)
treee512c8ff74ef2e862db0c6d6992f76dcc78309b6
parentkde-frameworks/solid: remove udev USE flag (diff)
downloadkde-1c696f46e11ace58458cd57542f23e3684822d6b.tar.gz
kde-1c696f46e11ace58458cd57542f23e3684822d6b.tar.bz2
kde-1c696f46e11ace58458cd57542f23e3684822d6b.zip
kde-apps/kdepim-runtime: Disable kdelibs4support again
We don't build kolab, make sure Libkolabxml can not be found as well. Upstream has been busy porting away from deprecated stuff in EWS: 0935a3e91d32414db5cdc93ad807b7b026dc89c4 93c8dd8c1b49eb0ab593f7dcf620abed76b49475 Bug: https://bugs.gentoo.org/670958 Package-Manager: Portage-2.3.67, Repoman-2.3.14 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--kde-apps/kdepim-runtime/kdepim-runtime-19.04.49.9999.ebuild14
-rw-r--r--kde-apps/kdepim-runtime/kdepim-runtime-9999.ebuild14
2 files changed, 26 insertions, 2 deletions
diff --git a/kde-apps/kdepim-runtime/kdepim-runtime-19.04.49.9999.ebuild b/kde-apps/kdepim-runtime/kdepim-runtime-19.04.49.9999.ebuild
index 46b423a923..69ba1afd75 100644
--- a/kde-apps/kdepim-runtime/kdepim-runtime-19.04.49.9999.ebuild
+++ b/kde-apps/kdepim-runtime/kdepim-runtime-19.04.49.9999.ebuild
@@ -24,7 +24,6 @@ COMMON_DEPEND="
$(add_frameworks_dep kconfigwidgets)
$(add_frameworks_dep kcoreaddons)
$(add_frameworks_dep kdbusaddons)
- $(add_frameworks_dep kdelibs4support)
$(add_frameworks_dep kholidays)
$(add_frameworks_dep ki18n)
$(add_frameworks_dep kio)
@@ -76,3 +75,16 @@ RDEPEND="${COMMON_DEPEND}
"
RESTRICT+=" test"
+
+src_prepare() {
+ kde5_src_prepare
+ # We don't build kolab, so we can disable this
+ punt_bogus_dep KF5 KDELibs4Support
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_DISABLE_FIND_PACKAGE_Libkolabxml=ON
+ )
+ kde5_src_configure
+}
diff --git a/kde-apps/kdepim-runtime/kdepim-runtime-9999.ebuild b/kde-apps/kdepim-runtime/kdepim-runtime-9999.ebuild
index 46b423a923..69ba1afd75 100644
--- a/kde-apps/kdepim-runtime/kdepim-runtime-9999.ebuild
+++ b/kde-apps/kdepim-runtime/kdepim-runtime-9999.ebuild
@@ -24,7 +24,6 @@ COMMON_DEPEND="
$(add_frameworks_dep kconfigwidgets)
$(add_frameworks_dep kcoreaddons)
$(add_frameworks_dep kdbusaddons)
- $(add_frameworks_dep kdelibs4support)
$(add_frameworks_dep kholidays)
$(add_frameworks_dep ki18n)
$(add_frameworks_dep kio)
@@ -76,3 +75,16 @@ RDEPEND="${COMMON_DEPEND}
"
RESTRICT+=" test"
+
+src_prepare() {
+ kde5_src_prepare
+ # We don't build kolab, so we can disable this
+ punt_bogus_dep KF5 KDELibs4Support
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_DISABLE_FIND_PACKAGE_Libkolabxml=ON
+ )
+ kde5_src_configure
+}