aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-02-07 23:50:12 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-02-07 23:50:12 +0100
commit303548c5add9046a3c9465a2f5002b579580001c (patch)
tree688e2fc32d92bce41306893d4eca19446810f9ff
parentapp-office/skrooge: Sync with Gentoo ebuild repo (diff)
downloadkde-303548c5add9046a3c9465a2f5002b579580001c.tar.gz
kde-303548c5add9046a3c9465a2f5002b579580001c.tar.bz2
kde-303548c5add9046a3c9465a2f5002b579580001c.zip
media-sound/amarok: Remove virtual/mysql from RDEPEND, more postinst
There is a slim chance that someone indeed would run a shared DB instance. Package-Manager: Portage-2.3.59, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--media-sound/amarok/amarok-9999.ebuild15
1 files changed, 11 insertions, 4 deletions
diff --git a/media-sound/amarok/amarok-9999.ebuild b/media-sound/amarok/amarok-9999.ebuild
index 6ff515262e..58fdd12eba 100644
--- a/media-sound/amarok/amarok-9999.ebuild
+++ b/media-sound/amarok/amarok-9999.ebuild
@@ -77,7 +77,6 @@ DEPEND="
RDEPEND="${DEPEND}
!media-sound/amarok:4
$(add_qt_dep qtquickcontrols2)
- virtual/mysql
"
PATCHES=( "${FILESDIR}"/${PN}-2.8.90-mysqld-rpath.patch )
@@ -113,7 +112,15 @@ src_install() {
pkg_postinst() {
kde5_pkg_postinst
- elog "You'll have to configure amarok to use an external db server."
- elog "Please read https://community.kde.org/Amarok/Community/MySQL for details on how"
- elog "to configure the external db and migrate your data from the embedded database."
+ pkg_is_installed() {
+ echo "${1} ($(has_version ${1} || echo "not ")installed)"
+ }
+
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ elog "You'll have to configure amarok to use an external db server, one of:"
+ elog " $(pkg_is_installed dev-db/mariadb)"
+ elog " $(pkg_is_installed dev-db/mysql)"
+ elog "Please read https://community.kde.org/Amarok/Community/MySQL for details on how"
+ elog "to configure the external db and migrate your data from the embedded database."
+ fi
}