aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2016-06-19 19:25:37 +1000
committerMichael Palimaka <kensington@gentoo.org>2016-06-19 19:25:56 +1000
commit31eb8b4db1567c27007fe71b5bb8f19528c25294 (patch)
tree3928c91fc1f2f8db2a2255bb78227effc8d0f42f
parentkde-plasma/breeze: update dependencies (diff)
downloadkde-31eb8b4d.tar.gz
kde-31eb8b4d.tar.bz2
kde-31eb8b4d.zip
kde-plasma/breeze-plymouth: add very basic distro customisation
There are further customisations available, but I am not able to test. Upstream-commit: f2a6a581c3cd9e63f6b3392fb278f8184242a19b Package-Manager: portage-2.3.0_rc1
-rw-r--r--kde-plasma/breeze-plymouth/breeze-plymouth-5.6.95.ebuild9
-rw-r--r--kde-plasma/breeze-plymouth/breeze-plymouth-5.7.49.9999.ebuild9
-rw-r--r--kde-plasma/breeze-plymouth/breeze-plymouth-9999.ebuild9
3 files changed, 27 insertions, 0 deletions
diff --git a/kde-plasma/breeze-plymouth/breeze-plymouth-5.6.95.ebuild b/kde-plasma/breeze-plymouth/breeze-plymouth-5.6.95.ebuild
index 9f11a9d324..9f5ede3cb4 100644
--- a/kde-plasma/breeze-plymouth/breeze-plymouth-5.6.95.ebuild
+++ b/kde-plasma/breeze-plymouth/breeze-plymouth-5.6.95.ebuild
@@ -16,3 +16,12 @@ RDEPEND="sys-boot/plymouth"
DEPEND="${RDEPEND}
$(add_frameworks_dep extra-cmake-modules)
"
+
+src_configure() {
+ local mycmakeargs=(
+ -DDISTRO_NAME="Gentoo Linux"
+ -DDISTRO_VERSION=
+ )
+
+ kde5_src_configure
+}
diff --git a/kde-plasma/breeze-plymouth/breeze-plymouth-5.7.49.9999.ebuild b/kde-plasma/breeze-plymouth/breeze-plymouth-5.7.49.9999.ebuild
index 01926d0a62..e3f0ab91f5 100644
--- a/kde-plasma/breeze-plymouth/breeze-plymouth-5.7.49.9999.ebuild
+++ b/kde-plasma/breeze-plymouth/breeze-plymouth-5.7.49.9999.ebuild
@@ -16,3 +16,12 @@ RDEPEND="sys-boot/plymouth"
DEPEND="${RDEPEND}
$(add_frameworks_dep extra-cmake-modules)
"
+
+src_configure() {
+ local mycmakeargs=(
+ -DDISTRO_NAME="Gentoo Linux"
+ -DDISTRO_VERSION=
+ )
+
+ kde5_src_configure
+}
diff --git a/kde-plasma/breeze-plymouth/breeze-plymouth-9999.ebuild b/kde-plasma/breeze-plymouth/breeze-plymouth-9999.ebuild
index 01926d0a62..e3f0ab91f5 100644
--- a/kde-plasma/breeze-plymouth/breeze-plymouth-9999.ebuild
+++ b/kde-plasma/breeze-plymouth/breeze-plymouth-9999.ebuild
@@ -16,3 +16,12 @@ RDEPEND="sys-boot/plymouth"
DEPEND="${RDEPEND}
$(add_frameworks_dep extra-cmake-modules)
"
+
+src_configure() {
+ local mycmakeargs=(
+ -DDISTRO_NAME="Gentoo Linux"
+ -DDISTRO_VERSION=
+ )
+
+ kde5_src_configure
+}