aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2022-11-02 09:40:57 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2022-11-02 09:40:57 +0100
commit3934292cae8f1192a03354f9ee2bba169d94a1fd (patch)
treed79528c58ccfd3636ae37de04ca42a6e541828c0
parentkde-apps/poxml: 22.08.3 version bump (diff)
downloadkde-3934292c.tar.gz
kde-3934292c.tar.bz2
kde-3934292c.zip
kde-apps/umbrello: 22.08.3 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--kde-apps/umbrello/Manifest1
-rw-r--r--kde-apps/umbrello/umbrello-22.08.3.ebuild74
2 files changed, 75 insertions, 0 deletions
diff --git a/kde-apps/umbrello/Manifest b/kde-apps/umbrello/Manifest
new file mode 100644
index 0000000000..81f91daf6d
--- /dev/null
+++ b/kde-apps/umbrello/Manifest
@@ -0,0 +1 @@
+DIST umbrello-22.08.3.tar.xz 5687876 BLAKE2B 454673200be32570d89c76d6047bfbcccb4cb589769cbaf452f07a4d6348f64e9ebef6b43e2619745ac143adf64b2b34a1f518c7788af7e745fdedee83da43e2 SHA512 0c1e43e57b6a0a0eeb7ebe6c7c16c1751a109491fa12bb3edd0a528afc1d7215e22615670ea93fb0d3e525429bd6485cce27d94da3b841e188b5c87c7a31c9fb
diff --git a/kde-apps/umbrello/umbrello-22.08.3.ebuild b/kde-apps/umbrello/umbrello-22.08.3.ebuild
new file mode 100644
index 0000000000..ca64253f7e
--- /dev/null
+++ b/kde-apps/umbrello/umbrello-22.08.3.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_HANDBOOK="forceoptional"
+ECM_QTHELP="false" # TODO: figure out install error
+ECM_TEST="forceoptional"
+KFMIN=5.96.0
+QTMIN=5.15.5
+VIRTUALX_REQUIRED="test"
+inherit ecm gear.kde.org
+
+DESCRIPTION="KDE UML Modeller"
+HOMEPAGE="https://apps.kde.org/umbrello/ https://umbrello.kde.org"
+
+LICENSE="GPL-2" # TODO: CHECK
+SLOT="5"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="php"
+
+RDEPEND="
+ dev-libs/libxml2
+ dev-libs/libxslt
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtprintsupport-${QTMIN}:5
+ >=dev-qt/qtsvg-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=dev-qt/qtxml-${QTMIN}:5
+ >=kde-frameworks/karchive-${KFMIN}:5
+ >=kde-frameworks/kcompletion-${KFMIN}:5
+ >=kde-frameworks/kconfig-${KFMIN}:5
+ >=kde-frameworks/kconfigwidgets-${KFMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/kcrash-${KFMIN}:5
+ >=kde-frameworks/kdelibs4support-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kiconthemes-${KFMIN}:5
+ >=kde-frameworks/kio-${KFMIN}:5
+ >=kde-frameworks/kjobwidgets-${KFMIN}:5
+ >=kde-frameworks/ktexteditor-${KFMIN}:5
+ >=kde-frameworks/ktextwidgets-${KFMIN}:5
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:5
+ >=kde-frameworks/kwindowsystem-${KFMIN}:5
+ >=kde-frameworks/kxmlgui-${KFMIN}:5
+ php? (
+ dev-util/kdevelop:5=
+ dev-util/kdevelop-pg-qt:5
+ dev-util/kdevelop-php:5
+ )
+"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-20.08.3-gentoo-docbundledir.patch # fix hardcoded path
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_DISABLE_FIND_PACKAGE_Doxygen=ON # broken, re-enable w/ ECM_QTHELP
+ -DCMAKE_DISABLE_FIND_PACKAGE_Qt5WebKitWidgets=ON
+ -DBUILD_APIDOC=OFF
+ -DBUILD_KF5=ON
+ -DBUILD_PHP_IMPORT=$(usex php)
+ -DBUILD_unittests=$(usex test)
+ )
+ use test && mycmakeargs+=(
+ -DCMAKE_DISABLE_FIND_PACKAGE_LLVM=ON
+ -DCMAKE_DISABLE_FIND_PACKAGE_Clang=ON
+ -DCMAKE_DISABLE_FIND_PACKAGE_CLANG=ON
+ )
+
+ ecm_src_configure
+}